Trademarks
Macromedia, the Macromedia logo, the Made With Macromedia logo, Authorware, Backstage, Director, Extreme 3D, and Fontographer
are registered trademarks, and Afterburner, AppletAce, Authorware Interactive Studio, Backstage, Backstage Designer, Backstage Desktop
Studio, Backstage Enterprise Studio, Backstage Internet Studio, DECK II, Director Multimedia Studio, Doc Around the Clock, Extreme
3D, Flash, FreeHand, FreeHand Graphics Studio, Lingo, Macromedia xRes, MAGIC, Power Applets, Priority Access, SoundEdit,
Shockwave, Showcase, Tools to Power Your Ideas and Xtra are trademarks of Macromedia, Inc. Other product names, logos, designs,
titles, words or phrases mentioned within this publication may be trademarks, servicemarks, or tradenames of Macromedia, Inc. or other
entities and may be registered in certain jurisdictions.

Apple Disclaimer
APPLE COMPUTER, INC. MAKES NO WARRANTIES, EITHER EXPRESS OR IMPLIED, REGARDING THE ENCLOSED
COMPUTER SOFTWARE PACKAGE, ITS MERCHANTABILITY OR ITS FITNESS FOR ANY PARTICULAR PURPOSE.
THE EXCLUSION OF IMPLIED WARRANTIES IS NOT PERMITTED BY SOME STATES. THE ABOVE EXCLUSION MAY
NOT APPLY TO YOU. THIS WARRANTY PROVIDES YOU WITH SPECIFIC LEGAL RIGHTS. THERE MAY BE OTHER
RIGHTS THAT YOU MAY HAVE WHICH VARY FROM STATE TO STATE.

Copyright © 1998 Macromedia, Inc. All rights reserved. This manual may not be copied, photocopied, reproduced, translated or
converted to any electronic or machine-readable form in whole or in part without prior written approval of Macromedia, Inc.
Part Number ZDR70M100

Acknowledgments
Project Management: Joe Schmitz
Writing: Ben Melnick, Joe Schmitz, Peter Haase, and Corinne Chandel
Multimedia: James Khazar and John “Zippy” Lehnus
Multimedia Instructional Design: Ben Melnick
Developmental Editing: Judy Wahlters von Alten
Copy Editing: Judy Ziajka
Production Management: Gemma Londono
Production: Paul Benkman and Noah Zilberberg
Publication Design: Noah Zilberberg
Help Engineering: Peter Fenczik
Special thanks: David Adams, Christopher Campbell, David Dennick, Margaret Dumas, Mike Edmunds, John Emhow, Lisa Gelobter,
Alan Isaacs, Allison Kelsey, Buzz Kettles, Tracy Rankin, Gordon Smith, John “JT” Thompson

Second Edition: May 1999

Macromedia, Inc.
600 Townsend St.
San Francisco, CA 94103
# CONTENTS

## CHAPTER 1
*Getting Started* ........................................... 11
- System requirements ........................................ 11
- Installing Director ......................................... 12
- What's new in Director 7 ................................. 12
- Changes in Lingo .......................................... 15
- Features added in Director 6.5 ......................... 15
- Guide to instructional media ............................ 18

## CHAPTER 2
*Tutorial* .................................................. 21
- Tutorial: Overview ....................................... 21

## CHAPTER 3
*Director basics* ........................................ 43
- Director basics: Overview ............................... 43
- Using Director's work area ............................. 43
- Adding interactivity with Lingo ....................... 46
- Using the Score .......................................... 46
- Using markers ............................................ 52
- Selecting and editing frames in the Score .......... 55
- Identifying frames with Lingo ......................... 56
- Setting Stage and movie properties .................. 57
- Using the Control Panel to control movie playback 58
- Converting Director 5 and 6 movies ................. 59
- Using Xtras ............................................. 59
- About distributing movies .............................. 61
CHAPTER 11
Movies in a Window ............................. 219
Movies in a window: Overview .......................... 219
Creating a MIAW using Lingo .................. 220
Setting the window type ............................ 221
Opening the window ................................ 221
Setting the window size and location .......... 222
Cropping and scaling a MIAW .................. 222
Controlling a window’s appearance ........... 223
Closing windows .................................. 223
Listing the current windows ................... 224
Interaction between windows ................. 224
Events involving windows ...................... 224

CHAPTER 12
Parent Scripts ................................. 225
Parent scripts: Overview ....................... 225
Writing a parent script ......................... 228
Creating child objects ......................... 230
Removing a child object ...................... 230
Using the scriptInstanceList .................. 231
Using the actorList ............................ 232

CHAPTER 13
Vector Shapes and Bitmaps ................. 233
Vector shapes and bitmaps: Overview ........ 233
Drawing vector shapes ....................... 234
Editing vector shapes ....................... 237
Defining gradients for vector shapes ........ 238
About importing bitmaps ..................... 240
Using animated GIFs ......................... 241
Paint window basics ........................... 243
Changing selected areas of a bitmap ........ 250
Flipping, rotating, and applying effects to bitmaps 251
Changing registration points ............... 253
Changing size, color depth, and color palette for bitmaps 255
Controlling a bitmap image with Lingo .... 257
Using gradients ............................... 258
Creating a custom tile ....................... 259
Using bitmap filters .............................................. 260
Using onion skinning .............................................. 262
Using shapes ...................................................... 266

CHAPTER 14
Text ......................................................... 269
Text: Overview .................................................. 269
Embedding fonts in movies ...................................... 270
Creating text cast members ................................... 272
Editing and formatting text .................................... 273
Creating a hyperlink ............................................ 279
Using editable text ............................................. 279
Working with fields ............................................. 281
Converting text to a bitmap .................................... 281
Formatting chunks of text with Lingo ...................... 282
Formatting text cast members with Lingo .................. 285
Controlling scrolling text ...................................... 287
Checking for specific text with Lingo ....................... 288
Modifying strings with Lingo .................................. 288

CHAPTER 15
Sound, Video, and Synchronization ................. 289
Sound, video, and synchronization: Overview .......... 289
Importing internal and linked sounds ..................... 290
Controlling sound in the Score .............................. 291
Looping a sound .............................................. 292
Using sound in Windows ..................................... 293
Playing sounds with Lingo .................................... 293
Using Shockwave audio ....................................... 294
Compressing internal sounds with Shockwave audio .... 295
Streaming linked Shockwave Audio files ................... 296
Playing Shockwave audio with Lingo ...................... 297
Importing digital video ........................................ 299
Playing digital video direct-to-Stage ....................... 300
Controlling digital video in the Score ...................... 301
Playing digital video with Lingo ............................ 302
Controlling QuickTime with Lingo .......................... 304
Cropping digital video ........................................ 308
About using digital video on the Internet .................. 309
Contents

Preloading digital video ........................................ 310
Synchronizing media ........................................... 310
Synchronizing media with Lingo ............................ 312

CHAPTER 16
Using Interactive Media Types ....................... 313
Using interactive media types: Overview .............. 313
Using Flash Movies ......................................... 314
Controlling a Flash movie with Lingo ................. 317
Controlling a Flash movie's appearance with Lingo ... 318
Streaming Flash movies with Lingo ..................... 321
Playing back Flash movies with Lingo .................. 322
Sending Lingo from Flash movies ....................... 323
Playback performance tips for Flash movies ........... 325
Using Director movies within Director movies ....... 326
Using PowerPoint presentations ......................... 327
Using ActiveX controls ..................................... 332
Inserting an ActiveX control .............................. 333
ActiveX control properties .................................. 334
ActiveX control methods .................................... 335
ActiveX control events ..................................... 336

CHAPTER 17
Playing Movies over the Internet ................... 337
Playing movies over the Internet: Overview ........... 337
Setting movie playback options .......................... 339
Setting Shockwave playback options .................... 340
About streaming with the Score and behaviors .......... 341
Checking whether media is loaded with Lingo ........ 343
Downloading files from the Internet with Lingo ........ 343
Retrieving network operation results with Lingo ....... 346
Using Lingo in different Internet environments ....... 347
Testing your movie ........................................... 350
Downloading considerations .............................. 351
CHAPTER 1
Getting Started

Macromedia Director is the world’s foremost authoring tool for multimedia production.

Whether you’re a web site developer, a multimedia artist or producer, an educator, or an engineer, you’ll find Director the ideal tool for creating web sites, kiosks, entertainment and educational CD-ROM titles, simulations and visualizations, interactive presentations, and demo disks.

**System requirements**

The following hardware and software is required to run Director:

- For Microsoft Windows™: An Intel Pentium® 90 or equivalent processor running Windows 95 or NT version 4.0 or later; 32 MB of RAM plus 20 MB of available disk space; a color monitor; and a CD-ROM drive.

- For the Macintosh®: A Power Macintosh running System 7.6.1 or later; 32 MB of RAM plus 20 MB of available disk space; a color monitor; and a CD-ROM drive.
Installing Director

Follow these steps to install Director on either a Windows or Macintosh computer.

To install Director on a Windows or Macintosh computer:

1. Insert the Director CD into the computer's CD-ROM drive.
   In Windows the installation program starts automatically.
2. On the Macintosh, double-click the Director Installer icon.
3. Follow the on-screen instructions.
4. If prompted, restart your computer.

What’s new in Director 7

Director 7 offers exciting new features for dazzling playback on the web. In addition to playback features like Flash cast members, sprite rotation, and alpha-channel support, Director 7 includes dozens of authoring improvements such as Preview in Browser and HTML import support that make authoring movies for the web faster and easier than ever before.

New engine

Director has been rebuilt from the ground up. After five years of development, a completely new Director player is fully implemented for playback and authoring. Movies are smaller, faster, and work better than ever.

Transparency

Use alpha channel effects to import or create transparent color images. Import 32 bit images with transparency from Adobe Photoshop or any other image editor that supports alpha channel effects. See “About importing bitmaps” on page 240.

RGB color support

For accurate color anywhere, specify any color using RGB values instead of choosing colors from an indexed palette. Enter RGB values for sprites, the movie background, or anywhere you specify a color. Choose RGB colors from a standard color picker or enter hexadecimal values in the Sprite Inspector. See "Color, tempo, and transitions: Overview" on page 169.
Sprite rotation and skewing

Rotate and skew sprites on the stage without using multiple cast members. Specify the degree of rotation and tween the settings to make sprites tilt or spin. See “Rotating and skewing sprites” on page 83.

Library palette

Choose behaviors and other useful objects from a compact palette. Director 7 includes libraries of behaviors and objects. The Library palette prevents accidental editing and lets you see more behaviors at once. See “Attaching behaviors” on page 116.

More sprite channels

Use up to 1000 sprite channels to create more complex movies. Turn off unneeded channels to optimize performance.

Higher frame rate

Movies can now move at up to 999 frames a second, making movies go faster and Lingo more responsive.

Smaller, more editable text

Anti-aliased text can now be edited while a movie plays and controlled from Lingo and is much smaller than before. The size of text cast members is now limited only by system resources. See “Text: Overview” on page 269.

Embedded compressed fonts

Embed fonts in movies so that any fonts can be used in any movie, regardless of the fonts installed in the user's system. Director compresses embedded fonts so they usually add only 14 to 25K to a file. See “Embedding fonts in movies” on page 270.

HTML import support

Import formatted text from any HTML document. Director recognizes many common formatting tags. See “Importing text” on page 273.

Anti-aliased, Bézier-controlled vector shapes

Create a new type of shape in Director 7 called a vector shape. Vector shapes are anti-aliased against any background and controllable by Bézier control handles in the new Vector Shape window. Use a pen tool to create irregular shapes, just like in Freehand. See “Drawing vector shapes” on page 234.
**Preview in a browser**

Preview the current movie in a browser at any time to detect display or interactivity problems. Just choose File > Preview in Browser. See “Previewing a movie in a browser” on page 353.

**Improved Shockwave**

Shockwave is now installed as a system-level component, so it can play movies from the desktop outside of a browser as well as in a browser. A progress bar now appears to monitor movie downloading.

**Web palette**

Map all your 8-bit images to the included palette of web-safe colors to avoid any color display problems in browsers. See “Color, tempo, and transitions: Overview” on page 169.

**Easier streaming**

New movie playback properties and a library of behaviors make it easy to stream movies without writing any Lingo. See “Playing movies over the Internet: Overview” on page 337.

**Xtra downloading**

Download new Xtras from trusted sources to any system. Add new capabilities to your movies on the web. See “Managing Xtras for distributed movies” on page 354.

**Animated GIF playback**

Use animated GIFs anywhere in a movie as normal cast members. Control the number of times the animation loops and when it plays. See “Using animated GIFs” on page 241.

**Internal bitmap compression**

Imported GIF and JPEG images in Shockwave movies and projectors are stored in their original compressed formats. This produces smaller files and faster download times.
Lingo improvements

New dot property notation shortens the syntax and improves readability for complex objects or multidimensional arrays. Bracket list access and the optional equals (=) operator also make coding faster and easier. New date types provide international date formats. Scripts can now be of any length, limited only by system resources. See “Writing scripts with Lingo: Overview” on page 133.

Network Lingo improvements

Post text or form data to HTTP servers for easier communication with CGI scripts. Improved information on media loading makes it easier to author streaming Shockwave. Within browsers, network Lingo now supports the secure HTTPS protocol. See “Playing movies over the Internet: Overview” on page 337.

XML parsing

An XML parser lets you manipulate data stored in the open-standard XML format. See “Using XML Parsing,” in the Director Developers Center.

Multiuser server

Create Shockwave movies and Director projectors that communicate with others in real time over the network. Build chat rooms, multiuser games, shared experiences, and so on. See “Using the Multiuser Server Xtra,” in the Director Developers Center.

Changes in Lingo

Director 7 introduces many new Lingo terms. Many of these terms support new features such as sprite rotation and alpha channel support. Other terms provide expanded support for existing Director features such as network operation support and QuickTime 3 control. For a complete list of new and revised Lingo terms, see “Getting Started,” in Director Help.

Features added in Director 6.5

The following improvements were made in Director 6.5.

PowerPoint presentation import support

Import files saved in PowerPoint 4.0 format. Director imports the file as a complete presentation: Besides importing all the graphics and text into the Cast, Director builds a Score that reflects, as nearly as possible, the flow of the slides, including transitions and build effects. Just import the presentation and click the Play button. See “Using PowerPoint presentations” on page 327.
**QuickTime 3 support**

Director supports QuickTime 3. All your existing digital videos will continue to work with QuickTime 3, and in most cases you can use your existing Lingo scripts with QuickTime 3 cast members without modification.

Incorporate dozens of new media types, from QuickTime VR 2.0 to sound formats such as MPEG audio—and even graphic formats such as progressive JPEG. Use special effects such as nonrectangular masking, rotation, and scaling.

Also for Windows developers, QuickTime 3 support means you can now mix audio by simultaneously playing QuickTime audio with movie audio. See “Sound, video, and synchronization: Overview” on page 289.

**Save as Java**

Director is now the world’s most powerful tool for Java multimedia. Use the Save as Java feature to produce:

- A Java applet that can play your Director movie in any Java-enabled web browser
- An accompanying media file containing the movie’s assets
- The HTML code needed to embed the Java applet in a web page

You can reduce the player’s size by compiling just the functionality needed to play your project. You can even save a movie as Java source code that you can then tweak and compile yourself. You can further extend a Director movie by embedding Java directly into your Lingo scripts.

To help you get started, Director 6.5 also includes a version of the Behavior Library that has been optimized for use in Java applets. Detailed documentation explains exactly which Director features are supported.

For more information, see “Authoring for Save as Java,” in the Director Developers Center.

**Aftershock**

Use Aftershock to automatically create HTML files that display Shockwave movies in any browser. Using the Aftershock interface, you can set all of the possible Shockwave Director parameters for the `object` and `embed` tags without having to write any code. You can also generate a JPEG image to display if Shockwave is not installed. For more information, see “Creating a new HTML document with Aftershock” on page 372.
**Flash import**

Import animations and graphics created in Macromedia Flash 2 or 3 into your Director cast. A Flash animation cast member works much like a digital video in Director. You can extend it through the Score, letting the Flash cast member play once or loop continuously, or you can use Lingo to start, stop, or play the animation from a specific frame. You can also use static Flash graphics. You can composite both animations and graphics with other sprites, or you can display them direct-to-Stage for even better performance. See “Using Flash Movies” on page 314.

**ActiveX support**

Incorporate ActiveX controls directly in your movies. Simply import standard Windows ActiveX controls or any of hundreds of third-party controls as cast members and then deploy them as sprites in your movie. Through Lingo, you can access a control’s methods and properties, and the control can send events to your Lingo scripts. See “Using ActiveX controls” on page 332.

**Animated color cursors**

Create animated cursors with any series of 8-bit bitmap cast members, including text cast members. You can set the cursor’s hotspot and control the speed of its animation. The automasking feature ensures that white areas of the cursor remain transparent during the animation. Depending on the playback platform, you can create cursors up to 32 pixels square.

The animated cursors are true system-level cursors that provide much better performance than puppetted sprites controlled through Lingo. For more information, see “Creating an animated color cursor cast member” on page 216. Also see the animated color cursor tutorial in the Director Developers Center.
Guide to instructional media

The Director package contains a variety of media to help you learn the program quickly and become proficient in creating multimedia—including online help, a multimedia Guided Tour, a tutorial, printed books, and a regularly updated web site.

Director includes the following main instructional components.

**Director Help and the Guided Tour**

Director Help is the comprehensive information source for all Director features. The help includes complete conceptual overviews of all features, animated examples, descriptions of all interface elements, and a reference of all Lingo commands and elements. They are extensively cross-referenced and indexed to make finding information and jumping to related topics quick and easy.

The best place to start learning Director is the Guided Tour included with Director Help. The Guided Tour provides a quick conceptual overview of how to use key features to create and distribute a movie. The Guided Tour is composed of several Show Me movies; each Show Me movie describes a single feature. The Guided Tour plays all of the Show Me movies in sequence. You can also view individual Show Me movies within their respective overview topics.

Online topics with this icon contain a Show Me movie.

Choose Help > Help Contents (Windows) or Help > Director Help Topics (Macintosh) to open Help in your browser.

Click the Help button in any dialog box to open a relevant help topic.

**Director Tutorial**

When you're ready to actually start working in Director, proceed to the Director Tutorial. The tutorial shows you how to create a basic movie with some of Director's most useful and powerful features. The tutorial appears in the “Guided Tour” chapter in Director Help and the Using Director book.

**Using Director**

*Using Director* is a printed excerpt of Director Help. It includes all the main topics in Director Help, but omits some topics that are specialized or less frequently used.

**Lingo Dictionary**

*Lingo Dictionary* is a printed version of all the Lingo topics in Director Help.
Director Developers Center

The Director Developers Center web site contains the latest information on Director, plus additional topics, examples, tips, and updates. Check the web site often for the latest news on Director and how to get the most out of the program.

For example, you can visit the Director Developers Center for additional information about these topics:

- Using Director 7’s behaviors
- Troubleshooting Lingo
- Scripttable authoring
- Authoring movies that you intend to save as Java applets
- Additional browser scripting information
- Using the MUI Xtra
- XML parsing
- Multiuser server
- Known browser quirks
- Special color effects
Conventions used in instructional media

The help system and printed books use the following conventions:

▶ The terms Lingo and Director refer to version 7 of Director.
▶ Within the text and in Lingo examples, Lingo elements and parts of actual code are shown in code font. For example, set answer = 2 + 2 is a sample Lingo statement.
▶ Quotation marks that are part of Lingo statements are shown in the text and Lingo code examples as straight quotation marks (") rather than as curly quotation marks (").
▶ The continuation symbol (¬), which you enter by pressing Alt-Enter (Windows) or Option-Return (Macintosh), indicates that a long line of Lingo has been broken onto two or more lines. Lines of Lingo that are broken this way are not separate lines of code. When you see the continuation symbol in this book, type the lines as one line when you enter them in the Script window.

Variables used to represent parameters in Lingo appear in italics. For example, whichCastMember is commonly used to indicate where you insert the name of a cast member in Lingo.
Tutorial: Overview

This tutorial steps you through the creation of a simple banner for a web page and shows how to actually put the movie on the web. The tutorial explains how to import media, create sprites, work in the score, tween sprites, attach behaviors, and save the movie in Shockwave format. To better understand Director's basic concepts before you follow this tutorial, you should view all parts of the Guided Tour before you begin. The Guided Tour provides an animated introduction to the most important concepts in Director. See the Guided Tour in Director Help.

To see a completed version of the movie you are going to create in this tutorial, open the file Completed Tutorial Example in the Learning folder in the Director application folder.
Setting up the movie

Before you start placing media in your movie, you should create a new movie to clear your work space and decide how large you want the movie to be. Because you are creating a web banner, you should define a small Stage and choose a color palette for the movie that works well in web browsers. The Stage is the visible area of a movie.

To create a new movie and set the screen size:

1. Make sure the Stage window is visible. If the Stage is not visible, choose Window > Stage.
2. Choose File > New > Movie.
   If you’ve made changes to the current movie, Director prompts you to save them.
3. To change movie settings, choose Modify > Movie > Properties.
4. To specify a new Stage size, enter 464 in the Width box and 60 in the Height box.
   This is a common size for web banners.
   You also use the Movie Properties dialog box to change the default palette for the movie.
5. To choose the color palette for the movie, choose Web216 from the Default Palette pop-up menu.
   Web216 is the palette used by most web browsers. Using this palette for your movie can prevent many color problems caused by mismatched color palettes.
6. Click OK.
   The Stage should look like this:

   ![Stage](image)

To have your movie play through once without looping:

1. Choose Window > Control Panel.
   The Control Panel lets you play, stop, and rewind the movie. The Loop Playback button in the upper right corner of the panel controls whether the movie loops.
2. Make sure the Loop Playback button is deselected.
   When Loop Playback is deselected, the movie doesn’t loop.
Creating media in Director

You can create media in Director or import it from other programs. Simple media such as text and backgrounds are often best created in Director. In this section you’ll learn about creating vector shapes and text.

A vector shape is a mathematical description of a shape filled with a color or gradient. It uses much less memory than a comparable bitmap and downloads faster from the Internet. You will create a vector shape filled with a gradient to serve as the background of the banner.

**To create a vector shape:**

1. Choose Window > Vector Shape.
   The Vector Shape window provides basic drawing tools for creating and changing vector shapes.

2. Click the filled rectangle tool.

3. Draw a rectangle approximately the size of the stage.
   You can resize the image later, so the exact size is not important.

4. Click the Gradient Fill button.
   This fills the rectangle with a gradient using the current colors and settings.
   You need to change the gradient so it resembles a sunrise. The Gradient Colors control determines the colors used by the gradient.

5. Click the color box on the left side of the Gradient Colors control and choose a pale pink color from the Color menu.

6. Click the color box on the right side of the gradient color and choose a deep blue color from the Color menu.
7 From the Gradient Type pop-up menu at the top of the window, choose Radial.

8 In the Y Offset box, enter 30, and then press Return.
   This offsets the center of the gradient by 30 pixels, moving the pink area downward. This placement is more effective for simulating a sunrise.

9 Enter Sky as the name for the cast member you’ve created in the field at the top of the window.

![Image of Vector Shapes window with gradient]

Entering a name for the cast member makes it easier to identify media in the Score.

10 Close the Vector Shapes window.
Now that you’ve created the background, you can create the text for the banner title.
To create a text cast member:

1. Choose Window > Text. The Text window offers standard text formatting controls in a window that looks like a word processor.
2. Use the formatting controls at the top of the Text window to choose Arial (Windows) or Helvetica (Macintosh) 24-point bold type.
3. Type “The Bean Factory.”
4. Name the cast member Title.
   You also want a smaller text cast member that says the user can click to place an order.”
5. Click the New Cast Member button in the upper-left corner of the window.

This creates a new text cast member that you can edit in the Text window.
6. Change the point size to 12 points.
7. Type “To order.”
8. Name the cast member Order.
9. Close the Text window.
10. If the Cast window isn’t visible, choose Window > Cast and notice how the cast members you’ve created appear in the Internal cast with the names you’ve entered.

This movie is so simple it requires only one cast, but you can create as many casts as you need to organize your work.
Creating sprites and using inks

Now that you have some cast members, you’re ready to work with sprites. Sprites are objects that control when, where, and how cast member media appear in a movie. You move sprites on the Stage to determine where cast members appear. You move sprite bars in the Score to determine when cast members appear.

To create sprites:

1. Make sure the Cast window, Score, and Stage are visible, using any of the following methods:
   - For the Cast window, choose Window > Cast or press Control-3 (Windows) or Command-3 (Macintosh).
   - For the Score, choose Window > Score or press Control-4 (Windows) or Command-4 (Macintosh).
   - For the Stage, choose Window > Stage or press Control-1 (Windows) or Command-1 (Macintosh).
2 Drag the Sky cast member to the Stage as shown.

This creates a sprite that displays the Sky cast member. Notice the sprite bar in the Score that extends through 28 frames. The frames in the Score represent the passing of time. You define the number of frames per second in the Control Panel.

Director displays information about the selected sprite in a Sprite Overlay panel on the Stage. This information is usually helpful, but when the Stage is small, as when creating a banner, the information panel can make it difficult to work on the Stage. You can easily turn off this feature.

3 Choose View > Sprite Overlay > Show Info to turn off the display of the sprite information panels.

4 Resize the Sky sprite by dragging the handles on the sprite's bounding rectangle so that the sprite fills the entire Stage.

Now you’re ready to add more sprites for the banner text.
5 Drag the Title cast member to the lower part of the Stage as shown.

![Stage with Title](image)

The title will rise out of the horizon, so you want it to start near the bottom of the Stage.

The new sprite appears as a white box with text inside. You can remove the box by applying the Background Transparent ink. Background Transparent and the other inks change the way colors appear within sprites. Changing the ink of a sprite has no effect on the cast member displayed by the sprite.

6 Make sure the Title sprite is selected. Then, in the Sprite toolbar at the top of the Score, choose Background Transparent from the Ink pop-up menu.

![Sprite toolbar](image)

This removes the white box around the text.
7 Drag the Order sprite from the Cast window to the right side of the Stage and apply Background Transparent again.

The Stage and Score of the movie should now look like this. If you need to move a sprite to a different frame, drag it in the Score.

8 Choose File > Save to save the movie.

9 Enter MyBanner for the movie’s name and then click OK.
Creating simple animation

To make the title rise out of the horizon, you will use a simple animation technique called tweening. To animate with tweening, you define settings for the starting and ending frames, and Director fills in all the frames in between.

To tween a sprite:

1. Select the Title sprite in the Score.
2. On the Stage, locate the large blue and red circle in the upper-left corner of the Title sprite.
   This is a special handle for tweening the path of a sprite.
3. Hold down the Shift key and drag the handle up about half an inch.

As you drag, the handle separates into green and red circles. The green circle shows the starting location of the sprite, and the red circle represents the ending location. Holding down the Shift key constrains the movement to vertical or horizontal.

4. To see the animation, click Rewind and then click the Play button on the toolbar at the top of the screen. (You can click the buttons in the Control Panel or on the toolbar at the top of the Director window.)

The title moves between the starting and ending points you’ve defined.

Notice in the Score that there are now small circles at the beginning and end of the Title sprite. These circles represent keyframes. Keyframes are frames where the property of a sprite changes.

In addition to tweening the path of a sprite, Director can tween the blend, size, rotation, skew, and color of a sprite. In this example, you will tween the blend to make the title fade in as it rises.

5. Select the keyframe marker in the Score in frame 1 of the Title sprite.
At the top of the Score, enter 0 in the Blend field and then press Return. There is no 0 option on the Blend pop-up menu, but you can enter the number in the box. This makes the sprite disappear in the first frame.

Click the Rewind button and then the Play button on the toolbar at the top of the screen. The title fades in as it moves up.

Click the Rewind button to return the playback head to frame 1.

Choose File > Save to save your work.

**Importing media**

The cast members you've worked with so far are typical of media that you create within Director. For more complex media, you usually import from other applications. Director can import media from many popular media formats, including bitmaps, text, digital video, Flash movies, sounds, and so on. For this movie, you will import two bitmap cast members that were created in an image editing program, plus a Flash movie.

Importing media in Director involves choosing the files you want to import and then responding to prompts about how you want each one imported.
To import media:

1. Choose File > Import.

2. Open the Learning folder within the Director application folder and then open the Tutorial Media folder. You should see three files: Coffeman.swf, Cup.bmp, and Horizon.bmp.

3. Click Add All.
   This adds all the files in the current folder to the list of files to be imported.

4. Click Import.
   Director begins importing the files. Depending on the type of computer you have and how many colors your system is set to display, Director may prompt you to confirm the type of media you are importing or to change the color depth (number of colors) in the current image.

5. If the Image Options dialog box appears, choose Stage as the setting for Color Depth and click Same Settings for Remaining Images. If your system is set to 256 colors, choose Remap To from the Palette options, and Web216 from the pop-up menu to the right.

6. Click OK.
   The files you have imported appear as cast members. The cast member names are set to the file names of the imported files. You can change the names if you wish.
Creating more sprites

Now that you have more cast members, you can place them on the Stage to finish the design of the banner.

To place additional sprites:

1. Click frame 1 in channel 4 in the Score.
   When you create sprites by dragging cast members to the Stage, Director always places them in the current frame, so it's good practice to select the frame in the Score where you want the sprites to appear before dragging cast members to the Stage.

2. Drag the Flash movie, Coffeeman.swf, to the left edge of the stage.

3. Drag the bitmap cast member named Horizon into position at the bottom of the stage, as shown. Make sure the sprite bar appears in Score channel 5.

4. Making sure the Horizon sprite is still selected, choose Background Transparent from the Ink pop-up menu in the Sprite toolbar.
   Notice that a fuzzy white border appears at the edge of the artwork. This occurs because the image was created to be anti-aliased against a white background. Anti-aliasing blends the borders of images by adding pixels of intermediate colors. If an anti-aliased image is placed over a different colored background, as in this example, a fuzzy halo may appear. You can fix this using the Darkest ink instead of Background Transparent. Darkest ink compares the colors in the foreground and background images and uses whichever color is darkest.
5 Choose Darkest ink from the Ink pop-up menu.
   The fuzzy halo disappears.

6 Click Rewind and then Play to see the Flash movie animate while the banner movie plays.
   Director imports Flash movies with all of their animation and interactivity.

7 Click the Rewind button to return to the first frame of the movie.

**Tweening rotation**

Earlier you used tweening to make the title fade in as it rises. Now you’ll use tweening again to make a sprite spin as it moves across the stage.

**To tween rotation:**

1 Select frame 1 in channel 6.

2 Drag the Cup cast member onto the Stage and place it over the Flash movie.
   This may not look right, but the cup will be over the Flash movie for only one frame.

3 With the Cup sprite still selected, choose Background Transparent ink.

4 Hold down the Shift key and drag the blue and red tweening handle to the right side of the stage, as shown.

![Stage](image)

This places the sprite on the right side of the Stage in its last frame, but to make sure the sprite ends up in the right place, you should advance to the last frame and check to see if adjustments are necessary.

5 In the Score, select the keyframe at the end of the Cup sprite.

6 Make sure the sprite appears on the far right of the Stage as shown. (If it doesn’t, adjust the sprite’s location as needed.)

![Stage](image)

Now that you have the ending keyframe selected, you can define a degree of rotation.
7 In the Sprite toolbar at the top of the Score, enter 720 in the Rotation field.

Since you have selected only the ending keyframe, Director will tween the rotation of the sprite from its starting rotation, 0 degrees, through two complete revolutions, 720 degrees.

8 Rewind and play the movie to see the sprite spin as it moves across the Stage.

9 Rewind and save the movie when you are done.
Attaching behaviors

The animation and design of the banner is now complete, so you're ready to add behaviors. Behaviors provide a level of control over the movie not available using only the Score. Behaviors are prewritten scripts in Director's scripting language, Lingo. Attaching behaviors to sprites and frames lets you add Lingo’s interactivity without writing code yourself.

Behaviors add intelligence and flexibility to a movie. Instead of playing a series of frames exactly as the Score dictates, a behavior can control the movie in response to specific conditions and events. In this example, you use a behavior to open a new URL when the users clicks a sprite. This type of navigation is one of the most common uses of behaviors.

Director includes useful behaviors for common tasks. You can also create your own or get them from third-party developers.

To attach a behavior:

1. Choose Window > Library palette.

   The Library palette displays all the behaviors included with Director. There are several libraries of behaviors included with Director. Use the Library List pop-up menu to specify which library is displayed in the palette.

2. Open the Library List pop-up menu and choose Navigation.

   The Library palette displays the name of each behavior next to an icon indicating its type. You can scroll up or down through the list. You attach a behavior by dragging its icon to a sprite or frame.
3 Drag the Go to URL behavior from the Library palette to the Cup sprite on the Stage or in the Score.

It makes no difference whether you attach a behavior to a sprite on the Stage or in the Score. After you drag the behavior, a Parameters dialog box appears. Many behaviors require additional information to perform their tasks.

4 In the Destination URL field in the Parameters dialog box, enter http://www.macromedia.com or any other URL.

If you were creating a real banner, you would enter the URL to the page containing an order form.
5 Drag the Hold on Current Frame behavior to the Behavior channel in frame 28 (or whatever is the last frame of your movie).

The Behavior channel is the channel above the bar of frame numbers.

Hold on Current Frame is one of the few behaviors that has no parameters.

Now that you've attached these two behaviors, you can run the movie to test them. The Go to URL behavior requires an active Internet connection to work correctly.

6 Rewind and play the movie.

Notice that when the movie reaches the last frame, it continues to play and the Flash animation continues to run.

7 Click the Cup sprite.

Director opens a browser and attempts to load the specified page. If no connection is available, you may need to cancel the operation.

**Controlling streaming**

Director streams movies from the Internet, meaning that it begins playing a movie as soon as all the content required for the first frame has been downloaded, while the remaining movie content continues to download in the background. Streaming dramatically shortens the perceived download time of a movie.

To create movies that stream well, it's often a good idea to start with an introductory scene that uses a few small cast members and loops until the cast members for the next scene have downloaded. This approach helps maintain interest while the movie downloads.
The banner you are working on is so small that streaming makes little
difference, but its helpful to learn the technique so you can use it when
you create larger movies.

To create a looping introduction for a streaming movie:

1 Drag the starting frames of the Title, Order, Cup, and Horizon sprites so that
they begin in frame 2.

Make sure you drag only the starting frames and not the entire sprites.
This leaves only the Sky and Coffeman sprites in frame 1. These cast member
work well for an introduction because Sky is a vector shape and Coffeman is a
Flash movie. Both of these media types are small and download quickly. The
Flash movie will also animate and attract interest while Director loops through
frame 1.

2 In the Library palette, choose Internet > Streaming.

3 Drag the Loop Until Media in Frame is Available behavior to the Behavior
channel in frame 1.

4 In the Parameters dialog box, enter 2 in the Wait for Media in Frame field, and
then click OK. (The remaining parameters don't need to be changed.)
This makes the behavior loop on frame 1 until all the cast members for frame
2 have downloaded. There's no way to see this behavior working until you
actually put the movie on a server.
Creating a Shockwave movie

The authoring work on the movie is now complete. All that remains is to save the banner as a Shockwave movie.

A Shockwave movie is a compressed version of a movie that is optimized for downloading. You cannot edit a Shockwave movie. You can only make changes to the original source file and save a new Shockwave movie.

A Director movie cannot be opened in a browser by itself. To make a Director movie appear in a browser, an HTML document must include certain tags (<OBJECT> and <EMBED>) along with parameters telling the browser where to find the movie file, the size of the movie, and so on.

To create a Shockwave movie:

1. Choose File > Save to save any changes. Director cannot create a Shockwave movie unless you have saved all the changes in the open movie.

2. Choose File > Save as Shockwave Movie. MyBanner.dcr appears as the default name.

   Shockwave movies have a .dcr suffix. If you don't enter the suffix, Director adds it automatically.

3. Choose a location for the Shockwave movie, and click OK.
**Finishing the project**

If you were creating a banner for a real web page, at this stage you would probably create or edit an HTML document for the web page that contains the Shockwave movie.

After the HTML document is complete, you can use an FTP utility to transfer the HTML document and the Shockwave movie file to a web server location so the page and movie are accessible to the public.

While creating this simple banner, you’ve learned about some of Director's most important features, including:

- Creating cast members
- Importing cast members
- Creating sprites
- Working in the Score
- Creating tweened animation
- Attaching behaviors
- Controlling streaming
- Creating a Shockwave movie
- Creating an HTML document to run a movie

To learn more, continue reading “Director basics: Overview” on page 43.
CHAPTER 3  
Director basics

Director basics: Overview

Director movies are interactive multimedia pieces that can include animation, sound, text, digital video, and many other types of media. A movie can be as small and simple as an animated logo or as complex as an online chat room or game.

You’re probably familiar with Director movies in the Shockwave movie format, which play in web browsers. Millions of web users have received the Shockwave player with their computers, browsers, or system software; others have downloaded Shockwave from the Macromedia web site. The Shockwave player resides on the local computer, where it plays back movies in browsers or as stand-alone applications.

A Director movie is a single file that controls all the media that appears while the movie plays. A movie may link to external media or be one of a series of movies that refer to each other.

Director’s interactivity lets the movie respond to events and change in specified ways. Director divides lengths of time into a series of frames, similar to the frames in a celluloid movie.

Every movie has several unique properties, including Stage size, position, color, and much more. You specify the most important properties in the Movie Properties dialog box. See “Setting Stage and movie properties” on page 57.

Using Director’s work area

When creating and editing movies, you typically work in the four key windows that make up Director’s work area: the Stage, the rectangular area where the movie plays; the Score, where the movie is assembled; one or more Cast windows, where the movie’s media elements are assembled; and the Control Panel, which controls how the movie plays back.
To create a new movie:
Choose File > New > Movie.

The Score and the Stage
The Score coordinates the movie's media, determining when images appear and sounds play. Special channels control the movie's tempo, sound, and color palettes. The Score also assigns scripts—Lingo instructions that specify what the movie does when certain events occur in the movie.

The Stage is the visible portion of a movie. Use the Stage to determine where media appears.

Working together, the Score's settings and controls create a dynamic, high-quality interactive piece that plays in a web page or as a stand-alone application directly on the user's local computer.
**Sprites**

Sprites are objects that control when, where, and how media appears in a movie. The media assigned to sprites are cast members. Director organizes cast members in libraries called casts.

Creating a Director movie consists largely of defining where sprites appear on the Stage, when they appear in the movie, how they behave, and what their properties are. You work with sprites on the Stage and in the Score to change where and how cast members appear in the movie.

For information on creating and changing sprites, see “Creating sprites” on page 64.

**Cast members**

Cast members—the media that make up a movie—can include bitmap images, text, vector shapes, sounds, Flash movies, digital videos, and more. Create cast members in Director or import existing media. See “Working with cast members and casts: Overview” on page 93.

All these sprites display the same media.
Adding interactivity with Lingo

Lingo, Director’s scripting language, adds interactivity to a movie. Often Lingo accomplishes the same tasks—such as moving sprites on the Stage or playing sounds—that you can accomplish using Director’s interface.

Much of Lingo’s usefulness, however, is in the flexibility it brings to a movie. Instead of playing a series of frames exactly as the Score dictates, Lingo can control the movie in response to specific conditions and events. For example, whether a sprite moves can depend on whether the user clicks a specific button; when a sound plays can depend on how much of the sound has already streamed from the Internet.

Behaviors are preexisting sets of Lingo instructions. Attaching behaviors to sprites and frames lets you add Lingo’s interactivity without writing Lingo scripts yourself.

If you prefer writing scripts to using Director’s interface and behaviors, Lingo provides an alternative way to implement common Director features; for example, you can use Lingo to create animation, stream movies from the web, perform navigation, format text, and respond to user actions with the keyboard and mouse.

Writing Lingo also lets you do some things that the Score alone can’t do. For example, Lingo’s lists let you create and manage data arrays, and Lingo operators let you perform mathematical operations and combine strings of text. You can also write your own behaviors that perform tasks beyond those possible with the behaviors that you already have available.

For more general information about Lingo, see “Writing scripts with Lingo: Overview” on page 133.

Using the Score

The Score organizes and controls a movie’s content over time in channels. The most important components of the Score are channels, frames, and the playback head.

You can control the Score by zooming to reduce or magnify your view and by displaying multiple Score windows. You can also control the Score’s appearance using preference settings.

To display the Score:

Choose Window > Score.
Channels

Channels are the rows in the Score that contain sprites for controlling media. Sprite channels are numbered and contain the sprites that control all the visible media in the movie. Special effects channels at the top of Score contain behaviors as well as controls for the tempo, palettes, transitions, and sounds. The Score displays channels in the order shown here.

The channel at the very top of the Score contains markers that identify places in the Score, such as the beginning of a new scene. Markers are useful for making quick jumps to certain locations in a movie. See “Using markers” on page 52.

The Score can include up to 1000 channels. Most movies contain a much smaller number. To improve a movie's performance in the authoring environment and during playback, you should not use many more channels than necessary. Use Movie Properties to control the number of channels in the Score for the current movie. See “Setting Stage and movie properties” on page 57.

Use the button at the left of any channel to hide its contents on the Stage or to disable the contents if they are not visible sprites. When you turn off a special effects channel, the channel's data has no effect on the movie. Turn Score channels off when testing performance or working on complex overlapping animations.
To turn off a channel:

Click the gray button at the left side of the channel. A darkened button indicates that the channel is off.

This channel is on.

This channel is off.

To show or hide the special effects channels:

Click the Hide/Show Effects Channels button in the upper-right corner of the Score to change the display.

Frames

Frames are represented by the numbers listed horizontally in the sprite and special effects channels. A frame is a single step in the movie, like the frames in a traditional film. Setting the number of frames displayed per second sets the movie's playback speed; see “Using the Control Panel to control movie playback” on page 58.
The playback head

The playback head moves through the Score to show what frame is currently displayed on the Stage. The playback head moves to any frame you click in the Score.

Changing your view of the Score

Change the zoom percentage to narrow or widen the Score. Zooming in widens each frame so you can see more data in each frame. Zooming out shows more frames in less space and is useful when moving around large blocks of Score data.
To change the zoom setting:

Choose View > Zoom and then choose an option, or choose an option on the Zoom pop-up menu to the right of the Score.

Score zoomed out to 50%

Score at 100%

Score zoomed in to 200%
Using multiple Score windows

You can view and work in different parts of a movie at the same time by opening additional Score windows. For example, you can open a second Score window to work on another place in the movie without scrolling. You can also drag sprites between different Score windows.

To open a new Score window:

1. Activate the current Score window.
2. Choose Window > New Window to create a second Score window.

You can scroll in this window to a different location in the Score. Only the first Score window automatically scrolls to show the playback head location.

Changing Score settings

Use Score preference to control the appearance of the Score and the information displayed in numbered sprite channels. You can display a script preview and cast member information. In addition, if you are accustomed to older versions of Director, you can make the Score work as it did in Director 5.

To change Score settings:

1. Choose File > Preferences > Score.
2. The extended display option lets you display information within sprites in the Score. See “Displaying sprite labels in the Score” on page 72. To specify what cast member information appears in numbered sprite channels when Extended display is on, choose from the following options:
   - **Cast Member** displays the cast member number, name, or both.
   - **Behaviors** displays the behaviors attached to the sprite.
   - **Ink Mode** displays the type of ink applied to the sprite.
   - **Blend** displays the blend percentage applied to the sprite.
   - **Location** shows the sprite's X and Y screen coordinates.
   - **Change in Location** shows the change in X and Y coordinates relative to the previous cast member in that channel.
3. To display the first few lines of the selected script in a box at the top of the Score, click Script Preview.
To display the cast member’s name and number when the pointer is over a sprite for a few seconds, click Show Data Tips.

To make Score features work like those in Director 5 and earlier, choose from the following options:

**Director 5 Style Score Display** modifies the Director 7 Score window so it looks and behaves like the Director 5 Score window.

**Allow Drag and Drop** makes sections of the Score moveable by dragging in the Director 5 style Score. To override this setting temporarily, press the spacebar while the Score window is open.

**Allow Colored Cells** displays a cell color selector at the left of the Score window so that you can choose a color for selected cells. Otherwise, the cell color selector is hidden, which improves performance when scrolling the Score window. If you’ve already applied color to cells, turning off this option hides cell colors but doesn’t remove them.

### Using markers

Markers identify fixed locations at a particular frame in a movie. Markers are vital to navigation in movies. Using Lingo or draggable behaviors, you can instantly move the playback head to any marker frame. This is useful when jumping to new scenes from a menu or looping while cast members download from the web. Markers are also useful while authoring to advance quickly to the next scene.

Once you’ve marked a frame in the Score, you can use the marker name in your behaviors or scripts to refer to exact frames. Marker names remain constant no matter how you edit the Score. They are more reliable to use as navigation references than frame numbers, which can change if you insert or delete frames in the Score.

Use the Markers window to write comments associated with markers you set in the Score and to move the playback head to a particular marker.

**To create a marker:**

1. Click the markers channel to create a marker.
   
   A text insertion point appears to the right of the marker.

2. Type a short name for the marker.

**To delete a marker:**

Drag the marker up or down and out of the markers channel.
To jump to markers while authoring:

Do any of the following:

- Click the Next and Previous Marker buttons on the left side of the marker channel.
- Press the 4 and 6 keys on the numeric keypad to cycle backward and forward through markers.
- Choose the name of a marker from the Markers menu.
To move the playback head to a marker and enter marker comments:

1. Select a marker in the Score window and choose Window > Markers to open the Markers window and display comments associated with that frame.

2. Click a marker name in the list. Comments associated with markers appear in the right column.

   Note: Use Control-left or Control-right arrow (Windows) or Command-left or Command-right arrow (Macintosh) to move to the previous or next marker.

3. To enter or edit comments, begin typing at the insertion point that appears in the right column.

   By default, the marker name appears as the first line of text in the right column.

4. If you don’t want to edit the marker name, press Enter (Windows) or Return (Macintosh) to start a new line.
Selecting and editing frames in the Score

You can select a range of frames in the Score and then copy, delete, or paste all the contents of the selected frames. When you select frames, any sprite within the range is selected, even if it extends beyond the range. You can add new frames to a movie at any time.

To move or delete all the contents of a range of frames:

1. Double-click and drag in the frame channel to select frames.
2. Choose Edit > Cut or Edit > Copy, or press Delete.
   If you cut or delete the selected frames, Director removes the frames and closes up the empty space.
3. To paste copied frames, select any frame and choose Edit > Paste.

Note: To delete a single frame, choose Insert > Remove Frame.

To add new frames:

1. Select a frame in the Score.
2. Choose Insert > Frames.
3. Enter the number of frames to insert.
   The new frames appear to the right of the selected frame. If there are sprites in the frames you select, they are tweened or extended.
Identifying frames with Lingo

If you are writing scripts, use these Lingo terms to refer to frames in a movie:

- The function the frame refers to the current frame.
- The frame number or the frame marker label refers to a specific frame. For example, frame 60 indicates frame 60.
- The keyword loop refers to the marker at the beginning of the current segment. If the current frame has a marker, loop refers to the current frame; if not, loop refers to the first marker before the current frame.
- The word next or previous refers to the next marker or the marker before the current scene, respectively.
- The term the frame followed by a minus or plus sign and the number of frames before or after the current frame refers to a frame that's a specific number of frames before or after the current frame. For example, the frame - 20 refers to the frame 20 frames before the current frame.
- The function marker() with the number of markers used as the parameter refers to the marker that's a specific number of markers before or after the current frame. For example, marker(-1) gives the previous marker. If the frame is marked, marker(0) gives the current frame; if not, marker(0) gives the name of the previous marker.
- The word movie followed by the movie name refers to the beginning of another movie. For example, movie "Navigation" refers to the beginning of the Navigation movie.
- The word frame plus a frame identifier, the word of, the word movie, and the movie name refers to a specific frame in another movie; for example, frame 15 of movie "Navigation" refers to frame 15 of the Navigation movie.
Setting Stage and movie properties

Use the Movie > Properties command to specify properties that affect the entire movie, such as how colors are defined, the size and location of the Stage, the number of channels in the Score, copyright information, and font mapping. These settings apply only to the current movie, whereas the settings you choose from File > Preferences apply to every movie.

To set Stage and movie properties:

1 Choose Modify > Movie Properties.

2 To define the size of the Stage, choose a preset value from the Stage Size pop-up menu or manually enter values in the Width and Height fields.

3 To specify the location of the Stage during playback if the movie takes over the full screen, choose an option from the Stage Location pop-up menu or enter values for Left and Top.

   Centered places the Stage window in the center of your monitor. This option is useful if you play a movie that was created for a 13-inch screen on a larger screen, or if you're creating a movie on a larger screen that will be seen on smaller screens.

   Upper Left places the Stage in the top-left corner of the screen.

   Left and Top let you enter the number of pixels the Stage is placed from the top left corner of the screen. These values apply only if the Stage is smaller than the current monitor's screen size.

4 To set the color of the Stage, click the color box next to Stage Color and select a color, or enter an RGB value in the box on the right.

5 To determine how the movie assigns colors, choose either RGB or Index for Color Selection.

   For a complete description of color issues, see “Controlling color in Director” on page 170.

   RGB makes the movie assign all color values as absolute RGB values.

   Index makes the movie assign color according to its position in the current palette.

6 To choose a color palette for the movie, choose a palette from the Default Palette pop-up menu. This palette remains selected until Director encounters a different palette setting in the palette channel.

   For more on color palettes and using color in Director, see “Controlling color in Director” on page 170.
To remap colors in bitmaps with different color palettes to colors in the current palette, select Remap Palettes When Needed.

This option dynamically remaps bitmaps on the Stage without changing the cast members. For example, if a cast member uses a grayscale palette, it is drawn on the Stage using the grays available in the common palette.

To specify the number of channels in the Score, enter a value for Score Channels.

To enter Copyright and other information about the movie, enter values in the Copyright and About boxes.

This information is important if your movie is going to be downloaded from the Internet and saved on a user's system.

To save the current font map settings in a text file named Fontmap.txt, click Save Font Map. To load the font mapping assignments specified in the selected font map file, click Load Font Map. See "Mapping fonts between platforms for field cast members" in Director Help.

**Using the Control Panel to control movie playback**

The Control Panel controls how movies play back in the authoring environment. Choose Window > Control Panel to open this floating panel.

Use the toolbar buttons or keyboard shortcuts to play a movie. To go to a specific frame number, enter the number in the frame counter and press Enter.
Converting Director 5 and 6 movies

Director 7 can convert movies from Director 5 and 6. You can also update movies to Director 7 by simply opening and saving them, but the Update Movies command is faster for converting large projects. It’s also more effective for preserving links to external media. See “Processing movies with Update Movies” on page 363.

*Note:* The Director 7 Shockwave player can play Shockwave movies created with Director 5 and 6.

When you open a Director 5 or 6 movie in Director 7, or convert it to the new format with Update Movies, the following conversions occur:

- The data structure is changed to the latest file format.
- Text cast members become the new editable rich text cast members.
- Shapes are not converted to the new Bézier shapes.
- Ink functionality is not updated unless you turn off Maintain Outdated Ink Mode Limitations in the Movie Properties dialog box.
- Old Score data (Director 5) is converted to the new Score, combining adjacent frames in the old Score containing the same cast members into single sprites in the new Score. You may want to split or join sprites to make working in the Score more convenient.

Using Xtras

Xtras are software components that extend Director’s functionality. They provide important capabilities such as enabling you to import filters and connect to the Internet. Xtras also let third-party developers add specialized features to Director.

Although Xtras are written in C, you don’t need to be a programmer to use them in a movie. Finished Xtras already exist; you just need to make them available to Director. For information on creating Xtras, download the Xtras Developer’s Kit from the Director Developers Center.

You must distribute any Xtra that a movie requires along with the movie itself. Xtras can be packaged with projectors or downloaded by users from the Internet. See “Managing Xtras for distributed movies” on page 354.

If an Xtra that Director uses is missing, an alert appears when the movie opens. For missing Xtra transition cast members, the movie performs a simple cut transition instead. For other missing Xtra cast members, Director displays a red X as a placeholder.
Installing Xtras

Many Xtras are already installed with Director. To make other Xtras available to
Director, place the Xtra in the Xtras folder that is in the same folder as the
Director application before you launch the application.

Place any Director movie in the Xtras folder to make it appear on the Xtras menu
and open as a movie in a window.

An Xtra can be in a folder within the Xtras folder up to five layers deep.

After Director has started, you can use the openXlib command to open Scripting
Xtras located in any folder. If you open an Xtra this way, you must use the closeXlib
command to close it when Director has finished with it.

Copies of the same Xtra can have different file names or have the same file name
but reside in different folders. If duplicate Xtras are available when Director
launches, Director displays an alert. You should delete any duplicate Xtras.

Director automatically closes Xtras when the application quits.

Types of Xtras

Five types of Xtras are supplied with Director:

Cast member Xtras provide new media types to Director. They create or control a
wide range of objects for use as cast members. Some of the cast member types
built into Director, such as Shockwave Flash, Vector Shape, and Animated GIF,
are provided as Xtras. Xtras provided by third-party developers can include
databases, 3D graphics processors, special types of graphics, and so on. Cast
member Xtras built into Director appear on the Insert > Media Element menu.
Other cast member Xtras may not appear on this menu and may require Lingo
implementation.

When setting properties for an Xtra cast member, use the Xtra Cast Member
Properties dialog box, which provides properties standard to all types of Xtra cast
members. You must click Option to open a second Properties dialog box that lets
you changes settings unique to the current Xtra.
Some cast member Xtras have separate authoring and playback components. Include only the playback components when distributing movies.

**Importing Xtras** provide the code required to import various types of media into Director. When you link a movie to an external file, Director uses the importing Xtra to import the media every time the movie runs. To distribute a movie with external linked media, you must also include the Xtra required to import that type of media.

**Scripting Xtras** add Lingo elements to predefined Lingo scripts. The NetLingo Xtra, for example, provides special Lingo elements for controlling Internet functions.

**Transition Xtras** supply transitions in addition to the predefined transitions available in the Frame Properties: Transition dialog box.

**Tool Xtras** provide useful functions in the authoring environment, but they don’t do anything while a movie runs. They do not have to be distributed with movies.

### About distributing movies

When you finish creating a movie, you have several choices about how to distribute it to users. You can distribute the movie as a Shockwave movie that plays within a web page or as a projector that downloads to the user’s computer or that you distribute on a disk.

- A Shockwave movie is a compressed version of the movie data only.
- A projector is a stand-alone version of a movie. You can include several movies in a single projector. Projectors appear on the system desktop as applications.

For more information about distribution options, see “About distribution formats” on page 357.

Movies distributed from the Internet can begin playing as soon as the content for the first frame is downloaded. This is called streaming. You can control streaming with behaviors that make the movie wait for media at certain frames, or you can specify that a movie download completely before it begins playing. See “Playing movies over the Internet: Overview” on page 337.

To play a Shockwave movie in a web page, create an HTML document that includes instructions for the web page’s browser to load and run the movie. Director includes a stand-alone utility named Aftershock that automatically creates an HTML file that runs your movie. You can also create an HTML document yourself by using an HTML authoring tool such as Dreamweaver.
CHAPTER 4
Sprites

Sprites: Overview

A sprite is an object that controls when, where, and how cast member media appear in a movie. Use the Stage to control where a sprite appears and use the Score to control when it appears in the movie.

For an introduction to sprites, see the Sprites topic in the Guided Tour in Director Help.

A sprite has many properties, including the sprite’s size and location, the cast member assigned to the sprite, and the frames in which the sprite occurs. There are also properties that alter the appearance of a sprite’s media. You can rotate, skew, flip, and change the color of sprite media without affecting cast members. You can change sprite properties with the Sprite Inspector or with Lingo.

In Lingo, some properties are available for certain types of sprites only. Such properties typically are characteristics related to the specific sprite type. For example, Lingo has several digital video properties that determine the contents of tracks in digital video sprites.

Multiple sprites can use the same cast member. You can also switch the cast member assigned to a sprite as the movie plays.

Sprites appear on the Stage layered according to the channel in which they appear in the Score. Sprites in higher-numbered channels appear on top of sprites in lower-numbered channels. A movie can include up to 1000 sprite channels. Use the Movie Properties dialog box to control the number of channels. See “Setting Stage and movie properties” on page 57.
Sprite inks affect the way a sprite’s colors appear on the Stage. For example, Background Transparent ink makes all white pixels transparent and removes the white border (the “bounding box”) around bitmap images (assuming the sprite is over a white background). Other inks provide more complex and interesting effects such as reversed colors or colors that change in different ways depending on the background color.

Creating sprites

You create a sprite by dragging a cast member to either the Stage or the Score; the sprite appears in both places. New sprites span 28 frames unless you change the default sprite duration. To change the default sprite duration, choose File > Preferences > Sprite; see “Changing sprite preferences” on page 91.

If the Terminate at Markers option is turned on in the Sprite Preferences dialog box, Director ends newly created sprites at markers. See “Using markers” on page 52.

To create a new sprite:

1 Click to select the frame in the Score where you want the sprite to begin.
2 From the Cast window, do one of the following:
   ▶ Drag a cast member to the Stage.
   ▶ Drag a cast member to the Score. Director places the new sprite in the center of the Stage.
   ▶ Press Alt (Windows) or Option (Macintosh) and drag a cast member to the Stage or Score to create a sprite only one frame long.

Note: When two bitmap sprites overlap on the Stage, you often notice a white box around the image. Use the Matte or Background Transparent inks to remove the white box. See “Using sprite inks” on page 88.
Selecting sprites

Before changing a sprite, you must select it. There are several different ways to select sprites, frames within sprites, and groups of sprites.

Use the arrow tool on the tool palette to select sprites prior to most operations. You can also select sprites with the rotate and skew tool to enable rotation and skewing. See “Rotating and skewing sprites” on page 83.

A selected sprite appears on the Stage with a double-border. When you select a single frame within a sprite, the sprite appears on the Stage with a single border.

![Entire sprite selected](image)

Entire sprite selected

![Single frame within sprite selected](image)

Single frame within sprite selected

When selecting sprites, you often want to select a certain frame or range of frames within the sprite instead of the entire sprite. When you make certain changes to a frame within a sprite, it becomes a selectable object called a keyframe. See “Animation: Overview” on page 187.
To select sprites:

Do one of the following:

- On the Stage, click a sprite to select the entire sprite span.
  
  You can change sprite preferences so that selecting a sprite on the Stage selects only the current frame instead of the entire sprite. See “Changing sprite preferences” on page 91.

- In the Score, click the horizontal line within a sprite bar. (Do not click the keyframes, the start frame, or the end frame).

- To select a contiguous range of sprites either on the Stage or in the Score, select a sprite at one end of the range and then Shift-click a sprite at the other end of the range. You can also drag to select all the sprites in an area.

- To select discontiguous sprites, Control-click (Windows) or Command-click (Macintosh) the discontiguous sprites.

To select a keyframe:

Do one of the following:

- To select just a keyframe, click the keyframe indicator.

- To select a keyframe and sprites at the same time, Control-click (Windows) or Command-click (Macintosh) the elements you want to select.
To select a frame within a sprite that isn’t a keyframe:

Do one of the following:

- In the Score, Alt-click (Windows) or Option-click (Macintosh) the frame within the sprite.

- On the Stage, Alt-click (Windows) or Option-click (Macintosh) to select only the current frame of the sprite. The sprite appears on the Stage with a single border.

To select all the sprites in a channel:

Click the channel number at the left side of the Score.

Layering sprites

Sprites appear in front of other sprites on the Stage according to the channel the sprite is in. Sprites in higher-numbered channels appear in front of sprites in lower-numbered channels. Sprites in higher-numbered channels hide those in lower-numbered channels.

The rocket in channel 2 appears in front of the planet in channel 1.

To change a sprite’s layer on the Stage:

1. Select the sprite. To select the contents of an entire channel, click the channel number at the left side of the Score.

2. Do one of the following:

   - Choose Modify > Arrange and select a command from the submenu to change the order of sprites.
   - Drag the sprite in the Score from one channel to another.
   - If you selected a channel, drag its contents to another channel.
Displaying and editing sprite properties

You can display and edit many sprite properties using the Sprite Inspector. In addition, the Sprite Overlay displays the most commonly used properties for selected sprites directly on the Stage. You can also display important sprite properties in the sprite labels that appear within the sprite bars in the Score.

Using the Sprite Inspector

Use the Sprite Inspector to view and edit sprite properties in either a floating window or in a toolbar at the top of the Score.

To display the Sprite Inspector in a floating window:
Choose Windows > Inspectors > Sprite.

To change the orientation of the Sprite Inspector, click inside its lower-right corner and drag. Possible orientations are vertical, horizontal, and stacked.

To show or hide the Sprite toolbar in the Score:
Choose View > Sprite Toolbar while the Score is active.
To edit sprite properties:

1. Select one or multiple sprites.

   The Sprite Inspector displays properties for the current sprite. If multiple sprites are selected, the Sprite Inspector displays their common settings.

   ![Sprite toolbar at the top of the Score](image)

   **Sprite toolbar at the top of the Score**

   - **Ink and blend**
   - **Start and end frame**
   - **Moveable, editable, and trails**
   - **Behavior pop-up menu**
   - **Foreground and background color**
   - **Flip, rotate, and skew controls**
   - **Registration point location, height, and width**
   - **Left, top, right, and bottom**

   ![Sprite inspector as a floating window](image)

   **Sprite inspector as a floating window**

   A thumbnail image of the sprite’s cast member appears in the upper-left corner of the Sprite Inspector.

2. Double-click the thumbnail image to open a window in which you can edit the sprite’s cast member.

3. From the Behavior pop-up menu, display and edit any behaviors attached to the current sprite, as follows:
   - Assign an existing behavior to a sprite. The pop-up menu lists all the behaviors in the current movie and displays the first of multiple behaviors attached to a selected sprite. Use the Behavior Inspector to see all attached behaviors.
   - Choose Clear All Behaviors to remove all behaviors from the selected frame or sprite.
   - Choose New Behavior to create a new behavior for the current frame or sprite.
4 Edit additional sprite settings:

**Ink pop-up menu** displays the ink of the current sprite and lets you choose a new ink color. See “Using sprite inks” on page 88.

**Blend** determines the blend percentage of the selected sprites. See “Setting blends” on page 87.

**Start and End** display the start and end frame numbers of the sprite. Enter new values to adjust how long the sprite plays. See “Changing how long a sprite appears on the Stage” on page 80.

**Editable** makes the selected text sprite editable on the Stage during playback. See “Using editable text” on page 279.

**Moveable** makes the selected sprite draggable on the Stage during playback. See “Making sprites editable and draggable” on page 210.

**Trails** makes the selected sprite remain on the Stage, leaving a trail of images along its path as the movie plays. If Trails is not selected, the selected sprite is erased from previous frames as the movie plays.

**Foreground and Background color boxes** determine the colors of the selected sprite. See “Changing the color of a sprite” on page 86.

**Reg Point Horizontal and Vertical** display the location of the registration point in pixels from the top left corner of the Stage. See “Positioning sprites” on page 74.

**Width and Height** show the size of the sprite’s bounding rectangle in pixels.

**Sprite coordinates** specify the exact location of a selected sprite. See “Positioning sprites” on page 74.

**Rotate angle** rotates the sprite by the number of degrees you enter. See “Rotating and skewing sprites” on page 83.

**Skew angle** slants the sprite by the number of degrees you enter. See “Rotating and skewing sprites” on page 83.

**Flip horizontal and vertical** reverses the sprite horizontally or vertically to form an inverted image. See “Flipping sprites” on page 85.

**Left, Top, Right, and Bottom** show the location of the edges of the sprite’s bounding rectangle.
Editing sprite properties with Lingo

You can use Lingo to check and edit sprite properties with scripts as the movie plays.

To check a property value:

Use the put command or check in the Watcher window. See put in the Lingo Dictionary.

To edit a property:

Use the equals operator (=) or the set command to assign a new value to the property. See = (equals) and set...to in the Lingo Dictionary.

Using the Sprite Overlay

The Sprite Overlay displays the most important sprite properties directly on the Stage. You can open editors, inspectors, and dialog boxes to change sprite properties directly from the Sprite Overlay. Click icons in the Sprite Overlay to open editing windows related to the sprite’s properties.

To use the Sprite Overlay to edit a sprite:

1. Choose View > Sprite Overlay > Settings.
2. In the Sprite Overlay panel, click the icon that represents the data you want to edit:
   - To edit the sprite’s cast member, click this icon to open the Cast Member Properties dialog box. See “Setting cast member properties” on page 108.
   - To edit for the current sprite, click this icon to open the Sprite Properties dialog box.
   - To edit for a behavior, click this icon to open the Behavior Inspector. See “Creating and modifying behaviors” on page 120.
To change the Sprite Overlay display:

1. Choose View > Sprite Overlay > Settings.

2. Choose a Display option to determine when sprite properties are visible and active:
   - **Roll Over** displays sprite properties when the pointer is over a single sprite.
   - **Selection** displays sprite properties when a sprite is selected.
   - **All Sprites** displays sprite properties for all sprites on the Stage.

3. Use the Text Color box to set the color for text displayed in the Sprite Overlay.

To change the opacity of the Sprite Overlay panel:

Drag up or down the line that appears on the right edge of the overlay panel.

### Displaying sprite labels in the Score

Sprite labels appear in the sprite bars in the Score and display important information for work on a movie. For example, if you detect a strange blip caused by an ink effect, you can turn on Ink display and quickly locate the problem in a sprite label. You can change the information that appears in labels; for example, you can use the Extended display option to display the precise location of a sprite in every frame.

To display sprite labels:

1. Choose View > Sprite Labels.

2. Choose from the following options:
   - Keyframes
   - Changes Only (shown at 800%)
   - Every frame (shown at 800%)
   - First frame

Note that many options are useful only when the Score is zoomed to 400 or 800%.
To change sprite label options:

Choose a display option from the Display pop-up menu in the Score or from the View > Display menu.

**Member** displays the name and number of the sprite’s cast member.

**Behavior** displays the behavior assigned to the sprite.

**Location** displays the X and Y coordinates of the sprite’s registration point.

**Ink** displays the ink effect applied to each sprite.

**Blend** displays the blend percentage.

**Extended** displays any combination of display options; choose options with File > Preferences > Score.
**Positioning sprites**

To position sprites in a movie, simply drag them into position on the Stage. To be more precise, you can set their position on the Stage by entering coordinates in the Sprite Inspector, for the Sprite Properties dialog box or by setting the sprite’s coordinates in Lingo. You can also position sprites by tweaking (moving them an exact number of pixels in a certain direction) or by aligning them to each other or to a grid, as described in the following sections.

The following diagram shows all of the sprite coordinates you can specify.

Director places the image of a cast member on the stage by specifying the location of its registration point. For all bitmap cast members, the registration point is in the center of the bounding rectangle by default. (For instructions on changing the location of the registration point, see “Changing registration points” on page 253). For other types of cast members, the registration point is at the upper-left corner.

**Visually positioning sprites on the Stage**

The easiest way to position sprites on the Stage is by simply dragging them or using the arrow keys.

**To visually position a sprite on the Stage:**

1. Choose Window > Stage to display the Stage.

2. Do one of the following on the Stage:
   - Drag a sprite to a new position. Hold down Shift to constrain the movement to horizontal or vertical.
   - Select a sprite and use the arrow keys to move the selected sprite 1 pixel at a time. Hold down Shift as you press an arrow key to move the selection 10 pixels at a time.
Positioning sprites with the Sprite Inspector

Use the Sprite Inspector to specify the exact coordinates of a sprite.

**To set sprite coordinates in the Sprite Inspector:**

1. Select a sprite to reposition.

2. If the Sprite Inspector is not visible, choose Window > Inspectors > Sprite to open the floating Sprite Inspector, or choose View > Sprite Toolbar while the Score is active to display the inspector at the top of the Score.

3. Specify the sprite coordinates in pixels, with 0,0 at the upper-left corner of the Stage, as follows:
   - Specify X and Y to change the horizontal and vertical coordinates of the registration point.
   - Specify W and H to change the width and height of the sprite.
   - Specify l, r, t, and b to change the left, right, top, and bottom edges of the sprite's bounding rectangle.
   
   To move the sprite without resizing it, adjust only the X and Y coordinates.

Positioning sprites with Lingo

Lingo lets you control a sprite's position by setting the sprite's coordinates on the Stage. You can also test a sprite's coordinates to determine a sprite's current position and whether two sprites overlap.

**To check the location of a sprite's registration point or bounding rectangle on the Stage:**

Test the bottom, left, loc, locH, locV, right, or top sprite property.

The bottom, left, right, and top sprite properties determine the location of the sprite's individual edges. See bottom, left, right, and top in the Lingo Dictionary.
To place a sprite at a specific location:

Set one of the following properties:

- The loc sprite property sets the horizontal and vertical distance from the upper-left corner of the Stage to the sprite’s registration point. The value is given as a point. See loc in the Lingo Dictionary.
- The locV sprite property sets the number of pixels from the top of the Stage to a sprite’s registration point. See locV in the Lingo Dictionary.
- The locH sprite property sets the number of pixels from the left of the Stage to a sprite’s registration point. See locH in the Lingo Dictionary.
- The rect sprite property sets the location of the sprite’s bounding rectangle on the Stage. See rect (sprite) in the Lingo Dictionary.
- The quad sprite property sets the location of the sprite’s bounding box on the Stage. You can specify any four points; the points do not have to form a rectangle. The quad property can set the sprite’s coordinates as precise floating-point numbers. See quad in the Lingo Dictionary.

To determine whether two sprites overlap:

Use the sprite...intersects operator to determine whether a sprite’s bounding rectangle touches the bounding rectangle of a second sprite. Use the sprite...within operator to determine whether a sprite is entirely within a second sprite. See sprite...intersects and sprite...within in the Lingo Dictionary.

Positioning sprites with the Sprite Properties dialog box

Use the Sprite Properties dialog box to quickly specify the location of the top-left corner of a sprite. Use the Sprite Inspector to change other coordinates.

To position sprites with the Sprite Properties dialog box:

1. Select the sprite or sprites you want to position, as described in "Selecting sprites" on page 65.
2. Choose Modify > Sprite > Properties.
3. In the Location text boxes, enter the number of pixels to offset the sprite from the left edge (Left text box) and top-left corner position (Top text box) of the sprite on the Stage.
Aligning sprites

Aligning sprites to one another on the Stage is essential to creating professional-looking designs. You can align sprites in multiple channels and frames, and you can align individual frames within a sprite to other sprites using the Align window.

On the Stage, you can align sprites using the grid. Moving a sprite with Snap to Grid on makes the sprite’s edges and registration point snap to the nearest grid line. You can show or hide the grid lines on the Stage and change the distance between grid lines.

To align sprites using the Align window:

1. On the Stage or in the Score, select the sprites to align.
   Select entire sprites, keyframes, or frames within sprites in as many different frames or channels as you need. All of the elements will be aligned to the last sprite or frame selected.

2. Choose Modify > Align.

3. Align the selection:
   ▶ Click an area in the preview to choose an alignment.
   ▶ Choose a vertical or horizontal alignment option from the pop-up menus.

4. Click Align.
   Close the Align window when you have finished aligning selections.
To align sprites to the grid:

1. Choose View > Grids > Snap To to turn on Snap to Grid.
2. Choose View > Grids > Show Grids to display the grid lines on the Stage.
3. Move a sprite on the stage near a grid line to make the sprite snap to that exact location.

*Note:* Press G while moving or resizing a sprite to temporarily turn Snap to Grid off or on.

To change grid settings:

1. Choose View > Grids > Settings.
2. To change the amount of space between grid lines, enter values for Spacing.
3. To specify lines or dots as the grid markers, choose a Display option.
4. To specify the color of the grid lines, choose a color from the Color box.

**Positioning sprites with the Tweak window**

Use the Tweak window when you want to move sprites by a certain number of pixels.

To position sprites with the Tweak window:

1. Choose Modify > Tweak.
2. Select the sprite or sprites you want to move, as described in “Selecting sprites” on page 65.
3. In the Tweak window, drag the point on the left side of the window or enter the number of pixels in the fields for horizontal and vertical change; then click Tweak.
4. Click Tweak again to repeat the move.
Changing the frames in which a sprite appears

A sprite controls not only where media appears on the Stage, but also when. You change when and how long a sprite appears on the Stage by moving the sprite to different frames in the Score and by changing the number of frames the sprite spans.

Changing when a sprites appears on the Stage

You change when a sprite appears in a movie by moving it to different frames in the Score. You can either drag sprites to new frames or use copy and paste. Copy and paste is easier to use when moving sprites more than one screen-width in the Score. You can also use copy and paste to move sprites from one movie to another.

Moving a sprite in the Score

To change when a sprite appears on the Stage:
1. Choose Window > Score to display the Score.
2. Select a sprite or sprites, as described in “Selecting sprites” on page 65.
3. Drag the sprite to a different frame.
   To move a two-frame sprite without stretching it (increasing its duration), hold down the spacebar and drag. This technique is useful for moving any sprite that consists mostly (or entirely) of keyframes.

To cut and paste sprites between frames:
1. Select a sprite or sprites, as described in “Selecting sprites” on page 65.
2. Choose Edit > Copy or Edit > Cut to copy or cut the sprite.
3. Position the pointer where you want to paste the sprite and choose Edit > Paste.
4. If the pasting will overwrite existing sprites, choose a Paste option in the Paste Options dialog box:
   - **Overwrite Existing Sprites** replaces the sprites with the content of the Clipboard.
   - **Truncate Sprites Being Pasted** pastes the Clipboard contents in the space available without replacing existing sprites.
   - **Insert Blank Frames to Make Room** adds new frames for the contents of the Clipboard.
Changing how long a sprite appears on the Stage

By default, Director assigns each new sprite a duration of 28 frames. You can change the duration of a sprite—that is, the amount of time the sprite appears in a movie—by adjusting its length, changing the number of frames in which it appears, or using the Extend command.

Director maintains the spacing proportions of keyframes when a sprite is lengthened. For a description of keyframes, see “Animation: Overview” on page 187.

To extend a sprite:

1. Choose Window > Score to display the Score.
2. Do one of the following:
   - Drag the start or end frames. To extend a one-frame sprite, Alt-drag (Windows) or Option-drag (Macintosh).
   - To extend a sprite and leave the last keyframe in place, Alt-drag (Windows) or Option-drag (Macintosh) a keyframe at the end of the sprite.
   - To extend a sprite and leave all keyframes in place, Control-drag (Windows) or Command-drag (Macintosh) the end frame.
   - Enter new values in the Start and End fields of the Sprite Inspector to change the start and end frames.

To extend a sprite to the current location of the playback head:

1. Select the sprite or sprites to extend.
2. Click the frame channel to move the playback head:
   - To extend the sprite, move the playback head past the right edge of the sprite.
   - To shorten the sprite, move the playback head to the left, inside the sprite.
   - To move the sprite’s start frame, place the playback head to the left of the sprite.
3. Choose Modify > Extend Sprite.
Splitting and joining sprites

You may need to split an existing sprite into two separate sprites or join separate sprites—for example, if you've created a complex animation as separate sprites and now want to move the entire sequence in the Score. Splitting and joining also lets you update movies created with older versions of Director that may have several fragmented sprites.

To split an existing sprite:

1. In the Score, click the frame within a sprite where the split will occur.
   The playback head moves to the frame.

2. Choose Modify > Split Sprite.
   Director splits the sprite into two new ones.

To join separate sprites into a single sprite:

1. Select the sprites you want to join, as described in “Selecting sprites” on page 65.
   Director fills gaps between sprites. You can also select sprites in multiple channels. Director joins selected sprites in each individual channel.

2. Choose Modify > Join Sprite.

Changing the appearance of sprites

You can change the appearance of sprites on the Stage without affecting the cast member assigned to the sprite. You can resize, rotate, skew, flip, and apply new foreground and background colors to sprites. Applying these changes allows you to reuse the same cast member to create several different versions of an image. For example, you can create a flipped and rotated version of a cast member with a new color. Since each cast member adds to downloading time, reusing cast members in this way reduces the number of cast members in your movie and makes it download faster.
Resizing and scaling sprites

You can resize sprites directly on the Stage by dragging handles. To resize the sprite precisely, you can enter coordinates in the Sprite Inspector, scale sprites by a specified percentage in the Sprite Properties dialog box, or set the sprite's size with Lingo.

Changing a sprite's size on the Stage doesn't change the size of the cast member assigned to the sprite, nor is the size of the sprite affected if you resize its cast member.

In some cases, resizing bitmap sprites can cause noticeable delays. If a bitmap sprite must be a particular size, make the cast members displayed in the sprite the proper size. You can do this with Modify > Transform Bitmap or in any image editing program. Scaling and resizing sprites works best with vector shapes.

To resize a sprite by dragging its handles:

1. Select the sprite.
2. On the Stage, drag any of the sprite's resize handles. Hold down Shift to maintain the sprite's proportions.

To scale a sprite by an exact percentage:

1. Select the sprites you want to scale.
2. Choose Modify > Sprite > Properties.
3. In the Scale text box, enter a percentage.
   The sprite is scaled relative to its current size, not to the size of its parent cast member.

To resize a sprite with the Sprite Inspector:

1. Select a sprite.
2. Change values for Width, Height, Left, Right, Top, or Bottom.
   Left, Right, Top, and Bottom resize the sprite by moving only one side of the sprite.

To restore a sprite to its original dimensions:

Choose Modify > Transform > Reset Width and Height or Reset All.
To resize a sprite’s bounding rectangle with Lingo:

Set the sprite’s quad or rect sprite property. See quad or rect (sprite) in the Lingo Dictionary.

The rect sprite property determines the coordinates of a sprite’s bounding rectangle. The coordinates are given as a rect value, which is a list of the left, top, right, and bottom coordinates.

To change a sprite’s height or width with Lingo:

Set the height or width sprite property. See height and width in the Lingo Dictionary.

Rotating and skewing sprites

Rotate and skew sprites to turn and distort images and to create dramatic animated effects. You can rotate and skew sprites on the Stage by dragging. To rotate and skew sprites more precisely, use Lingo or the Sprite Inspector to enter degrees of rotation or skew. The Sprite Inspector is also especially useful for rotating and skewing several sprites at once by the same angle. Director rotates a sprite around its registration point. You can change the location of the registration point using the Paint window. See “Changing registration points” on page 253.

Rotation changes the angle of the sprite. Skewing changes the corner angles of the sprite’s rectangle.

After a sprite is rotated or skewed, you can still resize it.

Director can automatically change rotation and skew from frame to frame to create animation. See “Tweening other sprite properties” on page 191.

Director can rotate and skew bitmaps, text, vector shapes, Flash movies, QuickTime videos, and animated GIFs.
To rotate or skew a sprite on the Stage:

1. Select a sprite on the Stage.
2. Choose Window > Tool Palette to display the tool palette.
3. Click the rotate tool in the tool palette.
   You can also press Tab while the Stage window is active to choose the rotate tool.
   The handles around the sprite change to indicate the new mode.

4. Do either of the following:
   ▶ To rotate the sprite, move the pointer inside the sprite and drag in the direction you want to rotate.
   ▶ To skew the sprite, move the pointer to the edge of the sprite until it changes to the skew pointer and then drag in the direction you want to skew.

To rotate or skew a sprite with the Sprite Inspector:

1. Select the sprites you want to rotate or skew.
2. Choose Window > Sprite Inspector.
3. To rotate the selected sprites, enter the number of degrees in the Rotation box.
4. To skew the selected sprites, enter the number of degrees in the Skew box.
To resize rotated and skewed sprites:
Do any of the following:

► Click the rotate or skew tool and drag any of the sprite’s handles. Alt-drag (Windows) or Option-drag (Macintosh) to maintain the sprites proportions as you resize.

► Enter new values in the Sprite Inspector.

Director resizes the sprites at the current skew or rotation angle.

To restore a skewed or rotated sprite to its original orientation:
Choose Modify > Transform > Reset Rotation and Skew or Reset All.

To skew a sprite with Lingo:
Set the skew sprite property. See skew in the Lingo Dictionary.

Flipping sprites
Flipping a sprite creates a horizontally or vertically inverted image of the original sprite.

To flip a sprite:
1 Select a sprite.
2 Do any of the following:

► Click the Flip Vertical or Flip Horizontal button on the Sprite Inspector to flip the sprite without moving the registration point or changing the current skew or rotation angles.

► Choose Modify > Transform > Flip Horizontal in Place or Flip Vertical in Place to flip the sprite so that its bounding rectangle stays in place and the registration point is moved, if necessary.

► Choose Modify > Transform > Mirror Horizontal or Mirror Vertical to flip the sprite without moving the registration point, but inverting the skew and rotation angles.
Changing the color of a sprite

You can tint or color sprites by choosing new foreground and background colors from the Sprite Inspector or with Lingo. Choosing a new foreground color changes black pixels within the sprite to the selected color and blends dark colors with the new color. Choosing a new background color changes white pixels within the sprite to the selected color and blends light colors with the new color.

Director can animate foreground and background color changes in sprites, shifting gradually between the colors you specify in the start and end frames of a sprite. See “Tweening other sprite properties” on page 191.

To reverse the colors of an image, change the foreground color to white and the background color to black.

To change the color of a sprite:

1. Select a sprite.
2. Do one of the following:
   - Choose colors from the Foreground and Background color boxes in the Sprite Inspector.
   - Enter RGB values (hexadecimal) or palette index values (0-255) for the foreground and background colors in the Sprite Inspector.

To change the color of a sprite with Lingo:

Set the appropriate sprite property:

- The `color` sprite property sets the sprite's foreground color. The value is an RGB value. See `color` (sprite property) in the Lingo Dictionary.
- The `bgColor` sprite property sets the sprite's background color. The value is an RGB value. See `bgColor` in the Lingo Dictionary.
Setting blends

Use blending to make sprites transparent. Change a sprite’s blend setting in the Sprite Inspector.

Director can gradually change blend settings to make sprites fade in or out. See “Tweening other sprite properties” on page 191.

The Blend percentage value affects only Copy, Background Transparent, Matte, Mask, and Blend inks.

To set blending for a sprite:

1 Select the sprite.
2 Choose a percentage from the Blend pop-up menu in the Sprite Inspector.

To set blending with Lingo:

Set the blend sprite property. See blend in the Lingo Dictionary.
Using sprite inks

You can change a sprite’s appearance on the Stage by applying inks. Sprite inks change the display of a sprite’s colors. Inks are most useful to hide white bounding boxes around images, but they can also create many compelling and useful color effects. Inks can reverse and alter colors, make sprites change colors depending on the background, and create masks that obscure or reveal portions of a background.

For an animated demonstration and description of all the inks, see Director Help.

Use copy ink to achieve the fastest and animation rendering on the screen; other ink types may have a slight effect on performance.

Some inks work differently in Director 7 than they did in Director 6. For example, several inks ignore blend settings in Director 6 but recognize them in Director 7. To make inks work exactly as they did in Director 6, turn on Maintain Outdated Ink Mode Limitations in the Movie Properties dialog box.

Text cast members support only Copy, Background Transparent, and Blend inks.

Choosing inks

You change the ink for a sprite in the Sprite Inspector or with Lingo.

To change a sprite’s ink with the Sprite Inspector:

1. Select the sprite.
2. Choose the type of ink you want from the Ink pop-up menu in the Sprite Inspector.
To change a sprite’s ink with Lingo:

Set the sprite’s ink sprite property. See ink in the Lingo Dictionary.

Note: If Background Transparent and Matte inks don’t seem to work, the background of the image may not be true white. Also, if the edges of the image have been blended or are fuzzy, applying these inks may create a halo effect. Use the Paint window or an image editing program to change the background to true white and harden the edges. You can also re-create the image with an alpha channel (transparency) and re-import the image.

Using Mask ink to create transparency effects

Use Mask ink to reveal or tint certain parts of a sprite. Mask ink lets you define a mask cast member that controls the degree of transparency for parts of a sprite.

Black areas of a mask cast member make the sprite completely opaque in those areas, and white areas make it completely transparent (invisible). Colors between black and white are more or less transparent; darker colors are more opaque.

When creating a bitmap that is to serve as the mask for a sprite, use a grayscale palette if the mask cast member is an 8-bit (or less) image. An 8-bit mask affects only the transparency of the sprite and does not affect the color. Director ignores the palette of mask cast members that are less than 32-bit images; using a grayscale palette lets you view the mask in a meaningful way. If your mask cast member is a 32-bit image, the colors of the mask tints the sprite’s colors.

If you do not need variable levels of opacity, use a 1-bit mask cast member to conserve memory and disk space.

There are many ways to use Mask ink, but the following procedure explains the most basic method.

To use Mask ink:

1. Decide which cast member you want to mask.
   The cast member can be a bitmap of any depth.

2. In the next position in the same cast, create a duplicate of the cast member to serve as the mask.
   The mask cast member can actually be any image, but a duplicate of the original is usually the most useful.

3. Edit the mask cast member in the Paint window or any image editor.
   Black areas of the mask make the sprite completely opaque in those areas, and white areas make it completely transparent (invisible).

4. Drag the original cast member to the Stage or Score to create a sprite.

5. Make sure the new sprite is selected and choose Mask ink from the ink pop-up menu in the Sprite Inspector.
   Only the parts of the sprite revealed by the mask are visible on the Stage.
About Darken and Lighten inks

Darken and Lighten inks provide a great deal of control over the RGB properties of a sprite. Use them to create color effects in sprites varying from the subtle to the surreal.

Darken and Lighten both change how Director applies the foreground and background color properties of a sprite. Darken makes the background color equivalent to a color filter through which the sprite is viewed on the Stage. Lighten ink tints the colors in a sprite lighter as the background color gets darker. For both inks, the foreground color is added to the image to the degree allowed by the other color control. Neither ink has any effect on a sprite until you change the foreground or background color from the default settings of black and white.

These effects are much easier to see than to explain, so experiment to learn about the possibilities.

Darken and Lighten are especially useful for animating unusual color effects. Because the Foreground and Background color properties of the sprite control the effects, you can animate color shifts to create dazzling effects without having to manually edit colors in a cast member. See “Tweening other sprite properties” on page 191.

Assigning a cast member to a sprite with Lingo

Several Lingo properties specify which cast member is assigned to a sprite. You can use these properties to determine a sprite's cast member and switch the sprite's cast members as the movie plays.

To specify the cast member, including its cast:

Set the member sprite property. See member (sprite property) in the Lingo Dictionary.

Setting this property is the most reliable way to specify a sprite's cast member. You can also set the memberNum sprite property but this is reliable only when the new cast member is in the same cast as the current cast member.

To determine which cast contains the cast member assigned to a sprite:

Test the castLibNum sprite property. See castLibNum in the Lingo Dictionary.

This procedure can be useful for updating movies that serve as templates.
Changing sprite preferences

Use the sprite preferences dialog box to control the way sprites behave and appear in the Score window and on the Stage.

To change preferences for sprites:


2. To determine if selecting a sprite on the Stage selects the entire span of the sprite or only the current frame in the sprite, choose a Stage Selection option:
   - Entire Sprite selects the sprite in all frames that it occupies.
   - Current Frame Only selects only the current frame of the sprite.

3. To determine the appearance and behavior of sprites yet to be created, choose Span Defaults options. These options do not change settings for existing sprites.
   - Display Sprite Frames turns on Edit Sprite Frames for all new sprites. See “Editing sprite frames” on page 196.
   - Tweening turns on tweening for all tweenable properties. This option is on by default. With this option off, sprites must be manually tweened when new frames or keyframes are added to the sprite.

4. To determine the length of sprites measured in frames, choose Span Duration options:
   - Frames defines the default number of frames for sprites.
   - Width of Score Window sets the sprite span to the visible width of the Score window.
   - Terminate at Markers makes new sprites end at the first marker encountered. See “Using markers” on page 52.
Working with cast members and casts: Overview

A cast member is any media element in a movie. Cast members include bitmaps, vector shapes, text, scripts, sounds, Flash movies, QuickTime and AVI videos, and more.

For an introduction to cast members, see the Cast Members topic in the Guided Tour in Director Help.

Director organizes cast members into groups called casts. Once you have created the necessary casts, you can import and create cast members to populate them.
Casts can be internal—stored inside the movie file and exclusive to that movie—or external—stored outside the movie file and available for sharing with other movies.

**Internal casts**

**External casts**

External casts are useful for storing elements used by different movies and creating libraries of commonly used cast members such as buttons and behaviors. You can also use external casts to switch entire groups of media at run time, as when switching languages. External casts are often useful in keeping movie size small for downloading; an external cast file can be downloaded separately from the movie file if or when it is needed.

You can create and edit cast members in Director using basic tools and media editors such as the Paint and Text windows, and you can edit cast members using external editors. You can also import cast members from nearly every popular media format into a movie file and link cast members to external files on a disk or the Internet for dynamic updating.
Using the Cast window

Use the Cast window to manage and display all media in a movie, move groups of cast members, and change cast member settings. The Cast window can display any of the cast members in the current movie. For information on creating a cast, see “Creating casts” on page 112.

Use the Cast window to change the cast displayed, enter cast member names, and open cast member properties. You can also launch editors for cast members directly from the Cast window. The title bar displays the name of the current cast. The Cast window displays a thumbnail images and other information for each cast member.

To open a cast in a new Cast window:

Choose Window > Cast or press Control-3 (Windows) or Command-3 (Macintosh). If there is more than one cast in the movie, select a cast name from the Cast menu.
For every occupied position in the Cast window, Director displays an icon that represents the media type of the cast member, as follows:

<table>
<thead>
<tr>
<th>Cast member type</th>
<th>Icon</th>
</tr>
</thead>
<tbody>
<tr>
<td>Animated GIF</td>
<td><img src="image" alt="Animated GIF Icon" /></td>
</tr>
<tr>
<td>Behavior</td>
<td><img src="image" alt="Behavior Icon" /></td>
</tr>
<tr>
<td>Bitmap</td>
<td><img src="image" alt="Bitmap Icon" /></td>
</tr>
<tr>
<td>Button</td>
<td><img src="image" alt="Button Icon" /></td>
</tr>
<tr>
<td>Check box</td>
<td><img src="image" alt="Check box Icon" /></td>
</tr>
<tr>
<td>Custom Cursor</td>
<td><img src="image" alt="Custom Cursor Icon" /></td>
</tr>
<tr>
<td>Digital video</td>
<td><img src="image" alt="Digital video Icon" /></td>
</tr>
<tr>
<td>Field</td>
<td><img src="image" alt="Field Icon" /></td>
</tr>
<tr>
<td>Film loop</td>
<td><img src="image" alt="Film loop Icon" /></td>
</tr>
<tr>
<td>Font</td>
<td><img src="image" alt="Font Icon" /></td>
</tr>
<tr>
<td>Flash movie</td>
<td><img src="image" alt="Flash movie Icon" /></td>
</tr>
<tr>
<td>Linked bitmap (all linked cast member icons are changed in the same way)</td>
<td><img src="image" alt="Linked bitmap Icon" /></td>
</tr>
<tr>
<td>OLE</td>
<td><img src="image" alt="OLE Icon" /></td>
</tr>
<tr>
<td>Palette</td>
<td><img src="image" alt="Palette Icon" /></td>
</tr>
<tr>
<td>PICT</td>
<td><img src="image" alt="PICT Icon" /></td>
</tr>
<tr>
<td>Cast member type</td>
<td>Icon</td>
</tr>
<tr>
<td>-----------------------</td>
<td>------</td>
</tr>
<tr>
<td>QuickTime video</td>
<td>🎥</td>
</tr>
<tr>
<td>Radio button</td>
<td>🎧</td>
</tr>
<tr>
<td>Script</td>
<td>🗄</td>
</tr>
<tr>
<td>Shape</td>
<td>🗄</td>
</tr>
<tr>
<td>Shockwave Audio</td>
<td>🔊</td>
</tr>
<tr>
<td>Sound</td>
<td>🔊</td>
</tr>
<tr>
<td>Text</td>
<td>📧</td>
</tr>
<tr>
<td>Transition</td>
<td>🎥</td>
</tr>
<tr>
<td>Vector shape</td>
<td>🗄</td>
</tr>
<tr>
<td>Xtra</td>
<td>🎥</td>
</tr>
</tbody>
</table>

To turn the display of cast member icons off or on and change the Cast window display:

Choose File > Preferences > Cast see “Setting cast window display options,” in Director Help.
Using Cast window controls

Use the controls at the top of the Cast window to change the cast displayed in the Cast window, the cast member selection, or the name of cast member. You can also move cast members and open a cast member's Script window or Properties dialog box.

To change the cast displayed in the current Cast window or media editor:

Do one of the following:

▼ Click the Cast button and choose a cast from the pop-up menu.

▼ Alt-click (Windows) or Option-click (Macintosh) the Cast button and choose a cast from the pop-up menu to open the cast in a new Cast window.

To select the previous or next cast member:

Click the Previous or Next cast member button.

To drag a selected cast member to a new position in the Cast window:

Drag from the Drag Cast Member well to the desired position in the cast. This procedure is useful when the selected cast member has scrolled out of view.

To enter a cast member name:

Enter the name in the Cast Member Name box.

To edit a cast member script:

Click the Cast Member Script button.

To view cast member properties:

Click the Cast Member Properties button. See Changing cast properties in Director Help.

To view the cast member number:

Look at the Cast Member Number field.
**Selecting cast members in the Cast window**

Before changing cast members, you must select them in the Cast window.

**To select a range of cast members:**

1. Click the first cast member in the range.
2. Shift-click the last cast member in the range.

![Selecting cast members](image)

**To select multiple nonadjacent cast members:**

Control-click (Windows) or Command-click (Macintosh) all the cast members you want to select.

![Selecting multiple nonadjacent cast members](image)

**Moving cast members in the Cast window**

When you move a cast member to a new position, Director assigns it a new number and updates all references to the cast member in the Score, but it doesn’t automatically update references to cast member numbers in Lingo scripts.

**To move a cast member to a new position or a different cast:**

Drag the cast member to a new position in any open Cast window.

![Moving cast members](image)

A highlight bar appears to show you where the cast member will be placed.
To cut, copy, and paste cast members in a new position or a different cast:

Select a cast member, choose Cut or Copy from the Edit menu, select a position in any open Cast window, and then choose Paste.

To move a cast member to a position not presently visible:

1. Select the cast member you want to move.
2. Scroll the Cast window to display the destination position.
3. Drag from the Drag Cast Member button to the destination position.

Naming cast members

To avoid problems in Lingo when moving cast members, name cast members and refer to them by name. Naming cast members doesn’t affect performance. The name stays the same even if the cast member number changes. Avoid duplicating cast member names. If more than one cast member has the same name, Lingo uses the cast member with the lowest number in the cast.

To name a cast member:

- Select the cast member in the cast and enter a name in the Cast Member name field at the top of the Cast window or in any of the editing windows.

Enter the cast member name here.

- Enter a name in the Cast Member Properties dialog box.

To name a cast member with Lingo:

Set the `name` cast member property. See `name` in the Lingo Dictionary.
Launching cast member editors

You can open any cast member in the appropriate editor directly from the Cast window. You can use Director’s internal media editors such as the Text, Paint, or Vector Shape window, or you can specify external editors for certain types of cast members. See “Launching external editors” in Director Help.

To launch an editor for a cast member:

Do one of the following:

► Double-click a cast member in the Cast window.
► Double-click a sprite containing the cast member in the Score.

Organizing casts

The Sort command in the Modify menu helps clean up and organize the Cast window. Use Sort to order cast members by their media type, name, size, or usage in the Score. You can also use sort to remove empty positions in a Cast window.

Note: Make sure that cast members are named and referred to by name before sorting. When you sort a cast, Director moves many cast members to new positions in the Cast window. If you’ve written Lingo scripts that refer to cast members by number, Lingo won’t be able to find cast members that have been moved. Then you’ll need to update each reference number every time you sort the cast.

To sort the cast:

1 Click the Cast window you want to sort to bring it to the front.
2 Select the cast members you want to sort or choose Edit > Select All.
3 Choose Modify > Sort.
4 In the Sort Cast Members dialog box, choose a sorting method.

Usage in Score places selected cast member used in the Score at the beginning of the selection.

Media Type groups all cast members according to their media type.

Name groups the selection alphabetically by cast member name.

Size arranges the selection according to size.

Empty at End places all empty cast positions in the selection at the end.

5 Click Sort.

Director reorders the cast members according to the sorting method you selected. The Score automatically adjusts to the new cast member numbers.
Creating cast members

You can create several types of cast members in Director. Director includes editors for creating common types of media such as text, shapes, and bitmaps and for basic editing of media imported from other applications. You can also define external editors to launch from within Director when you double-click a cast member, and edit almost any type of supported media. See “Launching external editors,” in Director Help.

To create a new cast member from the Insert menu:

1 To place a cast member in a specific position, select the position. Otherwise, Director places the new cast member in the first empty position at or after the current selection in the Cast window.

2 To create a media element cast member, choose Insert > Media Element and then choose the type of cast member to create. For more information on each choice, see the following sections:
   ▶ “Paint window basics” on page 243
   ▶ “Using the Color Palettes window” on page 175
   ▶ “Importing digital video” on page 299
   ▶ “Using Shockwave audio” on page 294.
   ▶ “Creating text cast members” on page 272
   ▶ “Embedding fonts in movies” on page 270
   ▶ “Creating an animated color cursor cast member” on page 216
   ▶ “Using animated GIFs” on page 241
   ▶ “Drawing vector shapes” on page 234
   ▶ “Using Flash Movies” on page 314

3 To create a control or button, choose from the following options:
   ▶ Choose Insert > Controls > Field to create a corresponding cast member. Creating a field cast member also creates a sprite on the Stage. See “Working with fields” on page 281.
   ▶ Choose Insert > Control > Push Button, Radio Button, or Check Box to create a button cast member and a sprite on the Stage. See “Using shapes” on page 266.
   ▶ Choose Insert > Control > ActiveX to create an ActiveX cast member. See “Using ActiveX controls” on page 332.
To create a cast member in a media editing window:

Click the new cast member button in any of the media editing windows (Paint, Text, Script, and so on) to create a cast member of the corresponding type.

Importing cast members

Importing lets you create cast members from external media. You can either import data into a Director movie file or create a link to the external file and re-import the file each time the movie opens. Linked files let you display dynamic media from the Internet, such as sports scores, sounds, and weather pictures, and makes downloading movies faster. See “About linking to files” on page 106.

Director can import cast members from almost every popular media file format. See “About import file formats” on page 105.

You can import files with the Import dialog box, by dragging files from the desktop to a Cast window, or with Lingo.

To import cast members and specify import options:

1 Select an empty position in a cast.
   If no cast position is selected, Director places the new cast members in the first available position in the current cast.

2 Choose File > Import.

3 To select a file or files to import, choose from the following options:
   ▶ In the Import dialog box, choose the type of media to import from the Files of Type (Windows) or Show (Macintosh) pop-up menu. All the files in the current directory appear unless you make a selection.
   ▶ Double-click files to add them to the import list. You can switch folders and import files from different folders at the same time.
   ▶ To import from the Internet, click Internet and enter a URL.
4 From the Media pop-up menu at the bottom of the dialog box, choose an option to specify how to treat imported data:

- Standard Import imports all selected files, storing them inside the movie file but not updating them when changes are made to the source material. If you selected the option to import from the Internet in step 3, Director retrieves the file immediately from the Internet if a connection is available.

- Link to External File creates a link to the selected files and imports the data each time the movie runs. If you choose to import from a URL via the Internet, the media is dynamically updated. See “About linking to files” on page 106.

- Include Original Data for Editing preserves the original data in the movie file for use with an external editor. When this option is selected, Director keeps a copy of the original cast member data and sends the original to the external editor when you edit the cast member. This option preserves all of the editor's capabilities. For example, if you specify Photoshop to edit PICT images, Director maintains all of the Photoshop object data. See “Launching external editors,” in Director Help.

- Import Pict File as PICT prevents PICT files from being converted to bitmaps. See “Setting import options for PICS and Scrapbook files,” in Director Help.

5 If you selected a PICS or Scrapbook file to import, click Options to specify options for these files. See Setting import options for PICS and Scrapbook files,” in Director Help.

6 When you've finished selecting the files, click Import. If you've imported a bitmap with a color depth or color palette that differs from the current movie, the Image Options dialog box appears in which you must enter additional information. See “Choosing import image options” in Director Help.

For information on importing specific media, see these sections:

- “About importing bitmaps” on page 240
- “Importing digital video” on page 299
- “Using Director movies within Director movies” on page 326
- “Importing internal and linked sounds” on page 290
- “Text: Overview” on page 269
- “Using animated GIFs” on page 241
- “Using Flash Movies” on page 314
To import files by dragging:

1. On the system desktop, select a file or files to import.
2. Drag the files from the desktop to the Cast window.

To import files with Lingo:

Use the `importFileInto` command to import a file. Set the `fileName` cast member property to assign a new file to a linked cast member. See `importFileInto` and `fileName` in the Lingo Dictionary.

About import file formats

Director can import files in all the formats listed in the following table. For information on additional file formats Director may support, see the Director Developers Center web site.

<table>
<thead>
<tr>
<th>Type of file</th>
<th>Supported formats</th>
</tr>
</thead>
<tbody>
<tr>
<td>Animation and multimedia</td>
<td>Flash movies, Animated GIF, PowerPoint presentations, Director movies, Director external cast files</td>
</tr>
<tr>
<td>Image</td>
<td>BMP, GIF, JPEG, LRG (xRes), Photoshop 3.0 (or later), MacPaint, PNG, TIFF, PICT, Targa</td>
</tr>
<tr>
<td>Multiple image file</td>
<td>Windows only: FLC, FLI Macintosh only: PICS, Scrapbook</td>
</tr>
<tr>
<td>Sound</td>
<td>AIFF, WAV, MPEG3, Shockwave Audio, Sun AV, uncompressed and IMA compressed Macintosh only: System 7 sounds</td>
</tr>
<tr>
<td>Video</td>
<td>QuickTime 2 and 3 Windows only: AVI</td>
</tr>
<tr>
<td>Text</td>
<td>RTF, HTML, ASCII (often called Text Only)</td>
</tr>
<tr>
<td>Palette</td>
<td>PAL, Photoshop, CLUT</td>
</tr>
</tbody>
</table>
About linking to files

Director re-imports media every time a movie runs when Link to External File is selected in the Import dialog box. Linking makes it easier to use bulky media such as long sounds and is especially useful for showing media from the Internet that changes frequently. Linking also makes downloading movies faster; users can choose to view linked files, so the files are not downloaded unless they’re needed.

When you link to an external file, Director creates a cast member that stores the name and location of the file. Saving a movie saves only the link to the linked cast member. Keep linked files in a folder that’s close to the original movie file. Pathnames are restricted to 255 characters by the system. URLs can be up to 260 characters. If you store files too many folders away from the movie or using a very long URL, it may fail to link correctly.

When distributing movies with linked media, follow these guidelines:

- If you distribute a movie, you also must include all linked cast members, and they must be in their expected locations. In addition, the Xtras used to import the media must be present when the movie runs (either on the user’s computer or included in your movie.) For more information, see “Managing Xtras for distributed movies” on page 354.

- When linking to media on the Internet, the media must be present at the specified URL when the movie runs. Provide for link failure, because you can’t guarantee that an Internet transaction will be successful.

- To retrieve media from the Internet during playback, Director requires that the projector include certain Xtras. To include these Xtras automatically, click Add Network in the Movie Xtras dialog box. See “Managing Xtras for distributed movies” on page 354. (Movies playing in web browsers do not require these Xtras.)

**Note:** Use File > Preferences > Network to define standard network settings for the Director authoring environment; see the Network Preferences topic in Director Help.

Finding cast members

You can search for cast members by name, type, and color palette. You can search for selected cast members used in the Score—for example, when you are preparing a movie for distribution. You can also search for cast members that are not used in the Score—for example, to clean up a movie and reduce the space and memory required to save and run the movie.

Before releasing a movie, it’s a good idea to remove unused cast members to make the movie as small as possible for downloading.
To find cast members:

1. Choose Edit > Find > Cast Member.

2. In the Find Cast Member dialog box, choose a cast to search from the Cast pop-up menu.
   Choose All Casts to search every cast in the movie.

3. Choose a search option:
   - Select Name and enter search text in the text box. For example, search for a group of related cast members that share a common element in their names (such as Bird 1, Bird 2, and so on).
   - Select Type and choose an option from the pop-up menu to search for cast members by media type.
   - Select Palette and choose an option from the pop-up menu. You can use this option to search for and resolve palette conflicts.
   - Select Not Used in Score to locate all cast members that aren’t used in the Score. Note that cast members found with this option may be used in the movie by a Lingo script.

4. When Director displays the found cast member:
   - Choose a cast member on the list and click Select to close the dialog box and select the cast member in the Cast window.
   - Click Select All to close the dialog box and select all listed cast members in the Cast window.

To find a cast member in the Score:

1. Select a cast member you want to search for in the cast or the Score. If you select a sprite, Director searches for the first cast member in the sprite; to select a cast member other than the first, open the sprite to select a cast member.

2. Choose Edit > Find > Selection or press Control-H (Windows) or Command-H (Macintosh).
   Director searches the Score and highlights the first Score cell it finds.

3. Choose Edit > Find Again to find the next occurrence of the cast member in the Score.
Setting cast member properties

You can display and set properties for individual cast members or groups, even if they are different types, using the Cast Member Properties dialog box. You can also use this feature to specify the size of a group of cast members.

To display and edit cast member properties:

1. Select a cast member or group of cast members.
2. To open the Cast Member Properties dialog box, do one of the following:
   - Select a cast member in the Cast window and choose Modify > Cast Member > Properties.
   - Right-click (Windows) or Control-click (Macintosh) a cast member and choose Cast Member Properties from the menu that appears.
   - In the Cast window, or any of the editing windows (for example, the Paint window), click the Cast Member Properties button.

The dialog box displays the selected cast member’s name, type, and size in kilobytes, the number of cast members, and special options for different cast member types. For type, Multiple appears if several cast members are selected, unless all the selected cast members are the same type.

3. For an Xtra cast member, click Options to display an Options dialog box and define the appearance and behavior of the selected cast member.

The content of the Options dialog box is determined by the developer of the Xtra; not all Xtras have these additional options. For non-Macromedia Xtras, refer to documentation supplied by the developer.
For information on specific cast member properties, see these topics in Director Help:

- “Using animated GIFs”
- “Embedding fonts in movies”
- “Using Flash movies”
- “Setting bitmap cast member properties”
- “Setting vector shape cast member properties”
- “Setting button cast member properties”
- “Setting digital video cast member properties”
- “Setting film loop cast member properties”
- “Setting palette cast member properties”
- “Setting PICT cast member properties”
- “Setting shape cast member properties”
- “Setting sound cast member properties”
- “Setting text cast member properties”
- “Setting field cast member properties”
- “Setting transition cast member properties”
- “Setting Xtra cast member properties”
- “Creating an animated color cursor cast member”
- “Streaming linked Shockwave Audio files”
Controlling cast member unloading

When Director runs low on memory, it removes cast members from memory. Use Cast member properties to specify the priority with which a cast member is removed from memory. When a cast member is available in memory, it appears almost instantly. When it needs to be loaded from disk, it can cause a delay. Set your cast members so that frequently used cast members remain in memory as long as possible.

These settings are the same for all types of cast members.

To remove cast members from memory:

1. Select a cast member or group of cast members.
2. Choose Modify > Cast Member > Properties.
3. Choose an option from the Unload pop-up menu:
   - 3—Normal sets the selected cast members to be removed from memory after all purge priority 2 cast members have been removed.
   - 2—Next sets the selected cast members to be among the next removed from memory.
   - 1—Last sets the selected cast members to be the last removed from memory.
   - 0—Never retains the selected cast members in memory; these cast members are never purged.

Creating custom cast member thumbnail

You can create a unique thumbnail image for any cast member. The thumbnail image is the small picture that appears in the cast position in the Cast window or in the upper left corner of the Sprite inspector. A thumbnails image also appears in the Library inspector. Unless you define a custom thumbnail, Director displays a scaled version of the cast member. Creating a custom thumbnail is most useful for behaviors (which have no identifying image) you want to identify in the Library palette.
To change a cast member thumbnail:

1. Copy to your system clipboard a bitmap image to use as the new thumbnail.
   You can copy the image from any bitmap editor, including the Paint window.
   The image can be of any size, but smaller images look better because they
   require less scaling.

2. Select a cast member in the Cast window.

3. Choose Modify > Cast Member > Properties.

4. Click the down arrow in the lower left corner of the cast member thumbnail
to open a pop-up menu and choose Paste.

The image from the clipboard replaces the current cast member thumbnail.
You can also copy or remove the current thumbnail with the other commands
on the menu.

Setting cast member properties from Lingo

Lingo lets you control and edit cast members by setting their properties. Some
properties are available for every type of cast member. Other properties are
available only for specific cast member types.

Lingo can set several properties for all cast members:

To specify the cast member’s content:
Set the media cast member property. See media in the Lingo Dictionary.

To specify the cast member’s name:
Set the name cast member property. See name (cast member property) in the
Lingo Dictionary.

To specify the cast member’s purge priority:
Set the purgePriority cast member property. See purgePriority in the Lingo Dictionary.

To specify the content of the script, if any, attached to the cast member:
Set the scriptText cast member property. See scriptText in the Lingo Dictionary.
For additional cast member properties that Lingo can test and set, see the sections
that discuss the specific cast member type.
Working with casts

Before assembling a large number of cast members, it’s good practice to create the casts necessary to keep them organized. You can sort casts by type, edit cast properties, and use external casts for storing and sharing common media elements.

Creating casts

Create as many casts as necessary; the number of casts does not affect the size of a movie for downloading.

You can include up to 32,000 cast members in a single cast, but it’s better to group media such as text, buttons, and images logically in a few different casts for each movie.

To create a new cast:

2. Type a name for the new cast.
3. Specify how the cast is stored:
   - **Internal** stores the cast within the movie file. This option makes the cast available only to the current movie.
   - **External** stores the cast in a separate file outside the movie file. This option makes the cast available for sharing with other movies. See “Managing external casts” on page 113.
4. If you chose External, deselect the Use in Current Movie option if you don't want to use the cast in the current movie.
   - For information about internal and external casts, see “Working with cast members and casts: Overview” on page 93.
5. Click Create.
Changing cast properties

Use the Cast Properties option to change the name of a cast and define how it is loaded into a memory.

To change cast properties:

1. Select the cast for which you want to change properties.
2. Choose Modify > Cast Properties.
3. To change the name of the current cast, enter the new name in the Name box.
4. Choose a Preload option to define how cast members are loaded into memory when the movie runs:
   - **When Needed** loads each cast member into memory when it is required by the movie. This setting can slow down the movie while it plays, but it makes the movie begin playing sooner. This setting is the best choice when controlling cast members loading with Lingo.
   - **After Frame One** loads all cast members (except those required for frame 1) when the movie exits frame 1.
   - **Before Frame One** loads all cast members before the movie plays frame 1. This setting makes the movie take longer to start playing, but it provides the best playback performance if there is enough memory to hold all cast members.

Managing external casts

An external cast is a separate file that must be explicitly linked to a movie for the movie to use its cast members.

If you link an external cast to a movie, Director opens the cast every time it opens the movie. If you don’t link an external cast to a movie, you must open and save the file separately. Use unlinked external casts as libraries to store commonly used elements for authoring, such as scripts, buttons, and so on; see “Creating libraries” on page 114.

When you distribute a movie that uses an external cast, you must include the external cast file. For disk-based movies, the cast must be in the same position relative to the movie as it was when the movie was created. For Shockwave movies on the web, the cast must be at the specified URL.

To link an external cast to the current movie:

Do one of the following:

- Open an external cast and then drag a cast member from the external cast to the Stage or Score. A dialog box offers you the choice of linking the cast to the movie or copying the cast member to an internal cast.
- Import a cast with File > Import.
To link an external cast to a movie without adding a cast member:

1. Choose Modify > Movie > Casts.
2. In the Movie Casts dialog box, click Link.
3. Locate and select the external cast you want and then click Open.
   
   You can link to casts on your local disk or to casts stored at any URL. Click Internet to enter a URL for a linked external cast.
4. Click OK.

To unlink a cast from a movie:

1. Choose Modify > Movie > Casts.
2. In the Movie Casts dialog box, select the external cast.
3. Click Remove.

To save a movie and all open casts, linked or unlinked:

Choose Save All.

Note: To use a cast member from an external cast without creating a link to the cast file, first copy the cast member to an internal cast.

Creating libraries

A library is a special type of unlinked external cast. When you drag a cast member from an external cast library to the Stage or Score, Director automatically copies the cast member to one of the movie's internal casts. Libraries are useful for storing any type of commonly used cast members, especially behaviors. A library cannot be linked to a movie. See “Attaching behaviors” on page 116.

When you create a library as explained the following procedure, it appears on the Library pop-up menu in the Library palette.

To create a library:

1. Create an unlinked external cast file, following the procedure in “Creating casts” on page 112.
2. Save the external cast in the Libs folder in the Director application folder.
   
   For example: My library.cst.
Behaviors: Overview

You can use behaviors to make sprites and frames interactive without writing Lingo. Most behaviors respond to simple events such as a click on a sprite or the entry of the playback head into a frame. When the event occurs, the behavior performs an action, such as jumping to a different frame or playing a sound.

A behavior is a type of Lingo script that functions as a reusable, customizable object. You can attach the same behavior to as many sprites or frames as necessary and use different parameters for each instance.

You drag behaviors from the Library palette and drop a behavior on a sprite or frame to attach the behavior. If the behavior is written to include parameters, a dialog box appears when you attach the behavior. For example, most navigation behaviors let you specify a frame to jump to.

For an introduction to behaviors, see the Behaviors topic in the Guided Tour in Director Help.

Director includes behaviors for many basic functions. Use the Library palette to view any of the behavior libraries. You can use behaviors included with Director or behaviors provided by other developers. For more information about using included behaviors, see "Using Director 7’s Behaviors," in the Director Developers Center. You can also create and modify behaviors yourself by using the Behavior Inspector or create a behavior by writing Lingo script.

You can attach as many behaviors as you need to a sprite, but you can attach only one behavior to a frame. Behaviors attached to frames are best suited to actions that affect the whole movie. For example, you might attach Loop Until Media in Frame is Available to make the movie wait while the media for a particular frame downloads.
Attaching behaviors

Attach behaviors to sprites or frames. Use the Library palette to display behaviors included in Director.

For an animated introduction to attaching behaviors, see Behaviors—overview in Director Help.

When you attach a behavior, the Parameters dialog box for the behavior appears. The parameters you specify apply only to the behavior as it is attached to the current sprite or frame. These settings do not affect the way the behavior works when attached elsewhere. Use the Behavior Inspector to change parameters for behaviors that have been attached to sprites. You can attach as many behaviors as you want to a sprite.

You can attach only one behavior to a frame. If you attach a behavior to a frame that already has a behavior, the new behavior replaces the old one.

Once you attach a behavior to a sprite or frame, Director copies the behavior from the behavior library to the currently selected cast in the movie. This means you don't have to include the behavior library when you distribute the movie.

To attach a behavior to a sprite or frame:

1. Choose Window > Library Palette.
2. Choose a library from the Library pop-up menu in the upper-left corner of the palette.
3. To view a brief description of included behaviors, move the pointer over a behavior icon.

If the behavior includes a longer description, you can view it in the Behavior Inspector. See “Getting information about behaviors” on page 119. The behaviors included with Director have descriptions. Behaviors from other sources may not.

Choose Show Names from the Library pop-up menu to turn the display of behavior names off or on.
To attach a behavior, do one of the following:

- Drag a behavior from the Library palette to a sprite on the Stage or in the Score.

- Drag a behavior from the Library palette to a frame in the behavior channel.

Enter parameters for the behavior in the Parameters dialog box.

*Note:* If you attach a behavior from an included library of behaviors, Director copies the behavior to an internal cast. This prevents you from accidentally changing the original behavior.
To attach the same behavior to several sprites at once:
Select the sprites on the Stage or in the Score and drag a behavior to any one of them.

To attach behaviors to sprites or frames using the Behavior Inspector:
1. Choose Window > Inspectors > Behavior to open the Behavior Inspector.
2. Select a sprite or frame.
3. Choose a behavior from the Behavior pop-up menu.
   Director attaches the behavior you choose to the sprite or frame.

   ![Behavior Inspector](image)

   Note: Some behaviors are written to work only when applied to either a sprite or a frame; read the behavior descriptions to learn more.

To change parameters for a behavior that is already attached to a sprite or frame:
1. Select the sprite or frame where the behavior is attached.
2. Choose Window > Inspectors > Behavior to open the Behavior Inspector.
3. Double-click the behavior name in the Behavior Inspector.
4. Enter parameters for the behavior.
Changing the order of attached behaviors

Director executes behaviors in the order they were attached to a sprite. It’s sometimes necessary to change the sequence of behaviors so that actions occur in the proper order. The Behavior Inspector lists a sprite’s behaviors in the order they are processed.

To change the order of the behaviors attached to a sprite:

1. Select the sprite in the Score or on the Stage.
2. Open the Behavior Inspector.
3. Select a behavior from the list.
4. Click the arrows in the toolbar to move the selected behavior.

Getting information about behaviors

Use the Behavior Inspector to view behavior descriptions and the parameters for behaviors attached to sprites. Behaviors included with Director include pop-up descriptions that appear when you hold the pointer over a behavior in the Library palette. Some behaviors, however, have longer descriptions and instructions. The Behavior Inspector includes a a scrolling pane that displays the complete description provided by the author of the behavior.

The Behavior Inspector can only display information about a behavior that is attached to a sprite or frame, so before viewing a behavior description, you must attach it to something.
To view a behavior description:

1. Open the Behavior Inspector.
2. Select a sprite or frame to which a behavior has been attached.
3. Click the arrow that expands the Behavior Inspector’s description pane.

You can leave the description pane expanded and select different behaviors to see their descriptions.

All of the behaviors included with Director have descriptions. Behaviors from other sources may not.

Creating and modifying behaviors

Use the Behavior Inspector to create and modify behaviors.

All behaviors detect an event and then perform one or more actions in response. The Behavior Inspector lists the most common events and actions used in behaviors.

Without any scripting or programming experience, you can use the Behavior Inspector to create and modify behaviors to perform basic actions. To create behaviors with more complex structures, you need to understand Lingo.

Using the Behavior Inspector in this way is a good way to begin learning Lingo. You can examine the scripts created by the Behavior Inspector to see how basic functions are assembled. Select any behavior and click the Script button to view the associated Lingo script.

For experienced Lingo programmers, the Behavior Inspector also provides a shortcut for writing simple scripts.
**Note:** To always edit behaviors in the Script window instead of the Behavior Inspector, choose File > Preferences > Editors. In the Editors Preferences dialog box, choose Behaviors from the list and then click Editor. In the Select Editor box, choose Script Window.

**To create or modify a behavior:**

1. Do one of the following:
   - Select a behavior in the Behavior Inspector.
   - Click the Behavior pop-up menu, choose New Behavior, and enter a name for the new behavior.

   If you create a new behavior, it appears in the currently selected cast. Select an empty cast position first if you want the behavior to appear in a certain place.

2. Click the arrow to expand the editing pane of the Behavior Inspector.

The editing pane shows the events and actions in the current behavior. If you’re creating a new behavior, no events or actions appear. There are several steps you can take at this point.

- To add a new event or action group to the behavior, choose an event from the Event pop-up menu and then choose actions for the event from the Actions pop-up menu.
  
  You can choose as many actions as you need for a single event.

- To change an existing event or action group, choose an event from the list and then add or remove actions in the Actions list.

- To delete an event or action group, choose the event and press Delete.

- To change the sequence of actions in an event or action group, choose an event from the Events list, choose an action from the Actions list, and then click the up and down arrows above the Actions list to change the order of actions.
To lock the current selection so nothing changes in the Behavior Inspector when new sprites are selected, click the Lock Selection button.

If you are familiar with Lingo, you can also edit a behavior’s script directly.

**Events and actions in the Behavior Inspector**

The included actions and events are basic building blocks you can use to create simple or complex behaviors.

The Behavior Inspector makes the following events available:

- **Mouse Up** indicates that a mouse button was released.
- **Mouse Down** indicates that a mouse button was clicked.
- **Right Mouse Up** indicates that the right mouse button was released. (On the Macintosh, Director treats a Control-click the same as a right mouse click on a Windows system.)
- **Right Mouse Down** indicates that the right mouse button was clicked.
- **Mouse Enter** indicates that the pointer entered a sprite’s region.
- **Mouse Leave** indicates that the cursor left a sprite’s region.
- **Mouse Within** indicates that the cursor is within the sprite’s region.
- **Key Up** indicates that a key was released.
- **Key Down** indicates that a key was pressed.
- **Prepare Frame** indicates that the playback head has left the previous frame, but has not yet entered the next frame.
- **Enter Frame** indicates that the playback head entered the current frame.
- **Exit Frame** indicates that the playback head exited the current frame.
- **New Event** indicates that a specified message was received from a script or behavior. You must specify a name for this event.

The Behavior Inspector makes the following actions available:

- **Go to Frame** moves the playback head to the specified frame.
- **Go to Movie** opens and plays the specified movie.
- **Go to Marker** moves the playback head to the specified marker.
- **Go to Net Page** goes to the specified URL.
- **Wait on Current Frame** waits at the current frame until another behavior or script advances to the next frame.

---

122 Chapter 6
Wait until Click waits at the current frame until the mouse button is clicked.

Wait until Key Press waits at the current frame until a key is pressed.

Wait for Time Duration waits at the current frame for the specified time.

Play Cast Member plays the specified sound cast member.

Play External File plays the specified external sound file.

Beep plays the current system beep.

Set Volume sets the system volume level to the specified setting.

Change Tempo changes the movie's tempo to the specified setting.

Perform Transition performs the specified transition.

Change Palette changes to the specified palette.

Change Location moves the current sprite to the specified coordinates.

Change Cast Member switches the sprite's cast member to the specified cast member.

Change Ink switches to the specified ink.

Change Cursor changes the pointer to the cursor you choose from the pop-up menu.

Restore Cursor restores the current system pointer.

New Action executes any Lingo function or sends a message to a handler. You specify the new handler's name.
Writing behaviors with Lingo

If you are familiar with Lingo, you can author your own behaviors.

From the perspective of Lingo, a behavior is a script with these additional features:

- Each instance of the behavior has independent values for properties. Lingo uses a `property` statement to declare properties that can have independent values in each instance of the behavior. See “property” in the *Lingo Dictionary*.

- The same set of handlers can be shared by multiple sprites or frames.
  
  The handlers in a behavior are basically the same as other handlers. Include as many handlers as appropriate to implement the behavior.

  A behavior is usually attached to multiple sprites or frames. As a result, the sprites and frames share the same handlers. Director tracks which instance of the behavior is which by assigning each instance a reference number. The variable `me` contains the reference for the object that the instance of the behavior is attached to.

  It’s often most efficient to create behaviors dedicated to specific tasks and then attach a set of behaviors that perform the variety of actions you want.

- The behavior can have parameters that users edit from the Parameters dialog box. The optional `on getPropertyDescriptionList` handler sets up the Parameters dialog box. See “on `getPropertyDescriptionList`” in the *Lingo Dictionary*.

- A description of the behavior can be added to the Behavior Inspector. The optional `on getBehaviorDescription` handler displays a description of the behavior in the Behavior Inspector. See “on `getBehaviorDescription`” in the *Lingo Dictionary*.

- A brief description that appears as a tooltip for the behavior in the Library palette. The optional `on getBehaviorToolTip` handler creates the tooltip. See “on `getBehaviorToolTip`” in the *Lingo Dictionary*. 
Setting up a Parameters dialog box

It’s impossible to predict exactly what a user will want behaviors to do. You can make behaviors more flexible by letting the user customize the behavior’s parameters.

For example, this handler moves the sprite five pixels to the right each time the playback head enters a new frame:

```lingo
on enterFrame me
  if the locH of sprite the spriteNum of me > the stageRight then
    set the locH of sprite the spriteNum of me = the stageLeft
  else
    set the locH of sprite the spriteNum of me to ¬
      (the locH of sprite the spriteNum of me + 5)
  end if
end
```

However, users could adjust the speed of each sprite if they could specify how far individual sprites move to the right in each frame.

To allow users to set different values for a property in different instances of the behavior, the behavior’s script needs two types of Lingo:

- A property statement that allows each instance to maintain a separate value for the property
- An on getPropertyDescriptionList handler that sets up the property

Setting behavior properties with Lingo

Behaviors usually have properties that each instance of the behavior maintains its own values for. (An instance is each sprite or frame that the behavior is attached to.) These properties are shared among handlers in a behavior’s script the same way that properties are shared among handlers in an object.

To declare which properties can have independent values in each instance of the behavior:

Use a property statement.

A property statement starts with the word `property` followed by the names of the individual properties. For example, the statement `property movement` declares that movement is a property of the behavior.

Put the property statement at the beginning of the behavior’s script.
Customizing a behavior’s property

If a behavior’s script includes an `on getPropertyDescriptionList` handler, Director lets users set the property’s initial values from the Parameters dialog box. The behavior’s Parameters dialog box opens in three circumstances:

- After the user drags a behavior to a sprite or frame
- When the user double-clicks the behavior in the Behavior Inspector dialog box
- When the user clicks the Parameters button in the Behavior Inspector

The `on getPropertyDescriptionList` handler generates a property list that specifies these attributes of the property:

- The default initial value
- The type of data the property contains, such as Boolean, integer, string, cast member data, or a specific type of cast member.
- A comment in the Parameters dialog box to describe what the user is setting.

The definition of a behavior’s property must include the property’s name, default value, and data type and the descriptive string that appears in the Parameters dialog box. The definition can also include an optional specification for the range of values allowed for the property.

The name of the property comes first in the definition. The remainder of the definition is a property list that assigns a value to each of the property’s attributes.
For example, to define the property movement as an integer that can be set to a value from 1 to 10 and whose default value is 5, use a phrase similar to this:

```lingo
#movement: [#default: 5, #format: #integer, ¬
#comment: "Set motion to the right.", #range: [#min:1, #max:10]]
```

- #movement is the property’s name. A symbol operator (#) must precede the name in the property definition. A colon separates the name’s definition and the list of parameters.
- #default specifies the property’s default value. This example sets 5 as the default.
- #format specifies the property’s type. This example sets the type as an integer. Some other possible types are Boolean, string, cast member, event, and sound. For a complete list of possible values for #format, see on getPropertyDescriptionList in Director Help or the Lingo Dictionary.
- #comment specifies a string that appears next to the parameter in the Parameters dialog box. This example makes “Set motion to the right” the comment that appears in the Parameters dialog box.
- #range specifies a range of possible values that the user can assign to the property. Specify the possible values as a list.
  
  To specify a range between a minimum and maximum number, use the form [#min:minimum, #max:maximum]. The example sets the range from 1 to 10. When the range is between a maximum or minimum number, the Parameters dialog box provides a slider that sets the value.

  To specify no range, omit the #range parameter. If the property’s definition doesn’t include #range, a text entry field appears for the user to enter a value in the Parameters dialog box.

  To specify a set of possible choices, use a linear list. For example, the list [#mouseUp, #mouseDown, #keyUp, #keyDown] makes these four events possible choices for a parameter. When you specify values in a linear list, the choices appear in a pop-up menu in the Parameters dialog box. (For this example list, you need to specify #format: #symbol for the list to display correctly.)

As another example, this statement defines the property whichSound:

```lingo
addProp description, #whichSound, [#default: "", #format: #sound, #comment: ¬
"Which cast member"]
```

The value #sound assigned to #format provides a pop-up menu in the Parameters dialog box that includes every sound cast member available in the movie.

If the behavior includes a command that plays a sound, this property can be used to specify a sound cast member to play. For example, if the user chooses Growl from the pop-up menu in the Parameters dialog box, the statement puppetSound whichSound would play the sound cast member Growl.
Creating an on getPropertyDescriptionList handler

To build a list of properties for a behavior, add each property to the list that the on getPropertyDescriptionList handler returns. Then use the return command to return the list.

For example, this handler creates a property list named Description that contains the definitions for movement and whichSound:

```
on getPropertyDescriptionList
    set description = []
    addProp description, #Movement, [#default: 5, #format:#integer, #comment: "Set motion to the right.", #range: [#min:1, #max:10]]
    addProp description, #noise, [#default: "", format: #sound, #comment: "Sound cast member name"]
    return description
end```

Alternatively, you can use this syntax to do the same as the previous handler:

```
on getPropertyDescriptionList
    return [
        #Movement: [#default: 5, #format:#integer, #comment: "Set motion to the right.", #range: [#min:1, #max:10]]
        #noise: [#default: "", format: #sound, #comment: "Sound cast member name"]
    ]
end```

Including a description for the Behavior Inspector

An on getBehaviorDescription handler in a behavior's script provides a description that appears in the bottom pane of the Behavior Inspector when the behavior is selected. For example, this handler displays the phrase “This changes sprite color and position.” in the Behavior Inspector:

```
on getBehaviorDescription
    return "This changes sprite color and position."
end```
Example of a complete behavior

If the handlers described here were in one behavior, the script would look like this:

```Основной язык
property movement, noise

on getPropertyDescriptionList
    set description = []
    addProp description, #movement, [#default: 5, #format: #integer, #comment: "Set motion to the right", #range: [#min:1, #max:10]]
    addProp description, #noise, [#default: "", #format: #sound, #comment: "Sound cast member name"]
    return description
end

on getBehaviorDescription
    return "This changes sprite position and color"
end

on mouseUp me
    set the foreColor of sprite the spriteNum of me to random(255)
    puppetSound noise
end

on enterFrame me
    if the locH of sprite the spriteNum of me > the stageRight then
        set the locH of sprite the spriteNum of me = the stageLeft
    else
        set the locH of sprite the spriteNum of me to (the locH of sprite the spriteNum of me + movement)
    end if
end
```

When this behavior is attached to a sprite, each time the playback head enters a frame, the sprite moves to the right by the amount the user specifies. When the user clicks a sprite, its color changes and a specified sound plays. (The `puppetSound` command was added to the `on mouseUp` handler in this example.)
Sending messages to behaviors attached to sprites

Lingo can run handlers in behaviors attached to specific sprites by sending messages to the behaviors attached to one sprite, all sprites, or specific sprites.

Sending messages to a sprite

The sendSprite command sends a message to a specified sprite. If none of the sprite's behaviors has a handler that corresponds to the message, the message passes to the cast member script, the frame script, and then to the movie script. See “sendSprite” in the Lingo Dictionary.

For example, this handler sends the custom message bumpCounter and the argument 2 to sprite 1 when the user clicks the mouse:

```lingo
on mouseDown me
    sendSprite (1, #bumpCounter, 2)
end
```

**Note:** The symbol operator (#) must precede the message in the sendSprite command.

Sending messages to all sprites

The sendAllSprites command sends a message to every sprite in the frame. If no behavior of the specified sprite has a handler that corresponds to the message, the message passes to the cast member script, the frame script, and then to the movie script. See “sendAllSprites” in the Lingo Dictionary.

For example, this handler sends the custom message bumpCounter and the argument 2 to all sprites in the frame when the user clicks the mouse:

```lingo
on mouseDown me
    sendAllSprites (#bumpCounter, 2)
end
```

**Note:** The symbol operator (#) must precede the message in the sendAllSprites command.

Sending messages to specific behaviors only

The call command sends an event to specific behaviors. Unlike the sendSprite command, the call command doesn't pass the message to frame scripts, scripts of the cast member, or movie scripts.

Before sending a message to a specific behavior, check the scriptInstanceList sprite property to find a behavior script reference to use with the call command.

The scriptInstanceList property provides a list of references for the behaviors attached to a sprite while a movie is playing.
For example, this handler displays the list of references for all behaviors attached to the same sprite as this behavior's handler:

```lingo
on showScriptRefs me
    put the scriptInstanceList of sprite the ¬
    spriteNum of me
end
```

This handler sends the message `bumpCounter` to the first script reference attached to sprite 1 (the `getAt` function identifies the first script reference in the `scriptInstanceList`):

```lingo
on mouseDown me
    xref = getAt (the scriptInstanceList of sprite 1, 1)
    call (#bumpCounter, xref, 2)
end
```

**Note:** The symbol operator (#) must precede the message in the call command.

To remove instances of a sprite while the movie is playing:

Set the sprite's `scriptInstanceList` property to an empty list([]). See “`scriptInstanceList` in the Lingo Dictionary.”

### Using inheritance in behaviors

Behaviors can have ancestor scripts in the same way that parent scripts do.

- The ancestor's handlers and properties are available to the behavior.
- If a behavior has the same handler or property as an ancestor script, Lingo uses the property or handler in the behavior instead of the one in the ancestor.

For more information about the concept of ancestors and inheritance, see “Parent scripts: Overview” on page 225.

To make a script an ancestor:

- Declare that `ancestor` is a property in the `property` statement at the beginning of the behavior's Score script.
  
  For example, the statement `property ancestor` declares that `ancestor` is a property.

- Include a statement that specifies which script is the ancestor. Put the statement in an `on beginSprite` handler in the behavior.

  For example, this handler makes the script `Common Behavior` an ancestor of the behavior when Director first enters the sprite:

  ```lingo
  on beginSprite
      set the ancestor of me to new (script "Common Behavior")
  end
  ```

  This handler will let the behavior also use the handler in the script `Common Behavior`. 

Writing scripts with Lingo: Overview

Lingo, Director's scripting language, adds interactivity to a movie. Use Lingo to control a movie in response to specific conditions and events. For example, Lingo can play a sound after a specified amount of the sound has streamed from the Internet.

Use the Script window to write and edit scripts.

For an introduction to scripting, see the Lingo topic in the Guided Tour in Director Help.

Controlling when Lingo runs

When an event occurs, Director generates a message that describes the event. For example, when the user types at the keyboard, a movie stops, a sprite starts, or the playback head enters a frame, these actions are events and generate event messages.

Handlers contain groups of Lingo statements that run when a specific event occurs in a movie. Each handler begins with the word on followed by the message that the handler is set to respond to. The last line of the handler is the word end; you can repeat the handler's name after end, but this is optional.

For example, the mouseDown message indicates that the user clicked the mouse button. A handler that started with the line on mouseDown contains Lingo statements that run when the handler receives a mouseDown message. Whether the handler receives the message depends on which objects the handler is attached to in the movie.

Director contains handlers within scripts. Attach a set of handlers to an object by attaching the handlers' script to the object.
Understanding Lingo as a language

Lingo, like any scripting language, has certain elements that you use and rules that you follow.

Lingo terms fall into seven categories: commands, properties, functions, keywords, events, constants, and operators.

A Lingo statement is any valid instruction that Director can execute. An expression is any part of a statement, meant to be taken as a whole, that produces a value. For example, \( 2 + 2 \) is an expression but is not a valid statement all by itself. The line \( \text{go to frame 23} \) is a statement—\( \text{go to} \) is the command, and \( \text{frame 23} \) is the expression that produces the value that the command requires to execute the instruction.

Lingo supports a variety of data types: references to sprites and cast members, TRUE and FALSE (Boolean) values, strings, constants, integers, and floating-point numbers.

Scripts can use variables to store, update, and retrieve values as the movie plays. Use the equals operator (\( = \)) or the \( \text{set} \) command to assign values to variables or change the values of many properties.

Use \( \text{if...then} \), case, and repeat loop structures to set up statements so that they run when specific conditions exist. For example, you can create an \( \text{if...then} \) structure that tests whether text has finished downloading from the Internet and then attempts to format the text if it has.

How Lingo flows

Director always executes Lingo statements in a handler starting with the first statement and continuing in order until it reaches the final statement or a statement that instructs Lingo to go somewhere else.

Some statements that send Lingo to somewhere other than the next statement are repeat loops, \( \text{if...then...else} \) structures, the \( \text{exit} \) command, the \( \text{return} \) function, and handler names placed within scripts.

The order in which statements are executed affects the order in which you should place statements. For example, if you write a statement that requires some calculated value, you need to put the statement that calculates the value first. For instance, in the following example, the first statement adds two numbers, and the second assigns them to a field cast member to be displayed on the Stage:

\[
x = 2 + 2 \\
\text{put } x \text{ into member 'The Answer'}
\]
Using lists to manage data

Lists provide an efficient way to track and update an array of data such as a series of names or the values assigned to a set of variables.

Lists are basically a set of elements separated by commas. Lingo encloses the set of values in square brackets. A simple example of a list is a list of numbers such as [1, 4, 2].

Lingo can create, retrieve, add to, reorder, sort, or substitute a list’s contents.

Director offers two types of lists:

- **Linear lists** in which each element is a single value. For example, this list is a simple set of numbers:
  
  [100, 150, 300, 350]

- **Property lists** in which each element contains two values separated by a colon. The first value is a property. The second value is the value associated with that property. For example, this list could be a sprite’s Stage coordinates, with a value for each one:
  
  [#left:100, #top:150, #right:300, #bottom:350]

  Properties can appear more than once in a property list.

Advice about writing scripts

When you write scripts for an entire movie, the quantity and variety of scripts can be enormous. Deciding which Lingo to use, how to structure scripts effectively, and where scripts should be placed requires careful planning and testing, especially as the complexity of your movie grows.

Before you begin writing scripts, formulate your goal and understand what you want to achieve. This is as important—and typically as time consuming—as developing storyboards for your work.

When you have an overall plan for the movie, you are ready to start writing and testing scripts. Expect this to take time. Getting scripts to work the way you want often takes more than one cycle of writing, testing, and debugging.

The best approach is to start simple and test your work frequently. When you get one part of a script working, start writing the next part. This approach will help you identify bugs efficiently and ensures that your Lingo is solid as you write more complex scripts.

For more information about troubleshooting, see “Troubleshooting Lingo,” in the Director Developers Center.
Types of scripts

Director uses four types of scripts.

**Behaviors** Behaviors are attached to sprites or frames in the Score. Behaviors assigned to sprites are sprite behaviors. Behaviors assigned to a frame's behavior channel are frame behaviors.

Director includes a set of behaviors that are already written. Using Lingo, you can create additional behaviors for your specific needs.

Behaviors are script cast members that appear in a Cast window. The Cast window thumbnail for each behavior contains a behavior icon in the lower-right corner.

All behaviors appear in the Sprite Inspector's Behavior pop-up menu. (Other types of scripts don't appear in the Behavior pop-up menu.)

Attach behaviors to sprites or frames in two ways:

- Drag a behavior from a cast to a sprite or frame in the Score or on the Stage.
- Select the sprites or frames that you're attaching the behavior to and then choose the behavior from the Behavior pop-up menu.

You can attach the same behavior to more than one location in the Score. When you edit a behavior, the edited version is applied everywhere the behavior is attached in the Score.

**Movie scripts** Movie scripts are available to the entire movie, regardless of which frame the movie is in or which sprites the user is interacting with.

When a movie plays in a window or as a linked movie, a movie script is available only to its own movie.

In addition to responding to events such as key presses and mouse clicks, movie scripts can control what happens when a movie starts, stops, or pauses. Handlers in a movie script can be called from other scripts in the movie as the movie plays.

Movie scripts are cast members that appear in a Cast window. A movie script icon appears in the lower-right corner of the movie script's Cast window thumbnail.
**Parent scripts** Parent scripts are special scripts that contain Lingo used to create child objects. Parent scripts are cast members that appear in a Cast window. A parent script icon appears in the lower-right corner of the Cast window thumbnail.

For information about parent scripts, see “Parent scripts: Overview” on page 225.

**Scripts attached to cast members** Scripts attached to cast members are attached directly to a cast member, independent of the Score. Whenever the cast member is assigned to a sprite, the cast member's script is available.

Unlike movie scripts, parent scripts, and behaviors, cast member scripts don’t appear in the Cast window. Open scripts attached to cast members by clicking Script in the cast member’s Cast Member Properties dialog box or by selecting a cast member in the Cast window and then clicking the Script button. You can also open a cast member script from the Script window.

If Show Cast Member Script Icons is selected in the Cast Window Preferences dialog box, cast members that have a script attached display a small Script icon in the lower-left corner of their thumbnails in the Cast window.

---

**Using messages to identify events**

To run the appropriate set of Lingo statements at the right time, Director must determine what is occurring in the movie and which Lingo to run in response to specific events.

Director sends messages to indicate when specific events occur in a movie, such as when sprites are clicked, keyboard keys are pressed, a movie starts, the playback head enters or exits a frame, or a script returns a certain result.

Handlers contain instructions that run when a specific message is received. The handler's name begins with the word `on` followed by the message name. When an object receives a message that corresponds to a handler attached to the object, Director runs the Lingo statements within the handler. For example, a handler named `on enterFrame` that is attached to a frame runs when the playback head enters the frame.
Most common events that occur in a movie have built-in message names. See the following categories in the *Lingo Dictionary* for the built-in messages that describe events:

- Keyboard and mouse events. See “Keyboard events” and “Mouse events” in the Lingo by Feature appendix of the *Lingo Dictionary*.
- Frame events. See “Frame events” in the Lingo by Feature appendix of the *Lingo Dictionary*.
- Browser and Internet events. See “Network Lingo” in the Lingo by Feature appendix of the *Lingo Dictionary*.
- Sprite events. See “Sprite events” in the Lingo by Feature appendix of the *Lingo Dictionary*.
- Movie in a window events. See “Movie in a window events” in the Lingo by Feature appendix of the *Lingo Dictionary*.
- Movie events. See “Movie events” in the Lingo by Feature appendix of the *Lingo Dictionary*.
- Synchronizing media events. See “Media synchronization” in the Lingo by Feature appendix of the *Lingo Dictionary*.
- Idle events. See “Memory management” in the Lingo by Feature appendix of the *Lingo Dictionary*.
- Timeout events. See “Time” in the Lingo by Feature appendix of the *Lingo Dictionary*.
- Authoring behavior events. See “Authoring behaviors” in the Lingo by Feature appendix of the *Lingo Dictionary*.

**Custom messages**

You can also define your own messages and corresponding handler names. A custom message can call another script, another handler, or the statement’s own handler. When the called handler stops executing, the handler that called it resumes.

Director can send a custom message from any location. The message is first available to handlers in the script from which the message was sent. If no handler is found, the message is available to movie scripts.

If more than one movie script contains a handler for the message, the handler in the movie script that has the lowest cast member number is executed.
A custom handler name must:

- Start with a letter
- Include alphanumeric characters only (no special characters or punctuation)
- Consist of one word or multiple words connected by an underscore—no spaces are allowed
- Not be the same as the name of a predefined Lingo element

Using Lingo keywords for handler names can create confusion. Although it is possible to explicitly replace or extend the functionality of a Lingo element by using it as a handler name, this should be done only in certain advanced situations.

When you have multiple handlers with similar functions, it is useful to give them names that have similar beginnings so they appear together in an alphabetical listing, such as the listing displayed by the Find Handler option in the Edit menu.

**The order of messages in a movie**

Director follows a definite order when sending messages about events that occur during the course of a movie.

When the movie first starts, events occur in the following order:

- `prepareMovie`
- `beginSprite`. This event occurs when the playback head enters a sprite span.
- `prepareFrame`. Immediately after the `prepareFrame` event, Director plays sounds, draws sprites, and performs any transitions or palette effects. This event occurs before the `enterFrame` event. An `on prepareFrame` handler is a good location for Lingo that you want to run before the frame draws.
- `startMovie`. This event occurs in the first frame that plays.

When Director plays a frame, events occur in this order:

- `beginSprite`. This event occurs only if new sprites begin in the frame.
- `stepFrame`.
- `prepareFrame`. Immediately after the `prepareFrame` event, Director plays sounds, draws sprites, and performs any transitions or palette effects. This event occurs before the `enterFrame` event.
- `enterFrame`. After `enterFrame` and before `exitFrame`, Director handles any time delays required by the tempo setting, `idle` events, and keyboard and mouse events.
- `exitFrame`.
- `endSprite`. This event occurs only if the playback head exits a sprites in the frame.
When a movie stops, events occur in this order:

- `endsprite`. This event occurs only if sprites currently exist in the movie.
- `stopMovie`.

### Determining when handlers receive a message

A movie can contain more than one handler for the same message. Director manages this situation by sending the message to objects in a definite order.

The general order in which messages are sent to objects is as follows:

- Messages are sent first to behaviors attached to a sprite involved in the event. If a sprite has more than one behavior attached to it, behaviors respond to the message in the order in which they were attached to the sprite.
- Messages are sent next to a script attached to the cast member assigned to the sprite.
- Messages are then sent to behaviors attached to the current frame.
- Messages are sent last to movie scripts.

When a message reaches a script that contains a handler corresponding to the message, Director executes the handler's instructions.

After a handler intercepts a message, the message doesn't automatically pass on to the remaining locations. (You can use the `pass` command to override this default rule and pass the message to other objects.) If no matching handler is found after the message passes to all possible locations, Director ignores the message.

The exact order of objects to which Director sends a message depends on the message. See the message's Lingo Dictionary entry for details about the sequence of objects to which Director sends specific messages.

### Deciding where to place handlers

You can place handlers in any type of script. However, the following are some useful guidelines for many common situations:

**To set up a handler that affects a specific sprite or runs in response to an action on a specific sprite:**

Put the handler in a behavior attached to the sprite.
To set up a handler that should be available any time that the movie is in that frame:

Put the handler in a frame script attached to the frame.

For example, to have a handler respond to a mouse click while the playback head is in a frame, regardless of where the click occurs, place an on mouseDown or on mouseUp handler in the frame script rather than a sprite script.

To set up a handler that runs in response to an event that affects a cast member, regardless of which sprites use the cast member:

Put the handler in a cast member script.

To set up a handler that runs in response to messages about events anywhere in the movie:

Put the handler in a movie script.

A script can contain multiple handlers. It’s a good idea to group related handlers in a single place, though, for easier maintenance.

Using Lingo’s components

Lingo terms fall into these categories:

**Commands** are terms that instruct a movie to do something while the movie is playing. For example, go to sends the playback head to a specific frame, marker, or another movie.

**Functions** are terms that return a value. For example, the date function returns the current date set in the computer. The key function returns the key that was pressed last. Parentheses occur at the end of a function.

**Properties** are attributes that define an object. For example, colorDepth is a property of a bitmap cast member.

**Operators** are terms that calculate a new value from one or more values. For example, the add operator (+) adds two or more values together to produce a new value.

**Constants** are elements that don’t change. For example, the constants TAB, EMPTY, and RETURN always have the same meaning.

**Keywords** are reserved words that have a special meaning. For example, end indicates the end of a handler.
Using Lingo’s syntax

Lingo has rules of grammar and punctuation that you must follow. The following are general rules that apply to all Lingo. Most Lingo terms also have their own individual requirements about terms that they must be combined with. For the rules for a specific Lingo term, see the term’s syntax in the *Lingo Dictionary*.

**Dot syntax**

Use dot syntax to express the properties or functions related to an object or to specify a chunk within a text object. An dot syntax expression begins with the name of the object, followed by a period (dot), and then the property, function, or chunk that you want to specify.

For example, the `loc` sprite property indicates a sprite’s horizontal and vertical position on the Stage. The expression `sprite(15).loc` refers to the `loc` property of sprite 15.

As another example, the `number` cast member property specifies a cast member’s number. The expression `member("Hot Button").number` refers to the cast member number of the Hot Button cast member.

Expressing a function related to an object follows the same pattern. For example, the `pointInHyperLink` text sprite function reports whether a specific point is within a hyperlink in a text sprite. In addition to the syntax demonstrated in the *Lingo Dictionary*, you can use the dot syntax `textSpriteObject.pointInHyperlink` to express this function.

For chunks of text, include terms after the dot to refer to more specific items within text. For example, the expression `member("News Items").paragraph(1)` refers to the first paragraph of the text cast member News Items. The expression `member("News Items").paragraph(1).line(1)` refers to the first line in the first paragraph.

**List syntax**

The list operator ([]) designates that the items within the brackets are list elements.

The elements in a list follow the usual Lingo syntax for designating strings, symbols, integers, and floating-point numbers.

**Parentheses**

Functions that return values require parentheses. When you define functions in handlers, you need to include parentheses in the calling statement.

Use parentheses after the keywords `sprite` or `member` to identify the object’s identifier: for example, `member("Patrice Lumumba")`.

You can also use parentheses to override Lingo’s order of precedence or to make your Lingo statements easier to read.
Character spaces

Words within expressions and statements are separated by spaces. Lingo ignores extra spaces.

In strings of characters surrounded by quotation marks, spaces are treated as characters. If you want spaces in a string, you must insert them explicitly.

You can see Lingo that uses strings in “Working with fields” on page 281.

Uppercase and lowercase letters

Lingo is not case sensitive—you can use uppercase and lowercase letters however you want. For example, the following statements are equivalent:

member ("Cat").hilite = TRUE
Set the hiLite of member 'cat' to True
set the hilite of member 'Cat' to True
SET THE HILITE OF MEMBER 'CAT' TO TRUE
Set The Hilite Of Member 'Cat' To True

However, it’s a good habit to follow script writing conventions, such as the ones that are used in this book, to make it is easier to identify names of handlers, variables, and cast members when reading Lingo code.

Comments

Comments in scripts are preceded by double hyphens (--). You can place a comment on its own line or after any statement. Lingo ignores any text following the double hyphen on the same line. For more information about comments in Lingo, see “Troubleshooting Lingo,” in the Director Developers Center.

Comments can consist of anything you want, such as notes about a particular script or handler or notes about a statement whose purpose might not be obvious. Comments make it easier for you or someone else to understand a procedure after you’ve been away from it for a while.

Use the Comment and Uncomment buttons in the Script window to enter and remove comments easily.

Optional keywords and abbreviated commands

You can abbreviate some Lingo statements. Abbreviated versions of a command are easier to enter but may be less readable than the longer versions. The go command is a good example. All the following statements are equivalent. The last one takes the fewest number of keystrokes.

go to frame "This Marker"
go to "This Marker"
go 'This Marker'

It is good practice to use the same abbreviations throughout a movie.
Expressing literal values

A literal value is any part of a statement or expression that is to be used exactly as it is, rather than as a variable or a Lingo element. Literal values that you encounter in Lingo are character strings, integers, decimal numbers, cast member names, cast member numbers, symbols, and constants.

**Note:** The value function can convert a string into a numerical value. The string function can convert a numerical value into a string.

Each type of literal value has its own rules.

**Writing strings**

Strings are characters that Lingo treats as characters instead of as variables. Strings must be enclosed in double quotation marks. For example, in the statement

```
member("Greeting").text = "Hello"
```

“Hello” and “Greeting” are both strings. “Hello” is the actual string being put into a text cast member; “Greeting” is the actual name of the cast member.

Similarly, if you test a string, double quotation marks must surround each string, as in the following example:

```
if "Hello Mr. Jones" contains "Hello" then soundHandler
```

Lingo treats spaces at the beginning or end of a string as a literal part of the string. The following expression includes a space after the word to:

```
put "My thoughts amount to 
```

**Using integers**

An integer is a whole number, without any fractions or decimal places.

Director works with integers between -2,147,483,648 and +2,147,483,647. (For numbers outside of this range, use floating-point numbers.) Enter integers without using commas. Use a minus (-) sign for negative numbers.

You can convert a decimal number to an integer by using the `integer()` function. For example, the statement `set theNumber = integer(3.9)` rounds off the decimal number 3.9 and converts it to the integer 4.

Some Lingo commands and functions require integers for their parameters. The requirements for specific Lingo elements can be found in Director Help or the Lingo Dictionary.
Using decimal numbers

A decimal number, sometimes called a floating-point number, is any number that includes a decimal point. The floatPrecision property controls the number of decimal places used to display these numbers. (However, Director always uses the complete number in calculations.) See the floatPrecision entry in Director Help or the Lingo Dictionary for information about setting the number of decimal places used for decimal numbers.

You can also use exponential notation with decimal numbers: for example, -1.1234e-100 or 123.4e+9.

You can convert an integer or string to a decimal number by using the float() function. For example, the statement set theNumber = float(3) stores the value 3.0 in the variable.

Identifying cast members and casts

Lingo refers to a cast member by using the term member followed by a cast member name or number in parentheses. If more than one cast member has the same name, Director uses the lowest numbered cast member in the lowest numbered cast. (Cast member names are strings and follow the same syntax rules as other strings.) An alternative syntax is the term member without parentheses, followed by the cast member name or number.

For example, the following all refer to cast member 50, which has the name Hammer:

member("Hammer")
member(50)
member 'Hammer'
member 50

Use an optional second parameter to specify the cast member’s cast. If more than one cast contains a cast member with the same name, you must also specify the cast.

If you identify a cast member by its cast member number, you must also specify the cast.

To specify a cast when using member without parentheses, include the term of castLib followed by the cast’s name or number. When the cast member’s name is unique in the movie, the cast’s name isn’t required, but you can include it for clarity.
For example, the following statements refer to cast member 50, which is named Hammer, in castLib 4, which is named Tools:

```
member(50, 4)
member 50 of castLib 4

member("Hammer", 4)
member 'Hammer' of castLib 4

member(50, "Tools")
member 50 of castLib 'Tools'

member("Hammer", "Tools")
member 'Hammer' of castLib 'Tools'
```

If more than one cast member has the same name and you use the name in a script without specifying the cast or cast member number, Lingo uses the first (lowest numbered) cast member in the lowest numbered cast that has the specified name.
Using symbols

A symbol is a string or other value that begins with the pound sign (#).
Symbols are user-defined constants. Comparisons using symbols can usually be performed very quickly, providing more efficient code.

For example, the statement

userLevel = #novice

runs more quickly than the statement

userLevel = 'novice'

Symbols can’t contain spaces or punctuation.

Convert a string to a symbol by using the symbol() function. Convert a symbol back to a string by using the string() function.

See # (symbol operator and string() function in the Lingo Dictionary.

Expressing constants

A constant is a named value whose content never changes. For example, TRUE, VOID, and EMPTY are constants because their values are always the same.

The constants BACKSPACE, ENTER, QUOTE, RETURN, SPACE, and TAB refer to keyboard characters. For example, to test whether the user is pressing the Enter key, use the following statement:

if the key = ENTER then beep

Checking and setting values

Lingo can test and set the values of properties and variables.

To test the values of properties or variables:

Use the put command in the Message window or check the values in the Watcher window.

For example, the statement put myNumber displays the value assigned to the variable myNumber in the Message window.

To set the value of a property or a variable:

Use the equals operator (=). For easier readability, you can use the optional set command at the beginning of the statement. (If you use the of syntax to refer to cast members or sprites, you must use the set command.)
For example, any of these statements change the cast member assigned to sprite 2 by setting the sprite's member property to a different cast member:

\[
\text{sprite (2).member = member ('Big Flash')}
\]
\[
\text{set sprite (2).member = member ('Big Flash')}
\]
\[
\text{set the member of sprite 2 = member 'Big Flash'}
\]

Some properties can only be tested. Often these are properties that describe some condition that exists outside of Director's control. For example, the \text{numChannels} cast member property, which indicates the number of channels within a Shockwave audio cast member, can only be tested.

**Describing conditions**

A script often needs to determine whether a certain condition exists before carrying out a set of instructions. For example, a script may need to check whether a network operation is finished before doing something that requires the operation's result.

The term \text{TRUE} or the number 1 indicates that the condition you're testing for exists. The term \text{FALSE} or the number 0 indicates that a condition doesn't exist.

**Manipulating and checking values**

Operators are elements that tell Lingo how to combine, compare, or modify the values of an expression. They include:

- Arithmetic operators (such as +, -, /, and *)
- Comparison operators (for example, +, >, and >=), which compare two arguments
- Logical operators (not, and, or), which combine simple conditions into compound ones
- String operators (& and &&), which join strings of characters

When two or more operators are used in the same statement, some operators take precedence over others in a precise hierarchy that Lingo follows to determine which operators to execute first. This is called the operators' precedence order. For example, multiplication is always performed before addition. However, items in parentheses take precedence over multiplication. For example, without parentheses, Lingo performs the multiplication in this statement first:

\[
\text{total = 2 + 4 * 3}
\]

The result is 14.
When parentheses surround the addition operation, Lingo performs the addition first:

\[
\text{total} = (2 + 4) \times 3
\]

The result is 18.

The operators and their precedence order are described in the following sections. Operators with higher precedence are performed first. For example, an operator whose precedence order is 5 is performed before an operator whose precedence order is 4. Operations that have the same order of precedence are performed left to right.

**Arithmetic operators** Arithmetic operators add, subtract, multiply, divide, and perform other arithmetic operations. Parentheses and the minus sign are arithmetic operators.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Effect</th>
<th>Precedence</th>
</tr>
</thead>
<tbody>
<tr>
<td>()</td>
<td>Groups operations to control precedence order.</td>
<td>5</td>
</tr>
<tr>
<td>-</td>
<td>When placed before a number, reverses the sign of a number.</td>
<td>5</td>
</tr>
<tr>
<td>*</td>
<td>Performs multiplication.</td>
<td>4</td>
</tr>
<tr>
<td>mod</td>
<td>Performs modulo operations.</td>
<td>4</td>
</tr>
<tr>
<td>/</td>
<td>Performs division.</td>
<td>4</td>
</tr>
<tr>
<td>+</td>
<td>Performs addition.</td>
<td>3</td>
</tr>
<tr>
<td>-</td>
<td>When placed between two numbers, performs subtraction.</td>
<td>3</td>
</tr>
</tbody>
</table>

**Note:** When only integers are used in an operation, the result is an integer. Using integers and floating-point numbers in the same calculation results in a floating-point number.

When dividing one integer by another doesn't result in a whole number, Lingo rounds down the result to the nearest integer. For example, the result of \(4/3\) is 1.

Use `float()` on one or more values in an expression to force Lingo to calculate a value without rounding the result. For example, the result of \(4/\text{float}(3)\) is 1.333.

**Comparison operators** Comparison operators compare two values and determine whether the comparison is true or false.
These are the comparison operators available in Lingo:

<table>
<thead>
<tr>
<th>Operator</th>
<th>Meaning</th>
<th>Precedence</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;</td>
<td>Is less than</td>
<td>1</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Is less than or equal to</td>
<td>1</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>Is not equal to</td>
<td>1</td>
</tr>
<tr>
<td>&gt;</td>
<td>Is greater than</td>
<td>1</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Is greater than or equal to</td>
<td>1</td>
</tr>
<tr>
<td>=</td>
<td>Equals</td>
<td>1</td>
</tr>
</tbody>
</table>

**Logical operators** Logical operators test whether two logical expressions are true or false.

These are the logical operators available in Lingo:

<table>
<thead>
<tr>
<th>Operator</th>
<th>Effect</th>
<th>Precedence</th>
</tr>
</thead>
<tbody>
<tr>
<td>and</td>
<td>Determines whether both expressions are true.</td>
<td>4</td>
</tr>
<tr>
<td>not</td>
<td>Negates an expression.</td>
<td>5</td>
</tr>
<tr>
<td>or</td>
<td>Determines whether either or both expressions are true.</td>
<td>4</td>
</tr>
</tbody>
</table>

The `not` operator is useful for toggling a **TRUE** or **FALSE** value to its opposite. For example, the following statement turns on the sound if it’s currently off and turns off the sound if it’s currently on:

```basic
set the soundEnabled = not (the soundEnabled)
```

**String operators** String operators combine and define strings.

These are the string operators available in Lingo:

<table>
<thead>
<tr>
<th>Operator</th>
<th>Effect</th>
<th>Precedence</th>
</tr>
</thead>
<tbody>
<tr>
<td>&amp;</td>
<td>Concatenates two strings.</td>
<td>2</td>
</tr>
<tr>
<td>&amp;&amp;</td>
<td>Concatenates two strings and inserts a space between the two.</td>
<td>2</td>
</tr>
<tr>
<td>&quot;</td>
<td>Marks the beginning or end of a string.</td>
<td>1</td>
</tr>
</tbody>
</table>
Making choices in scripts

Lingo uses if...then...else and case statements to perform an action depending on whether a condition exists. The case statement is a shorthand alternative to repeating if...then statements when setting up a multiple branching structure.

Statements that check whether a condition is true or false begin with the Lingo element if. If the condition exists, Lingo executes the statement that follows then. If the condition doesn't exist, Lingo skips to the next statement in the handler.

To optimize your script’s performance, test for the most likely conditions first.

The statement if sprite 1 intersects 2 then alert "Move Over" is a test of one condition. The alert appears only if sprite 1 intersects sprite 2.

The statements

\[
\text{if the mouseMember = memberNum("1") then}
\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \text{go to "Cairo"}
\]
\[
\text{else if the mouseMember = member("map 2") then}
\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \text{go to "Nairobi"}
\]
\[
\text{else}
\]
\[
\text{alert "You’re lost."
}
\]
\[
\text{end if}
\]

test several conditions. The term else specifies alternative tests to perform if previous conditions are false.

When writing if...then structures, place the statement following then in the same line as then, or place it on its own line by inserting a carriage return after then. For example, the statement

\[
\text{if the mouseMember = member("map 1") then go to "Cairo"}
\]

is equivalent to

\[
\text{if the mouseMember = member("map 1") then}
\ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \text{go to "Cairo"}
\]
\[
\text{end if}
\]

You must include an end if statement at the end of the if...then structure if its lines include a carriage return.

The case statement lists the possible statements to run when a specific condition exists. The condition to test for follows the term case in the first line of the case structure. The comparison goes through each line in order until Lingo encounters an expression that matches the test condition. When a matching expression is found, Director executes the Lingo that follows the matching expression.
For example, the following case statement tests which key the user pressed most recently and responds accordingly:

```lingo
case (the key) of
    'A': go to frame "Apple"
    'B', 'C':
        puppetTransition 99
        go to frame "Oranges"
    otherwise beep
end case
```

- If the user pressed A, the movie goes to the frame labeled Apple.
- If the user pressed B or C, the movie performs the specified transition and then goes to the frame labeled Oranges.
- If the user pressed any other key, the computer beeps.

A case statement can use comparisons as the test condition. See if and case in the Lingo Dictionary.

**Repeating an action**

Lingo can repeat an action a specified number of times or while a specific condition exists.

**To repeat an action a specified number of times:**

Use a repeat with structure. Specify the number of times to repeat as a range following repeat with.

This structure is useful for performing the same operation on a series of objects. For example, the following repeat loop makes Background Transparent the ink for sprites 2 through 10:

```lingo
repeat with n = 10 down to 2
    sprite(n).ink = 36
end repeat
```

**To repeat a set of instructions as long as a specific condition exists:**

Use a repeat...while statement.

For example, these statements instruct a movie to beep continuously whenever the mouse button is being pressed:

```lingo
repeat while the mouseDown
    beep
end repeat
```

Lingo continues to loop through the statements inside the repeat loop until the condition is no longer true or until one of the instructions sends Lingo outside the loop. In the example, Lingo exits the repeat loop when the mouse button is released because the mouseDown condition is no longer true when this occurs.
To exit a repeat loop:

Use the exit repeat command.

For example, the following statements make a movie beep while the mouse button is pressed, unless the mouse pointer is over sprite 1. If the pointer is over sprite 1, Lingo exits the repeat loop and stops beeping. (The term rollover followed by a sprite number indicates whether the pointer is over the specified sprite.)

```
repeat while the stillDown
  beep
  if rollover (1) then exit repeat
end repeat
```

See repeat with, repeat while, and exit repeat in the Lingo Dictionary.

Storing and updating values in variables

Director uses variables to store and update values. As the name implies, a variable contains a value that can be changed or updated as the movie plays.

By changing the value of a variable as the movie plays, you can do things such as store a URL, track the number of times a user takes part in an online chat session, or record whether a network operation is complete.

Variables can hold any of the types of information found in Director: numbers, strings, TRUE or FALSE values, symbols, lists, or the result of a calculation.

To assign a value to a variable:

Use the equals operator (=). You can include the optional set command for improved readability.

For example, these statements assign a URL to the variable placesToGo:

```
placesToGo = "http://www.macromedia.com"
set placesToGo = "http://www.macromedia.com"
```

Variables can also hold the results of mathematical operations. Both of these statements add the result of an addition operation to the variable mySum:

```
mySum = 5 + 5
set mySum = 5 + 5
```

It's a good habit to use variable names that indicate what the variable is used for. For example, the variable mySum indicates that the variable contains the sum of numbers.

A variable in Lingo can contain different types of data. For example, a variable that contains a number can be assigned a string. (The ability to change a variable's type distinguishes Lingo from other languages such as Java, in which a variable's type cannot be changed.)
For example, the statement `set x = 1` creates the variable `x`, which is an integer variable because you assigned the variable an integer. If you subsequently use the statement `set x = "one"`, the variable `x` becomes a string variable because the variable now contains a string.

Variables can be global or local.

**Using global variables**

Global variables can be shared among handlers and movies. A global variable exists and retains its value as long as Director is running or until you issue the `clearGlobals` command.

Every handler that declares a variable as global can use the variable’s current value. If the handler changes the variable’s value, the new value is available to every other handler that treats the variable as global.

It is a good habit to start the names of all global variables with a lowercase `g`. This helps identify which variables are global when you examine Lingo code.

Because you usually want global variables to be available throughout a movie, it is good practice to declare global variables in an `on prepareMovie` handler. This ensures that the global variables are available from the very start of the movie.

It’s also a good idea always to assign a variable a known value the first time you define the variable. This makes it easier to track and compare the variable’s value as the movie plays.

**To declare that a variable is global:**

Use one of the following techniques:

- Use the variable in the Message window.
- Use the term `global` before the variable name in every handler that uses the global variable. You can also use the term `global` before the variable name at the top of the Script window, before any individual handlers. This makes the variable global for every handler in the script.

When you use the term `global` to define global variables, the variables automatically have `VOID` as their initial value.

The following statements make `gName` a global variable and give it the value Mary:

```lingo
global gName
gName = 'Mary'
```

**To display all current global variables and their current values:**

Use the `showGlobals` command in the Message window.

See `global` and `showGlobals` in the *Lingo Dictionary*. 

---

154  Chapter 7
Using local variables

A local variable exists only as long as the handler in which it is defined is running. However, after a local variable is created, you can use the variable in other expressions or change its value while Lingo is within the handler.

It’s a good idea always to assign a variable a known value the first time you define it. This makes it easier to track and compare the variable’s value as the movie plays.

To create a local variable:

Assign the variable a value using the equals operator (=) or the set...= command.

Unless the handler uses the term global to declare that a variable is global, the variable is automatically a local variable.

To display all current local variables in the handler:

Use the showLocals command.

This command can be used in the Message window or in handlers to help with debugging. The result appears in the Message window. Director’s debugger can also track the value of local variables. For more information about using the debugger, see “Troubleshooting Lingo,” in the Director Developers Center.

Treating variables as local is a good idea when you want to use a variable only temporarily in one handler. This helps you avoid unintentionally changing the value in another handler that uses the same variable name.

Returning results from handlers

Often you want a handler to report some condition or the result of some action.

Use the return function to have a handler report a condition or the result of an action. For example, the following handler returns the current color of sprite 1:

```
on findColor
   return sprite(1).foreColor
end
```

When you define a handler that returns a result, you must use parentheses after the handler when you call it from another handler. For example, the statement `put findColor()` calls the `on findColor` handler and then displays the result in the Message window.
Using arguments to pass values

Arguments are placeholders that let you pass values to handlers.

By using arguments for values, you can give the handler exactly the values that it needs to use at a specific time, regardless of where or when you call the handler in the movie. Arguments can be optional or required, depending on the situation.

To create arguments for a handler:

Put the arguments after the handler name. Use commas to separate multiple arguments.

For example, the following handler, called addThem, adds two values it receives in arguments a and b, stores the result in local variable c, and uses the Lingo term return to send the result back to the original handler:

```lingo
on addThem a, b
    -- a and b are argument placeholders
    c = a + b
    return c
end
```

Provide specific values for the arguments that the handler uses when you call the handler. You can use any type of value, such as a number, a variable that has a value assigned, or a string of characters. Values in the calling statement must be in the order they follow in the handler’s arguments, and they must be surrounded by parentheses.

The following statement is a calling statement for the on addThem handler:

```lingo
set mySum = addThem (4, 8).
```

Because 4 is first in the string of arguments, Lingo substitutes it for a in the handler. Likewise, because 8 is second in the string of arguments, Lingo substitutes 8 for b everywhere in the handler. You can also use variables as values.

After the calling statement sends these parameters to the handler, the handler returns the value 12, which corresponds to the variable c inside the on addThem handler. The variable mySum is then set to 12.
Managing lists

The most common way to create a linear list or property list is to use the list operator ([ ]). You can also use the list() function to create a linear list. (This function is useful when using a keyboard that doesn't provide square brackets.

A linear list or a property list can contain no values at all. An empty linear list consists of two square brackets ([ ]). An empty property list consists of two square brackets surrounding a colon ([:]).

It's usually easier to manipulate a list by first assigning it to a variable when you create the list. The value contained in the variable is actually a reference to the list, not the list itself.

To use the list operator to create a list:

Surround the list elements within the list operator. Use commas to separate items in the list.

For example, the following statement creates a linear list of three names:

```lingo
set workerList = ["Bruno", "Heather", "Carlos"]
```

To record what each person wants for dinner, you can create a property list that contains this information:

```lingo
foodList = ['Bruno': #pizza, 'Heather': #noodles, 'Carlos': #soup]
```

To create an empty linear list:

Set the list to [].

To create an empty property list:

Set the list to [:].

You can also use the list operator to specify values within a list.

To create a linear list by using the list() function:

Specify the list’s elements as parameters of the list() function.
Representing and setting items in a list

Lingo lets you represent and set individual items in a list. The syntax differs for linear and property lists.

To retrieve a value in a linear list:

Use the list's name followed by the number that indicates the value's position in the list. Place square brackets around the number. (You can also use the `getAt` command, which was introduced in earlier versions of Director.)

For example, in the linear list `set workerList = [ "Bruno", "Heather", "Carlos"]`, the expression `workerList[2]` represents the second value in the list `workerList`. The value is Heather.

To set a value in a linear list:

Use the equals operator. (You can also use the `setAt` command introduced in earlier versions of Director.)

For example, the statement `workerList[2] = "Tiffany"` makes Tiffany the new value for the second item in the list `workerList`.

To retrieve a value in a property list:

Use the list's name followed by the name of the property associated with the value. Place square brackets around the property. (You can also use the `getAProp` command, which was introduced in earlier versions of Director.)

For example, in the property list `foodList = ["Bruno": #pizza, "Heather": #noodles, "Carlos": #soup]`, the expression `foodList["Bruno"]` represents the value associated with the property Bruno. The value is #pizza.

To set a value in a property list:

Use the equals operator. (You can also use the `setAProp` command, which was introduced in earlier versions of Director.)

For example, the statement `foodList["Bruno"] = #sushi` makes sushi the new value associated with the property Bruno in the list `foodList`. 
Checking items in a list

You can determine the characteristics of a list and the number of items the list contains.

**To display the contents of a list:**
Use the `put` command followed by the variable that contains the list.

**To determine the number of items in a list:**
Use the `count()` function.

**To determine a list's type:**
Use the `ilk()` function.

**To determine the maximum value in a list:**
Use the `max()` function.

**To determine the minimum value in a list:**
Use the `min()` function.

**To determine the position of a specific property:**
Use the `findPos`, `findPosNear`, or `getOne` command.

Adding and deleting items in a list

You can add or delete items in a list.

**To add an item at the end of a list:**
Use the `append` command.

**To add an item at its proper position in a sorted list:**
Use the `add` or `addProp` command.

**To add an item at a specific place in a linear list:**
Use the `addAt` command.

**To add an item at a specific position in a property list:**
Use the `addProp` command.

**To delete an item from a list:**
Use the `deleteAt`, `deleteOne`, or `deleteProp` command.
To replace an item in a list:

Use the setAt or setaProp command.

You do not have to explicitly remove lists. Lists are automatically removed when they are no longer referred to by any variable.

Copying lists

Assigning a list to a variable and then assigning that variable to a second variable does not make a separate copy of the list. For example, the statement landList = ['Asia', 'Africa'] creates a list that contains the names of two continents. The statement continentList = landList assigns the same list to the variable continentList. However, adding Australia to landList using the statement add landList, 'Australia' automatically adds Australia to continentList also. This happens because both variable names point to the same object in memory.

To create a copy of a list that is independent of the first list:

Use the duplicate() function.

For example, this statement creates a list and assigns it to the variable oldList:

oldList = ['a', 'b', 'c']

This statement uses the duplicate() function to make an independent copy of the list and assign it to the variable newList:

newList = duplicate(oldList)

After newList is created, editing either oldList or newList has no effect on the other.

Sorting lists

Lists can be unsorted. However, Lingo can sort a list by alphanumeric order, with numbers before strings. Strings are sorted according to their initial letters, regardless of how many characters they contain.

Lingo sorts a linear list according to the values in the list. Lingo sorts a property list according to the properties in the list.

To sort a list:

Use the sort command followed by the list's name. See sort in the Lingo Dictionary.
Using the Script window

Use the Script window to create scripts and write the Lingo statements that make up handlers.

To open the Script window, do one of the following:

- Choose Window > Script.
- Double-click a script in a Cast window.

You can change the font of text in the Script window and define different colors for various code components. See Setting Script window preferences in Director Help.

Setting Script window preferences

Use Script window preferences to change the default font of text in the Script window, and the color of various code elements. Director automatically colors different code elements unless you turn off Auto Coloring.

To set Script window preferences:

1. Choose File > Preferences > Script
2. To choose the default font, click the Font button and choose settings from the Font dialog box.
3. To choose the default color of text in the Script window, choose a color from the Color menu.
4. To choose the background color for the Script window, choose a color from the Background color menu.
5. To make the Script window automatically color certain code elements, turn check Enable for Auto Coloring. This option is on by default. With Auto Coloring off, all text appears in the default color.
6. If Auto Coloring is on, choose colors for the following code elements from the corresponding color menus:
   - Keywords
   - Comments
   - Literals
   - Custom (terms defined in your own code)
Creating and attaching scripts

The following are ways to perform common tasks for creating, assigning, and opening scripts.

To create a behavior:

Choose New Script from the Behavior pop-up menu or double-click the behavior channel in the frame that you want to attach a behavior to.

When you create a new behavior, the behavior receives the cast number of the first available location in the current Cast window.

When you create a new behavior assigned to a frame in the behavior channel, the window already contains the line `on exitFrame`, followed by a line with a blinking cursor, and then a line with the word `end`.

To create a movie script:

If the current script in the Script window is a movie script, click the Add button in the Script window. (Clicking the Add button always creates a script of the same type as the current script.)

To change a script’s type:

Open the script’s Cast Member Properties dialog box and then choose a type from the Type pop-up menu.

To assign a behavior to one or more sprites or frames:

Do one of the following:

- Select the locations in the Score and then choose the behavior number from the Behavior pop-up menu.
- Drag the behavior from the Cast window to the locations where you want to attach the behavior.

To remove a behavior from a Score location:

Select the location and then choose Clear Script from the Behavior pop-up menu.

To cycle through the scripts in the Script window:

Use the Previous Cast Member and Next Cast Member arrows at the top of the Script window to advance or back up to a script.
To open a behavior for editing:

1. Double-click the behavior in the Cast window.
   The Behavior Inspector opens.
2. Click the script icon.
   The Script window displays the behavior.

Alternatively, you can open the Script window and cycle through the scripts until you reach the behavior.

To open a movie script or parent script for editing:

Double-click the script in the Cast window.

To duplicate a script:

Select the script in the Cast window and choose Duplicate from the Edit menu.

To open the script assigned to a cast member for editing:

Click Script in the Cast Member Properties dialog box or select the cast member in the Cast window and then click the Script button at the top of the Cast window.
Inserting Lingo in a script

The Script window provides a pop-up menu of common Lingo terms that you can use to insert Lingo in a script.

- The Alphabetical menu lists every element in alphabetical order.
- The Categories menu lists categories of elements according to the features they are often used for.

Some cast member types and scripting Xtras provide additional Lingo terms that do not appear in the Lingo menus.

When you choose an element from the Lingo pop-up menu, Director inserts the element at the cursor.

When an element requires additional parameters, Lingo includes placeholder names that indicate the additional required information. When more than one argument or parameter is required, Lingo highlights the first one for you, so all you have to do is type to replace it. You must select and change the other parameters yourself.
**Editing text in scripts**

Entering and editing text in a Script window is similar to entering text in any other field.

The following are common editing tasks you perform in the Script window.

**To select a word:**

Double-click the word.

**To select an entire script:**

Choose Select All from the Edit menu.

**To start a new line:**

Enter a carriage return.

**To wrap a long line of code with a continuation symbol:**

Press Alt-Enter (Windows) or Option-Return (Macintosh) where you want to insert a soft line break. The continuation symbol (¬) that appears indicates that the statement continues on the next line.

**To locate a handler in the current script:**

Choose the handler's name from the Handler pop-up menu in the Script window.

**To compile the Lingo you have written:**

Click the Script window's Recompile button or close the Script window.

Lingo automatically indents statements when the syntax is correct. If a line doesn't indent properly, there is a problem in the Lingo syntax on that line. Pressing Tab at any time in the Script window also formats a script's layout.
Finding handlers and text in scripts

The Find command in the Edit menu is useful for finding handlers and for finding and editing text and handlers.

To find text in scripts:
1. Make the Script window active.
2. Choose Edit > Find > Text.

The Find Text dialog box appears.

3. Enter text that you want to find in the Find field and then click Find.

Find is not case sensitive: ThisHandler, thisHandler, and THISHANDLER are all the same for search purposes.

To specify which cast members to search:
Select the appropriate radio button in the Search: Scripts field.

To start the search over from the beginning after the search reaches the end:
Turn on the Wrap-Around option.

To search only for whole words and not fragments of other words that match the word:
Turn on the Whole Words Only option.

To find the next occurrence of the text specified in the Find field:
Choose Edit > Find Again.

To find occurrences of selected text:
1. Select the text.
2. Choose Edit > Find > Selection.
To find handlers in scripts:

1. Choose Edit > Find > Handler.
   The Find Handler dialog box appears.

2. Click the handler that you want to find to select it.
3. Click Find.
   The handler appears in the Script window.
   The title bar at the top of the Script window indicates the script's type.
CHAPTER 8

Color, Tempo, and Transitions

Color, tempo, and transitions: Overview

There are a number of behind-the-scenes functions in Director that are important to the appearance and performance of a movie.

To control the way Director manages colors, it’s important to understand the difference between RGB and index color and how to assign colors to various elements in your movie.

To control the speed at which your movie plays, use settings in the tempo channel.

To make scenes in your movie flow together without creating the animation yourself, you can use predefined transitions.

All of these features involve using the channels at the top of the Score.
Controlling color in Director

Choosing colors for movie elements is as simple as making a selection from a menu. To make sure that the colors you choose are displayed correctly on as many systems as possible, it helps to understand as much as possible about how Director controls color.

Director provides a variety of color controls. The following list describes the most important:

- Use the Movie Properties dialog box to change modes for selecting colors. The options are palette index or RGB values. Also use the Movie Properties dialog box to set the Remap Palettes When Needed option. If this option is on, Director either dithers or remaps the colors in bitmapped images to the best available colors. If the option is off, Director assumes that all bitmaps use the movie's color palette and does not perform remapping or dithering, regardless of the settings for individual cast members. See "Setting Stage and movie properties" on page 57.

- Choose colors for movie elements using the pop-up color menus that appear throughout the Director application.

- Use Transform Bitmap to remap bitmap images to new palettes and change their color depth. You can also make the same changes when you import a bitmap. See "Changing size, color depth, and color palette for bitmaps" on page 255, and “About importing bitmaps” on page 240.

- Use the Score's palette channel to change the movie's color palette as a movie plays.

- Use the Color Palettes window to change the colors in a color palette.
**Specifying palette index and RGB color**

Director can use either palette index or RGB values to specify colors. RGB values are much more reliable and accurate for specifying colors than palette index values. RGB is the system that most web pages use.

Director identifies a palette index color by the number of its position in a set of colors called a color palette. Color number 12, for example, might be blue. If a different palette is active, color number 12 might be red. When a computer is set to display 256 colors or less, it can only display the colors in the palette currently active in the system. This means that images created to display with the colors of one palette do not appear correctly when a different palette is active. If you use palette index color in a movie and then switch palettes during the movie, or never make sure that the correct palette is active, the images in your movie may appear with the wrong colors.

Director identifies an RGB color as a set of hexadecimal numbers that specify the amounts of red, green, and blue required to create the color. When a computer is set to display thousands or millions of colors, Director always displays RGB colors correctly. When a computer is set to 256 colors or less, Director finds the closest color in the current color palette to approximate the RGB color.

Use the Color Selection options in the Movie Properties dialog box to choose the color mode for the current movie. When you choose RGB, all the colors you choose from the color menu in Director are specified in RGB values. When you choose Palette Index, the colors you choose are specified according to their position in the current palette. The color menu indicates which method is being used.

**To change the color mode of a movie:**

1. Choose Modify > Movie > Properties.
2. For Color Selection, choose either RGB or Palette Index.

**Changing the color depth of a movie**

A Director movie is set to the same color depth as the system when the movie is saved. In Windows, a movie cannot change the color depth of the system. On the Macintosh, you can make the movie reset the system color depth by turning on the Reset Monitor to Match Movie’s Color Depth option in the General Preferences dialog box.

**To change the color depth of a movie:**

1. Use system utilities to change the color depth of your system.
2. From within Director, save the movie file.
Choosing colors for movie elements

Use the Color menu to choose colors for movie elements such as the color for the Stage, vector shapes, and the foreground and background of sprites. For some elements, such as Stage and sprite colors, you can also enter hexadecimal values for any RGB color. The Color menu displays the colors in the current palette; the 16 larger color chips at the top of the menu identify your favorite colors.

If the movie is set to specify colors as RGB values, choosing a color from the Color menu specifies the RGB value of the color, not its index value. For an explanation of the difference between index and RGB color, see “Specifying palette index and RGB color” on page 171.

If you want to choose a color that is not in the current palette (and therefore not available on the Color menu), use the system color picker to specify any color.

You can change the set of colors available on the Color menu by choosing a new color palette in the Color Palette window.

The bar at the top of the color menu indicates whether the movie is set to RGB or index color.

**Note:** Hold down the Alt key (Windows) or Option key (Macintosh) while clicking the color chip to open the Color menu in the opposite mode (RGB or index).

**To choose colors not on the Color menu:**

1. Open the Color menu from the Sprite Inspector, the tool palette, or any other location.
2. Click Color Picker.
3. Use the Windows or Macintosh System Color dialog box to choose a color.
To edit the favorite colors on the Color menu:

1. Open the Color menu from the Sprite Inspector, the tool palette, or any other location.
2. Choose Edit Favorite Colors.
3. Choose the color position you want to change.
4. Choose a new color for the position using one of the following options:
   - Click the color box to open the Color menu and choose a color from the current palette.
   - Enter RGB values for a color in the box to the right of the color box.
   - Click Color Picker and use the system color utilities to specify a new color.
5. Click OK.

To change the colors available on the Color menu:

1. Choose Window > Color Palettes.
2. Choose a color palette from the pop-up menu.

*Note:* Single-click the Foreground and Background Color buttons in the tools palette to open the Color Picker; double-click to open the Palette window.

### Changing color palettes during a movie

The palette channel in the Score determines which palette is active for a particular frame in a movie. Use Modify > Frame > Palette to define the palette that is active in a particular frame of a movie. When the playback head reaches the frame with the palette change, Director switches to the new palette.

The settings in the palette channel have no effect on a movie playing in a web browser. Do not use any of these settings for movies on the web.

For a stand-alone disk-based movie that takes over the entire screen, changing palettes during a movie is a viable option for displaying 8-bit graphics with the best possible colors.

If you place a cast member that has a different palette on the Stage—and if it’s the first cast member that has a different palette in the frame—Director automatically assigns the new palette to the palette channel. The new palette becomes the active palette unless you clear it from the palette channel or replace it with a different palette, and it remains in effect until you set a different palette in the palette channel.

Only one palette can be active at any time. If an 8-bit image appears with the wrong colors, it requires a different palette. See “Solving color palette problems” on page 179.
Director includes several color palettes. The Windows and Macintosh system palettes are the default selections. Web216 is nearly identical to the palettes used by Netscape and Internet Explorer. Use it for any movie you plan to play in a browser. Any additional palettes you create or import appear as cast members.

While working on a movie, you can change the active palette in the authoring environment by choosing a new palette in the Color Palettes window. The palette that is active in the authoring environment while you work does not change the palette in the movie you’re working on. Any settings in the palette channel reset the active palette as soon as the movie plays.

To set a palette in the palette channel:

1  In the Score, select the frame in the palette channel where you want the new palette to take effect.
   Click the expander on the right side of the Score if the palette channel isn’t visible.

2  Choose Modify > Frame > Palette or double-click a cell in the palette channel.
   When the Frame Properties: Palette dialog box appears, you have many options:
   ▶ To set a new palette without any transition, first choose a new palette from the pop-up menu and then click the Palette Transition option.
   ▶ To hide a palette change within a fade, first choose a new palette from the pop-up menu. Click the Palette Transition option and then Select Fade to Black or Fade to White. Use the Rate slider to set the speed of the fade.
   ▶ To stop the movie while the palette changes, first choose a new palette from the pop-up menu. Click the Palette Transition option and then Select between Frames. Use the Rate slider to set the speed of the transition.

3  Click Set.
   The palette you chose now appears in the cell you selected in the Score’s palette channel. The setting remains in effect in the movie until you set a different palette in the palette channel.
Using the Color Palettes window

Use the Color Palettes window to change and rearrange color palettes and to
determine which colors in a palette are used in an image. This section explains
basic features of the Color Palettes window. For a description of specialized
features, see “Special Color Effects” in the Director Developers Center.

Select a palette to change. Reserve, select, and rearrange colors.

If you add new palettes to your movie from other graphics applications, those
palettes appear in the palette list and in the Cast window.

The row of buttons on the right side of the Color Palettes window are for
reserving, selecting, and rearranging colors in the current palette. If you attempt
to change one of the nine built-in palettes, Director creates a copy of the palette
for you to modify.

Note: Choosing a new palette in the Color Palettes window does not change the palette for
the movie or any frame in the movie. Use Movie Properties on the Modify menu to choose
the movie color palette or use Frame Palette on the Modify menu to change the color palette
at a particular frame.

When you change a palette, all the cast members using the palette change as well,
so make sure you always keep a copy of the original palette.

To open the Color Palettes window:
Choose Window > Color Palettes.
To edit a palette already used in a movie:

1. Duplicate and rename the palette.
2. Edit the palette.
   Use any of the methods discussed later in this section.
3. Select all the cast members that use the old version of the palette.
   Use Find to locate all the cast members using a particular palette.
4. Choose Modify > Transform Bitmap and remap all the cast members to the new palette.
   Be sure to remap and not dither.

To select one or more colors:

1. Click a color in the Color Palettes window. If the selection arrow is not active, click the selection arrow tool at the bottom of the window.
2. To select a range, drag across colors—or click the first color in the range, and then Shift-click the last.
3. Control-click (Windows) or Command-click (Macintosh) to select multiple discontiguous colors.

To match the color of any pixel on the Stage with the same color in the Palette:

1. Click the eyedropper tool.
2. Click any color in the Color Palettes window and without releasing the mouse button, drag to any point on the Stage.
   The selection in the Color Palettes window and the foreground color in the tools palette changes to the color at the pointer location.
To select colors in the palette used by the current cast member:

1. Select the cast member or open the cast member in the Paint window.

2. Click the Select Used button.

To select all colors not currently selected:

Click the Invert Selection button.
**Changing colors in a color palette**

You can define a new color for a color palette by selecting a color you want to change and then using either the controls at the bottom of the Color Palettes window or the system color controls (the Windows Color dialog box or the Macintosh Color Picker).

![Color Palettes window](image)

Define a new color by hue, saturation, and brightness. Open the Windows Color dialog box or the Macintosh Color Picker.
To edit selected colors in the Color Palettes window:

1. Choose Window > Color Palettes.
2. Select the palette you want to change from the Palettes pop-up menu.
3. Select a color within the palette to change.
   If you attempt to change one of the default palettes, Director makes a copy of the palette and prompts you to enter a name.
4. To change the color using the H, S, and B (hue, saturation, and brightness) controls, click the arrows next to the controls.
   - **Hue** is the color created by mixing primary colors.
   - **Saturation** is a measure of how much white is mixed in with the color. A fully saturated color is vivid; a less saturated color is a washed out pastel or, in the case of black, a shade of gray.
   - **Brightness** controls how much black is mixed in with a color. Colors that are very bright have little or no black. As more black is added, the brightness is reduced, and the color gets darker. If brightness is reduced to 0, then no matter what the values are for Hue or Saturation, the color is black.
5. To change the color using the system color picker, click the Color Picker button.
   For instruction on using the Windows Color dialog box or the Macintosh Color Picker, see your system documentation.

Controlling palettes with Lingo

Use the `puppetPalette` command to change the current palette and specify how quickly a new palette fades in. This command is useful when you want to change the palette to suit changing conditions in the movie without entering a new frame. For example, you can change the palette when you switch a cast member assigned to a sprite.

The new palette remains in effect until a new `puppetPalette` command is issued, a new palette is set in the palette channel, or a new movie starts.

See `puppetPalette` in the *Lingo Dictionary*.

Solving color palette problems

When images in your movie appear with the wrong colors, you probably have the wrong color palette active. Color palette problems are an issue only if you are using 8-bit bitmaps and you want your movie to be displayed correctly on 256 color systems (8-bit bitmaps always appear correctly on computers set to display thousands or millions of colors).
Eight-bit bitmaps don't store information about actual colors; they identify colors by referring to positions in the current color palette. When saving 8-bit bitmaps, graphics programs create palettes with the colors required to display a particular image. This palette is saved with the file and must be active when the bitmap appears in a Director movie for the bitmap to appear with the proper colors. Only one palette can be active at once. Whenever it's necessary to display more than one 8-bit bitmap on the screen at one time, as is often the case in Director movies, all the images must refer to the same palette.

To solve color palette problems:

Follow these guidelines:

- To avoid color problems in movies for the web, map all 8-bit bitmaps in your movie to Director's built-in Web216 color palette. This is essentially the same palette used by Netscape and Internet Explorer.
- Do not attempt to change palettes during a movie that plays in a web browser. The browser, not the Director movie, controls the palette. Browsers ignore all palette channel settings.
- Make sure all 8-bit images on the Stage at the same time refer to the same palette.
- If bitmaps are not dithering or remapping to the current palette, make sure the Remap Palettes When Needed option in the Movie Properties dialog box is on. See “Setting Stage and movie properties” on page 57.
- Make sure there are no palette changes in the palette channel that you were unaware of. When a cast member you are placing on the Stage has a palette different from the currently active palette, Director adds the new palette to the palette channel. If you don't realize that this has happened, you may find the palette changing unexpectedly when the movie plays.
- For disk-based movies, simplify your work and avoid frequent palette changes by mapping all the images in your movie to as few palettes as possible.
- Remap existing cast members to a new color palette using the Transform Bitmap command option.
- If the Import option for Palette is not available in the Import Options dialog box, the image's palette may not meet standard system requirements. Use an image editor to make sure the image's palette meets the following requirements: The palette must contain exactly 16, or 256 colors. The first and last colors in the palette must be black or white. There must be only one black and one white in the entire palette.
- Don’t change colors used by your system software for interface elements. In Windows, these color always appear as the first 10, and the last 10 colors in the palette.
Controlling tempo

Tempo is the number of frames per second Director tries to play. You can control tempo using the Score tempo channel or Lingo’s puppetTempo command.

Directors tempo settings control the maximum speed at which the playback head moves from frame to frame. The tempo doesn’t affect the duration of any transitions set in the transition channel, nor does it control the speed at which a sound or digital video plays.

Settings in the tempo channel can also make a movie pause and wait for a mouse click or key press. For information on making a movie wait for a cue point in a sound or video, see “Synchronizing media” on page 310.

For simple movies, using the tempo channel is often the best way to define tempos. For more sophisticated control of the speed of a movie, use Lingo’s puppetTempo command to control tempo.

You can’t make a movie go faster than the computer allows. Many factors can make movies play more slowly than the specified tempo, such as:

- Playing the movie on a slower computer
- Making the movie wait for cast members to download from a slow Internet connection
- Animating several large sprites at the same time
- Animating stretched sprites
- Color depth differences between the movie and monitor
- Animating sprites that have blend values

Using the tempo channel

Enter tempo changes in the tempo channel at the top of the Score. It’s best to begin a movie with a tempo setting in the first cell of the tempo channel.

If you don’t set a tempo until later in the movie, the beginning tempo is determined by the setting in the Control Panel. Director plays a movie at the tempo you’ve set until it encounters a new tempo setting in the tempo channel or a puppetTempo command is issued.
To specify a tempo setting:

1. In the Score, select a frame in the tempo channel and choose Modify > Frame > Tempo, or double-click the cell in the tempo channel where you want the new tempo setting to appear.

   Click the expander on the right side of the Score if the tempo channel isn’t visible.

2. Select the option you want to use in the Frame Properties Tempo dialog box.
   - To set a new tempo for the movie, use the Tempo arrows or drag the slider.
   - To pause the movie at the current frame for a certain amount of time, use the Wait arrows or drag this slider.
   - To pause the movie until the user clicks the mouse or presses a key, click Wait for Mouse Click or Key Press.
   - To pause the movie until a sound or digital video cue point passes, click Wait for Cue Point and choose a channel and cue point. See “Synchronizing media” on page 310.

3. Click OK.

   A number that matches the setting you’ve chosen appears in the tempo channel.

Comparing actual speed with tempos you’ve set

It’s a good practice to test the performance of your movie on a system similar to what your users have. Make sure the movie plays well on the slowest systems likely to be used.

The tempo you’ve set and the actual speed of a movie both appear in the Control Panel.
To compare the actual speed of a movie with the tempos you’ve set:

1. Play the move from start to finish.
2. Use the Step Forward button to step through the movie frame by frame.
3. In each frame, compare the tempo setting shown in the Control Panel with the actual speed shown there.
   If you haven’t recorded the actual speed of a movie in a particular frame, the Control Panel displays two dashes (--)..

**Locking frame durations**

Use the Lock Frame Durations option in the Movie Playback dialog box to make Director play a movie at the same tempo on all types of computers. For frames without tempo settings, Director uses the current tempo. Lock Frame Duration prevents a movie from going too fast on a fast system, but it cannot prevent a movie from going slowly on a slow system.

**To turn on Lock Frame Durations:**

1. Choose Modify > Movie > Playback.
2. Click Lock Frame Durations.

**Controlling tempo with Lingo**

Use the `puppetTempo` command to override the tempo set in the movie’s tempo channel. This approach is useful when you want to change the movie’s tempo in response to conditions that you can’t control, such as the type of computer the movie is playing on or a user’s action.

The `puppetTempo` command doesn’t retain control of the tempo channel. The movie uses any subsequent tempo settings in the Score after the `puppetTempo` command is issued.

See `puppetTempo` in the **Lingo Dictionary**.

**Using transitions**

Transitions create brief animations that play between frames to create a smooth flow as sprites move, appear, or disappear or as the entire stage changes. Director provides dozens of transitions built into the application. For example, you can dissolve from one scene to the next, display a new scene strip by strip, or switch to a scene as though revealing it through venetian blinds. You can also use many of the transitions to make individual elements appear or disappear from the screen.

Once they are defined, transitions appear in the Cast window as cast members. You can place them in the transition channel by dragging them from the cast to the Score.
Creating transitions

Transitions, like temps, palettes, sounds, and behaviors, have a channel set aside for them in the Score.

A transition always takes place between the end of the current frame and the beginning of the frame where the transition is set. If you want to create a dissolve between two scenes, set the transition in the first frame of the second scene, not in the last frame of the first scene.

To add a transition:

1. In the transition channel, select the frame in which you want the transition to occur.
2. Choose Modify > Frame > Transition or double-click the frame in the transition channel.
3. In the Frame Properties Transition dialog box, scroll to the transition you want and then select it. You can quickly select the transition by typing the first letter of the transition’s name.

   Many transitions have default settings for Duration and Smoothness. You can adjust the sliders to change the settings.

   For many transitions, you can also select whether the transition affects the entire Stage or just the area that’s changing.

   Xtra transitions may offer additional options provided by the developer. If the Options button is available when you choose an Xtra transition, click it to view and change the transition options.

4. Click OK.

   Director displays the cast member number that corresponds to the transition in the transition channel. The transition also appears in the cast.
Tips for using transitions

Here are some points to keep in mind when working with transitions:

- To play a sound while a transition occurs, place the sound in the frame immediately before the transition.
- The Dissolve Pixels, Dissolve Pixels Fast, or Dissolve Patterns transitions may look different on Windows and Macintosh systems. Test to ensure satisfactory results.
- If you export a movie that contains transitions as a digital video or PICS file, the transitions may not be preserved.
- A transition that occurs while a sound or digital video is decompressing may require more system resources than are available on less powerful systems. This may cause the sound to stop playing. If you notice this behavior while testing on low-end systems, try making the transition shorter, and avoid complex transitions such as Dissolve.

Using transition Xtras

You can add custom transitions that are available as transition Xtras. Transition Xtras appear with special icons in the Frame Properties: Transitions dialog box. Transition Xtras are often more complex than the transitions provided with Director and may include an additional dialog box for specialized settings.

To install a transition Xtra:

Place the transition Xtra in the Xtras folder in the Director application folder. The transition Xtra must be present when the movie runs.

Controlling transitions with Lingo

Use the `puppetTransition` command to set a transition with Lingo. This command gives you the flexibility to select a transition appropriate for current movie conditions or to apply a transition to sprites before the playback head exits the current frame.

For example, use the `puppetTransition` command to specify one of several transitions, depending on which sprites are on the Stage when the playback head enters a new frame, or apply a transition to a new sprite when it appears but the playback head doesn’t exit the frame.

The `puppetTransition` command applies only to the frame in which you issue the command. You do not need to explicitly return control of the transition channel to the Score after the transition occurs.

The `puppetTransition` command's parameters perform the same functions as the options in the Frame Properties: Transition dialog box.

See `puppetTransition` in the Lingo Dictionary.
CHAPTER 9

Animation

Animation: Overview

Animation is the changing of an image over time. The most common types of animation involve moving a sprite on the Stage and using a series of cast members in the same sprite. Other forms of animation include making a sprite smaller, larger, rotate, change colors, or fade in and out. Use either tweening or frame-by-frame animation to make sprites change over time.

For an introduction to animation, see the Animation topic in the Guided Tour in Director Help.

Frame-by-frame animation involves manually creating every frame in an animation, whether that involves switching cast members for a sprite or manually changing settings for sprites on the Stage.

Tweening is a traditional animation term that describes the process in which a lead animator draws only the animation frames where major changes take place, called keyframes. Assistants draw the frames in between.
To use tweening in Director, you define properties for a sprite in frames called keyframes and let Director change the properties in the frames in between. Tweening is very efficient for adding animation to movies for web sites since no additional data needs to be downloaded when changing a single cast member.

Properties that can be tweened are position, size, rotation, skew, blend, and foreground and background color. Each keyframe defines a value for all of these properties, even if you only explicitly define one.

Keyframes are where you define sprite properties.

Creating a film loop can consolidate animation into a single cast member. A film loop repeats an animation through as many frames as you extend it.
Tweening the path of a sprite

You can tween a sprite directly on the Stage by editing the sprite's path. Director displays the path of the selected sprite directly on the Stage. You can adjust the path by dragging keyframe indicators.

To tween the path of a sprite:

1. Place a sprite on the Stage where you want the path to start. If the sprite is already on the Stage, select it.
   This places the start frame of the sprite in the proper location. The start frame is also the first keyframe of the sprite.

2. If necessary, choose View > Sprite Overlay > Sprite Paths.
   The Show Paths option is on by default. With this option turned on, Director displays the paths of moving sprites on the Stage. Keyframes appear as hollow circles. Small tick marks show the sprite's position in tweened frames.

3. Drag the red handle within the sprite to the place on the stage where you want the sprite to move.

   The red handle represent the sprite's location in the end frame.
   For bitmaps, the red handle is usually in the center of the image. For vector shapes and other media types, the handle is often in the upper-left corner.
   Director displays the path the sprite will follow. The tick marks along the path show the sprite location in each frame in between.

4. To make the sprite curve between more points, hold down the Alt key (Windows) or Option key (Macintosh) and move the pointer on the Stage over a tick mark. When the pointer changes color, drag the tick mark to a new location.

   This creates a new keyframe and records the new location. Repeat this step to create additional keyframes.
5 To make the property changes defined by a keyframe occur at a different time, drag the keyframe in the Score to a new frame within the sprite.

6 To change the degree of curvature between keyframes, choose Modify > Sprites > Tweening and adjust the Curvature slider. See “Changing tweening settings” on page 194.

7 To make the sprite move in the same direction at the beginning and end, turn on Continuous at Endpoints in the Sprite Tweening dialog box. This creates a circular motion.

**Accelerating and decelerating sprites**

Use settings in the Sprite Tweening dialog box to create more natural motion in tweened sprites.

Ease-In makes a sprite move more slowly in the beginning frames; Ease-Out makes the sprite slow down in the ending frames. This setting makes the sprite move more like an object in the real world.

Ease-In and Ease-Out control how a sprite moves from its start frame to its end frame, no matter how many keyframes are in between.

The Speed settings control how Director moves a sprite between each keyframe. The Sharp Changes option is the default setting. Using this option, Director calculates how to move the sprite between each pair of keyframes separately. If a sprite's keyframes are an unequal number of frames apart from each other in the Score, or different amounts of space apart from each other on the Stage, if they are abrupt changes in speed may occur as the sprite moves between keyframe locations. Smooth out these speed changes by choosing the Smooth Changes option.
To change the acceleration or deceleration of a sprite:

1. Use one of the tweening methods to create a moving sprite.
2. Turn on View > Sprite Overlay > Show Paths to see how far the sprite moves between each frame.
3. Select the sprite and choose Modify > Sprites > Tweening.
4. Use the Ease-In and Ease-Out sliders to specify the percentage of the sprite’s path through which the sprite should accelerate or decelerate.
5. Choose one of the following speed settings:
   - **Sharp Changes** moves the sprite between keyframe locations without adjusting the speed.
   - **Smooth Changes** adjusts the sprite’s speed gradually as it moves between keyframes.

Changing sprite path settings

Sprite paths are the lines Director displays on the Stage to show the movement of a sprite. Sprite paths are controlled by the Sprite Overlay Settings dialog box. You can change settings to make the paths appear for all sprites, when the pointer rolls over a sprite, or for selected sprites. See “Using the Sprite Overlay” on page 71.

Tweening other sprite properties

In addition to tweening a sprite’s path, Director can tween the size, rotation, skew, blend, and foreground and background color of a sprite. Director can tween all of these properties at once.

Tween blend settings to make a sprite fade in or out. Tween rotation to make sprites spin or tilt. Tween color to create gradual shifts in color. Tweening size works best for vector-based cast members created in the Vector Shape window or Flash (bitmaps can become distorted when resized).

*Note:* To make Director not tween a certain property, choose Modify > Sprites > Tweening and turn off any of the tweening options.
To tween sprite properties:

1 Position a sprite and make sure it spans all the frames in which you want the sprite to change.

2 If the Score isn’t open, choose Window > Score.

3 Select the start frame of the sprite in the Score and define the beginning property settings. Do any of the following:
   ▶ To make the sprite fade in or out, enter a blend setting in the Sprite Inspector. Enter 0 to make the sprite fade in or 100 to make it fade out. For more information, see “Setting blends” on page 87.
   ▶ To tween size, scale the sprite or resize the sprite on the Stage. See “Resizing and scaling sprites” on page 82.
   ▶ To tween rotation or skew, manually rotate or skew the sprite to the beginning position or enter an angle in Sprite Inspector. See “Rotating and skewing sprites” on page 83.
   ▶ To tween color, use the color boxes in the Sprite Inspector to open the color menu for foreground and background color, or enter the RGB values for a new color in the boxes at the right.

4 In the Score, select the end frame of the sprite.

5 Choose Insert > Keyframe.
   Note that the end frame is not a keyframe unless you’ve create one there.

6 Make sure only the keyframe is selected (not the entire sprite) and then enter the ending values of the sprite properties you are tweening.

7 If necessary, create additional keyframes in the sprite and enter new values for the tweened properties.

8 To make the property changes defined by a keyframe occur at a different time, drag a keyframe in the Score to a new frame within the sprite.
   Rewind and play the movie to see the tweening occur. Director gradually changes the value of the tweened property in the frames between the keyframes.
Suggestions and shortcuts for tweening

Follow the suggestions listed here to improve results and productivity while tweening sprites.

- For smoother movements, tween across more frames, increasing the tempo if necessary.
- To achieve some types of motion, you may need to split the sprite and tween the sprites separately.
- Alt-drag (Windows) or Option-drag (Macintosh) keyframes to quickly make duplicates. This technique is useful when you want the start and end frames to have the same settings. This shortcut also provides a quick way to create a complex path. Insert a single keyframe, drag several duplicates to the proper frames, and then select the various keyframes and set positions on the Stage.
- Alt-drag (Windows) or Option-drag (Macintosh) a keyframe at the end of a sprite to extend the sprite and leave the last keyframe in place.
- Control-click (Windows) or Command-click (Macintosh) multiple keyframes to select them and then move the sprite on the Stage to move all keyframe positions at once.
- To make the animation look smoother, use an image editor to blur the edges of bitmaps.
- When tweening sprites that have a series of cast members, consider using a film loop instead. For more information, see “Using film loops” on page 201.
- Turn off all tweening options to make a sprite jump instantly between settings in different keyframes.
Changing tweening settings

Use the Sprite Tweening dialog box to change tweening properties for sprites. You can turn tweening on and off for certain properties and control the curve of a tweening path and the way the speed changes as a sprite moves. For information on creating tweened animation, see “Tweening the path of a sprite” on page 189.

To change tweening settings:

1. Select a tweened sprite on the Stage or in the Score.

2. Choose Modify > Sprites > Tweening to open the Sprites Tweening dialog box. The diagram in the upper-left corner shows the sprite’s path as specified by the Curvature, Speed, Ease-In, and Ease-Out settings. This does not show the actual path of the sprite, just the type of curve it will follow.

   If the start and end points of the sprite are the same, the diagram is circular, indicating that the sprite travels in a circle when tweened. If the start and end points are not the same, the diagram describes a curved path, indicating that the sprite ends at a point different than the starting point.

3. To change the properties of the sprite that are tweened, change the values for Tween. A check mark indicates the property will be tweened. The available properties are Path, Size, Rotation, Skew, Foreground Color, Background Color, and Blend.

4. To change how the sprite curves between positions defined by keyframes, adjust the Curvature slider.
   - Linear makes the sprite move in a straight line between the keyframe positions.
   - Normal means the sprite follows a curved path inside the keyframe positions.
   - Extreme makes the sprite follow a curved path outside the keyframe positions.

5. To make the sprite move smoothly through start and end frames when moving in a closed path, turn on Continuous at Endpoints.

6. To define how the tweened sprite positions change between keyframes, choose an option for Speed. See “Accelerating and decelerating sprites” on page 190.
   - Sharp Changes makes the changes in position occur abruptly.
   - Smooth Changes makes the changes in position occur gradually.

7. To define how tweened sprite positions change over the whole length of the sprite, use the sliders to change the values for Ease-In and Ease-Out.
   - Ease-In defines the percentage of the sprite span through which the sprite accelerates.
   - Ease-Out defines the percentage of the sprite span through which the sprite decelerates.
Switching a sprite’s cast members

Exchange the cast member assigned to a sprite to show different content while maintaining all other sprite properties. This technique is useful when you’ve tweened a sprite, and you decide to use a different cast member. When you exchange the cast member, the tweening path stays the same.

To exchange cast members:

1. Select a sprite.
   You can also select part of a sprite to change a cast member in those frame only.

2. Open the Cast window and select the cast member you want to use next in the animation.

3. Choose Edit > Exchange Cast Members.
   Director replaces the cast member for the entire sprite.

Before cast members are exchanged, the sprite moves like this.

After cast members are exchanged, the sprite still moves in the same way, but it displays a different cast member.

Lingo can also switch the cast member assigned to a sprite. See “Assigning a cast member to a sprite with Lingo” on page 90.
Editing sprite frames

Use the Edit Sprite Frames option to change how a sprite is selected and how keyframes are created. Use Edit Sprite Frames with sprites that have animation you need to adjust frequently. This option is especially useful for cell animation in which each frame contains a different cast member in a different position.

Ordinarily, clicking a sprite on the Stage or in the Score selects the entire sprite.

When Edit Sprite Frames is turned on for a certain sprite, clicking the sprite selects a single frame. Any change you make to a tweenable property, such as moving a sprite on the Stage, defines a new keyframe.

To use Edit Sprite Frames:

Select sprites and choose Edit > Edit Sprite Frames. You can also Alt-double-click (Windows) or Option-double-click (Macintosh) a frame within the sprite.

To return sprites to their normal state:

Select sprites and choose Edit > Edit Entire Sprite. You can also Alt-double-click (Windows) or Option-double-click (Macintosh) a frame within the sprite.
**Animating with a series of cast members**

Use a series of cast members to create animation more complex than is possible with simple tweening. Sprites usually refer to only one cast member, but they can also include several cast members. For example, an animation of a man walking may include several cast members showing the man in different positions. By placing all the images within a single sprite, you can work with the animation as if it were a single object.

Single sprite in the Score

![Single sprite in the Score](image)

**Sprite animating**

![Sprite animating](image)

*A single sprite can display several cast members.*

Use this approach sparingly for movies that will downloaded from the Internet; all cast members must be downloaded before the animation can run. Consider using vector shapes, rotation, and skewing on bitmapped cast members, or a Flash movie, as an alternative to this type of animation.

There are many ways to create multiple-cast member animations in Director. The following procedure explains a basic approach. Cast to Time provides an effective shortcut. See “Shortcuts for animating with multiple cast members” on page 199.

**Note:** The best way to prepare cast members for use in multiple-cast member animation is with onion skinning in the Paint window. For more information, see “Using onion skinning” on page 262.
To animate a sprite with multiple cast members:

1. Create a sprite by placing the first cast member in the animation on the Stage in the appropriate frame.

2. Change the length of the sprite as needed.
   - Drag the start or end frame in the Score or enter a new start or end frame number in the Sprite Inspector.

3. Choose View > Display > Cast Member.
   - This setting displays the name of the cast member on each sprite. For more information, see “Displaying sprite labels in the Score” on page 72.

   - This setting changes the view of the Score to show the name of each sprite’s cast member when it changes. This makes it easy to identify frames where the cast member changes. You may also want to zoom the score in to 800% so the frames are wide enough to display the cast member information.

5. Choose Edit > Edit Sprite Frames.
   - Edit Sprite Frames makes it easier to select frames within a sprite. See “Editing sprite frames” on page 196.

6. Select the frames in the sprite where you want a different cast member to appear.

7. Open the Cast window and select the cast member you want to use next in the animation.

8. Choose Edit > Exchange Cast Members.
   - Director replaces the cast member in the selected frame with the cast member selected in the Cast window.
9 Repeat these steps to complete the animation. Choose Edit Entire Sprite when you're done.

Sometimes a series of cast members placed in the Score jumps unexpectedly when you play the movie. This occurs because the cast member's registration points aren't aligned properly. When you exchange cast members, Director places the new cast member's registration point precisely where the previous cast member's registration point was. By default, Director places registration points in the center of a bitmap cast member's bounding rectangle.

For information about aligning registration points, see “Changing registration points” on page 253. You can also align sprites relative to their bounding rectangles. For more information, see “Aligning sprites” on page 77.

**Shortcuts for animating with multiple cast members**

The Cast to Time and Space to Time commands are both useful shortcuts for animating with multiple cast members.

**Cast to Time**

Use Cast to Time to move a series of cast members to the Score as a single sprite. This is one of the most useful methods for creating animation with multiple cast members. Typically, you create a series of images and then use Cast to Time to quickly place them in the Score as a single sprite. Director's onion skinning feature is also useful for creating and aligning a series of images for use in animation. For more information, see “Using onion skinning” on page 262.

![Cast to Time places selected cast members in the Score as a single sprite.](image)
To create a sprite from a sequence of cast members:

1. Select the frame in the Score where you want to place the new sprite.
2. Make the Cast window active.
3. Select the series of cast members to be placed in the new sprite.
4. Choose Modify > Cast to Time, or hold down Alt (Windows) or Option (Macintosh) and drag the cast members to the Stage.

   The selected series of cast members becomes a single sprite.

**Space to Time**

Use the Space to Time command on the Modify menu to move sprites from adjacent channels to a single sprite. This method is convenient when you want to arrange several images on the Stage in one frame and then convert them to a single sprite.

*Arrange sprites on the Stage in a single frame.*

*Space to Time converts sprites from adjacent channels to a single sprite.*

Onion skinning provides a benefit in the Paint window similar to that provided by Space to Time on the Stage. For more information, see “Using onion skinning” on page 262.
To use the Space to Time command:

1. Choose File > Preferences > Sprite and set Span Duration to 1 frame.
   
   Set the span duration to any setting you like, but Space to Time works best with shorter sprites.

2. Select an empty frame in the Score.
   
   This is usually at the end of the Score.

3. Drag cast members onto the Stage to create sprites where you want them to appear in the animation.
   
   As you position the sprites on the Stage, Director places each sprite in a separate channel. Make sure all the sprites are in consecutive channels.

4. Select all the sprites that are part of the sequence in the Score or on the Stage.

5. Choose Modify > Space to Time.

   The Space to Time dialog box appears. Set the number of frames you want between each cast member.

6. Enter an interval (usually 1).

   Director rearranges the sprites so that instead of being arranged from top to bottom in a single frame, they're arranged in sequence from left to right in a single sprite.

**Note:** Space to Time is a fast way to set up keyframes for a sprite to move along a curve. Arrange the cast members in one frame, choose Modify > Space to Time, and add 10 to 20 cells between each cast member to produce a smooth curve.

### Using film loops

A film loop is an animated sequence that you can use like a single cast member. For example, to create an animation of a bird flying across the Stage, you can create a film loop of the sequence of cast members that shows the bird flapping its wings. Instead of using the frame-by-frame technique, you create a sprite containing only the film loop and then animate it across as many frames as you need. When you run the animation, the bird flaps its wings and at the same time moves across the Stage.

You can also use film loops to consolidate Score data. Film loops are especially helpful when you want to reduce the number of sprite channels you're using. You can combine several Score channels into a film loop in a single channel.
To determine if a film loop is cropped or scaled within a sprite's bounding rectangle and to make the film loop repeat or mute its sounds, use the Film Loop Cast Member Properties dialog box. See Setting film loop properties in Director Help.

Film loops are useful for animating repetitive motions and combining sprites to use fewer channels.

To create a film loop:

1. In the Score, select the sprites you want to turn into a film loop.
   - Use sprites in as many channels as you need in film loops—even in the sound channel. Select sequences in all the channels you want to be part of the film loop. You can select sprite fragments if you first select a sprite and choose Edit > Edit Sprite Frames. Control-click (Windows) or Command-click (Macintosh) to select sequences that aren't in adjacent channels.

2. Choose Insert > Film Loop.
   - A dialog box appears asking you to name the film loop.

3. Enter a name for the film loop.
   - Director stores all the Score data and cast member references as a new film loop cast member.

   Note: Drag a selection from the Score to the Cast window to quickly create a film loop cast member in that position.

If you delete any cast member used in the film loop from the Cast window, Director can't run the film loop. You can edit or reposition the cast members in the Cast window, but the cast members in the film loop must remain in the same cast for the film loop to work.

A film loop behaves just like any other cast member, with a few exceptions:

▶ When you step through an animation that contains a film loop (either by using Step Forward or Step Backward or by dragging the playback head in the Score), the film loop doesn't animate. Animation occurs only when the movie is running.

▶ You can't apply ink effects to a film loop. If you want to use ink effects with a film loop, you need to apply them to the sprites that make up the animation before you turn the animation into a film loop.

▶ Lengthening or shortening a sprite containing a film loop doesn't affect how fast the film loop plays. It changes the number of times the film loop cycles.
Director provides three other ways of incorporating a completed animation into a movie as a discrete element: you can export it as a digital video (QuickTime or AVI), save and import it as a linked Director movie, or play it in a window in another Director movie.

*Note:* If you need to edit a film loop and you’ve deleted the original Score data it was based on, it’s possible to restore the Score data for editing. Copy the film loop cast member to the Clipboard, select a cell in the Score, and then paste. Director pastes the original Score data instead of the film loop.

**Animating sprites with Lingo**

Lingo can create animation regardless of the settings in the Score. This lets you create or modify animation depending on movie conditions.

To move a sprite on the Stage, use Lingo that controls the sprite’s location. See “Positioning sprites with Lingo” on page 75.

To animate a sprite by switching the sprite’s cast members, change the sprite’s member of sprite property. See “Assigning a cast member to a sprite with Lingo” on page 90.
CHAPTER 10
Navigation and User Interaction

Navigation and user interaction: Overview

Adding interactivity lets you involve your audience in your movies. Using the keyboard, the mouse, or both, your audience can jump to different parts of movies, add information, move objects, click buttons, and perform many other interactive operations.

Unless made to do otherwise, a movie plays through every frame in the Score from start to finish. Behaviors and Lingo can make the movie jump to a different frame, movie, or URL when a specified event occurs. With Lingo, you can include simple navigation instructions as part of more complex handlers and place navigation Lingo in movie scripts and scripts attached to cast members.

There are a number of other interactive features that you can add to your movie:

- Draggable sprites give your audience the ability to move sprites anywhere on the stage. You can also create boundaries beyond which sprites cannot move.
- Editable fields are fields in which your audience can enter or edit information.
- Rollovers make certain sprites change in appearance when the cursor passes over them, even if the user has not clicked the mouse. Using rollovers is an excellent way to give your audience feedback based on their actions.
- Changing cursors, which change based on criteria you choose. Lingo can provide animated cursors or specify one of the standard cursors or a bitmap cast member as a cursor image. See See cursor (command) and cursor (sprite property) in the Lingo Dictionary.


Creating basic navigation controls with behaviors

Director provides behaviors that create basic navigation controls without using Lingo. You can use behaviors to move the playback head to a frame number or marker. You can also stop the playback head at any frame and wait for the user to act.

The following examples explain the basic use of Hold on Current Frame and Go To Marker. You can also create your own navigation behaviors or get them from third-party developers.

To use basic navigation behaviors:

1. Create a movie that contains a sprite in frame one, and at least one marker in a later frame.
2. Choose Window > Library palette and select the library containing the navigation behaviors.
3. Drag Hold on Current Frame to frame one in the script channel.
   Typically, you use this behavior in a frame that contains a menu of choices.
4. Play the movie.
   The playback head remains in frame one where you attached the behavior.
   Notice that the movie is still playing, but the playback head remains on the single frame. Use Go To Frame or Go To Marker to send the playback head to a new frame and continue playing, as described in the following steps.
5. Stop the movie.
6. Drag the Go To Marker behavior from the Library palette to the sprite in frame 1.
7. In the Parameters dialog box, select the name of the marker where you want to send the playback head.
8. Rewind and play the movie again.
   The playback head is again stopped in the first frame by the Hold on Current Frame behavior.
9. Click the sprite to which you attached the Go To Marker behavior.
   The playback head jumps to the frame containing the specified marker and continues playing.
   You can use Go To Marker or Go To Frame to send the playback head back to the menu.
Jumping to locations with Lingo

Lingo’s navigation features can make a movie jump to other frames, other movies, or to Internet movies and web pages. You can also use Lingo to make a movie appear to pause by looping in one or a group of frames.

For details about specifying the location of frames, markers, and movies, see “Identifying frames with Lingo” on page 56.

Jumping to a different frame or URL

Lingo lets you jump to a different frame in the current movie or in another movie.

To jump to a specific frame in the current movie:

Use the go to command, followed by an identifier for the location.

For example, the statement go to "Begin Over" jumps to the frame labeled Begin Over.

To jump to the beginning of a different movie:

Use the go to command followed by an identifier for the movie.

For example, the statement go to movie "Citizen_Kane" goes to the beginning of the movie Citizen Kane.

To jump to a frame in a different movie:

Use the go to command followed by an identifier for the frame and the movie; use frame followed by the frame identifier and movie followed by the name of the movie.

For example, the statement go to "Rosebud" of movie "Citizen_Kane" goes to the frame labeled Rosebud in the movie Citizen Kane.

To jump to an Internet movie:

Use the goToNetMovie command.

To jump to a web page:

Use the goToNetPage command.
Looping in a group of frames

Looping within frames lets you create animation that recycles or have a movie to appear to pause. Such looping is useful for allowing a network operation to complete before the movie proceeds. Looping a movie by jumping from the current frame back to the first frame in the sequence can create a recycling animation effect.

To loop within one segment of the Score:
Use the statement go loop to return to a marker at the beginning of the segment. If there is no previous marker, the playback head jumps to frame 1.

To pause a movie in one frame but keep it playing so the movie can react to events:
Use the statement go to the frame to loop in the current frame.

To resume a movie that is looping in one frame:
Use the go to the frame + 1 command.

Jumping away and returning to the original location

You may want a movie to jump to a different frame or a separate movie and then return to the original frame. For example, at a web site that describes the weather, you could jump to a movie segment that explains weather term, and then return to the original location.

To jump away and return to the original location:
Use the play and play done commands.

The play command branches a movie to another frame, another movie, or a specified frame in another movie. The play done command remembers the original frame and returns to it without requiring that you specify where to return.

Use the play and play done commands when:

▷ The movie you want to play does not have instructions about where to return.
▷ You want to play several movies sequentially from a single script. When one movie finishes, Lingo returns to the script that issued the play command.
▷ You want to put one sequence inside another sequence and easily return to where you were in the outer sequence.
▷ You want to jump to one loop from several different locations.

See play and play done in the Lingo Dictionary.
Detecting mouse clicks with Lingo

Users can click the mouse button in several ways, each of which Lingo can detect. The following are ways that you can use Lingo to detect what the user does with the mouse.

To determine the last place the mouse was clicked:
Use the `clickLoc()` function.

To determine the last active sprite (a sprite with a script attached) that the user clicked:
Use the `clickOn()` function.

To determine whether the last two clicks were a double-click:
Use the `doubleClick()` function.

To determine the time since the mouse was last clicked:
Use the `lastClick()` function.

To determine whether the mouse button is pressed:
Check the `mouseDown` property.

To determine whether the mouse button is released:
Check the `mouseUp` property.

To determine whether the right mouse button is pressed (Windows only):
Check the `rightMouseDown` property.

To determine whether the right mouse button is released (Windows only):
Check the `rightMouseUp` property.

For example, this handler checks whether the user double-clicked the mouse button and, if so, runs the handler `on openWindow`:

```lingo
on mouseDown
  if the doubleClick = TRUE then openWindow
end
```
Making sprites editable and draggable

Using the Sprite Inspector, you can make a sprite editable, draggable, or both while your movie is running. See “Using the Sprite Inspector” on page 68.

To make a sprite draggable on the Stage:
Select the Moveable option in the Sprite Inspector.

To make a text sprite editable:
Select the Editable option in the Sprite Inspector.

Checking which text is under the pointer with Lingo

Lingo can detect which text component in a text or field cast member is currently under the mouse pointer.

To detect which character in a text cast member is under the pointer:
Use the pointToChar() function. See pointToChar() in the Lingo Dictionary.

To detect which item in a text cast member is under the pointer:
Use the pointToItem() function. See pointToItem() in the Lingo Dictionary.

To detect which word in a text cast member is under the pointer:
Use the pointToWord() function. See pointToWord() in the Lingo Dictionary.

To detect which paragraph in a text cast member is under the pointer:
Use the pointToParagraph() function. See pointToParagraph() in the Lingo Dictionary.

To detect whether a specific point is in a hyperlink within a text cast member and is under the pointer:
Use the pointInHyperlink() function. See pointInHyperlink() in the Lingo Dictionary.

To detect which line in a field is under the pointer:
Use the mouseLine() function. See mouseLine() in the Lingo Dictionary.

To detect which word in a field is under the pointer:
Use the mouseWord() function. See mouseWord() in the Lingo Dictionary.
Making sprites editable or moveable with Lingo

Lingo can make sprites editable or moveable regardless of the settings in the Score.

To make a text sprite editable with Lingo:

Set the text sprite’s editable property. For best results, set this property in a script attached to the sprite or the frame where the sprite is located. See editable in the Lingo Dictionary.

To make a sprite moveable from Lingo:

Set the moveableSprite sprite property to TRUE. For best results, set this property in a script attached to the sprite or the frame where the sprite is located. See moveableSprite in the Lingo Dictionary.

You can also use Lingo to constrain a moveable sprite to a certain region. For example, you can create a draggable slider with an indicator that moves across a gauge.

To restrict the registration point of a moveable sprite so it stays within the bounding rectangle of a second sprite:

Use the constraint sprite property. See constraint in the Lingo Dictionary.

To constrain a sprite along only horizontally or vertically:

Use the constrainH() or constrainV() function. See constrainH () or constrainV in the Lingo Dictionary.
Responding to rollovers with Lingo

You often want some action to occur when the user rolls the cursor over a particular place on the Stage. Specify how the movie responds by placing Lingo in a handler that runs when the cursor rolls over a sprite.

Director provides several event handlers that run when the cursor rolls over a sprite. Messages for each of these events are sent to the sprite script, the script of the cast member, the frame script, and then to the movie script.

**To set up Lingo that runs when the cursor enters a sprite’s bounding rectangle:**

Place the Lingo in an `on mouseEnter` event handler. See `on mouseEnter` in the *Lingo Dictionary*.

**To set up Lingo that runs when the cursor leaves a sprite’s bounding rectangle:**

Place the Lingo in an `on mouseLeave` event handler. See `on mouseLeave` in the *Lingo Dictionary*.

**To set up Lingo that runs when the user clicks a sprite and rolls off the sprite before releasing the mouse button:**

Place the Lingo in an `on mouseUpOutside` event handler. See `on mouseUpOutside` in the *Lingo Dictionary*.

**To set up Lingo that runs when the cursor is within a sprite’s bounding rectangle when the playback head enters the frame that contains the sprite:**

Place the Lingo in an `on mouseWithin` event handler. See `on mouseWithin` in the *Lingo Dictionary*.

The `on mouseWithin` event can occur repeatedly as long as the cursor remains inside the sprite.

Use the `rollOver()` function to determine whether the cursor is over a specific sprite. See `rollOver()` in the *Lingo Dictionary*.
Finding cursor locations with Lingo

Determining where the cursor is on the Stage is a common need in Director.

To determine the cursor’s horizontal and vertical positions:

Check the `mouseH()` and `mouseV()` functions. See `mouseH` and `mouseV` in the Lingo Dictionary.

The `mouseV()` function returns the number of pixels the cursor is below the upper-left corner of the Stage. The `mouseH()` function returns the number of pixels the cursor is to the right of the upper-left corner of the Stage.

The statements `put the mouseH` and `put the mouseV` display the cursor’s location in the Message window.

For example, this handler directs the Message window to display the distance (in pixels) between the cursor and the upper-left corner of the Stage:

```lingo
on exitFrame
  put the mouseH
  put the mouseV
  go to the frame
end
```

Checking keys with Lingo

Lingo can detect which key the user pressed last.

To obtain the ANSI value of the last key that was pressed:

Use the `key()` function. See `key()` in the Lingo Dictionary.

To obtain the keyboard’s numerical value for the last key pressed:

Use the `keyCode()` function. (The numerical value is the same as the ASCII value.) See `keyCode()` in the Lingo Dictionary.

A common place for using `key` and `keyCode` is in an `on keyDown` handler. This instructs Lingo to check the value of `key` only when a key is actually pressed. For example, the following handler in a frame script sends the playback head to the next marker whenever the user presses Enter (Windows) or Return (Macintosh):

```lingo
on keyDown
  if the key = RETURN then go to marker (1)
end
```
**Equivalent cross-platform keys**

Because of inherent differences between Windows and Macintosh keyboards, keys on Windows and Macintosh computers don't always directly correspond.

This can create confusion because Lingo often uses the same term to refer to corresponding keys on Windows and Macintosh computers, even though the key's name differs on the two platforms.

The following table lists Lingo elements that refer to specific keys and the keys they represent on each platform.

<table>
<thead>
<tr>
<th>Lingo term</th>
<th>Windows key</th>
<th>Macintosh key</th>
</tr>
</thead>
<tbody>
<tr>
<td>RETURN</td>
<td>Enter</td>
<td>Return</td>
</tr>
<tr>
<td>commandDown</td>
<td>Control</td>
<td>Command</td>
</tr>
<tr>
<td>optionDown</td>
<td>Alt</td>
<td>Option</td>
</tr>
<tr>
<td>controlDown</td>
<td>Right mouse button</td>
<td>Control</td>
</tr>
<tr>
<td>ENTER</td>
<td>Enter key on the numeric keypad (during authoring, pressing Enter starts playing the movie)</td>
<td>Enter key on the numeric keypad (during authoring, pressing Enter starts playing the movie)</td>
</tr>
<tr>
<td>BACKSPACE</td>
<td>Backspace</td>
<td>Delete</td>
</tr>
</tbody>
</table>

**Identifying keys on different keyboards**

Characters can vary on different keyboards. Avoid possible confusion by identifying a character by its ASCII value.

**To obtain a character's ASCII value:**

Use the `charToNum()` function. See `charToNum()` in the Lingo Dictionary.

For example, this statement finds the ASCII value for the letter `A` and displays it in the Message window:

```lingo
put charToNum("A")
-- 65
```

**To find out which character corresponds to an ASCII value:**

Use the `numToChar()` function. See `numToChar()` in the Lingo Dictionary.

For example, this statement finds the character that corresponds to the ASCII value 65. The result is the letter `A`:

```lingo
put charToNum(65)
-- A
```
Using animated color cursors

Director supports animated cursors. You can use any 8-bit bitmap source in your Director cast as an image in the cursor animation, automatically scale images, and generate masks for 16-pixel by 16-pixel and 32-pixel by 32-pixel cursors. (The Macintosh doesn’t support 32-pixel by 32-pixel cursors.)

An animated cursor consists of a series of bitmap cast members. Each bitmap cast member is a frame of the cursor. You can control the rate at which Director plays the frames of an animated cursor. Using the Cursor Properties Editor, you designate one or more bitmap cast members as frames of a single cursor cast member.

Xtras that support animated cursors

The Director installation program places two animated color cursor files in the Media Support folder within the Director application’s Xtras folder. The specific files depend on the platform you are using.

<table>
<thead>
<tr>
<th>Windows</th>
<th>PowerPC</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cursor Options.x32</td>
<td>Cursor Options</td>
<td>This file supports the creation of cursors while authoring movies in Director. Do not distribute this file with projectors. This file is not licensed for redistribution.</td>
</tr>
<tr>
<td>Cursor Asset.x32</td>
<td>Cursor Asset</td>
<td>Distribute this file with any movies or projectors that you create using the animated custom cursors.</td>
</tr>
</tbody>
</table>

Requirements for animated color cursors

All cast members used for an animated color cursor must:

- Be bitmap cast members
- Have a color depth of 8 bits (256 colors)
- Use only the first eight or the last eight colors that are in the standard System-Win palette. These provide the most predictable results when playing back across platforms. Other colors may not appear correctly.

The cast members need not be in sequence in the cast, and they need not be in the same cast.

A cursor’s maximum size depends on the computer:

- In Windows 95, you can create cursors of either 16 by 16 pixels or 32 by 32 pixels (almost always 32 by 32 pixels, but some video cards may support only 16 by 16 pixels).
- In Windows NT, you can create cursors of 16 by 16 pixels or 32 by 32 pixels.
- On the Macintosh, you can create cursors of 16 by 16 pixels.
When you are creating cursors in the Cursor Properties Editor, Director dims any size option that is not available on your computer.

The 16-pixel by 16-pixel and 32-pixel by 32-pixel sizes are the maximum sizes at which Director can display a cursor on the screen. The actual cast members you specify for the cursor can be larger than the maximum, and Director will scale the cast members to the appropriate size, maintaining the aspect ratio as it scales them. If you specify a cast member smaller than the maximum size, Director displays the cast member at its original size, without scaling. For example, if you select a maximum size of 16 by 16 pixels and then specify a cursor that is 12 by 14 pixels, Director displays the cursor at 12 by 14 pixels.

Creating an animated color cursor cast member

Before creating an animated color cursor cast member, make sure that the cast members you want to use in the cursor are stored in a cast linked to the movie. See “Working with casts” on page 112.

To create an animated color cursor cast member:

1. Choose Insert > Media Element > Cursor. Director opens the Cursor Properties Editor dialog box, which you use to set up the cursor.
2. From the Cast pop-up menu, choose the cast that contains the cast member you want to add as a frame in your cursor.
   The cast members used for a single cursor can be stored in different casts.
3. Use the < and > buttons to find the cast member you want.
   As you click the buttons, the preview shows a thumbnail of the selected cast member. If you do not see the cast member you want, the cast member probably isn’t a bitmap or has a color depth greater than 8 bits (256 colors). The Cursor Properties Editor shows only bitmaps that can be used in an animated color cursor.
   You can also type a cast member number in the Member box and press Tab; Director will select the cast member that has that number or the cast member with the number closest to it.
4. Select the cast member you want and click Add.
   You see the cast member in the Cursor Frames area preview. The Frame X of Y field shows where the cast member falls within an animated series of cursor frames.
5 Repeat steps 2 through 4 until you have added all the cast members for the cursor.

In the Cursor Frames area, you can use the < and > buttons to review the order of the cursor frames. Click the Remove button to delete the currently selected frame from the cursor (this deletes the cast member only from the cursor animation, not from the cast).

6 In the Interval field, specify the number of milliseconds that elapse between each frame of the cursor animation.

This interval affects all frames of the cursor and cannot vary for different frames. The cursor frame rate is independent of the frame rate set for the movie using the tempo channel or the puppetTempo Lingo command.

*Note:* By inserting the same bitmap in multiple frames of the cursor, you can create the illusion of variable-rate cursor animation.

7 In the Hotspot Position fields, specify the location of the cursor’s active point.

Director uses this point to track the cursor’s position on the screen. For example, Director uses this point’s location when it returns values for the mouseH() and mouseV() functions. The hotspot also determines the point where a rollover occurs.

The first field specifies the horizontal (x) location, and the second field specifies the vertical (y) location. The upper-left pixel is location 0,0. In a 16-pixel by 16-pixel cursor, the lower-right pixel is location 15,15. You can’t enter a point that is beyond the bounds of the cursor.

8 Click one of the Size options to specify the maximum size of the cursor.

If one of the Size options is dimmed, your computer does not allow you to create cursors of that size.

9 Select the Automask option if you want the white pixels of the cursor frames to be transparent.

*Note:* The Automask option turns all white pixels transparent. If you want some white pixels to be opaque, you can’t use white for those pixels, but you can achieve the same effect by instead using the lightest shade of gray available in the system palette.

10 Click OK to close the Cursor Properties Editor.

After you create a cursor cast member, use Lingo to use the cursor in a movie. See “Using an animated color cursor in a movie” on page 218.
Using an animated color cursor in a movie

Once you have added an animated color cursor to the cast, use Lingo to switch to the animated cursor just as you would any other cursor. You can set up an animated cursor as the movie's cursor or a sprite's cursor.

To switch to an animated color cursor, use this command:

```lingo
cursor (member whichCursorCastMember)
```

For `whichCursorCastMember`, substitute a cast member name (surrounded by quotation marks) or a cast member number. For example, this sprite script changes the cursor to the cast member named myCursor when the cursor is over the sprite:

```lingo
on mouseEnter
  cursor (member "myCursor")
end
```

To reset the cursor to the regular arrow cursor, specify a cursor type of -1 (and do not use parentheses). This sample sprite script resets the cursor:

```lingo
on mouseLeave
  cursor -1
end
```

**Note:** Do not place an animated color cursor cast member on the Stage.
Movies in a window: Overview

Director can play multiple movies simultaneously by creating windows that additional movies can play in. The movie in a window (MIAW) is a distinct Director movie that retains all its interactivity.

You can use MIAW simply to play another movie in a separate window while the main movie plays on the Stage. In addition, movies in windows and the main movie can communicate and interact with each other. This lets you use movies in a window for a variety of purposes, such as creating an interactive portfolio, a control panel for a second movie or digital video, or a status display window.

The original movie that created the window can open and delete the window.

Here’s the typical workflow for using a movie in a window:

➤ Create and set up the window.
➤ Assign a movie to the window.
➤ Open the window and play the movie.
➤ Delete the window when the reason for playing the movie no longer applies.

When creating a movie in a window, first decide how you want it to behave and work. For example, decide how you want to display it, how users should be able to move the window around the screen and dismiss it, and how the window should appear. You can specify the window’s size and whether the window is visible, has a frame and title, or is in front of or behind other windows on the screen.

You can create and control MIAWs using behaviors from the Behavior Library or by writing your own Lingo scripts.

Shockwave doesn’t support MIAWs. Use MIAWs only with movies that you intend to distribute as projectors.
Creating a MIAW using Lingo

In Lingo, you create a window by specifying the window’s rectangle on the Stage and then specifying the file name for the movie assigned to the window. You can also make the window visible, change its type, set its title, and set the window’s size and location.

You can create a MIAW using variables, which make it easier to write the handler and reuse it. Alternatively, you can use the movie’s file name as the argument for the open window command. This approach assigns that movie to a window and instructs Director to use the file name as the window title.

To create a new MIAW using variables:

Follow this example:

```lingo
on beginNewMovie theMovie
  global newWindow
  set newWindow to window 'The Big Picture'
  set the rect of newWindow to rect(0, 0, 250, 200)
  set the fileName of newWindow to theMovie
  set the titleVisible of newWindow to FALSE
  open newWindow
end beginNewMovie
```

The variable `newWindow` contains a new window named The Big Picture. The handler specifies the coordinates of a rectangle, instructs Director to use that rectangle as the window named The Big Picture, and then assigns a movie file to the window. The handler makes the title bar at the top of the window invisible and then opens the window.

To create a new MIAW using a file name and the open window command:

Follow this example:

```lingo
on beginNewMovie theMovie
  global newWindow
  set newWindow to window 'theMovie'
  set the titleVisible of newWindow to FALSE
  open newWindow
end beginNewMovie
```

This version of the handler uses the movie’s rectangle to determine the size of the window’s rectangle.
Setting the window type

You can choose from seven styles of windows:

- Four document windows styles: the standard document window, a document window with a zoom box and variable resize box, a document window with the variable resize box disabled, and a document window without a resize box
- An alert box style
- A plain box style
- A curved-border style

To specify the window type:

Assign a value for the `windowType` property.

Different numerical values for the `windowType` property specify different types of window styles. When you don’t specify a window type, Director uses a moveable, sizeable window without a zoom box, which is type 0.

In most cases, it’s best to specify window settings before you actually open the window, to avoid delays as the window redraws. Changing the window type after the window is open can result in a delay as the window is redrawn.

See `windowType` in the Lingo Dictionary.

Note: In Windows, a MIAW is constrained to the window that makes up the main movie’s Stage. If you use a type of window that is draggable, users will not be able to drag the MIAW outside the Stage. To let the user drag a MIAW anywhere on the screen, set the projector to play back in full-screen mode.

Opening the window

Use the `open window` command to open the window any time after the window has been created.

Unless Lingo explicitly preloads the movie, the movie isn’t loaded into memory until the window is first opened, which can result in a noticeable pause. Use `preLoadMovie` to load the first frame of the movie.

You can specify other window characteristics before or after you open the window.

See `open window` in the Lingo Dictionary.
Setting the window size and location

Setting the window’s screen coordinates lets you control how large the window is and where the window appears. Setting the coordinates before the movie appears controls the initial position of the window. Setting them after the window appears moves the window.

To specify a window’s coordinates:

Set the rect window property to the coordinates of the location where you want the window to appear, choosing from the following options:

- Define the coordinates as a list (called a rect) in the order left, top, right, and bottom.
- Use the rect function to define the window rectangle’s four coordinates, as in these statements:
  ```lingo
  set aRect = rect(0, 0, 200, 300)
  set the rect of window "Sample" = aRect
  
  For convenience, assign the coordinates to a variable and then use the variable in the statements you write.
  ```

See rect(window) in the Lingo Dictionary.

Cropping and scaling a MIAW

Lingo can crop or scale a MIAW.

To crop a MIAW:

Set the rect window property to an area smaller than the movie that plays in the window. See rect(window) in the Lingo Dictionary.

To scale a movie:

Set the drawRect property to coordinates smaller than the movie’s original size and apply the position to the window, as shown in the following example:

```lingo
set aRect = [0, 0, 200, 300]
set the drawRect of window "Sample" = aRect

When the drawRect property specifies a window rectangle that is smaller than the movie, the window appears in the upper-left corner, and the movie is compressed to fit within the window. See drawRect in the Lingo Dictionary.
```
Controlling a window’s appearance

Lingo controls whether a window is visible, is in front of or behind other windows, and has a title.

To specify whether the window is visible:
Set the window’s `visible` property. You can avoid a potential time lag when the window opens by using `preLoadMovie` to preload the movie before it’s needed and then opening the window when it needs to be visible. See `visible` in the Lingo Dictionary.

To control whether a movie appears in front of or behind other windows:
Use the `moveToFront` and `moveToBack` commands. See `moveToFront` and `moveToBack` in the Lingo Dictionary.

To assign a title to a window:
Set the `title` window property. See `title` in the Lingo Dictionary.

Closing windows

You can close or forget a MIAW. Closing a window prevents reduced performance when the user clicks something that reopens the window and reloads the movie; however, the movie still takes up space in memory. Forgetting a window causes Director to remove the movie from memory when it’s no longer in use.

To close a window:
Use the `close window` command. After the window is closed, the window becomes invisible, but the movie in the window continues playing. See `close window` in the Lingo Dictionary.

To reopen a window:
Use the `open` command. See `open window` in the Lingo Dictionary.

To dispose of a window when no other window or global variables still refer to it:
Use the `forget window` command. See `forget window` in the Lingo Dictionary.
Listing the current windows

The windowList property displays a list of all known windows in the main movie. For example, the statement put the windowList displays a list of current window names in the Message window. See windowList in the Lingo Dictionary.

Interaction between windows

Movies can interact with each other by sending Lingo messages back and forth. This lets movies share current values for variables, share information about current conditions, and send each other Lingo instructions.

To have a specific movie run a Lingo statement:

Use the tell command. See tell in the Lingo Dictionary.

When using the tell command, be sure to specify to which window the instructions are directed. When you want a MIAW to send a Lingo message to the main movie, use the stage to refer to the main movie. For example, the statement tell the stage to go to 'Help' instructs the main movie to go to the frame marked Help in the main movie.

At times, you may want only one movie to respond when the user clicks the mouse or types on the keyboard. To control when Director can respond to any events that occur outside a window, set the modal window property.

In Lingo, only the main movie can open a MIAW.

To have a MIAW open another MIAW:

Use the tell command in the existing MIAW to tell the stage, which is the main movie, to open another MIAW.

Events involving windows

Lingo provides event handlers for the typical events, such as the movement of a window by the user, that can occur to a movie. These handlers are a good place for instructions that you want to run in response to an event that involves a window.

For example, an on closeWindow handler runs whenever the MIAW that contains the handler closes. To play a sound each time the MIAW closes, use a puppetSound command in an on closeWindow handler in a movie script within the movie that plays in the window.

See “Movie in a window events,” in the Lingo by Feature appendix in the Lingo Dictionary.
Parent Scripts

Parent scripts: Overview

Parent scripts provide the advantages of object-oriented programming within Director. Use parent scripts to generate objects that behave and respond similarly yet can still behave independently of each other.

Lingo can create multiple copies (or instances) of a parent script. Each instance of a parent script is called a child object. You can create child objects on demand as the movie plays. Director doesn't limit the number of child objects that can be created from the same parent script. You can create as many child objects as the computer's memory can support.

Director creates multiple child objects from the same parent script just as Director can create multiple instances of a behavior.

This chapter describes the basics of how to write parent scripts, and create and use child objects, and it provides script examples. This section doesn't teach object-oriented programming concepts; however, using parent scripts and child objects successfully requires that you understand object-oriented programming principles.
**Similarity with other object-oriented languages**

If you are familiar with an object-oriented programming language such as Java or C++, you may already understand the concepts that underlie parent scripting, but know them by different names.

Terms that Director uses to describe parent scripts and child objects correspond to common object-oriented programming terms:

- **Parent scripts** correspond to classes.
- **Child objects** correspond to instances.
- **Property variables** correspond to instance variables or member variables.
- **Handlers** correspond to methods.
- **Ancestor scripts** correspond to the Super class or base class.

**Similarities between parent scripts and behaviors**

Parent scripts and behaviors are similar in many ways. The main difference between parent scripts and behaviors is that behaviors are associated with locations in the Score. Behavior child objects are automatically created from initializers stored in the Score as the playback head moves. In contrast, parent scripts must be created explicitly by a handler.

Behaviors and parent scripts differ in how they become associated with sprites. Director automatically associates a behavior with the sprite that the behavior is attached to, but you must explicitly associate a parent script with a sprite.

Typically, parent scripts are used to build objects that make it easier to organize movie logic. Parent scripts are useful as classic stacks, queues, and other information managers. You can also add a parent script to a sprite’s `scriptInstanceList` or the `actorList` as a way to control animation.

**Parent script basics**

A parent script is a set of handlers and properties that define a child object; it is not a child object itself. All the parent script’s handlers appear in a child object. Because child objects of the same parent script have identical handlers, the child objects respond to events in similar ways.

The property variables defined in the parent script are properties for which each child object maintains separate values. For example, you can create a parent script that defines editable text fields, each with its own property settings, editable text, and color regardless of the other text fields’ settings. You can change any of these characteristics as the movie plays without affecting the other fields.

Parent scripts are a distinct type of script just like score or movie scripts.
**Child object basics**

A child object is a self-contained, independent instance of a parent script. Child objects created from the same parent script share these characteristics:

- Related child objects have identical handlers, so child objects in the same group can have similar responses to events and messages.
- Each child object maintains independent values for the properties defined in the parent script. As a result, each child object can behave differently than its related child objects—even though they are instances of the same parent script.

For example, child objects from the same parent script can all contain a property named `theNumber`, but the value of `theNumber` can differ for each child object. Also, a child object can have a property set to TRUE or FALSE regardless of the property’s setting for related child objects.

**Ancestor basics**

Parent scripts can have ancestors, which are additional scripts whose handlers and properties a parent script can call on and use.

Ancestor scripting makes writing parent scripts more convenient by enabling you to create a set of handlers and properties that you can use and reuse for multiple parent scripts.

A parent script makes another parent script its ancestor by assigning the script to the `ancestor` property. For example, the following statement makes the script `What_Everyone.Does` an ancestor:

```
set ancestor to new(script"What_Everyone.Does")
```

When handlers and properties are not defined in parent scripts, Director searches for the handler or property in an ancestor script. If a handler is called and the parent script contains no definition for it but a definition exists in the ancestor script, the handler in the ancestor script is used. The same reference to the ancestor script occurs for a property variable reference.

A child object can have only one ancestor at a time, but an ancestor can have its own ancestor. This lets you create a series of parent scripts whose handlers are available to a child object.

See ancestor in the *Lingo Dictionary*. 

---

Parent Scripts  227
Writing a parent script

A parent script contains the Lingo needed to create a child object and define its possible behaviors and properties. First decide how you want the child objects to behave. Then write a parent script that does the following:

- Declares any appropriate property variables. This optional statement declares the variables that each child object maintains independent of other child objects.
- Sets up the child objects’ initial values and parameters in the on new handler.
- Contains additional handlers that control the child objects’ behavior and properties.

Declaring property variables

Each child object created from the same parent script contains the same set of variables. Individual child objects can receive different messages and behave differently after they are created. To have each child object maintain its own values for some variables independent of other child objects, make these variables property variables.

A property variable’s value belongs only to the child object it’s associated with. Each property variable and its value persists as long as the child object exists. The initial value for the property variable is typically set in the on new handler; if it’s not set, the initial value is VOID.

To declare a variable as a property variable:

Use the property keyword at the beginning of the parent script. See property in the Lingo Dictionary.

To set and test property variables from outside the child object:

Set and test property variables the same as for any other property in Lingo.
Creating the on new handler

Each parent script typically uses an on new handler. This handler creates the new child object. (The handler can also set the child object’s initial values, if you want.) The on new handler always starts with the phrase on new, followed by the me variable and any arguments being passed to the new child object. See new() in the Lingo Dictionary.

The following is a sample on new handler:

```lingo
property spriteNum

on new me, aSpriteNum
    spriteNum = aSpriteNum
    return me
end
```

Adding other handlers

You determine a child object’s behavior by including in the parent script the handlers that produce the desired behavior.

Using the me variable

Typically, one parent script creates many child objects, assigning each child object more than one handler. The me variable lets you refer to an instance of a child object wherever it’s used without actually naming it.

The term me is a special parameter variable. It must always be the first parameter variable and should be stated in every parent script handler definition.

The me parameter is a place holder for the child object. When an object is the first parameter in a handler that is called, the handlers defined in the child object’s parent script receive priority. This is why it is always important to define me as the first parameter for parent scripts and to pass the same parameter if you need to call other handlers in the same parent script.

When referring to properties defined in ancestor scripts, you must use the me parameter as the source of the reference. For example, these statements both use me to refer to an object:

```lingo
--access ancestor property
x = me.y
or
x = the y of me
```

Because the me variable is present in each handler of the child object, it indicates that all the handlers control the same child object.

See me in the Lingo Dictionary.
Creating child objects

Child objects exist entirely in RAM.

To create a new child object, you use the new function and assign the child object a variable name or position in a list so you can identify and work with it later.

The new function creates a child object by calling the on new handler in a parent script and specifying an identification number for the child object, a reference to the parent script, and the values of the object’s property variables.

You can issue a new statement from anywhere in a movie. You can customize the child object’s initial settings by changing the values of the arguments in the new statement.

The number of objects that you can create and maintain is relatively limitless. Each child object requires only enough memory to record the current values of its properties and variables and a reference to the parent script.

You can produce additional child objects from the same parent script by issuing additional new statements.

To create a child object and assign it to a variable:

Use the syntax

```
set variable = new(script "scriptName", argument1, argument2, argument3...))
```

where scriptName is the name of the parent script and argument1, argument2, argument3... are any arguments you are passing to the child object’s on new handler.

Removing a child object

You can remove a child object from a movie by setting all variables that contain a reference to the child object to another value. (If the child object has been assigned to a list, such as the actorList, you must also remove the child object from the list.)

To remove a child object and the variables that refer to it:

Set each variable to VOID.

Director deletes the child object when there are no more references to it. For example, if ball1 contains the only reference to a specific child object, then the statement set ball1 = VOID deletes the object from memory.

The actorList property is useful for tracking and manipulating the child objects in a movie.

To remove an object from actorList:

Use the delete command to delete the item from the list. See delete in the Lingo Dictionary.
**Using the scriptInstanceList**

You can use the scriptInstanceList to dynamically add new behaviors to a sprite. Normally, the scriptInstanceList is the list of behavior instances created from the behavior initializers defined in the Score. If you add child objects created from parent scripts to this list, the child objects receive the messages sent to other behaviors.

For example, this statement adds a child object to the scriptInstanceList of sprite 10:

```plaintext
add sprite(10).scriptInstanceList, new(script "rotation", 10)
```

This is a possible parent script that the statement refers to:

```plaintext
-- parent script "rotation"
property spriteNum

on new me, aSpriteNum
  spriteNum = aSpriteNum
  return me
end

on prepareFrame me
  sprite(spriteNum).rotation = sprite(spriteNum).rotation + 1
end
```

When child objects are added to the scriptInstanceList, you must initialize the child object’s spriteNum property. Typically you do this from a parameter passed in to the on new handler.

**Note:** The beginSprite message is not sent to dynamically added child objects.
Using the actorList

Lingo can set up a special list of child objects (or any other objects) that receives its own message each time the playback head enters a frame or the updateStage command updates the Stage.

- The special list is actorList, which contains only objects that have been explicitly added to the list. See actorList in the Lingo Dictionary.
- The message is the stepFrame message that is sent only when the playback head enters a frame or the updateStage command is used. See on stepFrame in the Lingo Dictionary.

Objects in actorList receive a stepFrame message instead of an enterFrame message at each frame. If the objects have an on stepFrame handler available, the Lingo in the on stepFrame handler runs each time the playback head enters a new frame or the updateStage command updates the Stage.

Some possible uses of actorList and stepFrame are to animate child objects that are used as sprites or to update a counter that tracks the number of times the playback head enters a frame.

An on enterFrame handler could achieve the same results, but the actorList property and on stepFrame handler are optimized for performance in Director. Objects in the actorList respond to stepFrame messages more efficiently than to an enterFrame message or to a custom message sent after an updateStage command.

To add an object to the actorList, use the statement add the actorList, theObject. The object's on stepFrame handler in its parent or ancestor script will then run automatically each time the playback head advances.

Director doesn't clear the contents of actorList when branching to another movie, which can cause unpredictable behavior in the new movie. If you don't want child objects in the current movie to be carried over into the new movie, insert a statement that clears the actorList in the on prepareMovie handler of the new movie.

Clear child objects from actorList by setting actorList to [], which is an empty list.

Don't remove an object from actorList in an on stepFrame handler as this may cause unexpected results.
Vector shapes and bitmaps: Overview

Director’s two main types of graphics are vector shapes and bitmaps. A vector shape is a mathematical description of a geometric form that includes the thickness of the line, the fill color, and so on. A bitmap defines an image as a grid of colored pixels. It stores the color for each pixel in the image.

A vector shape is best for a simple, smooth, clean-looking image. It typically includes less detail, but it can be resized without distortion. Like a bitmap, Director anti-aliases a vector shape against its background. A vector shape can also be dynamically controlled with Lingo. You can create a vector shape entirely with Lingo or modify an existing one as the movie plays. Because a vector shape is stored as a mathematical description, it requires less RAM and disk space than an equivalent bitmap image and downloads faster from the Internet.
Bitmaps are best for complex and irregular images with a lot of detail at the pixel level. You can easily make minute changes to a bitmap by editing single pixels, but resizing the image can cause distortion as pixels are redistributed. Director anti-aliases a bitmap against its background, meaning that Director blends the bitmap's colors with background colors around the edges to make the edge appear smooth instead of jagged. A bitmap typically requires more RAM and disk space than a comparable vector shapes—and it can take longer to download from the Internet.

Create vector shapes in Director’s Vector Shape window by defining points through which a line passes. The shape can be a line, a curve, or an irregular shape and can be filled with a color or gradient.

Create bitmaps in the Paint window or import them from any of the popular image editors in most of the popular formats, including GIF and JPEG. Director can also import bitmaps with alpha channel (transparency) data and animated GIFs. The Paint window includes a variety of tools for editing and applying effects to bitmaps.

**Drawing vector shapes**

You create vector shapes with drawing tools in the Vector Shape window. Use the pen tool to create irregular shapes, or use shape tools to create rectangles and ellipses. A vector shape can include only a single open or closed line. You cannot create a vector shape cast member that includes disconnected lines or curves.

**To open the Vector Shape window:**

Choose Window > Vector Shape.

**Using the vector shape drawing tools**

Use the tools in the Vector Shape window to draw free-from shapes or geometric figures. Define a shape with the pen tool by creating curve or corner points through which a line passes. Use the rectangle, rounded rectangle, and ellipse tools to draw regular shapes.

For an introduction to vector shapes, see the vector shapes topic in the Guided Tour in Director Help.
To create a vector shape using the pen tool:

1. In the Vector Shape window, click the New Cast Member button.
2. Click the pen tool and begin drawing:

   ▶ To create a corner point, click once.
   ▶ To create a curve point, click and drag. Dragging creates control handles that define how the line curves through the point you define.
   ▶ To constrain a new point to vertical, horizontal, or a 45 degree angle, hold down the Shift key while clicking.

To draw using a basic shape tool:

1. In the Vector Shape window, click the New Cast Member button.
2. Select the filled or unfilled rectangle, rounded rectangle, or ellipse tool.

3. Hold down the mouse button to start a path, drag to draw, and release the mouse button to end the path.
   To constrain a rectangle to a square, or to constrain an ellipse to a circle, hold down Shift while dragging.
Choosing fill and line settings for vector shapes

Use controls in the Vector Shape window or Lingo to choose the fill color, the line width and color, and the background color. The background is the area outside of a vector shape but within the cast member’s bounding rectangle.

Because a vector shape is a single object, you don’t need to select any part of the vector shape to make the following changes.

To choose the fill and line settings:

1. Open a vector shape in the Vector Shape window.
2. Choose fill and line settings using the appropriate controls at the left of the window.

- To choose a fill color, choose a color from the Fill Color menu.
- To choose the line color, choose a color from the Line Color menu.
- To set the line width, choose a point size option from the Line Width menu.
- To set the background color, choose a color from the Background Color menu. Choosing a background color that matches the color of the background results in better performance than using Background Transparent ink.

Specifying vector shapes with Lingo

You can use Lingo to specify a vector shape’s fills and strokes.

To specify the strokes that form a vector shape with Lingo:

Set the strokeColor and strokeWidth cast member properties. See strokeColor and strokeWidth in the Lingo Dictionary.

To specify a vector shape’s fill with Lingo:

Set the fillColor, fillMode, fillOffset, and fillScale cast member properties. See fillColor, fillMode, fillOffset, and fillScale in the Lingo Dictionary.
Editing vector shapes

To edit a vector shape you must work in the Vector Shape window. You change vector shapes by moving, adding, or deleting control points and changing the way they control curves. You can also change the way a vector shape is placed on the Stage by moving its registration point either from Director's user interface or with Lingo.

To adjust the outline of a vector shape:

1. Open a vector shape in the Vector Shape window.
2. Click the arrow tool so you can move points in the vector shape.
3. Make any of the following changes:
   - To move a curve or corner point, drag it to any location.
   - To move multiple points, Shift-click or drag a selection rectangle around all the points you want to move and then drag any of the selected points.
   - To adjust a curve, select a curve point and drag a control handle. By default, the two control handles remain at a 180 degree angle from each other. If you want to drag one control handle independently from the other one, hold down Control (Windows) or Command (Macintosh) when you drag it. To constrain the control handles to vertical, horizontal, or a 45 degree angle, hold down Shift as you move them.
   - To change a corner point to a curve point, Alt-click (Windows) or Option-click (Macintosh) and drag away from the handle to extend a control handle.
   - To change a curve point to a corner point, drag the control handles directly over the curve point.
   - To delete a point, select the point and press Backspace or Delete.
   - To move the window view without using the scroll bars, click the Hand tool and drag anywhere inside the movie.

To add a point in the middle of a line:

1. Open a vector shape in the Vector Shape window.
2. Click the pen tool.
3. Hold down Alt (Windows) or Option (Macintosh) and move the pointer over a line until it changes and then click the mouse button.

To add a new point that is connected to a certain end point:

1. Click the arrow tool and select an end point.
2. Click the pen tool and then click the location where you want the next point.
To change the registration point:

1. Click the registration point tool.
   The dotted lines in the window intersect at the registration point. The default registration point is the center of the cast member.
   The pointer changes to a cross hair when you move it to the window.

2. Click to set the new registration point.
   You can also drag the dotted lines around the window to reposition the registration point.

3. To reset the default registration point at the center of the cast member, double-click the registration point tool.

To change a vector shape cast member’s registration point with Lingo:
Set the regPoint cast member property. You can test the centerRegPoint property to determine whether Director automatically recenters the registration point when the cast member is edited. See centerRegPoint and regPoint in the Lingo Dictionary.

To close or open a vector shape:
Check or uncheck the Closed box at the left side of the window.
If the shape is open, Director draws a line between the last and first points defined; if it is closed, Director removes the line between the last and first points.

To close a point with Lingo:
Set the closed cast member property to TRUE. See closed in the Lingo Dictionary.

To scale a vector shape:
Control-Alt-drag (Windows) or Command-Option-drag (Macintosh) to proportionally resize a vector shape.
You can also enter a scaling percentage for a vector shape using the Cast Member Properties dialog box. See Setting vector shape cast member properties in Director Help.

Defining gradients for vector shapes
Use controls in the Vector Shape window or Lingo to specify the type of gradient, how it is placed within a shape, and how many times it cycles within the shape. A gradient for a vector shape shifts between the fill color and the end color you define. You can create linear or radial gradients. Changes you make to vector shape gradients have no effect on gradients for bitmaps in the Paint window. You can fill only closed vector shapes with gradients.
To define a gradient for a vector shape:

1. Create or open a closed vector shape in the Vector Shapes window.
2. Click the Gradient button.
3. To choose colors for the gradient, click the color box on the left side of the Gradient Colors control and choose a starting color from the Color menu. To choose the ending color, repeat this step using the color box on the right side of the Gradient Colors control.
4. Choose Linear or Radial from the Gradient Type pop-up menu at the top of the window.
5. To define the number of times the gradient should change colors within the shape, use the Cycles control.
6. To specify the rate at which the gradient shifts between colors, use the Scale control to enter a percentage.
   A setting of 100% uses the entire width or height of the shape to gradually shift colors. Lower settings make the shift more abrupt. For settings over 100%, the end color is reached at a theoretical location beyond the edges of the shape.
7. To rotate the gradient within the shape, use the Angle control to enter the number of degrees.
   This setting affects only linear gradients.
8. To offset the gradient within the shape, enter X Offset (horizontal) and Y Offset (vertical) values.

To specify a gradient with Lingo:

Set the fillDirection, fillMode, fillOffset, fillScale, gradientType, and endColor cast member properties. See fillColor, fillDirection, fillMode, fillOffset, gradientType, and endColor in the Lingo Dictionary.
About importing bitmaps

Importing bitmaps is similar to importing other types of cast members. If you import a bitmap with a color palette or depth different than the current movie, the Image Options dialog box appears. You must choose to import the bitmap at its original color depth or at the current system color depth. If you are importing an 8-bit image, you have the choice of importing the image's color palette or remapping the image to a palette already in Director.

Director can import images with alpha channel (transparency) effects. Images with an alpha channel are 32 bits. If you reduce the image to a lower color depth, Director removes all the alpha channel data.

When importing bitmaps, you should always consider that they will be displayed on the screen at your monitor's resolution (generally 72 to 96 dots per inch). Higher resolution images that you place on the Stage in Director may appear much larger than you expect. Other applications, particularly those focused on creating images for print, allow you to work on the screen with high-resolution images at reduced sizes. Within Director, you can scale high-resolution images to the right size, but this may reduce the quality of the image. Also, high-resolution images use extra memory and storage space, even after they've been scaled.

If you are working with a high-resolution image, convert it to between 72 and 96 dots per inch with your image editing program before you import it into Director.

Director supports JPEG compression at runtime for internal cast members imported through the Standard or Include Original Data for Editing import options. A JPEG file imported with either of these options contains both the original compressed bits as well as decompressed bits. Once imported, the JPEG file decompresses in the authoring environment. The cast member size displays the member's size in RAM after it has been decompressed. The amount of RAM required to display a JPEG file is larger than its size on disk, so do not be surprised that your cast member size is larger than its original size on disk in the Cast Properties window.

Director takes advantage of compressed JPEG data at runtime. The original compressed data bits are saved in a Shockwave movie or a projector (if the Shockwave compression option is on). If you edit the member within Director in the Paint window, the compressed data will be lost. An alert appears before the data is overwritten.
Using animated GIFs

Import an animated GIF into Director with File > Import just as you would any other bitmap cast member. Director supports both the GIF89a and GIF87 formats. GIFs must have a global color table to be imported. You can import an animated GIF within a movie file or link to an external file. You also have the choice of importing the first frame of an animated GIF as a still image. Just as with an ordinary bitmap, place an animated GIF in the Score in a sprite channel and extend it through all the frames in which you want it to appear. An animated GIF can play at the same frame rate as the Director movie, at a different rate that you specify, or at its original rate.

Director does not support the following inks for animated GIFs: Background Transparent, Reverse, Not Reverse, Darkest, Lightest, Add, Add Pin, Subtract, Subtract Pin.

You can make an animated GIF play direct-to-stage, meaning that it is immediately displayed on the Stage instead of being first composed in an off-screen buffer with other sprites. A direct-to-stage GIF take less time to load, but you cannot place other sprites in front of it or use any ink effect.
To set properties for an animated GIF:

1. Select an animated GIF cast member and choose Modify > Cast Member > Properties. Director displays noneditable information about the cast member on the left side of the dialog box, including:
   ▶ The cast member number
   ▶ The cast name
   ▶ The size in kilobytes

2. Use the Name field to view or edit the cast member name.

3. To specify how Director removes the cast member from memory if memory is low, choose an option from the Unload pop-up menu. See “Controlling cast member unloading” on page 110.

4. To set specific animated GIF settings, click Options.

5. To change the file of a linked external cast member, enter a new pathname in the Import field or click Browse to choose a new file. Click Internet to enter a new URL for a file to be imported from the Internet.

6. To achieve the fastest playback rate, turn on Direct to Stage. When Direct to Stage is on, you can only use Copy ink and you cannot place any sprites on top of the animated GIF sprite.

7. Choose an option from the Tempo pop-up menu.
   - Normal plays at the GIF’s original rate, independent of the Director movie. The GIF cannot exceed Director’s frame rate.
   - Fixed plays at the frame rate you enter on the right.
   - Locked-Step plays at the same rate as the Director movie.
Paint window basics

The Paint window has a complete set of paint tools and inks for creating and changing bitmap cast members for movies. Anything you draw in the Paint window becomes a cast member. When you make a change to a cast member in the Paint window, the image in the Cast window is instantly updated—as is the cast member wherever it appears on the Stage.

To open the Paint window, do any of the following:

► Choose Window > Paint.
► Click on the toolbar.
► Press Control-5 (Windows) or Command-5 (Macintosh).
► Double-click a bitmap sprite on the Stage or in the Score or double-click the sprite’s cast member in the Cast window.

Paint window tools and controls

The paint window contains the following tools and controls:

Note: If you see an arrow in the lower-right corner of a tool, click it to display a pop-up menu of options for that tool.

To select an irregular area:

Click the lasso tool and drag to enclose the pixels you want to select.

The lasso selects only those pixels of a color different from the color the lasso was on when you first started dragging it.

Press Alt (Windows) or Option (Macintosh) while dragging to create a polygon-shaped selection. Every time you click, you create a new angle in the selection polygon.

Press and hold the mouse button over the lasso icon to choose new settings from the pop-up menu.

See “Using the lasso” in Director Help.
To select a rectangular area:

Click the marquee tool and drag to select a rectangular area.
Double-click the marquee tool to select the entire bitmap.
Press and hold the mouse button over the marquee tool to choose new settings from the pop-up menu.
See “Using the selection marquee” in Director Help.

To change the location of the registration point:

Click the registration point tool and click where you want to place the registration point.
Double-click to set the registration point in the center of the image.
See “Changing registration points” on page 253.

To erase:

Click the eraser tool and drag to erase pixels.
Double-click to erase the cast member.

To move the view of the Paint window:

Click the hand tool and drag to move the visible portion of the image within the Paint window.
Shift-drag to move straight horizontally or vertically.
Press the spacebar to temporarily activate this tool while using other paint tools.

To zoom in or out on an area:

Click the magnifying glass tool to and click in the Paint window to zoom in.
Shift-click to zoom out.
See “Zooming in and out in the Paint window” on page 249.
To select a color in a cast member:

- Click the eyedropper tool and do one of the following:
  - Click a color to select it as the foreground color.
  - Shift-click a color to select it as the background color.
  - Alt-click (Windows) or Option-click (Macintosh) to select the destination color for a gradient.

Press D to temporarily activate the eyedropper while using other paint tools.

To fill all adjacent pixels of the same color with the foreground color:

- Click the paint bucket tool and then click the area you want to fill.
- Double-clicking the paint bucket tool opens the Gradient Settings dialog box.

To enter bitmapped text:

- Click the text tool and then click in the Paint window and begin typing.
- Choose character formatting with the Modify > Font command.
- Bitmap text is an image. Before you click outside the text box you can edit text you’ve typed by using the Backspace key (Windows) or Delete key (Macintosh). Once you have clicked outside the text box, you cannot edit or reformat bitmap text.

To draw a 1-pixel line in the current foreground:

- Click the pencil tool and drag in the Paint window.
- If the foreground color is the same as the color underneath the pointer, the pencil tool draws with the background color.
- Hold down Shift to constrain the line to horizontal and vertical.

To spray variable dots of the foreground color:

- Click the airbrush tool and drag in the Paint window.
- Press and hold the mouse button on the air brush icon to choose a new brush type from the pop-up menu. Choose Settings to change the selected brush.
- See “Using the air brush tool” in Director Help.

To paint brush strokes of the foreground color:

- Click the paint brush tool and drag in the Paint window.
- Press and hold the mouse button over the paint brush tool and choose a new brush type from the pop-up menu. Choose Settings to change the selected brush.
- Hold down Shift to constrain the stroke to horizontal or vertical.
- See “Using the paint brush tool” in Director Help.
To paint shapes:

Drag the shape tools to create a shape or line.

Press and hold the Shift key to constrain lines to horizontal or vertical, ovals to circles, and rectangles to squares.

The filled tools create shapes filled with the foreground color and the current pattern. The thickness of lines is determined by the line width selector.

To choose a foreground and destination color for color-shifting inks:

Click the color chip on the left to choose a foreground color; click the color chip on the right to choose a destination color.

These colors affect Gradient, Cycle, and Switch inks. Each of these uses a range of colors that shifts between the foreground color and the destination color.

See “Using gradients,” or “Using Paint window inks” in Director Help.

To choose the foreground and background colors:

Use the Foreground Color pop-up menu to choose the primary fill color (used when the pattern is solid and the ink is Normal).

Use the Background Color pop-up menu to choose the secondary color (the background color in a pattern or text).

To choose a pattern for the foreground color:

Choose an option from the Patterns pop-up menu.

To change the pattern palette, choose Pattern Settings at the bottom of the menu.
To define a tile—a pattern based on a rectangular section of an existing cast member—choose Tile Settings.

See “Editing patterns” in Director Help, or “Creating a custom tile” on page 259.

To choose a line thickness:

Choose the None, One-, Two-, or Three-pixel line button to set the line width. Double-click the Other Line Width button to open Paint window Preferences and assign a width to the line.

To change the color depth the current cast member:

Double-click the Color Depth button to open the Transform Bitmap dialog box. The button displays the color depth of the current cast member. See “Changing size, color depth, and color palette for bitmaps” on page 255.

To choose a Paint window ink:

Choose the type of ink from the Ink pop-up menu at the bottom left of the window. See “Using Paint window ink” in Director Help.
Using rulers in the Paint window

The Paint window has vertical and horizontal rulers to help you align and size your artwork.

To hide or show the rulers in the Paint window:

Choose View > Rulers.

To change the location of the zero point:

Do either of the following:

- Drag along the ruler at the top or side of the window.
- Drag into the window to align the zero point with a specific point in the cast member.
Zooming in and out in the Paint window

Use the magnify tool or the Zoom commands on the View menu to zoom in or out at four levels of magnification.

To zoom in or out:

Do one of the following:

► Click the magnify tool and then click the image. Click again to increase the magnification. Shift-click to zoom out.
► Choose View > Zoom and then choose the level of magnification.
► Press Control-plus key (Windows) or Command-plus key (Macintosh) to zoom in, or Control-minus key (Windows) or Command-minus key (Macintosh) to zoom out.
► Control-click (Windows) or Command-click (Macintosh) the image to zoom in on a particular place.

To return to normal view:

Do one of the following:

► Click the normal-sized image in the upper-right corner.
► Choose View > Zoom > Normal.
Changing selected areas of a bitmap

Once you have selected part of an image in the Paint window with the lasso or marquee tool, you can change that selected area in several ways.

Reposition the area you have just selected by moving the cross hair inside the selected area (the cross hair becomes an arrow pointer). Then drag the selected area.

You can use key combinations to affect how the selected area behaves when you drag it.

**To make a copy of the selected area as you drag:**
Alt-drag (Windows) or Option-drag (Macintosh) the selection.

**To stretch the selection (marquee tool only):**
Control-drag (Windows) or Command-drag (Macintosh) the selection.

**To stretch the selection proportionally (marquee tool only):**
Control-Shift-drag (Windows) or Command-Shift-drag (Macintosh) the selection.

**To copy and stretch the selection (marquee tool only):**
Control-Alt-drag (Windows) or Command-Option-drag (Macintosh) the selection.

**To constrain the movement of the selection to horizontal or vertical:**
Shift-drag the selection.

**To move the selection one pixel at a time:**
Use the arrow keys.
Flipping, rotating, and applying effects to bitmaps

The toolbar at the top of the Paint window contains buttons to apply effects to bitmaps. Before using any of these options, you must select part of the bitmap with the lasso or marquee tool. Effects that change the shape of the selection work only when the selection is made with the marquee tool. Effects that change colors within the selection work with both the marquee and lasso tools.

Lingo flips and rotates bitmaps by flipping and rotating bitmap sprites. See “Rotating and skewing sprites” on page 83 and “Flipping sprites” on page 85.

*Note:* To repeat any of these effects after using them, press Control-Y (Windows) or Command-Y (Macintosh).

To flip, rotate, skew, or apply effects to part of a bitmap:

1. Select part of a bitmap in the Paint window with the marquee tool.
2. Use any of the following effects:
   - To flip the selection, click the flip horizontal button to flip right to left, or click the flip vertical button to flip top to bottom.
   - To rotate the selection 90 degrees counterclockwise or 90 degrees clockwise, click the rotate left or rotate right buttons.
   - To rotate the selection by any amount in either direction, click the Free Rotate button and then drag the rotate handles in any direction. (You can rotate a sprite containing a bitmap instead of the bitmap itself. See “Rotating and skewing sprites” on page 83.)
► To skew the selection, click the Skew button and drag any of the skew handles.

► To warp the shape of the selected area, click the Warp button and drag any handle in any direction.

► To create a perspective effect, click the Perspective button and drag one or more handles to create the effect you want.

► To create an outline around the edges of the selected artwork, click the Trace Edges button.
To apply color effects to a selected area:

1. Select an area within a bitmap cast member using either the marquee or lasso tool.

2. Use any of the following effects:
   - To soften the edges of the selected artwork, click the Smooth button. This works only with 8-bit cast members.
   - To reverse the colors of the selected area, click the Invert Color button.
   - To increase or reduce the brightness of the selected area, click the Lighten or Darken Color button. This works on 8-bit (256 color) images only.
   - To fill the selected area with the current foreground color and pattern, click the Fill Color button.
   - To change all pixels of the foreground color within the selection to the currently selected destination color, click the Switch Colors button.

Changing registration points

Registration points are crucial to precisely placing vector shapes, bitmaps, and all cast members that appear on the Stage. A registration point is a marker that appears on a sprite when you select it with your mouse. (Registration points do not appear on unselected sprites or when a movie is playing). Registration points provide a fixed reference point within an image, thereby helping you align sprites and control them from Lingo.

By default, Director assigns a registration point in the center of all bitmaps, but for many types of animation, you may want to move the registration point. Use the registration point tool to move the registration point.

Edit a bitmap’s registration point in the Paint window or from Lingo.
Moving the registration point is useful for preparing a series of images for animation. When you use Cast to Time or exchange cast members, Director places a new cast member’s registration point precisely where the previous one was. By placing the registration point in the different locations, you can make a series of images move around a fixed position without having to manually place the sprites on the Stage. Use onion skinning to set registration points when images are placed in relation to each other. See “Using onion skinning” on page 262.

To set a registration point:

1. Display the cast member you want to change in the Paint window.

2. Click the Registration Point tool.
   
   The dotted lines in the Paint window intersect at the registration point. The default registration point is the center of the cast member.
   
   The pointer changes to a cross hair when you move it to the Paint window.

3. Click a location in the Paint window to set the registration point.
   
   You can also drag the dotted lines around the window to reposition the registration point.

**Note:** To reset the default registration point at the center of the cast member, double-click the registration point tool.
To set a bitmap’s registration point from Lingo:

Set the `regPoint` cast member property. Set the `centerRegPoint` property to specify whether Director automatically centers the registration point if the bitmap is edited. See `centerRegPoint` and `regPoint` in the Lingo Dictionary.

**Changing size, color depth, and color palette for bitmaps**

Use Transform Bitmap to change the size, color depth, and palette of selected cast members. Any change you make to a cast member’s color depth or palette affects the cast member itself—not just its appearance on the Stage. You can’t undo changes to the color depth and palette. If you want to keep a cast member’s original bitmap unchanged but temporarily apply a different palette, use the Cast Member Properties dialog box instead. To change the size of only the sprite on the Stage, use the Sprite Properties dialog box.

You can also remap images to new palettes with image editing programs such as Debabelizer and Photoshop.

The Transform Bitmap dialog box displays values for the current selection. If more than one cast member is selected, a blank value indicates that cast members in the selection have different values. To maintain a cast member’s original value, leave that value blank in the dialog box.

**To use Transform Bitmap:**

1. Select the bitmap cast members to change.
2. Choose Modify > Transform Bitmap.
3. To change the size of the bitmap, do one of the following:
   - If multiple cast members are selected, you can resize all the cast members to the dimensions you enter.
   - Enter new measurements (in pixels) in the Width and Height fields.
   - Enter a scaling percentage in the Scale box.
   
   Select the Maintain Proportions check box to keep the width and height of the selected cast member in proportion. If you change the width, the proportional height is automatically entered in the Height field. If you use Transform Bitmap to change several cast members at once, be sure to deselect Maintain Proportions. If you don’t, all cast members will be resized to the values in the Width and Height boxes.
4. To change the color depth, choose an option from the Color Depth pop up-menu.
   
   For more information about the color depth of bitmap cast members, see “Controlling color in Director” on page 170.
To change the palette, choose a palette from the Palette pop-up menu and choose one of the following remapping options:

- **Remapping** replaces the original colors in the graphic with the most similar solid colors in the new palette. This is the preferred option in most cases.

- **Dithering** blends the colors in the new palette to approximate the original colors in the graphic.

5 256 grays

Remapped to closest colors in black and white

Dithered in black and white

6 Click Transform to execute the changes.
   The settings you choose in Transform Bitmap cannot be undone.
Controlling a bitmap image with Lingo

Lingo lets you control a bitmap's image, background, and foreground colors.

To change the image assigned to a bitmap cast member:

Set the picture cast member property. See picture (cast member property) in the Lingo Dictionary.

To specify the background or foreground of a bitmap sprite:

Set the backColor or foreColor sprite property. See backColor and foreColor in the Lingo Dictionary.

To capture the image currently on the Stage or in a window:

Set a bitmap picture cast member property to the Stage's picture property. See picture (cast member property) in the Lingo Dictionary.

For example, the statement member("Archive").picture = (the stage).picture makes the current image of the Stage the image for the bitmap cast member Archive.
Using gradients

Director can create gradients in the Paint window. Use gradients with the paint brush tool, the paint bucket tool, the text tool, or any of the filled shape tools. Typically, a gradient consists of a foreground color at one side (or the center) of an image, and another color, the destination color, at the other side (or outside edge) of the image. Between the foreground and destination colors, Director creates a blend of the two.

To use a gradient:

1. Choose the paint brush, paint bucket, or one of the filled shape tools.
2. Choose the type of gradient from the Gradient pop-up menu.
   - Choosing a gradient type automatically sets the current Paint window ink to Gradient. You can also choose Gradient ink from the Ink pop-up menu at the bottom left of the Paint window to create a gradient with all the current settings.
   - To manually specify a gradient, choose Gradient Setting from the pop-up menu. See “Editing gradients” in Director Help.
3. Choose a foreground color from Gradient Colors pop-up menu on the left.
   - The foreground color is the same color specified for the Paint window.
4. Choose a destination color from the Gradient Colors pop-up menu on the right.
   - The destination color is the color of the gradient when it completes the color transition.
5. Use the current tool in the Paint window.
   - Director uses the gradient you’ve defined to fill the image.
6. To stop using a gradient, choose Normal from the Ink pop-up menu.
Creating a custom tile

Custom tiles are an effective way of filling a large area with interesting content without using a lot of memory or increasing the downloading time. They are especially useful for large movies on the web. A custom tile uses the same amount of memory no matter what size area it fills.

To create a custom tile:

1. Create a bitmap cast member to use as a tile and display it in the Paint Window.
2. Click the pattern chip in the Paint window and choose Tile Setting from the bottom of the Pattern pop-up menu.
3. Click an existing tile position to edit.
   The existing tiles appear next to the Edit label. You have to replace one of the built-in tiles to create a new one. To restore the built-in tile for any tile position, select it and click Built-in.
4. Click Cast Member.
   The cast member appears in the box at the lower left. The box at the right shows how the image appears when it is tiled. The dotted rectangle inside the cast member image shows the area of the tile.
   To choose a different cast member for the tile, use the arrow buttons to the right of the Cast Member button to move through the movie's cast members.
5. Drag the dotted rectangle to the area of the cast member you want tiled.
6. Use the Width and Height controls to specify the size of the tile.
   The new tile appears in the tile position you selected. You can use it in the Paint window or from the Tools palette to fill shapes.
Using bitmap filters

Bitmap filters are plug-in image editors that apply effects to bitmap images. You can install Photoshop-compatible filters to change images within Director.

Original image

Filtered image

To install a filter, place the filter in the Xtras folder in the Director application folder. See “Installing Xtras” on page 60.

You can apply a filter to a selected portion of a bitmap image, to an entire cast member, or to several cast members at once.

To apply a filter:

1. Open the cast member in the Paint window or select the cast member in the Cast window.
   You can apply a filter to several cast members at once by selecting them all in the Cast window. To apply a filter to a selected portion of a cast member, use the marquee or lasso tool in the Paint window to select the part you want to change.

2. Choose Xtras > Filter Bitmap.

3. In the Filter Bitmap dialog box, choose a category on the left and a filter on the right.
   To view all the filters at once, choose All from the Categories list.

4. Click Filter.
   Many filters require you to enter special settings. When you choose one of these filters, a dialog box or other type of control appears after you click Filter. When you finish choosing filter settings and proceed, the filter changes the cast member.

Some filters have no changeable settings. When you choose one of these filters, the cast member changes with no further steps.
Using filters to create animated effects

Use Auto Filter to create dramatic animated effects with bitmap filters. Auto Filter applies a filter incrementally to a series of cast members. You can use it either to change a range of selected cast members, or to generate a series of new filtered cast members based on a single image. You define a beginning and ending setting for the filter, and then Auto Filter applies an intermediate filter value to each cast member.

You can tweening a bitmap filter with Auto Filter.

Note: Most filters do not support auto filtering. The Auto Filter dialog box lists only those filters that do.

To use Auto Filter:

1 Select a bitmap cast member or a range of cast members and then choose Xtras > Auto Filter.
   If you want to change only a portion of a bitmap cast member, use the marquee or lasso tool in the Paint window to select the part you want to change.

2 In the Auto Filter dialog box, select a filter.

3 Click Set Starting Values and use the filter controls to enter filter settings for the first cast member in the sequence.
   When you finish working with the filter controls, the Auto Filter dialog box reappears.

4 Click Set Ending Values and use the filter controls to enter filter settings for the last cast member in the sequence.

5 Enter the number of new cast members you want to create. The box is not available if you have selected a range of cast members.

6 Click Filter to begin the filtering.
   A message appears to show the progress. Some filters are very complex and require extra time for computing.
   Auto Filter generates new cast members and places them in empty cast positions following the cast member you selected. If you selected a range of cast members, no new cast members appear, but the cast members in the range you selected are changed incrementally.
Using onion skinning

Onion skinning derives its name from a technique used by conventional animators who drew on very thin “onion skin” paper so that they could see through it to one or more of the previous images in the animation.

With onion skinning in Director, you can create or edit animated sequences of cast members in the Paint window using other cast members as a reference. Reference images appear dimmed in the background. While working in the Paint window, you can view not only the current cast member that you're painting, but also one or more cast members blended into the image.

You can use onion skinning:

- To trace over an image or create a series of images all in register (aligned) with a particular image.
- To see previous images in the sequence and use those images as a reference while you are drawing new ones.
- To create a series of images based on another parallel animation. The series of images serves as the background while you paint a series of foreground images.

Onion skinning uses registration points to align the current cast member with the previous ones you have chosen. Be careful not to move registration points for cast members after onion skinning. If you do, the cast members may not line up the way you want them to. See “Changing registration points” on page 253.

To activate onion skinning:

1. Open the Paint window and choose View > Onion Skin. The Onion Skin toolbar appears.

2. Click the Toggle Onion Skin button at the far left of the toolbar to enable onion skinning.

   You must have created some cast members in order to use onion skinning.
To define the number of preceding or following cast members to display:

1. Open the Paint window and choose View > Onion Skin.
2. If necessary, click Toggle Onion Skin in the Onion Skin toolbar to activate onion skinning.
3. Specify the number of preceding or following cast members you want to display.
   - To specify the number of preceding cast members to display, enter a number in the Preceding Cast Member box.
   - To specify the number of following cast members to display, enter a number in the Following Cast Members box.

Two preceding cast members shown with onion skinning and registration points

The specified number of cast members appear as dimmed images behind the current cast member. The order is determined by the position in the cast.
To create a new cast member by tracing over a single cast member as a background image:

1. Open the Paint window and choose View > Onion Skin.
2. Open the cast member in the Paint window that you want to use as the reference image or background.

3. Click Toggle Onion Skin in the Onion Skin toolbar.
4. Click Set Background to set the background image.
5. Click the Add button in the Paint window to create a new cast member.
6. Click Show Background in the Onion Skin toolbar.

   The original cast member appears as a dimmed image in the Paint window. You can paint on top of the original cast member’s image.

7. Paint the new cast member using the background image as a reference.
To use a series of images that serve as a background while painting a series of foreground images:

1. In the Cast window, arrange in consecutive order the series of cast members you want to use as your background.

![Cast members arranged in order](image)

Cast members in both the foreground and the background series must be adjacent to each other in the cast.

2. Open the Paint window and choose View > Onion Skin.

   The Onion Skin toolbar appears.

3. If necessary, click Toggle Onion Skin in the Onion Skin toolbar to activate onion skinning.

   Make sure all values in the Onion Skin toolbar are set to 0.

4. Open the cast member you want to use as the first background cast member in the reference series. Click Set Background.

5. Select the position in the cast where you want the first cast member in the foreground series to appear. Click the Add button in the Paint window to create a new cast member.

   The first cast member in the foreground series can be located anywhere in any cast.

6. Click Show Background to reveal a dimmed version of the background image.

7. Click Track Background in the Onion Skin toolbar.

8. Paint the new cast member using the background image as a reference.

9. When you have finished drawing the cast member, click the Add button again to create the next cast member.

   When Track Background is enabled, Director advances to the next background cast member in the series. Its image appears in the background in the Paint window.

10. Repeat Step 8 until you have completed drawing all the cast members in the series.
Using shapes

Shape cast members are the same non–anti-aliased shapes that were available in older versions of Director. They are still available in Director 7 primarily to provide compatibility with old movies.

Shapes are the images you can create directly on the Stage with the tools on the tool palette. You can fill shapes with a color, pattern, or custom tile. Shapes require even less memory than vector shapes, but Director does not anti-alias shapes, so they don't appear as smooth on the Stage as vector shapes. Use shapes for creating simple graphics and backgrounds when you want to keep your movie as small as possible. Shapes are especially useful for filling an area with a custom tile to create an interesting background that downloads quickly from the Internet. See “Creating a custom tile” on page 259.

The tools for creating shapes are in the Tool palette. Choose Window > Tool Palette.

The radio button, check box, and button tools in the tool palette work just like the shape tools and create simple buttons. These buttons do not do anything unless you attach a behavior or Lingo script.

To create a shape:

1. Select a frame in the Score where you want to draw a shape.
2. Choose color, line thickness, and pattern settings with the controls in the tool palette.
3. Click a tool and then drag on the Stage to draw the shape.

The new shape appears on the Stage and in the Cast window.

Use the Field button to create Field cast members directly on the Stage.
To specify a shape’s type with Lingo:
Set the shapeType cast member property. See shapeType in the Lingo Dictionary.

To specify a shape’s fill with Lingo:
Set the filled and pattern shape cast member properties. See filled and pattern in the Lingo Dictionary.

To specify the line size for a shape with Lingo:
Set the lineSize cast member or sprite property. See lineSize in the Lingo Dictionary.
Text: Overview

Director creates text that is compact for fast downloading, editable, and anti-aliased in any font on any platform. Combine these features with any of Director’s animation capabilities, such as rotation, and you can create text effects not possible in any other application.

You can embed fonts in a movie to ensure that text appears in a specific font when a movie is delivered, regardless of which fonts are available on the user’s computer.

Most of the high-quality text you see in web browsers is actually a GIF or JPEG graphic that takes longer to download than Director text. Director renders text in the display font and anti-aliases it as the movie plays, so text in Director is very compact and downloads quickly from the Internet.

Director provides many ways to add text to a movie. You can either create new text cast members within Director or import text from an outside source such as a document stored on the Internet. You can import plain text, RTF, or HTML documents. Once text is part of your movie, you can format the text in a variety of ways using Director’s formatting tools. Director offers standard professional formatting functions, including alignment, tabs, kerning, spacing, subscripts, superscripts, color, and so on. You can also create hyperlinks for any text.

Text in Director is editable when you are working on your movie and, optionally, while a movie plays.

Text can also be controlled from Lingo. For example, Lingo can edit the text in existing cast members, specify text formatting such as font and size, and interpret strings that users enter.
To create the smallest possible text cast members, use field text. Field text is standard text controlled by your system software, just like the text you see in dialog boxes and menu bars. Director does not anti-alias field text nor support paragraph formatting and tabs for fields. Like regular text, Lingo can control field text and specify whether field text is editable while a movie plays. Field text from older versions of Director continues to work as it always did in Director 7.

Regular text is best for large type that you want to look as good as possible. Field text is an excellent choice for large blocks of smaller text in standard fonts (like Times or Helvetica) that do not need to be anti-aliased.

**Embedding fonts in movies**

Before creating text cast members, it’s good practice to embed the fonts you want to use in the movie. Embedding fonts makes Director store all font information in the movie file so that a font can be displayed even if it is not installed in a user’s system.

Embedded fonts appear in a movie as cast members and work on Windows and Macintosh computers. Director compresses embedded fonts so they usually add only 14 to 25K to a file.

For the best display quality at smaller sizes, include bitmap versions of a font when you embed a font. For smaller font sizes, usually from about seven to twelve points, bitmaps fonts often look better than anti-aliased outline fonts. Adding a set of bitmap characters does, however, make the font cast member larger. Examine the text display quality of your movie to find out if this option is worth while. See “About anti-aliased text” on page 278.

There are no legal obstacles to distributing fonts in Director movies because embedded fonts are available only to the movie itself.

To keep file size small to speed up movie downloading, you can specify a subset of characters to be included. You can also specify which point sizes to include as bitmaps and which characters to include in the font package. If you do not embed fonts in a movie, Director substitutes available system fonts. Embedded fonts work for both text and field cast members.

If you create embedded fonts using the original font name followed by an asterisk, for example, Arial* for the Arial font, Director used the embedded font for all existing text in the movie. This saves you the trouble of manually reapplying the font to all the text in existing movies.

Once you embed a font in a movie file, the font appears on all of Director’s font menus, and you can use it as you would any other font.
To embed a font in a movie:

1 Choose Insert > Media Element > Font.

2 Choose a font that is currently installed on your system from the Original Font pop-up menu.

   You cannot embed a font that is not installed on your system.

   In the New Font Name box, the name of the font appears followed by an asterisk. This is the name that will appear on all font menus in Director. In most cases, you should not change the name of a font.

3 To include bitmap versions of bold or italic characters with the font, click Bold or Italic.

   This provides better-looking bold and italic fonts if you are including a bitmap version of the font, but increases the file size. These options have no effect unless you are including a bitmap version of the font; turn them off unless you need them.

4 To include bitmap versions of the font in specified sizes, click the Sizes button for Bitmaps and enter the point sizes you want to include separated by spaces or commas. For example, 9, 10, 14.

5 To specify the characters included in the font, choose an option for Characters.

   ▶ Entire Set includes every character (symbols, punctuation, numbers, and so on) with the font.

   ▶ Partial Set lets you choose exactly which characters are included. To choose a group of characters, click Punctuation, Numbers, Roman Characters, or Other. If you choose Other, enter the characters to be included in the box on the right. In some double-byte languages, other groups of characters may appear.
Creating text cast members

You can create text within Director or import text from external files.

Creating text in Director

Director provides two ways to create text cast members: directly on the Stage or in the Text window.

To create text cast members directly on the Stage:

1. Click the Text tool in the tool palette.
2. Drag the pointer on the Stage to create a text cast member as wide as the rectangle you define.
   - You cannot adjust the height of the text object at this point—the height is adjusted automatically when you add text.
   - When you release the mouse button, a text insertion point appears in the area you just defined.
3. Enter text.
   - The new text cast member appears in the first available position in the current cast; the sprite is placed in the first open cell in the current frame in the Score.

To create text cast members in the Text window:

1. Choose Insert > Media Element > Text.
   - If the Text window is already open, click the Add button to create a new text cast member.
2. Enter text in the Text window.
   - Text you enter appears in the first available cast position, but it is not automatically placed on the Stage.
3. To change the width of the cast member, drag the bar at the right edge to the Text window.
**Importing text**

You can import text from any application that saves text in the rich text format (RTF), plain text (ASCII), or from HTML documents. Use the standard importing procedure with File > Import to import any RTF or HTML document. To import an HTML document from the Internet, use the Internet button in the Import dialog box and enter a URL.

When importing text from an HTML document, Director recognizes most standard tags and parameters, including tables, and approximates the formatting. It does not recognize embedded objects other than tables. It also does not recognize `<APPLET>`, `<FORM>`, `<FRAME>`, `<INPUT>`, or `<IMAGE>` tags.

Director ignores any tags it does not recognize. Be sure to test the importing of any HTML file that is updated frequently to make sure you're satisfied with the formatting.

When importing text from an RTF file, Director recognizes most standard RTF formatting, but it does not import pictures embedded in the file.

The amount of text in a cast member is limited only by the memory available in the playback system.

**Importing text with Lingo**

Lingo can import text in several ways.

**To import text from a URL:**

Use the `getNetText` command. See `getNetText()` in the Lingo Dictionary.

**To import text from an external file from a URL or the local computer:**

Set the text cast member's `fileName` property to the name of the external file that contains the text. See `fileName` (cast member property) in the Lingo Dictionary.

**Editing and formatting text**

Director offers a number of ways to edit and format text. You can edit text directly on the Stage and format it with the floating Text Inspector, or use the Text window to work in a more traditional text editing environment. Many of the same formatting controls are in the Font and Paragraph dialog boxes as well as in the Text window and the Text Inspector. Choose the most convenient option for your work style.
Selecting and editing text on the Stage

For basic text editing, it's fastest to edit text directly on the Stage.

To edit text on the Stage:

1. Click a text cast member on the Stage to select it as a sprite. The text sprite appears as a normal sprite with double borders.

2. Click twice to edit the text. An insertion point appears in the text, and you can begin editing.

3. Use the Text Inspector or the Modify > Font and Modify > Paragraph commands to reformat the text. When you make a change, Director updates all sprites that display the text cast member.

Formatting characters

Once you have created text cast members for your movie, you can format them in a variety of ways: you can set the font, style, size, spacing, and color. This procedure uses using the Font dialog box, but many of the same controls are available in the Text Inspector and the Text window.

To format characters:

1. Double-click inside a text sprite.
2. Drag to select the text you want to format.
3. Choose Modify > Font to open the Font dialog box.
4. Choose from the following options in the Font dialog box:
   - To specify the font, choose a font from the pop-up menu. Be sure to use embedded fonts for movies you intend to distribute, see "Embedding fonts in movies" on page 270.
   - To use bold, italic, underlined, superscript, subscript, or strikeout for text, click the appropriate box.
   - To change the point size of text, increase or decrease the size with the Size control.
To change the distance between lines of text, increase or decrease the spacing with the Spacing control.

To specify kerning between selected characters, use the Kerning control to specify the number of points. This setting is an addition to the standard kerning applied to the entire cast member in the Text Cast Member Properties dialog box. See “About kerning” on page 278.

To change the text color, click the Color box and choose a color from the Color menu.

**Formatting paragraphs**

You can specify the alignment, indent, tabs, and spacing for each paragraph in a text cast member. This procedure explains how to format paragraphs while working in the Text window. Many of the same formatting controls are available in the Text Inspector and the Paragraph dialog box.
To make formatting changes to a paragraph:

1. Double-click the text cast member in the Score to open the Text window.

2. If the ruler is not visible, choose View > Ruler.

3. Place the cursor in the paragraph you want to change (or select multiple paragraphs).

4. To define tabs, use any of the following options:
   - Set tabs by clicking the Tab well until the type of tab you want appears. Then click the ruler to place the tab.

   ![Tab well and tab marker](image)

   - Move a tab by dragging the tab marker on the ruler.
   - Remove a tab by dragging the tab marker up or down off the ruler.

5. To set margins, drag the indent markers on the ruler.

6. To set line spacing, change the setting with the Line Spacing control.

   ![Line Spacing](image)

   Director adjusts line spacing to match the size of the text you are using. If you change the line spacing setting, Director stops making automatic adjustments. To resume automatic adjustments of spacing, enter 0 in the Line Spacing box.

7. To set paragraph alignment, click one of the alignment buttons.
8 To change the kerning of selected characters, change the setting in the Kerning control.

9 Set spacing before and after paragraphs by choosing Modify > Paragraph and using the Spacing Before and After controls.

Note: To change the unit of measure on the text ruler, choose File > Preferences > General.

Formatting entire cast members

Director can apply formatting changes to entire cast members. This process is much faster than manually opening each cast member and applying changes. Any change you apply to a cast member affects all the text within the cast member.

To format text cast members:

1 In a Cast window or on the Stage, select the cast members you want to change. You can select as many cast members as you want to change.

2 Use the Text Inspector, Modify > Font, or Modify > Paragraph to make formatting changes. The change affects all selected cast members.

Formatting with the Text Inspector

The Text Inspector provides many of the most useful formatting controls in a compact floating window for use on the Stage or with entire cast members in the Cast window.

Most of the formatting controls also appear at the top of the Text window and in the Font and Paragraph dialog boxes. See “Editing and formatting text” on page 273.
To display the Text Inspector:

Choose Window > Inspector > Text, or press Control-T (Windows) or Command-T (Macintosh).

About anti-aliased text

Anti-aliased text is text that, through the use of variations of the text’s original color, appears to have had its jagged angles and curves removed for a smoother look. Director activates the anti-aliased text feature by default. You can change this setting in the Text Cast Member Properties dialog box. Select the cast member you want to change, choose Modify > Cast Member Properties, and click Options. See Setting Text cast member properties in Director Help.

Anti-aliasing functions the same way for embedded fonts and for system fonts that have not been embedded. See “Embedding fonts in movies” on page 270.

Using anti-aliased text dramatically improves the quality of large text on the Stage, but it can blur or distort smaller text. Experiment with the size settings to get the best results for the font you are using.

The effect of anti-aliasing on 12-point text

Director can anti-alias all outline (TrueType, PostScript, and embedded) fonts, but not bitmap fonts. When you select a font that cannot be anti-aliased, the message “This font cannot be anti-aliased” appears in the Font dialog box below the font list. Display the Font dialog box by selecting text or a text sprite and then choosing Modify > Font.

About kerning

Kerning is a specialized form of spacing between certain pairs of characters that look best when they overlap slightly, such as A and W (AW). Kerning dramatically improves the appearance of large text for headlines, but it often does not improve the appearance of text at small font sizes.

If the Kerning option is on in the Text Cast Member Properties dialog box, Director kerns all the characters in the cast member according to standard kerning tables. The setting you enter in the Text window or Font dialog box is in addition to the standard kerning. See “Formatting characters” on page 274 and “Setting text cast member properties” in Director Help.
Creating a hyperlink

Use the Text Inspector make any selected range of text a hyperlink that typically links to a URL, but can also initiate other actions. Director automatically adds standard hyperlink formatting to the selected text so that it initially appears with blue underlining. You can turn off this formatting in the Text Cast Member Properties dialog box. See “Setting text cast member properties” in Director Help.

This topic describes how to specify a range of text as a hyperlink. To make a hyperlink actually do something, you need to write an on hyperlinkClicked event handler. See on hyperlinkClicked in the Lingo Dictionary.

You can enter any string in the hyperlink box; it does not have to be a URL. The string can not contain a double quotation mark or Return character.

To define a hyperlink:

1. Select the text you want to define as a hyperlink.
2. Choose Window > Inspector > Text to open the Text Inspector.
3. In the Hyperlink box, enter the URL to which you want to link, or enter any message you want to send to the hyperlinkClicked handler.

Using editable text

Use editable text to allow users to enter text on a web page, to customize a game, and so on. When text is editable, editing the text changes the text cast member and all the text in the sprites where the cast member appears.

When using editable text, it is also convenient to allow users to tab between editable sprites. You can specify this in the Text Cast Member Properties dialog box.

You can make a text sprite editable in only a certain range of frames in the Score.

You can make text editable and let users tab between editable sprites from the user interface or from Lingo.
To define editing properties for a text cast member:

1. Select a text or field cast member in the Cast window.
2. Choose Modify > Cast Member > Properties and then click Options.
3. To make the cast member editable, click the Editable box.
   You can also make a text cast member editable by selecting a sprite containing
   the cast member and clicking the Editable box in the Sprite Inspector.
4. To make Director open the next editable sprite for editing when the user
   presses Tab, click Tab to Next Item.
   Pressing Tab while the movie is playing and the current cast member is being
   edited sends the text insertion point to the editable item on the Stage with the
   next highest sprite number.

To make a text sprite editable in range of frames:

1. Select a range of frames within a sprite.
   You can select an entire sprite, or Shift-Alt click (Windows) or Shift-Option
   click (Macintosh) to select frames within a sprite.
2. Click the Edible button in the Sprite inspector.

To control whether text is editable with Lingo:

Set the editable cast member or sprite property. See editable in the Lingo Dictionary.

To have Lingo specify whether pressing Tab opens the next sprite for editing:

Set the autotab cast member or sprite property. See autoTab in the
Lingo Dictionary.
Working with fields

Working with field cast members is similar to working with text. Just as with text cast members, you edit fields on the Stage or in a window and apply formatting with the Text Inspector. Not all text formatting options are available for fields. You cannot apply spacing, tabs, or indents to individual paragraphs within fields. Alignment settings apply to every paragraph in the field.

To create field cast members:

Do either of the following:

► Choose Insert > Control > Field.

► Choose the field tool in the tool palette and then drag on the Stage to define the area of the field.

To open the Field window:

Choose Window > Field, or double-click a field cast member in the Cast window.

Converting text to a bitmap

Use Convert to Bitmap to change a text or field cast member to a bitmap. The converted graphic can then be edited in the Paint window. Once you convert a cast member to a bitmap graphic, you cannot undo the change.

This command works only with text and field cast members. You can't convert a shape to a bitmap.

To convert text to a bitmap:

1 In the Cast window, select the cast members to convert.
2 Choose Modify > Convert to Bitmap. Director converts the cast members to bitmaps.

None provides no pre-rendering.
Copy Ink optimizes the pre-rendering for Copy Ink.
Other Ink pre-renders the text for all other ink types.

3 To further improve text rendering performance, turn on Save Bitmap to save the pre-rendered text bitmaps in the Director file.
This avoids the text rendering step altogether, but increases the file size. Save bitmap is only available with pre-rendered text, and should only be used for static, non-scrolling text.

Formatting chunks of text with Lingo
Director’s interface lets you format a variety of text characteristics such as the font, size, style, and line spacing. Using Lingo, you can format text dynamically as the movie plays. You can also use Lingo to rapidly format text during authoring.

To identify the first and last characters of a text selection in a field cast member:
Use the selEnd and selStart cast member properties. See selEnd and selStart in the Lingo Dictionary.

Formatting text with Lingo
Lingo can format text in an entire cast member or any specific chunk of text.

To specify the font for a text cast member, field cast member, or chunk expression:
Set the font cast member property. See font in the Lingo Dictionary.

To specify the character size for a text cast member, field cast member, or chunk expression:
Set the fontSize property. See fontSize in the Lingo Dictionary.

To specify the line spacing for a field cast member:
Set the lineHeight property. See lineHeight in the Lingo Dictionary.

To specify the style for a text cast member, field cast member, or chunk expression:
Set the fontStyle property. See fontStyle in the Lingo Dictionary.
To specify the drop shadow size for the characters in a field cast member:
Set the boxDropShadow property. See boxdropShadow in the Lingo Dictionary.

To specify additional spacing applied to a chunk expression in a text cast member
or chunk expression:
Set the fontspacing property. See fontSpacing in the Lingo Dictionary.

To specify the font color for a text cast member, field cast member, or
chunk expression:
Set the forecolor property. See foreColor in the Lingo Dictionary.
Applying paragraph formats

Lingo can control paragraph formatting such as alignment and indenting for a chunk expression.

To set text alignment for a text or field cast member:
Set the alignment property. See alignment in the Lingo Dictionary.

To set line spacing for a text cast member in number of points:
Set the fixedLineSpace property. See fixedLineSpace in the Lingo Dictionary.

To add pixels below paragraphs in a text cast member:
Set the bottomSpacing property. See bottomSpacing in the Lingo Dictionary.

To add pixels above paragraphs in a text cast member:
Set the topSpacing property. See topSpacing in the Lingo Dictionary.

To specify line spacing in a field cast member:
Set the lineHeight property. See lineHeight (cast member property in the Lingo Dictionary.

To add pixels to the first indent in a chunk expression in a text cast member:
Set the firstIndent property. See firstIndent in the Lingo Dictionary.

To set the number of pixels a chunk expression in a text cast member is indented from the left:
Set the leftIndent property. See leftIndent in the Lingo Dictionary.

To set the number of pixels that a chunk expression in a text cast member is indented from the right:
Set the rightIndent property. See rightIndent in the Lingo Dictionary.

To specify or obtain a list of tabs that are in a chunk expression in a text cast member:
Set or test the tabs property. See tabs in the Lingo Dictionary.
Formatting text cast members with Lingo

In addition to formatting text in any chunk expression, Lingo can specify anti-aliasing and kerning for an entire text cast member and control the appearance of the text’s bounding box.

Setting anti-aliasing and kerning with Lingo

Use Lingo to specify anti-aliasing and kerning for a text cast member.

**To specify whether text Director anti-aliases text in a text cast member:**
Set the `antiAlias` cast member property. See `antiAlias` in the *Lingo Dictionary*.

**To specify the size at which anti-aliased text in a text cast member takes effect:**
Set the `antiAliasThreshold` cast member property. See `antiAliasThreshold` in the *Lingo Dictionary*.

**To specify automatic kerning for a text cast member:**
Set the `kerning` cast member property. See `kerning` in the *Lingo Dictionary*.

**To specify the size at which autokerning for a text cast member takes effect:**
Set the `kerningThreshold` cast member property. See `kerningThreshold` in the *Lingo Dictionary*. 
**Formatting text boxes**

Lingo can specify the type of box that surrounds a text or field cast member. For field cast members, Lingo can also specify box characteristics such as borders, margins, drop shadows, and height.

**To specify the type of box around text:**
Set the `boxType` cast member property. See `boxType` in the *Lingo Dictionary*.

**To specify the size of the border around a field:**
Set the `border` field cast member property. See `border` in the *Lingo Dictionary*.

**To specify the size of the margin inside a field's box:**
Set the `margin` field cast member property. See `margin` in the *Lingo Dictionary*.

**To specify the size of the drop shadow for a field's box:**
Set the `boxDropShadow` field cast member property. See `boxDropShadow` in the *Lingo Dictionary*.

**To specify the height of a field's box on the Stage:**
Set the `pageHeight` field cast member property. See `pageHeight` in the *Lingo Dictionary*.

**Setting text autotabbing and wrapping with Lingo**

Lingo can set text autotabbing and wrapping.

**To specify autotabbing for text or field cast members:**
Set the `autoTab` cast member property. See `autoTab` in the *Lingo Dictionary*.

**To specify whether lines wrap in a field cast member:**
Set the `wordWrap` cast member property. See `wordWrap` in the *Lingo Dictionary*. 
Controlling scrolling text

Lingo can scroll text and determine the location of specific text within the text box for text and field cast members. For example, this statement sets the scrollTop value for the Discussion of a text or field cast member to 0, which makes its first line appear at the top of its scrolling field:

(member "Discussion").scrollTop = 0

This procedure can be useful for making a scrolling field automatically scroll back to the top.

To scroll up or down by a specific number of pages in a text or field cast member:
Use the scrollByPage command. See scrollByPage in the Lingo Dictionary.

To scroll up or down by a specific number of lines in a text or field cast member:
Use the scrollByLine command. See scrollByLine in the Lingo Dictionary.

To determine the number of lines that appear in a field cast member on the Stage:
Set the lineCount cast member property. (This doesn’t apply to text cast members.) See lineCount in the Lingo Dictionary.

To determine a line’s distance from the top edge of a text or field cast member:
Use the linePosToLocV() function. See linePosToLocV() in the Lingo Dictionary.

To determine the number of the line that appears at a specific vertical position in a text or field cast member:
Use the locVToLinePos() function. (This measures the distance from the top of the cast member, not what appears on the Stage.) See locVToLinePos in the Lingo Dictionary.

To determine the point in a text or field cast member that is closest to a specific character:
Use the charPosToLoc() function. See charPosToLoc() in the Lingo Dictionary.

To determine the character that is closest to a specific point in a text or field cast member:
Use the locToCharPos() function. See locToCharPos() in the Lingo Dictionary.

To check or set the distance from the top of the line that is currently visible to the top of the box for a scrolling field or text cast member:
Test or set the scrollTop cast member property. See scrollTop in the Lingo Dictionary.
Checking for specific text with Lingo

The Lingo element contains and the equals operator (=) are useful for checking strings. The contains function compares two strings to see whether one string contains the other. The equals operator can determine whether a string is exactly the same as the contents of a field cast member. Use these elements to check whether a specified string is in a field cast member. See contains in the Lingo Dictionary.

Modifying strings with Lingo

As time passes or other conditions change, you often will want to update and change text. For example, you may want to frequently update a text sprite that displays the user's name or a description of a musical selection that the user is currently streaming from a web site.

To set the entire content of a text or field cast member:

Set the text cast member property to a new chunk of text. The chunk can be a string or another text cast member. See text in the Lingo Dictionary.

To combine character strings:

Use the & and && operators. The & operator attaches the second string to the end of the first string. The && operator includes a space between two strings when they are combined. See & (concatenator) and && (concatenator) in the Lingo Dictionary.

To insert a string of characters into another string:

Use the put...after, put...into, or put...before command. The put...before command places the string at the beginning of another string. The put...into command replaces a specified chunk expression with another chunk expression. The put...after command places the string at the end of another string. See put...after, put...before and put...into in the Lingo Dictionary.

To delete a chunk expression from a string of text:

Use the delete command. See delete in the Lingo Dictionary.
Sound, video, and synchronization: Overview

You can give your movie added appeal by including a soundtrack, voiceover, ambient noises, or other sounds. Adding digital video to your movie creates even more interest. Digital video not only offers high-quality real-time image animation and sound, but supports new types of media such as QuickTime VR.

With Director, you have control over when sounds start and stop, how long they last, their quality and volume, and a number of other effects. Using Shockwave Audio, you can compress sounds for easier distribution and stream them from an Internet source.

Director supports QuickTime video for Windows and Macintosh, and Video for Windows (AVI). QuickTime is a multimedia format in its own right. It offers sophisticated sound features and can include graphics in many formats, including basic navigation of QuickTime VR2 files. For a list of supported QuickTime formats, see Apple's web site at www.apple.com. To use QuickTime, you must also obtain QuickTime 3 or later from Apple.

Director's media synchronization features let you synchronize events in a movie to precise points in both sound and digital video using Director's cue points.

Sound and video make significant demands on a computer's processing power, and you often need to manage them carefully to make sure they do not adversely affect your movie's performance.
Lingo gives Director more flexibility when playing sound and digital video and can help overcome performance concerns. You can use it to play sound and digital video in ways not possible with the Score alone. Using Lingo, you can:

- Turn sound on and off in response to movie events
- Control sound volume
- Synchronize sound, digital video, and animation
- Turn digital video on and off on demand and control individual video tracks
- Control QTVR

Note: You can export movies or portions of movies as QuickTime or AVI video. See “Exporting digital video or a series of bitmaps” on page 364.

Importing internal and linked sounds

Director handles sounds as either internal or linked. You determine whether a sound is internal or linked when you import it. Each type of sound has advantages for different situations.

Director stores all the sound data for an internal sound cast member in a movie or cast file and loads the sound completely into RAM before playing. After an internal sound is loaded, the sound plays very quickly. This makes internal sound best for short sounds that recur frequently in your movie, like beeps or clicks. For the same reason, making a large sound file an internal sound is not a good choice, since the sound may use too much memory.

Director does not store sound data in a linked sound cast member. Instead, it keeps a reference to a sound file’s location and imports the sound data each time the sound begins playing. Because the sound is never entirely loaded into RAM, the movie uses memory more efficiently.

Also, Director streams linked sounds, which means it begins playing the sound while the rest of the sound continues to load from its source, whether on disk or over the Internet. This can dramatically improve the downloading performance of large sounds. Linked sounds are best for longer sounds like voice-overs or nonrepeating music. When distributing movies with linked sounds, you must include the Xtras required for importing. See "Managing Xtras for distributed movies" on page 354.

Director imports AIFF and WAV sounds (both compressed and uncompressed), AU, Shockwave Audio, MP3, and Macintosh sounds. For best results, use sounds that have 8- or 16-bit depth and a sampling rate of 44.1, 22.050, or 11.025 KHz.
To import a sound:

1. Choose File > Import.
2. Choose sound files to import.
3. To determine whether the imported sounds will be internal or linked sounds, choose a Media option:
   - **Standard Import** makes all the selected sounds internal sound cast members.
   - **Link to External File** makes all the selected sounds linked.
4. Click Import.

**Note:** If you’re authoring on a Macintosh computer that has an audio input or microphone attached, you can record sounds by choosing Insert > Media Element > Sound. The Sound command opens the Macintosh sound recording dialog box. Director for Windows has no equivalent function.

### Controlling sound in the Score

You control sounds in the Score in much the same way as you control sprites. You place sounds in one of the two sound channels at the top of the Score and extend the sounds through as many frames as required.

Unless you use a behavior or other Lingo to override the Score’s sound channels, sounds play only as long as the playback head is in the frames that contain the sound. After a sound begins playing, it plays at its own speed. Director cannot speed up or slow down sounds. If a sound is not set to loop, it stops playing at the end, even if the sprite specifies a longer duration. See “Looping a sound” on page 292.

**Note:** You can speed up or slow down a sound by converting it to a sound-only QuickTime movie and using the `movieRate` sprite property.

In addition to the two sound channels in the Score, Director can use additional sound channels simultaneously. However, the additional channels are accessible only from Lingo, from behaviors, or by using sounds in digital videos. Available RAM and the computer’s speed are the real constraints on the number of sounds Director can use effectively.
To place a sound in the Score:

1. If the sound channels are not visible, click the expander at the right side of the Score. See “Channels” on page 47.

2. Do either of the following:
   - Drag a sound cast member from a Cast window to a frame in one of the sound channels.
   - Double-click a frame in the sound channel and then choose a sound from the Frame Properties: Sound dialog box. You can also preview any sound cast member in the movie from this dialog box.

3. Extend the sound through as many frames as necessary.
   New sounds are assigned the same number of frames as set for sprites in the Sprite Preferences dialog box. You may need to adjust the number of frames to make the sound play completely or change a tempo setting to make the playback head wait for the sound to finish. See “Synchronizing media” on page 310.

*Note:* Sound in the last frame of a movie continues to play or loop until the next movie begins or you exit the application. This sound can be a useful transition while Director loads the next movie. You can stop the sound using the puppetSound command.

**Looping a sound**

You may find that you want to play a sound over and over to create a continuous sound effect, such as the sound of a person walking. A looped sound repeats as long as the playback head is in a frame where the sound is set. You can loop only internal sounds, not linked sounds. See “Importing internal and linked sounds” on page 290.

**To make a sound loop:**

1. Select a sound cast member.
2. Choose Modify > Cast Member > Properties.
3. Turn on the Loop option in the Sound Cast Member Properties dialog box.
Using sound in Windows

The following issues are specific to managing sound for Windows:

- In Windows, a sound that is already playing in either sound channel overrides the sound in a QuickTime or AVI video or a Flash movie. It also prevents the video sound from playing even after the sound in the sound channel has stopped. Once the sound in a digital video has started, however, it overrides a sound in either sound channel. To mix QuickTime audio tracks with internal Director sounds, use the `soundDevice` system property to specify QT3Mix. See `soundDevice` in the Lingo Dictionary. Check the Director Developers Center web site for the latest developments related to this issue.

- The default number of sounds that Director can mix in Windows is eight. This number can be decreased by modifying the value for MinMaxChannels in the `Director.ini` file in the Director folder.

- To play a puppetted sound and a QuickTime sound simultaneously in Windows, you also need Microsoft DirectSound sound driver software, available from Microsoft's web site: http://www.microsoft.com.

Playing sounds with Lingo

Lingo lets you play and control sounds regardless of the settings in the Score. Use Lingo to turn sounds on and off and to play an external sound that isn't a cast member.

Sounds played from the Score's sound channels play at the volume set in the computer's sound level control. Use Lingo to modify the computer's sound level to suit the needs of your movie.

You can also use Lingo to control and stream Shockwave audio. See “Using Shockwave audio” on page 294.

To play sound cast members regardless of the settings in the Score:

Use the `puppetSound` command. See `puppetSound` in the Lingo Dictionary.

To play external sound files that aren’t cast members:

Use the `sound playFile` command. See `sound playFile` in the Lingo Dictionary.

The sounds must be AIFF or WAVE sounds playing from disk.

Playing external sound files from disk minimizes the amount of RAM used to play sounds. However, since the computer can read only one item from disk at a time, loading cast members or playing more than one sound from disk can cause unacceptable pauses when you use the `sound playFile` command.

You sometimes want to make actions in a movie dependent on whether a sound is playing.
To determine whether a sound is playing:

Use the soundBusy() function to tell whether a specific channel is playing a sound. See soundBusy() in the Lingo Dictionary.

To turn off the current sound in a specific channel:

Use the puppetSound command with 0 as the name of the sound file. See puppetSound in the Lingo Dictionary.

To fade a specific channel’s sound in and out:

Use the sound fadeIn and sound fadeOut commands. See sound fadeIn and sound fadeOut in the Lingo Dictionary.

To control a specific sound channel’s volume:

Specify the volume property. See volume (system property) in the Lingo Dictionary.

Using Shockwave audio

Shockwave Audio is a technology that makes sounds smaller and plays them faster from disk or over the Internet.

Shockwave Audio can compress the size of sounds by a ratio of up to 176 to 1 and is streamable, which means Director doesn’t have to load the entire sound into RAM before it begins playing. Director starts to play the beginning of the sound while the rest of the sound is still streaming from its source, whether coming from disk or over the Internet. When used properly, Shockwave Audio compression and streaming features provide fast playback of high-quality audio, even for users with relatively slow modem connections to the Internet.

About compression quality in Shockwave audio

Although Shockwave Audio uses advanced compression technology that alters original sounds as little as possible, the more a sound is compressed the more it is changed.

Set the amount of compression by choosing a bit rate setting in any of the Shockwave Audio Xtras. The bit rate is not related to sampling rates you may have used in other audio programs. Try compressing the same sound at several different bit rates to see how the sound changes.

Choose the bit rate appropriate for the intended delivery system (modem, ISDN, CD-ROM, hard disk, and so on), the type of movie, and the nature of the sound itself. Voiceover sound quality, for example, may not need to be as high as that of music. Test the sound on several systems to find the right balance between quality and performance.
The more compressed a sound is, the faster it streams. If you choose to use a high-quality, low rate of compression, a slow delivery system may not be able to send the data fast enough, resulting in gaps during playback. Most developers choose 16 Kbps for the best results over the Internet.

The following table suggests some general guidelines for setting the bit rate for different delivery systems. It also provides a rough estimate of perceived quality for different rates of compression. Note that real transmission times may be lower than the times shown in this table, depending on network traffic and server load.

<table>
<thead>
<tr>
<th>Delivery</th>
<th>Bit rate</th>
<th>Quality</th>
</tr>
</thead>
<tbody>
<tr>
<td>T1</td>
<td>64 to 128 Kbps</td>
<td>Equal to source material</td>
</tr>
<tr>
<td>ISDN or CD-ROM</td>
<td>32 to 56 Kbps</td>
<td>FM stereo to CD</td>
</tr>
<tr>
<td>28.8 modem</td>
<td>16 Kbps</td>
<td>FM monaural or good quality AM</td>
</tr>
<tr>
<td>14.4 modem</td>
<td>8 Kbps</td>
<td>Telephone</td>
</tr>
</tbody>
</table>

*Note:* Any sound compressed at less than 48 Kbps is converted to monaural.

### Compressing internal sounds with Shockwave audio

Shockwave Audio can compress any internal sounds in a movie. Although internal sounds are not streamed, compressing them with Shockwave Audio dramatically decreases the size of the sound data in a movie, shortens the download time from the Internet, and saves disk space.

Use Shockwave Audio Settings to specify compression settings for internal sound cast members. The compression settings you choose apply to all internal sound cast members. You cannot specify different settings for different cast members.

You can choose compression settings at any time, but compression occurs only when the Director movie is compressed with the Create Projector, Save as Shockwave Movie, or Update Movies commands. When creating a projector, Director compresses sounds only if the Compressed option is turned on in the Projector Options dialog box. Compressing sounds can substantially increase the time required to compress a Director movie. See “Creating projectors” on page 360.

*Note:* Shockwave Audio does not compress IMA compressed sounds.

When you distribute a movie that contains sounds compressed with Shockwave Audio, you must include the required Xtras to decompress and play the sounds. In most cases, Director handles this automatically. See “Managing Xtras for distributed movies” on page 354.
To compress internal sound cast members:

1. Choose Xtras > Shockwave Audio Settings.
2. Choose Enabled to turn on compression.
3. Choose a setting from the Bit Rate pop-up menu.
4. Click the Low or High option for the Accuracy setting.
   High provides better quality, but takes slightly more time to process during compression. If sound quality is critical to your work, leave this option set to High.
5. Click Convert Stereo to Mono if you want to convert a stereo file to monaural.
   At rates lower than 48 bits, all sounds are converted to monaural.
6. Click OK.

Streaming linked Shockwave Audio files

Director streams linked sounds that have been compressed with Shockwave Audio, either from a local disk or a URL. Before you can set up a streaming sound cast member, you must create the external Shockwave Audio files.

To create external Shockwave Audio files:

Do one of the following:

- For Windows, choose Xtras > Convert WAV to SWA and choose the WAV files to convert.
- For the Macintosh, use Peak LE 2 to export Shockwave Audio sounds.

For both methods, the audio settings are similar to those for using Shockwave Audio to compress internal sounds. See “Compressing internal sounds with Shockwave audio” on page 295.
To stream a linked Shockwave Audio sound:

1. Choose Insert > Media Element > Shockwave Audio.
   This creates a cast member that controls the streaming Shockwave Audio.

2. In the Cast Member Properties dialog box, click Browse and choose a Shockwave Audio file on a local disk or enter a URL in the Link Address box.
   Unless you choose a file in the same folder as the movie, the movie always links to the exact location you specify. Be sure to link to the correct location.

3. Set the remaining cast member properties as follows:
   - To set the volume of the sound, use the Volume option.
   - To choose the sound channel for the sound, choose a number from the Sound Channel pop-up menu. To avoid potential conflicts, choose Any.
   - To specify the size of the stream buffer, use the Preload Time option. Director attempts to load enough sound data to play for the specified time. This prevents gaps in sounds played over slow or interruption-prone Internet connections.

4. Click OK.

5. Drag the Shockwave Audio cast member to a sprite channel (not one of the sound channels) to create a sprite. Extend the sprite through all frames in which the sound should play, or use the tempo channel to make the movie wait for the end of the sound. See “Synchronizing media” on page 310.

   You cannot place streaming Shockwave Audio cast members in the sound channels. The sound streams from the source location when the movie plays.

---

**Playing Shockwave audio with Lingo**

Use SWA Lingo to preload and control SWA sounds, and to determine how much of a SWA sound has streamed over the Internet.

Lingo that controls other types of sounds can also control SWA sounds by controlling the sound channel that the SWA sound plays in.

**Controlling streaming SWA sound files**

**To preload part of a SWA file into memory:**

Use the preLoadBuffer member command. See preLoadBuffer member in the Lingo Dictionary.

**To specify the amount of a SWA streaming cast member to download before playback begins:**

Set the preLoadTime cast member property. See preLoadTime in the Lingo Dictionary.
To determine what percentage of a streaming SWA file has actually played:
Test the percentPlayed cast member property. See percentPlayed in the Lingo Dictionary.

To determine the percent of a SWA file that is already streamed from an Internet server:
Test the percentStreamed cast member property. See percentStreamed in the Lingo Dictionary.

To specify the sound channel in which a SWA sound plays:
Set the soundChannel property. See soundChannel in the Lingo Dictionary.

To begin playback of a SWA streaming cast member:
Use the play member command. See play member in the Lingo Dictionary.

To pause a streaming SWA file:
Use the pause member command. See pause member in the Lingo Dictionary.

To start, pause, play, or stop a streaming SWA file:
Set the state cast member property. See state in the Lingo Dictionary.

To stop a streaming SWA file:
Use the stop member command. See stop member in the Lingo Dictionary.

To determine whether an error occurred when streaming a SWA sound file:
Use the getError() function. See getError() in the Lingo Dictionary.

To obtain a string describing an error that occurred when streaming a SWA sound file:
Use the getErrorString() function. See getErrorString() in the Lingo Dictionary.

To determine the length of a SWA file:
Use the duration cast member command. See duration in the Lingo Dictionary.

To determine the bit rate of a SWA cast member:
Test the bitRate cast member property. See bitRate in the Lingo Dictionary.

To determine the original bit depth of a SWA sound:
Test the bitsPerSample property. See bitsPerSample in the Lingo Dictionary.
To determine the sample rate of the original sound used for a SWA cast member:
Test the sampleRate cast member property. See sampleRate in the Lingo Dictionary.

To determine the number of channels in a SWA sound:
Test the numChannels SWA cast member property. See numChannels in the Lingo Dictionary.

To specify a SWA sound’s volume:
Specify the volume SWA cast member property. See volume (cast member property) in the Lingo Dictionary.

To specify a SWA file’s URL:
Set the URL cast member property. See URL in the Lingo Dictionary.

To obtain or set the copyright text in a SWA file:
Test or set the copyrightInfo cast member property. See copyrightInfo in the Lingo Dictionary.

Importing digital video

When you import QuickTime or AVI digital video the cast member you create always remain linked to the original external file, even if you choose the Standard Import option. When you distribute a movie, you must always make sure to include all digital video files along with the movie.

QuickTime must be installed in a system for authoring or playing a movie that contains QuickTime digital video.

Director converts an AVI movie to QuickTime when it plays one on a Macintosh.

To import a digital video:

1 Choose File > Import.
2 Choose digital video files to import.
3 Choose Link to External File as the option for Media. (This option is used regardless of your selection.
4 Click Import.
   Director will prompt you to choose between importing as QuickTime or as a video clip.
Playing digital video direct-to-Stage

Director can play digital video using a feature called Direct to Stage. Direct to Stage allows QuickTime or Video for Windows to completely control the video playback.

Direct to Stage often provides the best performance from a digital video, but there are two disadvantages to using it:

- The digital video always appears in front of all other sprites on the Stage, no matter which channel contains the sprite.
- Ink effects do not work, so it is difficult to conceal the video's bounding rectangle with Background Transparent ink.

When Direct to Stage is off, Director layers a digital video on the Stage exactly like other sprites, and the Background Transparent ink works normally. (Matte ink does not work for digital videos.)

To set Direct to Stage options:

1. Select a digital video cast member.
2. Choose Modify > Cast Member > Properties.
3. For QuickTime videos, click Options. Skip this step for AVI videos.
4. Turn Direct to Stage off or on.
5. If Direct to Stage is on, choose a Video option:
   - **Sync to Soundtrack** to make the digital video skip frames (if necessary) to keep up with its soundtrack. The digital video may also take less time to play.
   - **Play Every Frame** makes every frame of the digital video appear, but does not play the soundtrack, since the video cannot play the soundtrack asynchronously while the video portion plays frame by frame. Depending on the data rate of the digital video, the sprite may play more smoothly with this option selected, but this is not a certainty. In addition, playing every frame may cause the digital video to take more time to play.
6. If Direct to Stage is on, select Show Controller to display a controller bar below the movie to allow the user to start, stop, and step through the movie.
Controlling digital video in the Score

Add a digital video cast member to a movie just as you would to create any other sprite. Digital videos begin playing when the playback head reaches the frame containing the video sprite. Use the Cast Member Properties dialog box to make the movie pause or loop. See “Setting digital video cast member properties” in Director Help.

If there’s a white bounding box around the video, use the Background Transparent ink to remove it. Inks don’t work if Direct to Stage is turned on (see “Playing digital video direct-to-Stage” on page 300). Matte ink does not work for any type of digital video.

To create a digital video sprite:
1. Drag a digital video cast member to any sprite channel in the Score.
2. Extend the sprite through as many frames as necessary.

Playing complete digital videos

A digital video, like a sound, is a time-based cast member. If you place a video in just a single frame of the Score, the playback head moves to the next frame before Director has time to play more than a brief instant of the video.

To make sure that Director plays a digital video until the movie is finished:

Do one of the following:

- Create a tempo setting in the tempo channel using the Wait for Cue Point option in the Frame Properties: Tempo dialog box. This option keeps the playback head from moving to the next frame until a cue point in the video has passed. You define cue points using Peak LE 2 or SoundForger, but you can use Wait for Cue Point to wait for the end of a digital video even if you have not defined any cue points in the file. For more information, see “Synchronizing media” on page 310.
- Use Lingo or behaviors to make the playback head stay in a frame until the end of the video or until a certain cue point passes.
- Extend the video through enough frames to give it time to play all the way through.

Using QuickTime VR

You can use a QuickTime VR movie in a Director movie by inserting it as a QuickTime cast member. Turn on Direct to Stage to get the best performance.
Playing digital video with Lingo

Lingo can take advantage of the most important and powerful features of digital video. Besides playing digital video linearly, Lingo can pause, stop, and rewind a video. These abilities are useful for jumping to segments within a digital video and for emulating a typical digital video control panel. This last feature is especially useful for AVI digital video, which has no control panel of its own.

Lingo also lets you work with individual tracks in a digital video by determining the tracks’ content and position and turning these tracks on and off.

Controlling digital video playback with Lingo

The following are ways that you can control digital video with Lingo.

To turn on looping in a digital video cast member:
Set the digital video’s loop cast member property to TRUE. See loop (cast member property) in the Lingo Dictionary.

To determine the current time of a digital video sprite:
Check the sprite’s currentTime property. See currentTime in the Lingo Dictionary.

To pause a digital video sprite:
Set the sprite’s movieRate property to 0. See movieRate in the Lingo Dictionary.

To start a paused digital video sprite:
Set the sprite’s movieRate property to 1. See movieRate in the Lingo Dictionary.

To play a digital video sprite in reverse:
Set the sprite’s movieRate property to -1. See movieRate in the Lingo Dictionary.

To rewind a digital video sprite to the beginning:
Set the sprite’s movieTime property to 0. See movieTime in the Lingo Dictionary.

To control a digital video sprite’s playback rate:
Set the sprite’s movieRate property to the desired rate. See movieRate in the Lingo Dictionary.

To mix QuickTime audio tracks with internal Director sounds:
Use the soundDevice system property to specify QT3Mix. See soundDevice in the Lingo Dictionary.
Determining digital video content with Lingo

The following are ways that Lingo can determine a digital video’s content:

**To determine the time units that a digital video cast member uses:**
Check the video’s `timeScale` cast member property. See `timeScale` in the Lingo Dictionary.

**To determine whether a digital video is QuickTime or AVI:**
Check the digital video’s `digitalVideoType` cast member property. See `digitalVideoType` in the Lingo Dictionary.

**To determine the number of tracks in a digital video sprite or cast member:**
Check the digital video’s `trackCount` sprite or cast member property. See `trackCount` (cast member property) and `trackCount` (sprite property) in the Lingo Dictionary.

**To determine which type of media a digital video track contains:**
Check the digital video’s `trackType` sprite or cast member property. See `trackType` (cast member property) and `trackType` (sprite property) in the Lingo Dictionary.

**To determine the start time of a track in a digital video sprite or cast member:**
Check the digital video’s `trackStartTime` sprite or cast member property. See `trackStart` (cast member property) and `trackStart` (sprite property) in the Lingo Dictionary.

**To determine the stop time of a track in a digital video sprite or cast member:**
Check the digital video’s `trackStopTime` sprite or cast member property. See `trackStop` (cast member property) and `trackStop` (sprite property) in the Lingo Dictionary.

**To determine whether a sprite’s track is enabled to play:**
Check the digital video’s `trackEnabled` sprite property. See `trackEnabled` in the Lingo Dictionary.

**To obtain the text at the current time from a text track in a digital video sprite:**
Check the digital video’s `trackText` sprite property. See `trackText` in the Lingo Dictionary.

**To determine the time of the track just before the current time in a digital video:**
Check the digital video’s `trackPreviousSampleTime` and `trackPreviousKeyTime` sprite properties. See `trackPreviousSampleTime` (cast member property) and `trackPreviousKeyTime` (sprite property) in the Lingo Dictionary.
To determine the time of the next track after the current time in a digital video:
Check the digital video's trackNextSampleTime and trackNextKeyTime sprite properties. See trackNextSampleTime (cast member property) and trackNextKeyTime (sprite property) in the Lingo Dictionary.

Turning digital video tracks on and off with Lingo
By turning a digital video’s sound tracks on or off, you can play just the animation or control which sounds play by turning on one or more sound tracks.

To control whether individual digital video tracks play:
Use the setTrackEnabled command. See setTrackEnabled in the Lingo Dictionary.

Controlling QuickTime with Lingo
Lingo can control QuickTime in ways that aren’t available for AVI. Use Lingo to control a QuickTime video’s appearance and sound volume. For QTVR, you can use Lingo to pan a QTVR digital video and specify what happens when the user clicks or rolls over portions of the video.

You can set the rotation, scale, and translation properties either for a QuickTime cast member or a sprite.

To determine whether a cast member or sprite is a QTVR digital video:
Test the isVRMovie property. See isVRMovie in the Lingo Dictionary.

To obtain a floating-point value that identifies which version of QuickTime is installed on the local computer:
Use the QuickTimeVersion() function. See quickTimeVersion in the Lingo Dictionary.

To control a QuickTime sprite’s sound volume:
Set the volume sprite property. See volume (sprite property) in the Lingo Dictionary.

To set the internal loop points for a QuickTime cast member or sprite:
Set the loopBounds sprite property. See loopBounds in the Lingo Dictionary.
**Applying masks for QuickTime**

Director has specific Lingo to use to apply masks to QuickTime digital videos.

**To use a black-and-white cast member as a mask for QuickTime media rendered direct-to-Stage:**

Set the `mask` cast member property. See `mask` in the *Lingo Dictionary*.

**To control the way Director interprets a QuickTime movie's mask cast member property:**

Set the `invertMask` property. See `invertMask` in the *Lingo Dictionary*.

---

**Responding to User interaction**

Lingo lets you control how QTVR responds when the user clicks a QTVR sprite. Use Lingo to specify how Director handles image quality, clicks and rollovers on a QTVR sprite, clicks on hotspots, and interactions with QTVR nodes.

**To set the codec quality to use when the user clicks and drags a QTVR sprite:**

Set the `motionQuality` sprite property. See `motionQuality` in the *Lingo Dictionary*.

**To specify the codec quality to use when a QTVR panorama image is static:**

Set the `staticQuality` sprite property. See `staticQuality` in the *Lingo Dictionary*.

**To enable or disable the specified hotspot for a QTVR sprite:**

Use the `enableHotSpot` command. See `enableHotSpot` in the *Lingo Dictionary*.

**To control how Director passes mouse clicks on a QuickTime sprite:**

Set the `mouseLevel` sprite property. See `mouseLevel` in the *Lingo Dictionary*.

**To find the approximate bounding rectangle for a specific hotspot in a QTVR sprite:**

Use the `getHotSpotRect` function. See `getHotSpotRect` in the *Lingo Dictionary*.

**To specify the name of the handler that runs when the pointer enters a QTVR hotspot that is visible on the Stage:**

Set the `hotSpotEnterCallback` QTVR sprite property. See `hotSpotEnterCallback` in the *Lingo Dictionary*.

**To find the ID of the hotspot, if any, that is at a specific point on the Stage:**

Use the `ptToHotSpotID` function. See `ptToHotSpotID` in the *Lingo Dictionary*. 
To specify the name of the handler that runs when the user clicks a hotspot in a QTVR sprite:
Set the triggerCallback sprite property. See triggerCallback in the *Lingo Dictionary.*

To determine the name of the handler that runs when the pointer leaves a QTVR hotspot that is visible on the Stage:
Set the hotSpotExitCallback property. See hotSpotExitCallback in the *Lingo Dictionary.*

To specify the ID of the current node that a QTVR sprite displays:
Set the node QTVR sprite property. See node in the *Lingo Dictionary.*

To specify the name of the handler that runs after the QTVR sprite switches to a new active node on the Stage:
Set the nodeEnterCallback QTVR sprite property. See nodeEnterCallback in the *Lingo Dictionary.*

To specify the name of the handler that runs when a QTVR sprite is about to switch to a new active node on the Stage:
Set the nodeExitCallback QTVR sprite property. See nodeExitCallback in the *Lingo Dictionary.*

To determine the type of node that is currently on the Stage:
Test the nodeType QTVR sprite property. See nodeType in the *Lingo Dictionary.*

**Rotating and scaling QuickTime video**

Lingo can rotate and scale QuickTime videos.

To control the rotation of a QuickTime sprite:
Set the rotation QuickTime sprite property. See rotation in the *Lingo Dictionary.*

To control the scaling of a QuickTime sprite:
Set the scale QuickTime sprite property. See scale in the *Lingo Dictionary.*

**Panning QTVR**

Use Lingo to pan a QTVR digital video without the user dragging the image.

To set the current pan of the QTVR sprite:
Set the pan QTVR sprite property. See pan in the *Lingo Dictionary.*

To nudge a QTVR sprite in a specific direction:
Use the nudge command. See nudge in the *Lingo Dictionary.*
Displaying QuickTime video

Lingo can control how a movie displays QuickTime videos.

To specify the type of warping performed on the panorama of a QTVR sprite:
Set the warpMode QTVR sprite property. See warpMode in the Lingo Dictionary.

To specify a QTVR sprite’s current field of view:
Set the fieldOfView QTVR sprite property. See fieldOfView in the Lingo Dictionary.

To swing a QTVR sprite to a specific pan, tilt, or field of view:
Set the swing sprite property. See swing in the Lingo Dictionary.
**Cropping digital video**

Cropping a digital video means trimming the edges off the top or sides of the movie image. Cropping doesn't permanently remove the portions you crop; it just hides them.

**To crop a digital video:**

1. Select the cast member in the Cast window.
2. Choose Modify > Cast Member Properties.
3. For QuickTime videos, click Options. Skip this step for AVI videos.
4. Select Crop.
   
   Director retains the movie’s original size if you resize the bounding rectangle; however, the edges of the movie will be clipped if you make the bounding rectangle too small.
5. Select Center, if you wish.
   
   Director centers the movie when you resize the bounding rectangle. If Center is not checked, the loop maintains its original position when you resize its bounding rectangle. Center is available only if Crop is selected.
6. Click OK.
7. Select the video in the Score.
8. Go to the Stage and drag any of the handles that appear on the selection rectangle that surrounds the video image.

Director displays only as much of the movie image as will fit in the area defined by the selection rectangle.

If you would rather scale the movie than resize it, select Scale instead of Crop in the Digital Video Cast Member Properties dialog box. Director scales the movie if you resize the bounding rectangle.
To use Lingo to move the image of a QuickTime video around within the sprite’s bounding box:

Set the digital video’s translation QuickTime sprite or cast member property. See translation in the *Lingo Dictionary*.

### About using digital video on the Internet

In both stand-alone projectors and movies playing in web browsers, Director handles digital video the same way it handles all other media. You can link the digital video to a URL, and the movie begins to download the digital video when its sprite first appears on the Stage.

When using digital video in a movie distributed on the Internet, keep these points in mind:

- The video does not appear on the Stage until it is fully downloaded. Once the media is fully downloaded, it begins to play (unless the member’s pausedAtStart property is set to TRUE or the controller member property is set to TRUE).

- Once a digital video begins to download, the download continues until it is finished, even if the sprite no longer appears on the Stage. Use the percentStreamed member property to test how much of the media has been downloaded. The feature works with QuickTime movies only. See percentStreamed in the *Lingo Dictionary*.

- If a Lingo script refers to properties or uses functions that require information about a digital video that has not finished downloading, the script receives only default information. Test the mediaReady property to determine whether a file is fully downloaded. See mediaReady() in the *Lingo Dictionary*.

- QuickTime cast members can open a wide variety of different file formats. Test the mediaValid of a member to determine if it can open the file it is pointing to.
Preloading digital video

You can eliminate the delay caused by loading a digital video during a movie by loading it at the beginning of the movie. You can preload an entire digital video (or as much of the video as will fit into available memory) using the Cast Member Properties dialog box.

To preload a digital video:

1. Select a digital video cast member.
2. Choose Modify > Cast Member > Properties.
3. Click Options for QuickTime. Skip this step for AVI.
4. Turn on Enable Preload.

This option uses the `preLoad` or `preLoadMember` command. If there is not enough memory to load the entire movie, Director loads only what will fit into memory. If this option is turned off, Director does not load the movie into memory and instead plays it from disk. This results in slower animation speeds, since each frame must be retrieved from disk before it is played.

Synchronizing media

Use the Wait for Cue Point option in the Tempo dialog box to pause the playback head until a specified cue point in a sound or digital video is reached. You can also use this function to wait for the end of the sound or digital video, even if it has no cue points. Cue points can also trigger events to be interpreted by Lingo. See “Synchronizing media with Lingo” on page 312.

For example, you can use cue points to make text appear in time with narration. First, use Peak LE 2 to place cue points corresponding to the text in the sound file. In Director, use the Tempo dialog box to pause the playback head at the frame where the corresponding text appears until the voice-over reaches the proper cue point.

In Windows, use Sound Forge 4.0 or later or Cool Edit 96 or later to define cue points (called markers or regions within these programs). (See the Readme Windows Sound Loop-Cue.txt file in the Director application folder for instructions on doing this.) On the Macintosh, use Peak LE 2 to define cue points in AIFF and Shockwave Audio sounds, and in QuickTime digital videos.

AVI digital video does not support cue points. Similarly, WAV files with cue points added in SoundForge or CoolEdit work on both platforms.

Note: If a QuickTime movie has a QuickTime chapter track instead of cue points, Director uses the chapter names as cue points and shortens chapter names longer than 32 characters to 32 characters.
To use cue points:

1. Place cue points in a sound file or in a QuickTime file.
   Use an audio editing program to define cue points in both sounds and
digital videos.

2. Import the sound or digital video into Director.
   The sound can be imported internally using the Standard Import option, or it
can be linked to an external file with the Link to External File option in the
Import dialog box. Cue points work the same way in both cases.

3. Place the sound or digital video in a channel in the Score and extend it
through all the frames in which you want it to play.

4. Double-click the frame in the tempo channel where you want the playback
head to wait for a cue point.

5. In the Tempo dialog box, choose Wait for Cue Point.

6. Select the sound or digital video from the Channel pop-up menu.

7. Choose the cue point to wait for from the Cue pop-up menu.
   Select the End or Next cue point or any named or numbered cue point in the
sound or digital video. Director recognizes the end of a sound regardless of
whether you’ve defined cue points ahead of time.

When the movie plays, the playback head pauses at the frame until the cue
point passes.
Synchronizing media with Lingo

By writing Lingo that performs an action when a cue point is reached in a SoundEdit or QuickTime file, you can synchronize a movie with sound or digital video.

To set up Lingo that runs when the movie reaches a cue point in a SoundEdit or QuickTime file:

Put the Lingo in an on cuePassed handler. See on cuePassed in the Lingo Dictionary.

To determine whether a SoundEdit or QuickTime file has passed a specific cue point:

Use the isPastCuePoint function. See isPastCuePoint in the Lingo Dictionary.

To find the ordinal number of the last cue point passed in a SoundEdit or QuickTime file:

Use the mostRecentCuePoint function. See mostRecentCuePoint in the Lingo Dictionary.

To obtain a list of names for the cue points in a specific SoundEdit or QuickTime file:

Test the cuePointNames property. See cuePointNames in the Lingo Dictionary.

To obtain a list of times for cue point times in a specific SoundEdit or QuickTime file:

Test the cuePointTimes property. See cuePointTimes in the Lingo Dictionary.
CHAPTER 16
Using Interactive Media Types

Using interactive media types: Overview

Use Flash movies, other Director movies, PowerPoint presentations, and ActiveX controls to add complex media and new capabilities to your movie. Each of these multimedia formats has interactive capabilities that are preserved by Director.

A Flash movie in a Director movie provides a vector-based, scalable, interactive animation that is optimized for use on the Web.

Director movies within other Director movies simplify complex productions. A linked movie appears within another movie as a single cast member, saving you the trouble of managing extra cast members and score data. Using discrete movies also helps you manage file size for easier downloading.

A PowerPoint presentation can be a starting point for a Director movie. Director converts the entire presentation into a movie file that works almost exactly like the original presentation. Director converts all the presentation media into cast members, lays them out on the Stage, and generates Score data to control events.

ActiveX controls in Director can manage ActiveX application resources from within a movie. ActiveX controls provide a variety of features, including Web browsing, spreadsheet functions, and database management. ActiveX controls function as normal sprites in a movie. ActiveX controls work only in Director for Windows.
Using Flash Movies

Incorporate Flash vector-based animation in your Director movies, projectors, and Shockwave movies for the web simply by importing a Flash movie into Director and using it like any other cast member. Effects that once required multiple versions of a bitmap cast member—such as blending one shape into another—can now be accomplished with a single, small Flash movie.

Director can import Flash 2.0 or later. It supports new features of Flash 3, including alpha channels (transparency), animated buttons, and so on.

In Director, you can control nearly every Flash movie property—including playing, rewinding, and stepping forward and backward through any Flash movie, adjusting quality settings, and turning sound on or off—using Lingo commands.

In Flash, you can create cross-platform Windows and Macintosh movies and then play or manipulate them in Director. You can create Flash movies that communicate with your Director movie by sending events that Director scripts can capture and process. You can store entire Flash movies in the Director cast file, or you can link to external Flash movies. Director automatically loads the Flash movie it encounters in the Score into memory from disk, from a network drive, or from anywhere on the Internet.

Flash movies are particularly effective for use in Shockwave movies because, as vector-based media, they are extremely small and therefore load much more quickly than most other media types. Because Flash movies are vector-based, you can scale and rotate them while still maintaining their sharpness. For example, you can create splash screens for your Director Shockwave movies that load with lightning speed and entertain your users while the rest of the Director movie streams into memory, or you can create interactive maps in Flash that users can pan across or zoom in on to reveal details with vector-based precision.

Adding a Flash movie cast member

All Flash cast members added to a Director movie must have been created with Flash 2.0 or later and saved in Shockwave Flash format.

The following procedure explains how to create a Flash cast member and set properties for it at the same time. You can also use File > Import to import a Flash movie, but you must then choose Modify > Cast Member > Properties to set properties for the new cast member.
To add a Flash movie as a cast member:

1. Choose Insert > Media Element > Flash Movie.

2. In the Flash Asset Properties dialog box, select the Shockwave Flash movie file you want to add to your Director cast.
   - To add a file from your computer or from a network drive, click Browse, select the file, and click Open.
   - To add a file from a location on the Internet, click Internet, type the URL of the file, and click OK.
   - Type the pathname or the URL of the file in the Link File box.

3. Set Media options:
   - Select Linked to store the actual media of the Flash movie in an external file. When a sprite created with this cast member appears on the stage in a Director movie, Director will automatically load the file into memory by looking in the location specified in the Link File box. Deselect Linked to have Director copy the Flash movie into the cast.
   - Select Preload to require Director to load the entire Flash movie into memory before playing the movie's first frame. Deselect Preload to have Director start playing the movie immediately while continuing to stream the cast member into memory. This option is available if you selected Linked.

4. Select Playback options to control how a Flash movie sprite plays in a Director projector, in a Shockwave Director movie, and while you are authoring in Director:
   - Image displays images from the Flash movie when it plays. When Image is deselected, the images are invisible.
   - Sound enables any sound in the Flash movie to play. When Sound is deselected, the movie plays without sound.
   - Paused displays only the first frame of the movie without playing the movie. When Paused is deselected, the movie begins playing immediately when it appears on the Director Stage.
   - Loop makes the movie play again from frame 1 once it finishes. When Loop is deselected, the movie plays once and stops.
   - Direct to Stage displays the movie immediately when it appears on the stage for the fastest, smoothest playback. Deselect Direct to Stage to have Director draw the entire sprite first in memory with other sprites and applying ink effects before actually displaying it. The disadvantage of Direct to Stage is that the movie always appears on top of other sprites, regardless of the channel in which it appears in the Score, and ink effects don't work.
Specify a Scale value by typing the percentage to scale the cast member.

Specify a Quality value:

- Select a high-quality setting to have the Flash movie play with anti-aliasing turned on, which slows down performance; choose Auto-High to have Director start playing the movie with anti-aliasing on but turn it off if it can't play the movie at the required frame rate.
- Select a low-quality setting to turn off anti-aliasing but speed up performance; choose Auto-Low to have Director start playing the movie without anti-aliasing but turn on anti-aliasing if it can do so and continue playing the movie at the required frame rate.

Select a scale mode to control how the Flash movie's sprites are scaled on Stage:

- **Show All** maintains the movie's aspect ratio and, if necessary, fills in any gaps along the horizontal or vertical dimension using the movie's background color.
- **No Border** maintains the movie's aspect ratio by cropping the horizontal or vertical dimension as necessary without leaving a border.
- **Exact Fit** stretches the movie to fit the sprite exactly, disregarding the aspect ratio.
- **Auto Size** adjusts the sprite bounding rectangle to fit the movie when it is rotated, skewed, or flipped. This option always sets the scale to 100%.
- **No Scale** places the movie on the Stage with no scaling. The movie stays the same size no matter how you resize the sprite, even if it means cropping the movie.

Select a tempo to control the rate at which Director tries to play the Flash movie:

- **Normal** plays the Flash movie at the required tempo.
- **Lock Step** plays a frame of the Flash movie for each Director frame.
- **Fixed Rate** plays the movie at a rate you specify by typing a value in the entry box.

When you have finished selecting options, click OK.

Director adds the Flash movie to the cast.

*Note:* You can also use Lingo extensions to adjust these and other properties of the Flash movie. See “Controlling a Flash movie with Lingo” on page 317.
About using a Flash movie in a Director movie

Once you have added a Flash movie to the Director cast, using it in your movie is as simple as dragging it to the stage and positioning it where you want it. You can then use the Flash movie sprite in much the same way as you use other sprites.

When working with a Flash movie on the Stage, keep these points in mind:

- A Flash movie’s animation plays only as long as the Flash movie’s sprite is actually on the Stage. (Flash movies resemble digital video and sound sprites in this regard.)
- Because a Flash movie uses a vector format, you can stretch the movie’s sprite without loss of the movie’s clarity.
- You can rotate, skew, scale, or flip a Flash movie just as you would a vector shape.
- If the movie is set up to play Direct to Stage, the movie will always appear on top of other sprites, regardless of the channel in which it is placed, and ink effects will be ignored.
- Only the Copy, Transparent, Background Transparent, and Blend ink effects work with Flash movies.
- Blend and color settings are supported for Flash sprites just as they are for vector shapes.

Controlling a Flash movie with Lingo

Lingo gives you precise control over the way Director streams and displays a Flash movie. You can use Lingo to check and control member streaming, zoom and colorize the Flash asset, and pan the Flash image.

When a movie is playing, Lingo can change the Flash cast member’s properties.

Some cast member properties, such as the flashRect and frameRate cast member properties, are valid only after the Flash movie’s header has streamed into memory.

Director provides the following Lingo that lets you manage how Director uses a Flash movie.

To control whether changes to a Flash movie cast member immediately appear in sprite’s that use the cast member:

Set the cast member’s broadcastProps property. See broadcastProps in the Lingo Dictionary.

To control whether a Flash movie is stored in an external file:

Set the linked property. See linked in the Lingo Dictionary.
To control which frame of a Flash movie Director uses for the Flash movie's thumbnail image:

Set the `posterFrame` property. See `posterFrame` in the *Lingo Dictionary*.

To display a list of a Flash movie's current property settings in the Message window:

Use the `showProps` command. See `showProps` in the *Lingo Dictionary*.

**Controlling a Flash movie’s appearance with Lingo**

Lingo can control how a Flash movie appears on the Stage, which part of the Flash movie appears in its sprite's bounding rectangle, and skew, rotate, scale, and flip the Flash movie.

Director supports only the copy, transparent, background transparent, and blend inks for Flash sprites.

**Flipping, rotating, and skewing Flash sprites**

Lingo can flip, rotate, and skew Flash sprites as the movie plays.

**To flip a Flash sprite:**

Set the `flipH` and `flipV` sprite property. See `flipH` and `flipV` in the *Lingo Dictionary*.

**To skew a Flash sprite:**

Set the `skew` sprite property. See `skew` in the *Lingo Dictionary*.

**To rotate a Flash sprite:**

Set the rotation property. Set the `obeyScoreRotation` property to specify whether a Flash sprite obeys the rotation specified in the Score.

If `obeyScoreRotation` is set to TRUE, Director ignores the cast member’s rotation property and obeys the Score rotation settings instead.

See `rotation` and `obeyScoreRotation` in the *Lingo Dictionary*. 
Colorizing and blending Flash sprites

You can use Lingo to change a sprite's color and blend as the Director movie plays.

To specify the color of a Flash sprite:
Set the color sprite property. See color (sprite property) in the Lingo Dictionary.

To specify the blend for a Flash sprite:
Set the blend sprite property. See blend in the Lingo Dictionary.

Scaling Flash movies

Lingo can scale Flash cast members and sprites.

To control the scaling of a Flash movie:
Set the scale and scaleMode properties. See scale and scaleMode in the Lingo Dictionary.

To set the scale percentage of a Flash movie within its sprites bounding rectangle:
Set the viewScale property. See viewScale in the Lingo Dictionary.

Controlling a Flash movie's bounding rectangle

Use Lingo to control a Flash movie's bounding rectangle and how the You can also use Lingo to set a Flash movie's registration points.

To control which part of a Flash movie appears within its sprite's bounding rectangle:
Set the viewH, viewpoint, viewScale, and viewV properties. See viewH, viewpoint, viewScale, and viewV in the Lingo Dictionary.

To control the default size for all new Flash sprites:
Set the defaultRect property. Use the defaultRectMode property to control how the default size is set. See defaultRect and defaultRectMode in the Lingo Dictionary.

To determine the original size of a Flash cast member:
Test the flashRect property. See flashRect in the Lingo Dictionary.

To specify a Flash movie's origin point around which scaling and rotation occurs:
Set the originH, originMode, originPoint, and originV properties. See originH, originV, originMode, and originPoint in the Lingo Dictionary.
To recenter a Flash cast member’s registration point after resizing the cast member:

Set the centerRegPoint property to TRUE. See centerRegPoint in the Lingo Dictionary.

**Placing Flash movies on the Stage**

Lingo can set whether a Flash movie appears at the front of the Stage and whether specific areas of a Flash movie and the Stage overlap.

**To determine whether a Flash movie plays in front of all other layers on the Stage and ink effects have no affect:**

Set the directToStage property. See directToStage in the Lingo Dictionary.

**To determine which Stage coordinate coincides with a specified coordinate in a Flash movie:**

Use the flashToStage() function. See flashToStage in the Lingo Dictionary.

**To determine which Flash movie coordinate coincides with a specified coordinate on the Director Stage:**

Use the stageToFlash function. See stageToFlash in the Lingo Dictionary.

**To improve performance for a Director movie that uses a static (non-animated) Flash movie:**

Set the static property. See static in the Lingo Dictionary.

**To control whether a Flash movie’s graphics are visible:**

Set the imageEnabled property. See imageEnabled in the Lingo Dictionary.

**To control whether a Flash movie plays sounds:**

Set the sound property. See sound in the Lingo Dictionary.

**To control whether Director uses anti-aliasing to render a Flash movie:**

Set the quality property. See quality in the Lingo Dictionary.
Streaming Flash movies with Lingo

In addition to the Lingo that lets you stream many of Director’s media types, Director offers Lingo that specifically lets you control and monitor streaming Flash movies. See “Playing movies over the Internet: Overview” on page 337 for general information about using Lingo to stream media in Director.

To specify whether a linked movie streams or not:
Set the preLoad property. See preLoad (cast member property) in the Lingo Dictionary.

To specify how much of a Flash cast member streams into memory at one time:
Set the bufferSize cast member property. See bufferSize in the Lingo Dictionary.

To check how many bytes of a Flash movie have streamed into memory:
Test the bytesStreamed property. See bytesStreamed in the Lingo Dictionary.

To determine how much a Flash movie is currently streamed:
Test the percentStreamed property or check the streamSize function. See percentStreamed and streamSize in the Lingo Dictionary.

To set when Director attempts to stream part of a Flash movie:
Set the streamMode property. See streamMode in the Lingo Dictionary.

To clear an error setting for a streaming Flash movie:
Use the clearError command. See clearError in the Lingo Dictionary.

To determine whether an error occurred while streaming a Flash movie:
Use the getError() function. See getError() in the Lingo Dictionary.

To check the current state of a streaming file:
Test the state property. See state in the Lingo Dictionary.

To attempt to forcibly stream a specified number of bytes of a Flash movie:
Use the stream command. See stream in the Lingo Dictionary.
Playing back Flash movies with Lingo

Lingo lets you control how a Flash movie plays back and whether the Flash movie retains its interactivity.

Controlling Flash movie playback with Lingo

Use Lingo to control a Flash movie’s tempo, specify which frame plays, and to start, stop, pause, and rewind the Flash movie.

To control the tempo of a Flash movie:
Set the fixedRate and playbackMode properties. See fixedRate and playbackMode in the Lingo Dictionary.

To determine the original frame rate of a Flash movie:
Test the frameRate property. See frameRate in the Lingo Dictionary.

To determine the number of frames in a Flash movie:
Test the frameCount property. See frameCount in the Lingo Dictionary.

To determine the frame number associated with a label in a Flash movie:
Use the frameLabel() function. See frameLabel() in the Lingo Dictionary.

To play a Flash movie starting from a specified frame:
Set the frame property or use the goToFrame command. See frame (sprite property) in the Lingo Dictionary.

To set whether a Flash movie starts playing immediately when the Flash sprite appears on the Stage:
Set the pausedAtStart property. See pausedAtStart in the Lingo Dictionary.

To check whether a Flash movie is playing or paused:
Test the playing property. See playing in the Lingo Dictionary.

To rewind a Flash movie to frame 1:
Use the rewind sprite command. See rewind sprite in the Lingo Dictionary.

To stop a Flash movie at its current frame:
Use the stop command. See stop in the Lingo Dictionary.

To stop a Flash movie at its current frame but let any audio continue to play:
Use the hold command. See hold in the Lingo Dictionary.
Controlling Flash movie interactivity with Lingo

Lingo can set control whether a Flash movie remains interactive.

To control whether the actions in a Flash movie are active:
Set the `actionsEnabled` property to TRUE. See `actionsEnabled` in the Lingo Dictionary.

To control whether buttons in a Flash movie are active:
Set the `buttonsEnabled` property. See `buttonsEnabled` in the Lingo Dictionary.

To control when a Flash movie detects mouse clicks or rollovers:
Set the `clickMode` property. See `clickMode` in the Lingo Dictionary.

To control whether clicking buttons in a Flash movie sends events to sprite scripts:
Set the `eventPassMode` property. See `eventPassMode` in the Lingo Dictionary.

To determine which part of a Flash movie is directly over a specific point on the Stage:
Use the `hitTest` function. See `hitTest` in the Lingo Dictionary.

To check whether the mouse pointer is over a button in a Flash movie:
Test the `mouseOverButton` property. See `mouseOverButton` in the Lingo Dictionary.

Sending Lingo from Flash movies

A Flash 3 movie can send Lingo instructions to a Director movie. The Lingo determines how the movie responds when the user clicks a button or the Flash movie enters a frame. You can send a string to an `on getUrl` handler, an event message, or a complete Lingo statement.

In Flash, you create a button or frame and then assign it a Get URL action in which you specify the Lingo that the Flash cast member sends. (Flash 2 movies do not support this feature.)
To set up a Flash movie to generate an event:

1. In Flash, select a button.

2. Choose Modify > Instance. In the Instance Properties dialog box, click the Actions tab and select Get URL from the Action menu. Do not specify anything for the Target Window option. (Director ignores this field.)

3. In the URL field, enter the Lingo that you want Flash to send to the movie.
   - To specify a string to pass to an on getURL handler in the Director movie, enter the string. In Director, include an on getURL handler that receives the string from the Flash movie and reads the string as a parameter.

   For example, in Flash, you can specify this in the Network URL field:
   
   Dali
   }
   
   In Director, you can write this handler:
   
   on getURL me stringFromFlash
     go to frame stringFromFlash
   end
   
   When the on getURL handler receives the text string, it reads the string and then jumps to the frame labeled Dali in the Director Score.

   - To specify an event message, specify the word event followed by a colon, the name of a handler you will write in Director, and a parameter (if any) to pass along with the event.

   For example, in Flash, you can specify this in the Network URL field:
   
   event: FlashMouseUp "Dali"
   
   In Director, you write this handler:
   
   on FlashMouseUp me whichFrame
     go to frame whichFrame
   end
   
   When the Director script receives the FlashMouseUp message and the parameter, the movie jumps to the frame specified by the parameter.

   - To specify a Lingo statement, specify the word lingo, followed by a colon, followed by the Lingo statement that you want Director to execute.

   For example, in Flash, you can specify this in the Network URL field:
   
   lingo: go to frame "Dali"
   
   When Director receives the getURL message from the Flash movie, the movie immediately executes the Lingo statement.

You can place handlers to capture events from Flash movies in a Flash sprite or cast member script or in a frame or movie script. The event follows the normal Director message hierarchy.
Playback performance tips for Flash movies

Performance can vary greatly, depending on the options in effect and the playback environment. Following are tips for getting optimal playback performance from Flash:

- If adequate for your needs, use the Low quality setting rather than High. Using Low turns off anti-aliasing, which speeds up Flash animation rendering. A handy technique is to switch the quality of the sprite to Low while displaying a fast-moving animation sequence (such as a spinning logo), and then switch the quality back to High on the fly as the animation slows down or comes to a stop. This way, performance can be improved during the part of the sequence where it would be more difficult to perceive the improved quality anyway, without sacrificing quality in the end result.

- Experiment with different system color depths to see what provides the best performance. Some display drivers are still optimized for 8 bits, so performance can be faster when running in this mode. Some graphics, such as gradients, display faster at 16 bits.

- Use Copy ink if possible. Transparency, using Background Transparent ink, requires much more processing time. If your Flash sprite is in the background (no other Director sprites are behind it), use Copy instead of Background Transparent, and author your Flash movie in such a way that its background color is the same as the background color you chose for your Director Stage.

- Use Direct to Stage if possible. Layering and transparency are not supported in this mode; however, if you just want to play a Flash movie within a box with the best performance possible, this may be the way to go.

- Make sure that the Director movie tempo is set high enough. Unless you’re using Direct to Stage, your Flash movie will not play faster than the Director movie frame rate, regardless of the frameRate or fixedRate setting. For smoothest playback, set the Director frame rate to at least 30 frames per second (fps).

- Use Lock-Step or Fixed playback mode to adjust the Flash movie frame rate. Lock-Step gives the best performance, because playback of the Flash movie is synchronized to the Director movie frame for frame.

- Set the static property of the sprite to TRUE if your sprite contains no animation (such as a static block of text) and doesn’t overlap other moving Director sprites. This keeps Director from redrawing the sprite every frame unless it moves or changes size.

- When modifying Flash properties using Lingo, set the properties for the sprite rather than the cast member. Setting the properties for the cast member modifies values at the cast member level and broadcasts the change to all sprites on the Stage. This overhead can affect performance. If you have only a single sprite for the cast member, modify the sprite property directly.
Limit the amount of Lingo that executes while the Flash movie plays. Avoid tight repeat loops between frames. The usual Director performance optimizations apply when using Flash movies.

Using Director movies within Director movies

You can import a Director movie into another movie as an internal or linked cast member. You import Director movies with the Import command just as you import other types of media. As with other media types, you can link to an external movie file or import the file so that it becomes internal media. The way you choose to import a movie affects its properties.

- For linked movies, cast member scripts and behaviors (sprite scripts) function as before. Turn on Enable Scripts in the Cast Member Properties dialog box to make them work. Frame and movie scripts do not work. As with other types of linked media, the external movie file must be present on the system when the host movie plays.

- For movies imported as internal media, the movie appears as a film loop.

For both types of imported movies, the host movie controls the tempo settings, palette settings, and transitions. Settings for these functions in the imported movie are ignored.

Once it is imported, the movie appears as a cast member in the Cast window. The cast members of a movie imported as internal media also appear in the Cast window. You can animate the cast member just as you would any graphic cast member, film loop, or digital video.

To import a Director movie:

1. Choose File > Import.
2. Select a Director movie.
3. To determine whether the movie is imported into the current movie file or linked externally, choose a Media option.
   - **Standard Import** imports the movie into the current movie file.
   - **Link to External File** creates a cast member that references the external movie file.
4. Click Import.

   For an internal movie, Director imports all the movie’s cast members into the current cast and creates a film loop that contains the Score data.

   A linked movie appears as a single cast member.
To place a Director movie cast member in the current movie:

1. Do one of the following:
   - For an internal movie, drag the film loop cast member to the Stage or Score.
   - For a linked external movie, drag the movie cast member to the Stage or Score.
2. Extend the sprite through all the frames in which you want it to appear.
3. To change any of the movie’s properties, choose Modify > Cast Member Properties.
   
   See “Setting linked Director movie properties” in Director Help.

Using PowerPoint presentations

You can import Microsoft PowerPoint 4 presentations into Director and then play your presentations as they are, or you can use them as a starting point for creating rich multimedia projects in Director. You can save your Director project as a stand-alone projector or as a movie for the web. For example, you can animate your presentation by adding bars or lines one at a time, or you can synchronize music, sounds, or video to action in your movie—such as a self-running presentation with voice-over narration—or advance a presentation to the next slide after the narration on the current slide finishes.

Importing your PowerPoint presentations into Director imports the artwork, text, and transitions as individual cast members into your Director cast, converts each PowerPoint slide into a Score section, and assembles the Score for you—complete with build effects and tempo settings that pause the action when necessary. You can use Director to add sophisticated interactivity, sounds, and animations.

Lingo can add more interactivity, such as letting users decide the order in which to view slides in a kiosk, and track the slides visited and list the slides still to be viewed.

Importing a presentation into Director creates a copy of the presentation file. Because the presentation you play in Director is a copy, not the original PowerPoint file, you can enhance your presentation in Director without affecting the PowerPoint original. In most cases, the Director movie will look and act almost exactly like the PowerPoint presentation. For a list of differences, see “Comparison of PowerPoint and Director features” on page 329.
Importing a PowerPoint presentation into Director

Director can import presentations from PowerPoint 4 or later. If necessary, open the presentation in PowerPoint and use the File > Save As command to save the presentation in the PowerPoint 4 format.

Presentations that contain OLE objects or large or numerous bitmaps may require additional memory. If you run out of memory while importing a presentation, try saving the presentation as two or more files. Import those files into Director movie files and then recombine the Director movie files by cutting and pasting.

To import a PowerPoint presentation:

1. Create a new movie by choosing File > New > Movie.
   You cannot import a presentation into an existing Director movie.

2. Choose Xtras > Import PowerPoint File and choose a PowerPoint presentation.
   Director opens the PowerPoint Import Options dialog box.

3. Set up the way you want to import the presentation.
   ▶ For Slide Spacing, enter the number of blank frames that you want between each slide in the Score.
   ▶ For Minimum Slide Duration, enter the minimum number of frames a slide will take up in the Score.
   ▶ For Item Spacing, if the presentation contains build effects (other than fly effects), enter the number of frames used for each item before the next item appears on the Stage.
   ▶ For Fly Transition Item Spacing, specify the number frames to the next keyframe, where the item is in full view. Fly transitions are imported as a Score animation. In the first frame in which the item appears, the item is positioned offstage. In general, the larger the number of frames, the smoother the fly effect will be, and the longer it will take to appear on screen.

   For more information on how Director assembles the Score, see “Using PowerPoint presentations” on page 327.

4. Click Import.
   When the presentation has been imported, save your movie.
Comparison of PowerPoint and Director features

In cases where there is no exact match for a PowerPoint feature in Director, Director uses the closest matching feature. The following tables summarize how Director handles nonmatching PowerPoint features as well as other issues that occur when importing presentations.

<table>
<thead>
<tr>
<th>PowerPoint text</th>
<th>Director equivalent</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text Tool objects on the Slide Master</td>
<td>Text Tool objects on the Slide Master aren’t placed in the Score. Cast members aren’t placed in the Score. Cast members are created, but you must manually add them to the Score.</td>
</tr>
<tr>
<td>Bold or italic text</td>
<td>Depending on the font used, text wrap and character spacing may differ in Director.</td>
</tr>
<tr>
<td>Embossed text font effect and shadow font effect</td>
<td>Text appears as regular text. As a workaround, in PowerPoint you can use the Format &gt; Shadow command to add a shadow effect to the entire text block.</td>
</tr>
<tr>
<td>Rotated text</td>
<td>Text is not rotated.</td>
</tr>
<tr>
<td>Text that uses unavailable fonts</td>
<td>Text uses the nearest matching font. Text spacing and wrapping may change as a result.</td>
</tr>
<tr>
<td>Text using non anti-aliased fonts and italic style</td>
<td>Cast members are inverted (reading left to right).</td>
</tr>
<tr>
<td>Text with text wrap turned off</td>
<td>Text wrapping is turned on.</td>
</tr>
<tr>
<td>Colored text in Microsoft Word tables within a presentation</td>
<td>Text appears as black text.</td>
</tr>
<tr>
<td>Multiple line spacing settings or line spacing in text objects that use multiple fonts</td>
<td>One line spacing setting is used per object.</td>
</tr>
</tbody>
</table>
### PowerPoint lines and fills

<table>
<thead>
<tr>
<th>PowerPoint lines and fills</th>
<th>Director equivalent</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dotted and dashed lines</td>
<td>Solid lines are used.</td>
</tr>
<tr>
<td>Medium dashed lines</td>
<td>Lines are not imported. Change the line weight in PowerPoint before importing.</td>
</tr>
<tr>
<td>Lines with arrowheads</td>
<td>Lines don’t have arrowheads.</td>
</tr>
<tr>
<td>Lines with blunt ends</td>
<td>Line ends are tapered or rounded, depending on the line type.</td>
</tr>
<tr>
<td>Pattern fills</td>
<td>The object appears as a solid object.</td>
</tr>
<tr>
<td>Arcs with fills that end flush with their fills</td>
<td>Arcs with fills extend beyond their fills.</td>
</tr>
<tr>
<td>Semitransparent AutoShape fills</td>
<td>No fill is used. It is recommended that you set the blend of the Director sprite to 50%.</td>
</tr>
<tr>
<td>From Title shading</td>
<td>From Center radial gradient is used.</td>
</tr>
</tbody>
</table>

### PowerPoint bulleted lists

<table>
<thead>
<tr>
<th>PowerPoint bulleted lists</th>
<th>Director equivalent</th>
</tr>
</thead>
<tbody>
<tr>
<td>Backgrounds for bullet text blocks using build effects</td>
<td>The background appears on the Stage in the same frame in which the first bullet item appears. If necessary, extend the background sprite’s duration to an earlier frame in the Score.</td>
</tr>
<tr>
<td>Bullet builds</td>
<td>Bullets always build one bullet item at a time, regardless of their level.</td>
</tr>
<tr>
<td>Bullet items with the Random Effects build effect</td>
<td>A single transition, selected at random, is assigned to each bullet in the text block.</td>
</tr>
<tr>
<td>Dimming of previous bullet items</td>
<td>Dimming is achieved by setting the cast member to a 50% blend. The dimming color is not used.</td>
</tr>
<tr>
<td>Text with a text anchor set to top centered, middle centered, or bottom centered</td>
<td>The vertical anchor setting is preserved. All items in a bulleted list must have consistent settings for the centered anchor setting to be preserved.</td>
</tr>
</tbody>
</table>
### PowerPoint transitions

<table>
<thead>
<tr>
<th>PowerPoint transitions</th>
<th>Director equivalent</th>
</tr>
</thead>
<tbody>
<tr>
<td>CheckerBoard Across transition</td>
<td>CheckerBoard Down transition</td>
</tr>
<tr>
<td>Fade Through Black transition</td>
<td>No transition</td>
</tr>
<tr>
<td>Cut and Cut Through transitions</td>
<td>No transition</td>
</tr>
</tbody>
</table>

### PowerPoint objects and bitmaps

<table>
<thead>
<tr>
<th>PowerPoint objects and bitmaps</th>
<th>Director equivalent</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bitmaps saved in a Macintosh presentation and imported into Director for Windows, or bitmaps saved in a Windows presentation and imported into Director for Macintosh</td>
<td>Cross-platform bitmaps are not imported. Before importing, open the presentation on the same platform you will use for Director and save the presentation. For example, before importing into Director for Windows, first open the Macintosh presentation file in PowerPoint for Windows and save the file.</td>
</tr>
<tr>
<td>Color depth of graphics</td>
<td>Director creates bitmaps for all graphics in the current monitor depth when importing. For a different color depth, change the monitor setting before importing or use the Modify &gt; Transform Bitmap command to modify the bitmap cast members.</td>
</tr>
<tr>
<td>Bitmaps with white extending beyond colored borders</td>
<td>Director strips white space from the outer edges of bitmaps. This may lead to differences in alignment of objects on the Stage, or objects may be stretched to fill the space.</td>
</tr>
<tr>
<td>EPS format graphics</td>
<td>There may be some distortion of graphics in this format when it is re-created in Director.</td>
</tr>
<tr>
<td>8-bit graphics</td>
<td>On occasion, some colors may not import correctly in 8-bit displays. If this occurs, set the display to a higher color depth before you import.</td>
</tr>
<tr>
<td>OLE objects (such as a Microsoft Excel chart or Microsoft Word table)</td>
<td>These objects are imported as bitmaps.</td>
</tr>
<tr>
<td>Solid-color shadows on clip art and charts</td>
<td>Solid-color shadows are reproduced as duplicates of the object and are offset by the number of pixels specified for the shadow.</td>
</tr>
<tr>
<td>Objects using shading that are created in PowerPoint on the Macintosh and imported into Director on Windows</td>
<td>In rare cases, Director may re-create the shaded objects in different colors.</td>
</tr>
</tbody>
</table>
Using ActiveX controls

In Director for Windows, you can embed ActiveX controls that let you take advantage of the technology and adapt ActiveX controls (formerly known as OLE/OCX controls) to make them function as sprites in Director. Use ActiveX controls to manage application resources for the hosted ActiveX control—for instance, use them to manage properties, events, and windows and filing properties. You can also manage resources used by the ActiveX control within the Director movie.

The range of uses for ActiveX in Director is as limitless as the variety of ActiveX controls available. Using the Microsoft Web Browser control (installed with Microsoft Internet Explorer 3.0 or higher), you can browse the Internet from within a multimedia production; using the FarPoint Spreadsheet control, you can create and access spreadsheets; using the InterVista VRML control, you can explore virtual worlds; using MicroHelp's extensive library of Windows widget controls, you can build and simulate complete Windows applications.

<table>
<thead>
<tr>
<th>PowerPoint objects and bitmaps</th>
<th>Director equivalent</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page numbers</td>
<td>Page numbers inserted on the SlideMaster using PowerPoint 4 are not imported. However, page numbers inserted into the master slide footer using PowerPoint 95 or PowerPoint 97 are imported properly after they are saved in PowerPoint4 format.</td>
</tr>
<tr>
<td>Hidden slides</td>
<td>If the last slide of your PowerPoint presentation is hidden, Director will display the slide and play it back. Either remove the slide from the Score or move the end marker and script one frame to the right.</td>
</tr>
<tr>
<td>Notes pages</td>
<td>Objects on the Notes pages aren’t placed in the Score. Bitmap cast members are created for objects such as pictures, clip art, and tables. However, text is ignored.</td>
</tr>
<tr>
<td>Rotated shapes</td>
<td>Changing and saving shapes several times may obscure rotation data in Director. Shapes may be imported with rotation off by 180 degrees. Try copying the shapes to a new PPT file and saving them.</td>
</tr>
<tr>
<td>Files edited and saved using multiple versions of PowerPoint</td>
<td>If items are not imported as expected, or if bullet builds do not occur, saving the PPT file in multiple PPT formats may have obscured the data to Director. Try copying the slides to a new PPT file and saving.</td>
</tr>
</tbody>
</table>
For more information about ActiveX with Director movies, see “Additional Information about ActiveX,” in the Director Developers Center.

**Note:** All ActiveX controls do not expose all of their methods and properties in all hosts. Test the controls you want to use to see how they work in Director.

## Inserting an ActiveX control

You can place ActiveX controls in a Director movie and have them function as sprites.

**To insert an ActiveX control on the Stage:**

1. Make sure that the ActiveX control you want to use in Director is installed on your system.
   Most controls have their own installation utilities provided by the manufacturer of the control.
2. Choose Insert > Control > ActiveX.
3. In the dialog box that appears, select the desired ActiveX control and then click OK. The ActiveX Control Properties dialog box appears.
   (If the desired ActiveX control does not appear in the list, it may not have been installed properly by the system. You can attempt to verify this by viewing the list of ActiveX controls in another application such as Visual Basic.)
   *The ActiveX Control Properties dialog box lets you edit each ActiveX control and view information regarding each method the control supports and each event the control can generate.*
4. Set the values for each property in the ActiveX control and then click OK. The ActiveX control now appears in the cast.
5. Drag the ActiveX control from the Cast to the Stage.
   Once the ActiveX control appears on the Stage, it can be repositioned and resized just like any other sprite Xtra. When you pause the movie, the ActiveX control stays in authoring mode and does not react to mouse or keyboard events. When you play the movie, the control responds to user input.
ActiveX control properties

An ActiveX control describes its information using properties—named characteristics or values such as color, text, font, and so on. Properties can include not only visual aspects but also behavioral ones. For example, a button might have a property that indicates whether the button is momentary or push-on/push-off. An ActiveX control’s properties define its state—some or all of which properties may persist. Although the control can change its own properties, it is also possible that the container holding the control might change a property, in response to which the control would change its state, user interface, and so on.

When an ActiveX control is inserted into a Director movie, the properties that the control exposes can be viewed and edited by selecting the Properties tab of the Control Properties dialog for the ActiveX Xtra. Each property exported by the ActiveX control is identified along with the current value of the property. The user edits a property value by simply clicking over the existing value with the mouse. For most properties such as numeric or string values, the new value will be directly entered into the list using the keyboard.

In Director, all properties that an ActiveX control exports are properties of the corresponding Sprite. The generic Lingo syntax for setting an ActiveX control property is:

```
set the PropertyName of sprite X to Value
```

The generic Lingo syntax for getting an ActiveX control property is:

```
put the PropertyName of sprite X into Value
```

As an example, if the Microsoft Access Calendar control is inserted into a Director movie as the second sprite on the score, the following Lingo code sets the Year property of the Calendar control to a specific year:

```
set the Year of sprite 2 to 1995
```

To get the Year property from the same Calendar control and place it into a Lingo variable named CalendarYear, you can use this Lingo code:

```
put the Year of sprite 2 into CalendarValue
```

Some ActiveX control properties are read-only, and trying to set a property for such a control causes an error in Director.
ActiveX control methods

An ActiveX control describes its functionality using methods. Methods are simply functions implemented in the control that Director can call to perform some action. For example, an edit or other text-oriented control supports methods that let Director retrieve or modify the current text, perhaps performing such operations as copy and paste.

When you insert an ActiveX control in a Director movie, you can view the methods exposed by the control by selecting the Methods tab of the Control Properties dialog box for the ActiveX control. The dialog box displays each method exported by the ActiveX control and a description of the parameters for each method.

In Director, all methods that an ActiveX control exports are functions for the corresponding Sprite. The generic Lingo syntax for calling an ActiveX control method is:

```
put MethodName (sprite N, param1, param2, ... ) into RetValue
```

As an example, if the Microsoft Access Calendar control is inserted into a Director movie as the second sprite on the Score, the following Lingo code would increment the year displayed within the Calendar control:

```
NextYear (sprite 2)
```

For the same Calendar control the following Lingo code would decrement the year displayed by the Calendar control:

```
PrevYear (sprite 2)
```

Parameters passed to the ActiveX control are automatically converted from their Director data types to equivalent ActiveX data types. Likewise, the return value is automatically converted from an ActiveX data type to an equivalent Director data type.
ActiveX control events

Each ActiveX control typically generates a variety of events. For example, a button ActiveX control may generate a click event when the button is pressed, and a calendar ActiveX control may generate a dateChanged event when the date within the calendar is changed. Director converts any event generated by the ActiveX control to a Sprite event that it can handle. A list of the control's events appears in the Events tab of the ActiveX Control Properties window.

To respond to an event generated by the ActiveX control, you must write an event handler to capture the event. You can place these event handlers in movie scripts, sprite behaviors, scripts assigned to cast members, or frame behaviors. However, you normally place the handler in the behavior attached to the sprite for the ActiveX control.

As an example, if the Microsoft Access Calendar control is inserted into a Director movie as a sprite on the score, the following Lingo code would capture the click event from the Calendar control:

```lingo
on click
    -- Do something interesting here.
    beep 2
end
```

A sprite behavior is a good location for this handler.
CHAPTER 17
Playing Movies over the Internet

Playing movies over the Internet: Overview

A Director movie can interact with the Internet in various ways: streaming movies and sounds, retrieving data from the network, and interacting with a browser.

You can embed a movie in an HTML document to make it appear in a browser. The associated movie can play from a local disk or an Internet server. When a user opens an HTML document stored on an Internet server, it begins streaming to the user’s system and usually begins playing when the contents of the first frame have downloaded.

Stand-alone projectors and movies playing in a browser can also interact with the Internet in many other ways. Whether it is distributed on disk or downloaded from the Internet, a movie can use an active network connection to retrieve linked files, send information, open web pages, and perform many other network activities.

If it is distributed on the Internet, a projector must be downloaded completely and executed before it can begin playing. A projector cannot play in a browser. See “About distribution formats” on page 357.

While authoring a movie, you need to consider how the movie will be distributed and played on users systems. If the movie will stream from an Internet source, you may need to modify the movie for better streaming performance and use included behaviors to make the movie wait while certain cast members download. There are also a variety of controls and Lingo commands for sending and retrieving media and other information, interacting with a browser, and monitoring downloading.
Streaming movies

When distributing a movie on the Internet, streaming provides a much more immediate and satisfying experience to users. Streaming can dramatically decrease the perceived downloading time. A streaming movie begins playing as soon as a specified amount of content reaches the user's system. As the movie plays, the remaining content downloads in the background and appears when it is needed.

When Director streams a movie over the Internet, it first downloads the Score data and other nonmedia information such as scripts and the size of each cast member's bounding rectangle. This data is usually quite small compared to the size of the movie's media—usually only a few kilobytes. Before starting the movie, Director then downloads the internal and linked cast members required for the first frame of the movie (or more frames if you have increased the number in the Movie Playback dialog box). After the movie starts, Director continues to download cast members (along with any associated linked media) in the background, in the order the cast members appear in the Score.

If the movie jumps ahead in the Score or uses cast members that are referenced only by Lingo scripts, the required cast member may not be available yet. If cast members are not available, the movie will either ignore them or display a placeholder, depending on how you set the streaming options in the Movie Playback Properties dialog box.

A big challenge of authoring for the Internet streaming is making sure that all cast members have been downloaded by the time the movie needs them. A movie that was not properly created for streaming may work poorly when streamed. To avoid missing cast members, make sure that all the cast members required for a particular scene have been downloaded before beginning the scene. You can use included behavior to wait for media in certain frames, or for particular cast members. See “About streaming with the Score and behaviors” on page 341. You can also write your own Lingo code to do the same thing. See “Checking whether media is loaded with Lingo” on page 343.

Director movies stream unless you explicitly turn off streaming. If you turn off streaming, the movie doesn't play until it has downloaded completely. In addition to turning streaming off and on, you can specify that the media for a certain number of frames download before the movie starts playing.

You control streaming movies by arranging sprites in the Score and controlling the movement of the playback head either with included behaviors or Lingo. You can also use Lingo to specify when externally linked files are downloaded.
Network operations

Director allows a network operation to begin even though a previous network operation isn't complete. This capability, often referred to as background loading, allows files to load while other operations proceed.

Background loading allows Director to perform multiple operations while communicating with the network. Because something else is happening while files are loading, the user doesn't perceive the wait.

*Note:* Loading data from a network has a different meaning than loading cast members in Director. Loading from a network loads data to the local disk. Loading cast members in Director means loading cast members into memory.

Because Internet operations require background loading, Lingo for the Internet behaves differently than Lingo commands that run within one movie.

It's a good idea to author a Shockwave movie so that it performs other tasks while data is loading in the background.

Setting movie playback options

Use the Movie Playback Properties dialog box to change basic streaming settings for a movie. You can turn streaming off and on, specify a number of frames to download before playing the movie, and make Director display placeholders if cast members haven't downloaded yet. The Movie Playback Properties dialog box also includes options for locking the current tempo and pausing the movie when the window is deactivated.

Turning off streaming makes sense for some types of movies. For example, a game that requires all cast member to be available at once might not be suitable for streaming. Other movies work best if the media for a certain number of frames downloads before the movie begins playing. This option is especially useful for streaming movies that were not originally designed for streaming.

Placeholders are rectangles that appear in the place of media for cast members that have not yet downloaded. Placeholders are useful when testing to point out missing media.

You can specify streaming options any time before saving a movie as a Shockwave movie.

*Note:* If you want to test a movie streaming from a server before saving the movie as a Shockwave movie, first use File > Save and Compact to make sure the data in the movie is properly ordered and that redundant data is removed.
To set playback options:

1. Choose Modify > Movie > Playback to define streaming options.

2. To stop the movie from streaming, turn off Play While Downloading Movie. A check mark indicates the option is on. This option is on by default. If you turn it off, Director does not begin playing the movie until the entire movie file has completely downloaded.

3. To make the movie wait for all media (internal and linked) for a specified range of frames, enter the number of frames in Download Frames Before Playing.
   By default, movies download the first frame only. Change this setting to download the number of frames that is best for your movie.

4. To make the movie display placeholders for media that has not yet downloaded, turn on Show Placeholders.
   The placeholders appear as rectangles when the movie plays.

5. To lock the movie to its current tempo settings, click Lock Frame Durations. See “Locking frame durations” on page 183.

6. To make the movie pause when its window is deactivated, turn on Pause When Window Inactive.

7. To set Shockwave playback options, see “Setting Shockwave playback options” on page 340.

Setting Shockwave playback options

To view Shockwave movies, users can use the free Shockwave player. The free Shockwave player is available for downloading from Macromedia’s web site and is also preinstalled on many computer systems. It includes a volume control and a standard context menu that appears when a user right-clicks (Windows) or Control-clicks (Macintosh) a movie.
To set Shockwave playback options:

1. Choose Modify > Movie > Playback.
2. Set the following options:
   - **Volume Control** lets users adjust the volume of the movie’s soundtrack.
   - **Transport Control** provides controls for rewinding, stopping, and stepping through the movie. This option is provided to allow for enhancements in future versions of Shockwave.
   - **Zooming** provides the ability to enlarge the movie’s Stage. This option is provided to allow for enhancements in future versions of Shockwave.
   - **Save Local** allows users to save the current movie on their system. This option is provided to allow for enhancements in future versions of Shockwave.
   - **Graphic Context Menu** determines whether the Shockwave context menu that appears when the user right-clicks (Windows) or Control-clicks (Macintosh) is a standard text menu or as a graphic menu with icons.

### About streaming with the Score and behaviors

The easiest way to create a movie that streams well is to arrange the Score properly and use behaviors to control the playback head. Director downloads cast members in the order they appear in the Score. Try to arrange the Score so it isn’t possible for users to make the playback head jump far ahead in the Score to where the cast members have not yet been downloaded. For example, if you place a menu in the first frame of a movie and a user chooses an option that sends the playback head to frame 400, there is a good chance that the cast members for frame 400 won’t be available right away.

A good way to avoid this problem is to begin a movie with a simple introductory scene containing a few small cast members, preferably vector shapes. You can use a streaming behavior from the Library palette to make the introduction loop until the cast members required for the next scene have downloaded in the background.

The introductory scene in the example that follows contains tweened vector shape cast members. While they appear on the Stage, the cast members needed for the menu are downloading in the background. The Loop Until Frame Ready behavior is attached to the frame where the introduction loops to make sure all the cast members required for the next scene are downloaded before the scene appears.

To see a movie stream from the Internet, see the Director Developers Center web site. You can also examine the source file by downloading the streaming.dir file for the streaming example and opening the movie in Director’s authoring environment.

Several behaviors included with Director pause and loop the playback head while waiting for media to download. These behaviors make it easy to allow enough time for downloading to catch up with action in the Score.
Looping behaviors

These are behaviors that make the playback head loop back to a frame or on the current frame until specified media has downloaded, and then continue to next frame. They should be attached to a frame in the script channel, not to a sprite.

**Loop until Next Frame is Available** loops the playback head to a specified frame until all the media required for the next frame has been downloaded.

**Loop until Member is Available** loops the playback head to a specified frame until a certain cast member has been downloaded.

**Loop until Media at Marker is Available** loops the playback head to a specified frame until all the media for the frame at the specified marker has been downloaded.

**Loop until Media in Frame is Available** loops the playback head to a specified frame until all the media required for a certain frame has been downloaded.

Jumping behaviors

These behaviors all make the playback head jump to a specified frame or marker once certain media has downloaded. They should be attached to a frame in the script channel, not to a sprite.

**Jump When Member is Available** moves the playback head to the specified frame once a certain cast member has downloaded.

**Jump When Media in Frame is Available** moves the playback head to the specified frame once the media for a particular frame has downloaded.

**Jump When Media at Marker is Available** moves the playback head to the specified frame once the media for the frame at a particular marker has downloaded.

Progress bar behaviors

These behaviors scale the width of a sprite to show how much of a movie or linked file has downloaded. Attach either of them to a rectangle shape to create a progress bar. When the movie runs the behavior reduces the width of the sprite to 0 and then widens it to its original width when the movie or file has downloaded completely.

**Progress Bar for URL Linked Media** shows the downloading progress of the specified linked file.

**Progress Bar for Streaming Movies** shows the downloading progress of the current movie.
Checking whether media is loaded with Lingo

Director’s interface has several options that let an initial portion of a movie start playing as soon as the required data and cast members are available. Lingo can test whether media has been loaded media from a network by:

- Testing whether a specific cast member is loaded before the movie proceeds
- Testing whether the cast members used in a specific frame are loaded before the frame plays

Movies and streaming SWA sounds always compete for control of the network. This can cause a noticeable problem on lower-rate connections.

Checking whether a specific cast member or sprite is loaded

Use the `mediaReady()` cast member or sprite property to determine whether the specified cast member is available locally. You can check for a specific cast member or the cast member assigned to a specific sprite. When `mediaReady` returns `TRUE`, the cast member is available. See `mediaReady` in the Lingo Dictionary.

This property always returns `TRUE` for local files. It is useful only for movies that stream from a remote server. Since playback can begin before the entire movie is downloaded, you must make sure that the needed media have been downloaded as the movie plays.

Checking whether a frame’s contents are loaded

Use the `frameReady()` function to determine whether all the media that the specified frame requires is available locally. See `selEnd` and `selStart` in the Lingo Dictionary.

Downloading files from the Internet with Lingo

Lingo utilizes the Internet’s resources by obtaining files from the Internet. The data is copied to the local disk or cache. After data is available on the local computer, use Lingo to retrieve the data for the movie. See “Retrieving network operation results with Lingo” on page 346.

For a movie or projector playing outside a browser, background loading isn’t required. However, preloading is a good idea because it improves playback performance.

All network Lingo operations that obtain data from the network begin downloading the data and return a net ID. The data isn’t immediately available.
An unlimited number of network Lingo operations can take place at once. When multiple network Lingo operations run simultaneously, rely on the net ID that the function returns to distinguish which operation is complete. Be aware that running more than four operations at once usually adversely affects performance.

When using network Lingo, the current handler must finish before an operation's result is returned. For best results, place Lingo that initiates a network operation and Lingo that uses the operation's result in different handlers. An on exitFrame handler is a good location to check whether an operation is complete.

To execute a network Lingo operation:

1. Start the operation.
   
   For example, this statement initiates a text downloading operation and assigns the netID of the getNetText() operation to the variable theNetID:
   
   ```lingo
   set theNetID = getNetText("http://www.thenews.com")
   ```

2. Make sure the operation is complete.
   
   Sometime after the download starts, the download operation should complete. Use the netDone() function to check an operation's status regularly until the function indicates that the operation is complete. Although netDone() indicates that an operation is complete, it doesn't indicate whether the operation was successful. See netDone() in the Lingo Dictionary.

   For example, this statement loops in the current frame until the download operation is complete:
   
   ```lingo
   if not netDone(theNetID) then go to the frame
   ```

3. Check an operation's error status by using the netError() function. See netError() in the Lingo Dictionary.

4. Obtain the results if the operation is complete.

To cancel a network operation in progress:

Use the netAbort command to cancel a network operation without waiting for a result. This frees up capacity for Internet access, which allows other network operations to finish faster. See netAbort in the Lingo Dictionary.

To start retrieving a file as text:

1. Use the getNetText or postNetText command. See getNetText() or postNetText in the Lingo Dictionary.

2. Use netTextResult to return the text you retrieved with getNetText or postNetText.
To retrieve and play a new Shockwave movie from the network:

Use the `goToNetMovie` command. See `goToNetMovie` in the Lingo Dictionary.

The current movie continues to run until the new movie is ready to play. After the new movie is ready, the player quits the current movie without warning and plays the new movie in the same display area as the calling movie.

To open a URL in the user's browser, whether it's a Shockwave Director movie, HTML, or another MIME type:

Use the `gotoNetPage` command. See `gotoNetPage` in the Lingo Dictionary.

The `gotoNetPage` command can replace a page's content or open a new page. If the browser isn't open, the command launches the browser. If the `gotoNetPage` command replaces the page that the movie is playing in, the movie keeps playing until the browser replaces the page.

The `gotoNetPage` command is similar to Director's `open` command. It doesn't return a value.

To preload a file from the server into the cache:

Use the `preLoadNetThing()` function. See `preLoadNetThing()` in the Lingo Dictionary.

The `preLoadNetThing()` function initiates downloading a linked movie asset. The data is cached, where it is available for later use. Subsequent preloading into memory by Director occurs without a download delay.

The current movie continues playing while preloading takes place.

To copy a file from the server to a specified file on a local disk:

Use the `downLoadNetThing` command. See `downLoadNetThing` in the Lingo Dictionary.

You can use the file or other item later as a local file. The file isn't deleted when the player quits.

The current movie continues playing while the file downloads. The `downLoadNetThing` command is disabled in any secure environment, such as a web browser.

To test whether `getNetText`, `downLoadNetThing`, `preLoadNetThing`, or `gotoNetMovie` operations are complete:

Use the `netDone()` function. See `netDone()` in the Lingo Dictionary.

To send information to a server using POST and retrieve a response:

Use the `postNetText` command. See `postNetText` in the Lingo Dictionary.
Retrieving network operation results with Lingo

Lingo can retrieve the results of network operations such as a text result, a unique identifier for a network operation, a file's MIME type, and the date an HTTP item was last modified.

The net ID is returned by the network operation whose results are being retrieved.

**To retrieve the text result of an Internet operation:**
Use the `netTextResult()` function. See `netTextResult()` in the *Lingo Dictionary.*

**To retrieve the date last modified string from the HTTP header for a specific item:**
Use the `netLastModDate()` function. See `netLastModDate()` in the *Lingo Dictionary.*

**To obtain the MIME type of the HTTP item:**
Use the `netMime()` function. See `netMIME()` in the *Lingo Dictionary.*

To conserve memory, Director discards the results of `netTextResult()`, `netMIME()`, and `netLastModDate()` functions within a short time after the operation completes successfully. For `netTextResult()`, Director discards the results when the next operation starts. For `netDone()`, `netError()`, `netMime()`, and `netLastModDate()`, Director retains the operation's results through seven subsequent operations.

**To determine the state of a network operation that retrieves data:**
Use the `getStreamStatus()` function or the `on streamStatus` event handler. See `getStreamStatus()` or `streamStatus()` in the *Lingo Dictionary.*
Using Lingo in different Internet environments

Some Lingo features behave differently depending on whether the movie is playing back in a browser, as a projector, or within the authoring environment.

Using Lingo with Internet security restrictions

Because of security issues for movies that playback in browsers, the following Lingo features are unsupported for Shockwave movies playing in a browser. Many of these restrictions exist because of restrictions imposed by the Internet environment. For details about security concerns when playing a movie on the Internet, see “Director and Internet Security,” in the Director Developers Center.

In general, the following Lingo features are unsupported because of Internet security concerns:

- Setting `colorDepth` for the end user’s monitor
- Saving a movie using the `saveMovie` command
- Printing using the `printFrom` command
- Opening an application using the `open` command
- Stopping an application or the end user’s computer using the `quit`, `restart`, or `shutdown` command
- Opening a local file that isn’t in a DSWMedia folder
- Pasting content from the Clipboard using the `pasteClipboardInto` command
- Searching for files on users system with `getNthFileNameInFolder`, `searchCurrentFolder`, or `searchPath`.

Using URLs with Lingo

In addition to the Lingo explicitly intended for use with network operations, some Lingo elements can use URLs as references to external files.

These Lingo elements can use URLs as file references in all circumstances:

- `moviePath`
- `pathName`
- `unLoadMovie`

The following Lingo supports URLs as references to external files. However, when using these to obtain Internet files, you can avoid problems with network delays by downloading the files using `preloadNetThing` first. After the file is downloaded, you can use these with the file’s URL.
When using the following Lingo in a browser, the Lingo fails if you do not first download the file by using the `preLoadNetThing` command. If you use this Lingo in projectors or during authoring without first downloading the file, the movie pauses while the file is downloaded.

- Setting the `fileName` cast property
- Setting the `fileName` cast member property
- Setting the `fileName` window property
- Using a `go to movie` statement
- Using an `importFileInto` command
- Using a `preLoadMovie` command
- Using a `play movie` command
- Using an `open window` command

These Lingo elements can use URLs to SWA sound files as file references:

- `streamName`
- URL cast member property

These Lingo elements can use URLs as file references only during authoring or in projectors:

- `getNthFileNameInFolder`
- `searchCurrentFolder`
- `searchPath`

These elements don’t work in Shockwave movies because Shockwave doesn’t support MIAWs:

- `forget window`
- `close window`

**Differences in scripting Lingo for browsers**

There are some general differences in the way to script Lingo for a movie that plays over the Internet, depending on whether the movie is in a browser.

- For a movie playing in a browser, it is best to use `preLoadNetThing` to load media into the browser’s cache first. If the media isn’t preloaded using `preLoadNetThing`, linked media may not be present.

- Avoid using long repeat loops in browsers; such repeat loops can make the computer appear to have hung. As an alternative, you can split long operations into sections and execute them over a series of frames or check for user actions in an `on exitFrame` handler.

- Do not use a `repeat...while` loop to check whether a network operation is complete.
Lingo that is unsupported in browsers

The following Lingo features are unsupported for movies that play back in browsers:

- Creating and managing a movie in a window
- Installing and managing custom menus

Interacting with browsers

Lingo lets you write and read a Prefs file within the DSWMedia folder, and display a string in a browser’s status area.

To specify text in a browser’s status area

Use the `netStatus()` function to set text in the status area of the browser. See `netStatus()` in the Lingo Dictionary.

*Note:* Some browsers do not support this function.

To write to a Prefs file on a local disk:

Use the `setPref` command. See `setPref` in the Lingo Dictionary.

After the command runs, a folder named Prefs is created inside the Plug-In Support folder. The `setPref` command can write only to that folder.

The `setPref` command can’t write to a file that is on a CD.

To return the content of a file that was written by a previous `setPref` command:

Use the `getPref()` function. If no `setPref` command has already written such a file, the `getPref()` function returns void. See `setPref` in the Lingo Dictionary.
Testing your movie

However you choose to create your movie, test it thoroughly before releasing it to the public. Make sure you test on systems with all common types of Internet connections, especially on slow modems and at busy times of day. Here is a basic checklist, but each movie has its own special needs.

- Compare a streaming version of the movie to a nonstreaming version to see if the performance is different. Some smaller movies may work better without streaming playback.
- Make sure all linked media appears correctly. Try forcing the linked media to fail to see if the movie correctly handles the error.
- Run the movie on all systems your users are likely to have. For the general public, this includes Windows 95, 98, and NT and Power Macintosh.
- Run the movie on very slow modem connections and also on fast T3 connections. In many cases, problems arise from fast as well as slow connections.
- Check for display problems on systems set to 8-, 16-, 24-, and 32-bit color. Also test as many types of monitors and display adapters as you can.
- Check for font mapping problems if your movie. Use embedded fonts if your movie uses non-standard fonts. See “Embedding fonts in movies” on page 270.
- Check for sound problems, particularly if you stream sounds with Shockwave Audio.
Downloading considerations

Multimedia delivered over the Internet is limited in size, primarily because the majority of users connect at relatively slow speeds. At 28,800 bps, it takes 30 seconds to one minute to download a 60K file.

Using streaming playback can help you avoid some of the problems caused by using large files, but it’s important to be aware of downloading times.

If there is heavy traffic at the Internet access point or on the Internet host, or if there’s network congestion, the rate drops even lower—to as low as a few hundred bytes per second. For now, it is a good idea to assume your movies will download at about 1K per second.

The following chart shows theoretical throughput times for modems of different speeds. The speeds 14,400 and 28,800 bps are common for modems, 64 Kbps and 128 Kbps are the throughput of an ISDN line, 1.5 Mbps is the throughput of a standard high-speed internet connection (T1).

Download times at common modem speeds

<table>
<thead>
<tr>
<th>Content</th>
<th>14.4</th>
<th>28.8</th>
<th>64</th>
<th>1.5</th>
</tr>
</thead>
<tbody>
<tr>
<td>Small graphics and animation, 30K</td>
<td>30 sec</td>
<td>10 sec</td>
<td>6 sec</td>
<td>1 sec</td>
</tr>
<tr>
<td>Small complete movie, 100 to 200K</td>
<td>100 to 200 sec</td>
<td>50 to 100 sec</td>
<td>20 to 40 sec</td>
<td>1 sec</td>
</tr>
<tr>
<td>500K movie</td>
<td>500 sec</td>
<td>120 to 240 sec</td>
<td>90 sec</td>
<td>3 sec</td>
</tr>
<tr>
<td>1 MB movie</td>
<td>NA</td>
<td>NA</td>
<td>180 sec</td>
<td>6 sec</td>
</tr>
</tbody>
</table>
CHAPTER 18

Distributing Movies

Distributing Movies: Overview

When you've completed the main authoring work for a movie, you have several choices to make about the format to use for distribution. You can distribute a movie as a Shockwave movie that plays in a browser or as a stand-alone projector. Stand-alone projectors can include the software needed to play the movie, or use an installed Shockwave player to play the movie. You can also export a movie as a Java applet or as digital video.

There are several Director features you use at the end of a project to prepare for distribution. You can set Shockwave playback options, decide which Xtras need to be included or downloaded, preview the movie in a browser, or batch-process movie files to compact them and protect them from editing.

Previewing a movie in a browser

Preview a movie in a browser on your local computer to check for appearance or performance issues, Lingo problems, or any other issues related to playing a movie in a browser. Previewing a movie creates temporary Shockwave (DCR) and HTML files that are then opened in a browser.
You may notice that linked media does not work as expected when you preview a movie in a browser. Because of security restrictions, movies playing in a browser cannot read files from a local disk unless they are in the dswmedia folder (also called the support folder). Dswmedia is a subfolder of the folder containing the Shockwave player. If you are trying to preview a movie that uses linked media, put the movie and all of its linked media in the dswmedia folder. The movie can open a file in a subfolder of dswmedia provided it has the same relative path to the media as when it was originally linked. When you move the movie and its media to another server, preserve the same folder structure and all the linked media will continue to work. For details about security issues when playing a movie in a browser, see “Director and Internet Security,” in the Director Developers Center.

To specify the browser to use for previewing:

1. Choose File > Preferences > Network.
2. In the Preferred Browser box, enter the path to the browser application file.

To preview a movie in a browser:

Choose File > Preview in Browser or press F12.

Managing Xtras for distributed movies

All the Xtras required by a movie must be installed on a user’s system when the movie runs. When you distribute a movie, you must include the Xtras required or provide the user the means to download them. Using the Movie Xtras dialog box, you can specify which Xtras should be included in a projector and whether Xtras should be downloaded for use with Shockwave movies. The Movie Xtras dialog box includes a list of the most commonly used Xtras. Including all these Xtras ensures that your movie will work in most cases, but makes the projector much larger. You may want to remove Xtras you know you aren’t using.

Each time you create a sprite in the Score that requires an Xtra, Director adds the Xtra to the list of required Xtras in the Movie Xtras dialog box. If you remove the sprite, Director does not remove the Xtra from the list, in case you later re-create the sprite. Director cannot detect Xtras required in Lingo code. You must manually add any Xtras required by your Lingo code to the list in the Movie Xtras dialog box.

Managing Xtras controls the size and capabilities of the movie you distribute. Many important features in Director, such as text and vector shapes, are controlled by Xtras, as is the ability to import all types of linked media. If you don’t use a feature or import a media type that is controlled by an Xtra, you should not distribute the related Xtra with your movie. This is especially true for movies distributed on the Internet.
The Shockwave player includes the Xtras that support the most common features and media types. These include text, Flash, BMP, PICT, JPEG, and GIF file importing; sound management; and Shockwave Audio.

Xtras that are not included with the Shockwave player must be installed in a user’s system before the movie plays. Use the Download If Needed option in the Movie Xtras dialog box to make the movie prompt the user to download the Xtra. Director downloads Xtras from the URL specified in the Xtrainfo.txt file in the Director application folder.

Xtrainfo.txt includes URLs for all Macromedia Xtras included with Director, but you may need to manually edit Xtrainfo.txt to add the URL for third-party Xtras or Macromedia Xtras not included with Director. Xtrainfo.txt includes a description of how to enter this information. Xtra developers may also provide installation programs or other means of modifying Xtrainfo.txt automatically.

If a user chooses to download an Xtra, Director retrieves the Xtra from the URL specified in Xtrainfo.txt using the Verisign download security system. Verisign is a standard means of downloading software from secure sources.

You can also include Xtras in projector files. Turn on the Include in Projector option in the Movie Xtras dialog box for any Xtra you want to include.

Xtras that must be present with a movie include the following:

- Xtras that create cast members (text, Flash, vector shapes, QuickTime, and so on)
- Shockwave Audio Xtras
- Transition Xtras
- Import Xtras, if the movie uses nonstandard types of linked external cast members
- Network Xtras required for a movie to access the Internet
- Lingo Xtras
To manage Xtras for the current movie:

1. Choose Modify > Movie > Xtras.

2. To add or remove Xtras from the list of movie Xtras, do any of the following:
   - To add the Xtras required to connect a projector the Internet, click Add Network.
   - To restore the list of default Xtras, click Add Defaults.
   - To manually add an Xtra to the list, click Add and choose from the list of Xtras installed in your system. If you write Lingo code that requires Xtras, those Xtras do not show up in the Movie Xtras list. Use Add to manually add these Xtras.
   - To delete a selected Xtra from the list, click Remove.

3. To change settings for Xtras in the list, select an Xtra and turn on either of the following options:
   - Include in Projector makes Director include the selected Xtra in any projector that includes the current movie.
   - Download If Needed makes the movie prompt the user to download a required Xtra if it is not installed in the user's system. The Xtra is downloaded from the location specified in the Xtrainfo.txt file and permanently installed in the user's system.

4. To get information about a selected Xtra, click Info.
   - The information comes from an Internet source. Not all Xtras include information. Third-party Xtras often include some explanations and information about the developers.

Note: Another way to include Xtras with a movie is to create an Xtras folder containing all required Xtras in the same folder as a projector file. This allows you to see which Xtras are includes without opening the movie. If you uses this method, you cannot include Xtras in the projector file or the movie will fail to initialize.
About distribution formats

Before deciding how to distribute a movie, it helps to understand how Director plays movies. A director movie can be played by the Shockwave player, or by a player in a project. The Shockwave player is a system component that can play movies in web browsers and also outside browsers as stand-alone applications. A projector player can only play movies outside of a web browser.

Distribute movies as Shockwave movies (DCRs), projectors, protected movies (DXRs), or Java applets. You should not distribute source movies (DIRs) unless you want your users to be able to change the movie in the Director authoring environment.

- A Shockwave movie (also called a DCR) is a compressed version of a movie’s data and does not include a player. Shockwave movies are created primarily to distribute over the Internet for playback in a web browser. You can also use them when you want to compress movies distributed on a disk that are not contained in a projector. Saving a movie as a Shockwave movie compresses the data, removes all the information needed to edit the movie, and excludes the software that plays the movie. A Shockwave movie can be played in a web browser with the proper Shockwave player installed in the system. It can also be played when opened by a projector or as a movie in a window.

- A projector is a movie intended for play outside of a web browser. A projector can include a player (called the Standard player), Xtras, multiple casts, and linked media in a single file. A projector can also include several different movie files. Configured in this way, a projector can be a completely stand-alone application.

Use the Shockwave player projector option to make a much smaller projector. A Shockwave projector uses an installed Shockwave player on the user’s system to play a movie instead of including the player code in the projector itself. A Shockwave projector is excellent for distributing movies on the Internet that you don’t want to play in a web browser.

You can also reduce the file size of a projector by turning on projector options that compress the movie data, the player code, or both. Compressing the player code reduces the minimum projector size from approximately 1.4 MB to 800K for a Windows projector, and from 2.2 MB to 1.1 MB for a Macintosh projector.
Protected movies (DXRs) are uncompressed movies that users can’t open for editing. These can be useful when you want to distribute uncompressed movies on a disk, but don’t want users to edit the source file. Protected movies may play faster than Shockwave movies from a disk because they do not need to be decompressed. These movies are preferable if disk space isn’t limited. Like Shockwave movies, protected movies do not include the information needed to edit the movie or the software that plays the movie. They can be played only by a projector, a movie in a window, or the Shockwave player.

A Java applet created by Director is a movie converted to Java. Java applets do not require the Shockwave player and provide an alternative for playing simple movies at web sites where plug-ins are not allowed. Not all Director features are available when saving as Java, so there are a number of authoring issues to consider. For a complete description of Java authoring issues, see “Authoring for Save as Java,” in the Director Developers Center. You cannot include Java applets in a projector or play them as a movie in a window.

You cannot edit a projector, Shockwave movie, protected movie, or Java applet in Director. You must edit the source file and then create a new movie in one of the distribution formats. Always save your source files.

Using linked media on the Internet

When you distribute a movie on the Internet for playback in a web browser, all linked media must be at the specified URL when the movie plays.

Distributing movies on a disk

Whenever a movie plays from a disk, it accesses all external linked files the same way that it did in the authoring environment. All linked media—bitmaps, sounds, digital videos, and so on—must be in the same relative location as they were when the movie was created. To make sure you don’t forget any linked media when you distribute a movie on a disk, place linked files in the same folder as the projector or in a folder inside the Projector folder.

If your movie includes Xtras, you must include the Xtras in the projector. If a movie distributed on a disk connects to the Internet in any way, be sure to choose Add Network button in the Movie Xtras dialog box. See “Managing Xtras for distributed movies” on page 354.

Distributing movies on a local network

If you plan to place a movie on a local area network (LAN), all files must be set to read-only, and users must have read/write access to their system folders. Otherwise, the requirements are the same as for normal disk-based distribution.
Creating Shockwave movies

Save your work as a Shockwave movie to prepare it for playback in a web browser with Shockwave or to make disk-based movies smaller. Using a Shockwave movie also prevent users from editing the movie if they own Director.

If the Shockwave movie you're creating will be distributed on the Internet and requires any Xtras, make sure the Xtras are listed in the Movie Xtra dialog box and that Download If Need is selected for each required Xtra. See “Managing Xtras for distributed movies” on page 354.

The new Shockwave movie file is created on the disk, but you continue to work in the original DIR file. You cannot edit a Shockwave movie file.

You have the options of immediately previewing the Shockwave movie in a browser and of saving an HTML document that contains the code necessary to run the movie in a browser.

**Note:** Use Update Movies to convert several movies at once to the Shockwave format. For more information, see “Processing movies with Update Movies” on page 363.

To create a Shockwave movie:

1. Open the movie you want to save.
2. Choose File > Save as Shockwave Movie.
3. Enter a name and location for the new file.
   To avoid problems with linked media, you should always save new Shockwave movies in the same folder as the original .dir file.
   Director automatically adds the .dcr extension. Shockwave plays only movies with the .dcr, .dxr, or .dir extension.
4. To generate an HTML document containing the code necessary to run the current movie in a browser, click Generate HTML.
   The HTML document will be created with same file name with the .htm extension in Windows and the .html extension on the Macintosh.
5. To preview the Shockwave movie in a browser immediately after it is saved, click Preview in Browser.
   See “Previewing a movie in a browser” on page 353.
Creating projectors

To create projectors for any version of Windows, you must use the Windows version of Director; likewise, you can create Macintosh projectors only with the Macintosh version of Director.

Certain Xtras must be included with a projector for it to be able to use features such as text, Flash movies, Internet connection and so on. The most commonly needed Xtras are included by default. You can explicitly include or exclude Xtras for each movie using the Include in Projector option in the Movie Xtras dialog box. You can also add Xtras to a projector manually the same way you select movie files. See “Managing Xtras for distributed movies” on page 354.

Be sure to place the starting movie at the top of the list of files in the Project dialog box. If the Play Every Movie option in the Projector Options dialog box is on, movies play in the order they appear in the list. If this option is off, only the first movie plays. If your movie contains Lingo that switches between movies, the order of the other movies may not be important.

You can include only Director 7 movies in projectors. Use Update Movies to convert older movies to the latest version of Director. For more information, see “Processing movies with Update Movies” on page 363.
To create a projector:

1. Choose Create Projector from the File menu.

2. Double-click the movies and external casts you want to include in the projector.
   Director transfers the name of the movie or cast to the file list.
   Click Add All to include all the movies in the open folder.

3. Use the Move Up and Move Down buttons to arrange the movies in the proper order.

4. Click Options.
   Director retains the options settings once you define them, so you don’t have to set them every time.

5. To control how movies interact with the user’s system, choose options for Playback options:
   - **Play Every Movie** specifies that the projector plays all movies in the play list. Otherwise, the projector plays only the first movie in the play list (unless other movies are called by Lingo from the first movie). In a projector with Play Every Movie checked, pressing Control-period (Windows) or Command-period (Macintosh) will branch to the next movie, and Control-Q (Windows) or Command-Q (Macintosh) will quit.
   - **Animate in Background** allows the movie to continue playing if a user switches to another application. This is useful if you want the movie to continue running in the background when its window is not active. If this option is not checked, the movie pauses if the user switches to another application and resumes when the user switches back.
   - **Reset Monitor to Match Movie’s Color Depth** (Macintosh only) automatically changes the color depth of your monitor to the color depth of each movie in the projector play list. For example, if you are working on a color monitor set to 256 colors and a movie in the play list was created in thousands of colors, the monitor will automatically switch to thousands colors.

6. To determine how the projector appears on the screen, make a selection for Options:
   - **Full Screen** displays the movie in the entire screen, placing the menu bar (if there is one) at the top of the screen and hiding all of the desktop. If there’s a menu, it overlays the top of the Stage.
   - **In a Window** displays the movie in a normal window, without taking over the screen. The window cannot be resized.
   - **Show Title Bar** is available only if In a Window is selected. If this option is selected, the window where the movie appears has a title bar. The window can be moved only if it has a title bar.
7 To specify how the stage size of multiple movies in the projector can be adjusted, choose a Stage Size option:

**Use Movie Settings** uses the Stage size of the new movie or matches the size of the current movie.

**Match First Movie** repositions and resizes the movie based on the first movie in the projector.

**Center** centers the Stage on the screen, which is useful if the Stage size is smaller than the screen size. Otherwise, the movie plays using its original Stage position. In Windows, projectors are always centered.

8 To compress the projector’s movie data in the Shockwave format, choose **Compress (Shockwave Format)**. This makes the projector smaller, but it may increase the load time as the movies are decompressed.

9 To determine how the player code is included in the projector, choose an option for Player. For more about these options, see “About distribution formats” on page 357.

**Standard** includes the uncompressed player code in the projector file. This option starts the movie faster than other options, but creates the largest projector file.

**Compressed** includes a compressed version of the player code in the projector file. This substantially reduces the projector file size, but decompressing the player code adds a few seconds to the start-up time of a movie.

**Shockwave** makes the projector use the Shockwave player installed in a user's system instead of including the player code in the projector file. If the Shockwave player is not available when the movie runs, the movie prompts the user to download it.

10 (Macintosh only) To make Director use available system memory when its own partition is full, choose **Use System Temporary Memory**.

11 Click OK once all projector options are set.

12 Click Create in the Projector dialog box and then enter a name and location for the projector. To avoid problems with linked media, it's best to create the new projector in its final folder location and not move it to a different folder after creation.

Director turns the movies, casts, and included Xtras into a single projector.
Processing movies with Update Movies

Use the Update Movies command on the Xtras menu to:

- Update movies and casts from older version of Director to the latest file format.
- Compress movies for faster downloading from the Internet.
- Remove redundant and fragmented data in movie and cast files. Save and Compact and Save As do this as well.
- Prevent users from opening movie and cast files.
- Batch-process movie and cast files in large projects.

When beginning a project, use Update Movies to convert Director 5, and 6 files to the latest file format.

At the end of a project, use update movies to compress all your movies and casts at once.

To update and compress movies and casts:

1. Choose Update Movies from the Xtras menu. The Update Movies dialog box appears.

2. Choose one of the Action options:
   - **Update** converts movies from Director 5 or later to the latest file format. As it updates movies, Director consolidates and removes fragmented data, the same as when you use Save As. (To update movies from older versions, you must first convert them to the Director 5 file format.)
   - **Protect** removes all the data required to edit the movie, but does not compress the movies further. It adds the .dxr extension to movies, and .cxt to casts.
   - **Convert to Shockwave Movie(s)** rewrites movies and casts in the compressed Shockwave file format and adds the DCR extension to movies and CCT to casts. This options also prevents users from opening the movie or cast and making changes. Once a movie is compressed, there is no way to decompress it to recover an editable file, so be sure to keep the original movie.

3. Choose one of the Original Files options:
   - **Back Up into Folder** specifies that the original files should be placed in a selected folder. Click Browse to select the folder for the original files. To avoid overwriting old backups, you should choose a new folder each time you run Update Movies.
   - **Delete** specifies that the original files should be overwritten by the newly updated files. Be very careful when using this option. Once a file is protected or compressed, you cannot open it again in Director.
4 Click OK.
   A dialog box appears from which you select the files you want to change:
5 Select the movies and casts you want to change and click Add.
   ▶ Click Add All to add all the movies in the current folder. The items you select
      appear in the file list at the bottom of the dialog box. You can update movies
      in different folders at the same time.
   ▶ Choose Add All Includes Folders before you click the Add All button to
      include any movies or casts inside folders appearing in the upper list. This
      option is useful for updating large projects with several levels of folders.
6 Click Update.
   Director saves new versions of the selected movies with the same names and
   locations as the original movies. This ensures that all links and references to
   other files continue to work properly. Director copies the original movies to
   the folder you specified, re-creating their original folder structure. If you didn't
   specify a folder for the original movies, Director prompts you to select one.
   Director adds the .dcr extension to Shockwave movies and the .cct extension
   to external casts in the Shockwave format. Protected movies have the .dxr
   extension, and protected casts have the .cxt extension.

Exporting digital video or a series of bitmaps

You can export all or part of a movie as a digital video. You can use this digital
video in other applications or import it back into Director. Any interactivity in
the movie is lost when it is exported as a digital video. You can also export a movie
or a part of a movie as a series of bitmaps: BMP in Windows, PICS, PICT or
Scrapbook on the Macintosh.

You can export QuickTime digital video from the Windows or Macintosh version
of Director. QuickTime must be installed on the system to export as QuickTime
(version 3 or later required for Windows). You can export the Video for Windows
(AVI) format only using the Windows version of Director. When you export to
AVI, all sounds are lost.

When Director exports animation as a video or bitmaps, it takes snapshots of the
Stage moment by moment and turns each snapshot into a frame in the video or a
bitmap file. Sprites animated solely by Lingo are not exported.

When Director exports video or bitmaps, it always uses the entire Stage.
To export to digital video or bitmaps:

1. Choose File > Export.
   
   The Export dialog box appears.

2. Select the range of frames you want from the Export options at the top of the dialog box:
   
   **Current Frame** exports the current frame on the Stage. This is the default.
   
   **Selected Frames** exports the selected frames in the Score.
   
   **All Frames** exports all frames.
   
   **Frame Range** exports only the range of frames that begin and end with the frame numbers you enter in the Begin and End boxes.

3. If you choose Selected Frames, All Frames, or Frame Range as the Export option, choose one of the following options:
   
   These options do not work with digital video.
   
   **Every Frame** exports all frames in the selected range.
   
   **One in Every _ Frames** exports only the frames at the interval you specify in the box.
   
   **Frames with Markers** exports frames with markers set in the Score window.
   
   **Frames with Artwork Changes in Channel** exports frames only when a cast member changes in the channel you specify in the box.

4. From the Format pop-up menu at the bottom of the dialog box, choose Video for Windows (AVI), BMP (Windows), QuickTime Movie, PICT (Macintosh), Scrapbook (Macintosh), or PICS (Macintosh).
   
   BMP is the standard format for a Windows bitmap series. PICT, Scrapbook, and PICS are all Macintosh bitmap file formats.

5. If you are exporting in PICS format, click Use Frame Differencing to create smaller files.
   
   This option is dimmed unless you choose PICS from the Format pop-up menu.

6. If you are exporting video, click the Options button.
   
   The Video for Windows or QuickTime Options dialog box appears.

7. Select the options you want to use and then click OK.
   
   For AVI movies, enter a number of frames per second for Frame Rate.
   
   For information about the QuickTime options, see “Setting QuickTime export options” on page 367.

   The Export dialog box reappears when you click OK.
8 Click Export.
   A dialog box appears, prompting you to save the movie.

9 Name the file and then click Save.
   When you click Export, a dialog box appears allowing you to name the file. If you are saving in video, PICS, or Scrapbook format, only one file will be created. If you are saving in BMP or PICT format, Director automatically creates one file for each frame, attaching the corresponding frame number to each file. For example, if the name of the exported file is Myfile, frame 1 will be exported to a file named Myfile0001.
Setting QuickTime export options

Use the QuickTime Options dialog box to specify options for exporting a movie as a QuickTime digital video. This dialog box appears when you click the Options button in the Export dialog box and QuickTime is the specified format.

To set QuickTime export options:

1. Choose File > Export.
2. Choose QuickTime Movie from the Format pop-up menu.
3. Click Options.
4. To set the speed the video will play, choose a Frame Rate option:
   - Tempo Settings exports the settings in the tempo channel to the QuickTime movie. This setting lets you create a QuickTime movie at any tempo, even if Director is not capable of playing the movie at that tempo in real time.
     The size of an exported QuickTime movie is influenced by the tempo settings, transitions, and palette transitions in the Director movie. Fast tempos, certain transitions, and palette transitions all increase the size of the QuickTime movie. The tempo settings determine the number of QuickTime frames per second and the number of frames per transition. The faster the tempo, the more frames per second.
     A movie that would work well with Tempo Settings as the Frame Rate option is one in which the tempos have been carefully timed. For instance, some frames could be set to a tempo of 10 per second, and their QuickTime frame durations would be exactly one tenth of a second. Other frames later in the movie could be set to a tempo of 1 frame per second; when the movie is exported, these slower frames would each last precisely 1 second in the QuickTime movie.
   - Real Time lets you export a QuickTime movie that matches the performance of the Director movie as it plays on your system. (You should always play the entire movie with Lingo disabled before using this feature.)
     When you export a movie with Real Time selected, each Director frame becomes a QuickTime frame. Each frame in the QuickTime movie will match the duration of the same frame in the Director movie.
     Director will generate as many frames as required to duplicate each transition, up to 30 frames per second. To increase the number of frames created for any transition, reduce the smoothness of the transition.
     This option causes Director to use the actual durations that were stored the last time you played the entire movie, regardless of the actual tempo settings of the movie.
5 To reduce the file size of a QuickTime movie at the expense of quality, choose an option from the Compressor pop-up menu. Different options appear on the Compressor pop-up menu depending on the video hardware and software available in your system. Consult your QuickTime documentation.

Animation compression is for simple animations.

Cinepak compresses 16-bit and 24-bit video for playback from CD-ROMs.

Component Video is usually used when capturing from a live video feed.

Graphics compression is for exporting single frames of computer graphics.

None exports with no compression.

Photo-JPEG compression is good for scanned or digitized continuous-tone still images.

Video compression is for exporting video clips.

6 To determine the compression quality and resulting file size when using the chosen compressor, use the Quality slider. A higher quality setting preserves the appearance of the images and motion but increases the size of the file. A lower quality setting results in poorer image quality but decreases the size of the file.

7 To determine the color depth (the number of colors) that artwork includes, choose a setting from the Color Depth pop-up menu. The compression method you choose determines the color depth options available to you in this pop-up menu.

8 To determine the method by which the exported QuickTime movie is resized, choose values for Scale. You can choose a percentage from the Scale pop-up menu, or you can type pixel dimensions in the fields. By entering the number of pixels, it is possible to stretch a movie so that it plays in a rectangle that does not adhere to the original aspect ratio.

9 To choose which sound tracks are exported with your movie, choose Channel 1 or Channel 2. A checked box indicates that the associated sound channel in the score is exported with your QuickTime file.

External sounds (sounds you imported as linked cast members) are not exported when you export a digital video. To include sound when you export a digital video movie, you must import the sounds as cast members instead of linking to them.

Looped sounds don’t loop in a movie that you have exported as a digital video. To loop a sound in a movie that you plan to export as a digital video, you must trigger the sound by alternating it between the two sound channels.
Organizing movie files

In most cases, you should divide a larger production into a series of smaller movies. You can combine as many movies as you want in a projector, but larger files take longer to save and are cumbersome to work with. Also, movies are easier to change if they are organized in discrete sections.

The best way to organize a larger production is to create a small projector file that launches the movie and then branches to Shockwave or protected movies. This saves you the trouble of re-creating the projector every time you change one part of a movie.

A typical file organization for a distributed movie

This approach also makes sense for movies on the Internet, but for different reasons. If the first movie is small, users don’t have to wait as long for something to happen. Branching to a series of smaller movies also enables users to avoid downloading time for parts of the movie they do not use.

The size of your movie may be less of an issue if you properly use streaming Shockwave. For more information, see “Setting movie playback options” on page 339.
CHAPTER 19
Running Movies with HTML

Running Movies with HTML: Overview

Once you have finished assembling the content of a movie, set the streaming options in the Movie Playback dialog box, and saved the movie as a Shockwave movie, all that remains is creating an HTML document to run the movie in a browser.

Director includes a stand-alone utility named Aftershock that makes delivering Director and Flash movies to the web quick and automatic. Use this utility to create HTML files that display Shockwave movies and Java applets. Using the Aftershock interface, you can set all of the possible Shockwave Director and Shockwave Flash parameters for the OBJECT and EMBED tags. OBJECT and EMBED are the actual HTML tags that make the browser display a Director movie.

You can also use Aftershock to:

- Add a Shockwave movie to or update the OBJECT and EMBED parameters in an HTML document that has already been converted by Aftershock.
- Deliver a movie as a Shockwave movie and a Java applet.
- Create a script to detect when the appropriate Shockwave plugin or ActiveX control is missing and then either download or display a JPEG or Java applet instead.
- Create a cookie that allows visitors to choose how to view your Shockwave movies.
- Create or update multiple HTML files containing Shockwave movies.
- Generate lists of the text and URLs used in the Shockwave movie so that search engines can index the text and link verification tools can verify the links.
After finishing, you may want to modify the HTML document generated by Aftershock with a web page editor such as Dreamweaver.

If you don't want to use Aftershock, you can manually create your own HTML document that runs a Shockwave movies using the \texttt{OBJECT} and \texttt{EMBED} tags. For information on these tags and their parameters, see [HTML code (currently at http://www.macromedia.com/support/director/how/shock/run.htm)] on the Director Developers Center web site.

**Creating a new HTML document with Aftershock**

The Aftershock interface lets you quickly set options that determine how your web page looks and how your movie plays. After you've chosen settings, Aftershock creates an HTML document with the appropriate HTML tags and generates alternative graphics files.

**To create a new HTML file containing a Shockwave movie:**

1. Start the Aftershock application.
   - In Windows, choose Aftershock from the Start menu.
   - On a Macintosh, start Aftershock from the Director application folder.

2. Choose File > Add > Shockwave and then use the open file dialog box to locate the Flash or Director movie you want to use. Repeat this step to add other movies.

3. Select the movie you want to change and click the Scripting tab and specify how to deliver the movie. Aftershock has several predefined schemes—Default, Ad Banner, User Choice, Shockwave Only, and Use Java. When you choose a scheme, the selected options change. You can also select options individually rather than choose a predefined scheme. See “Scripting settings in Aftershock” on page 374.

4. Click the Page Layout tab and specify the size of your movie and its alignment relative to the browser window. See “Page Layout settings in Aftershock” on page 376.

5. If you chose Plugin/ActiveX Control as the media type in the Scripting panel, click the Shockwave tab to specify the settings for your Shockwave movie. These options set \texttt{OBJECT} and \texttt{EMBED} tag attributes and parameters and affect how your movie appear in a browser. See “Shockwave settings for Flash movies in Aftershock” on page 377 or “Shockwave settings for Director movies in Aftershock” on page 379.
If you chose Flash Player Java Edition or Director Player for Java as the media type in the Scripting panel, click the Java tab to specify the location of the class files.

See “Java settings in Aftershock” on page 380.

If you chose JPEG as the media type in the Scripting panel, click the Alternate Image tab to specify the image’s size, type, and features. See “Alternate Image settings in Aftershock” on page 380.

**Updating an existing HTML document with Aftershock**

When you update an “Aftershocked” HTML file that already contains the code to run a Shockwave movie, the movie settings appear in the option tabs. Use the Aftershock interface to alter these settings or add JPEGs and Java applets as playback alternatives to Shockwave.

**To update the Shockwave movie settings in an existing HTML file:**

1. Choose File > Add > HTML to locate the HTML file you want to update.
   You can open only HTML files that have been previously modified by Aftershock.
2. Click each tab to find the settings you want to change and make your revisions.
   See the help topics on the individual panels for more information.
3. Choose File > Save.
Scripting settings in Aftershock

Use the Scripting panel in Aftershock to choose settings that determine how visitors view the Shockwave movie on your page.

To enter Scripting settings for a Shockwave movie:

1. Select a movie and click the Scripting tab.
   
   Each movie you’ve opened in Aftershock can have its own settings.

2. To choose a preset for all Scripting settings, choose an option from the Scheme pop-up menu:
   
   Scheme offers five sets of default values for typical Web pages—Default, Ad Banner, User Choice, Shockwave Only, and Use Java. If you change any other option in the Scripting panel, the scheme selection changes to Custom. If you choose one of the default values, you don’t need to choose any other options.

   **Default** attempts to play your movie as a Shockwave file, but displays it as a JPEG file if the Shockwave plugin isn’t available. This scheme automatically detects the Shockwave player or ActiveX control and uses it to display your movie. If Shockwave is not found and the visitor’s browser is Internet Explorer on Windows 95 or NT, the browser automatically installs the ActiveX control. In all other cases, the alternative JPEG image you specify is displayed.

   **Ad Banner** attempts to play your movie as a Shockwave file, but displays it as a JPEG file if the Shockwave plugin or ActiveX control is not already installed. This scheme automatically detects the Shockwave plugin or ActiveX control and uses it to display your movie. If the plugin or ActiveX control is not found, your movie is displayed as a JPEG file.

   **User Choice** lets the user choose how to display your movie. This scheme checks for a cookie with the user’s preference for viewing Shockwave movies (with the plugin or ActiveX control, as a Java applet, or as a JPEG file) and sets a cookie if none exists. Aftershock automatically generates four links so that the user can choose; as long as you preserve the function call that sets the cookie, you can change the text in this sample code to any wording.

   **Shockwave Only** automatically detects the appropriate Shockwave plugin or ActiveX control and uses it to display your movie. If Shockwave is not found and the visitor’s browser is Internet Explorer on Windows 95 or NT, the browser automatically installs the ActiveX control. If Shockwave is not found and the visitor’s browser is Netscape 4, the plugin download dialog box opens, allowing the user to install the Shockwave plugin for Netscape.
Use Java attempts to display your movie as a Shockwave file, but displays it with the appropriate Java player if the plugin or ActiveX control is not available. If neither the plugin nor Java is enabled, a JPEG file is displayed. See “Java settings in Aftershock” on page 380 for more information.

Custom uses a combination of Media Types, User Preference, and Installation options not provided by any of the other schemes.

3 To add the appropriate code to the HTML file to deliver your movie in the selected media types, choose a Media Type option:

Shockwave Plugin/ActiveX Control adds the OBJECT and EMBED tags needed to play the Shockwave movie.

Flash Player Java Edition or Director Player for Java adds the APPLET tag and a script to check that Java is enabled.

JPEG adds the IMG tags needed to display a JPEG file instead of the movie, if necessary.

4 To specify how users choose to view the movie, choose a User Preference option:

Allow User Cookies to Set Media Types checks for a cookie with the user’s preference for viewing Flash movies (with the plugin or ActiveX control, as a Java applet, as a JPEG file, or as whatever is appropriate for each situation) and sets a cookie if none exists.

Create Links to Choose Media Type automatically generates four links so that the user can choose; as long as you preserve the function call that sets the cookie, you can change the text in this sample code to any wording you want.

5 To specify what happens if the Shockwave player needs to be installed on the visitor’s system, choose an Installation option:

ActiveX Control on Internet Explorer automatically installs the most recent ActiveX control for Shockwave when the visitor’s browser is Internet Explorer on Windows 95 or NT.

Plugin on Netscape Communicator automatically installs the Shockwave plugin when the visitor’s browser is Netscape Navigator 4.0 or later.

Add Smart Shockwave Button places a button on the page that gives visitors the option of installing Shockwave.

6 To check the movie for buttons or actions that send scripting messages to the browser and add appropriate JavaScript and VBScript, click Movie Uses Browser Scripting.
Page Layout settings in Aftershock

Use the Page Layout settings in Aftershock to determine the size and position of a Shockwave movie within a Web page.

To set Page Layout settings in Aftershock:

1. Select a movie and click the Page Layout tab.
   Each movie can have its own settings.

2. To determine the size of the movie, enter values for Width and Height.
   Click Percentage of Browser Window Size to enter width and height values expressed as a percentage of the browser window instead of as pixels.
   This sets the values of the WIDTH and HEIGHT attributes in the OBJECT and EMBED tags. The size is in pixels by default and matches the document size that was specified in the Flash or Director file. Entering values for Width and Height turns off the Match Movie option.

3. To specify how the movie is aligned on the page, choose an option from the Alignment pop-up menu.
   This specifies the ALIGN attribute for the OBJECT, EMBED, and IMG tags and positions the movie window in the browser window.
   ▶ Choose Left or Right to align the movie along the left or right edge of the browser window, respectively, and crop the top, bottom, and sides, as necessary. (Left crops the right side; Right crops the left side.)
   ▶ Choose Top or Bottom to align the movie along the top or bottom edge of the browser window and crop the left and right sides and the top or bottom, as necessary. (Top crops the bottom edge, and Bottom crops the top edge.)

4. To generates a list of the URLs used by the Get URL action in the movie and store them in a comment in your HTML document, click List URLs Used in (movie name).
   The list allows link verification tools to see and verify the links inside your movie.

5. To generate a list of the text used in the movie and store it in a comment in your HTML document, click List Text Used in (movie name).
   This list allows search engines to see and index the text inside your movie.
Shockwave settings for Flash movies in Aftershock

Use the Flash settings in Aftershock to control how Flash movies play in a browser.

To set Shockwave settings for Flash movies in Aftershock:

1. Select a Flash movie and click the Shockwave tab.
   Each movie you've opened in Aftershock can have its own settings.

2. To set the background, enter the hexadecimal code value you want to use, or click Match Movie to use the background color set in the movie file. The color box displays the color you set.
   This option assigns a value to the BGCOLOR parameter of the OBJECT and EMBED tags. If your Background color value differs from that used in the movie, the new color value overrides the normal background color for the movie when it appears in the browser.
   Background color does not affect the BGCOLOR attribute of the BODY tag.
   The BODY’s BGCOLOR value is set to match the movie's background color for new documents and is left untouched in existing documents. If you want the background color of your HTML page to differ from the normal background color of the Flash movie, you must change the value manually in the HTML file.

3. To control the quality of Flash movie playback, choose a Playback option:
   The Playback option sets the QUALITY parameter of the OBJECT and EMBED tags and determines the level of anti-aliasing performed. Because anti-aliasing requires a faster processor to smooth each frame of the movie before it is rendered on the viewer's screen, the QUALITY parameter assigns priorities to appearance and playback speed, as follows:
   - **Low** favors playback speed over appearance and never applies anti-aliasing.
   - **High** favors appearance over playback speed and always applies anti-aliasing
   - **Autohigh** emphasizes playback speed and appearance equally, but sacrifices appearance for the sake of playback speed if necessary. Playback begins with anti-aliasing turned on. If the actual frame rate drops below the specified frame rate, anti-aliasing is turned off to improve playback speed. Use this setting to emulate the View > Smooth setting in Flash.
   - **Autolow** emphasizes speed, but improves appearance whenever possible. Playback begins with anti-aliasing turned off. If the Flash player detects that the processor can handle it, anti-aliasing is turned on.
To take advantage of transparent movie, absolute positioning, and layering capabilities available in Internet Explorer 4.0, choose a Window Mode option. The Window Mode option sets the WMODE parameter of the OBJECT and EMBED tags.

**Default** sets the WMODE parameter value to WINDOW and plays a Shockwave Flash movie in its own rectangular window on a Web page. This setting normally provides the fastest animation performance.

**Opaque Windowless** sets the WMODE parameter value to OPAQUE. Use this setting if you want to move elements behind Flash movies (for example, with dynamic HTML) and don't want them to show through.

**Transparent Windowless** sets the WMODE parameter to TRANSPARENT. Use this setting to make the background of the HTML page on which the movie is embedded show through all transparent parts of the movie. Animation performance may be slower with this setting. (Transparent capabilities are available only in Internet Explorer 4.0.)

To define how the movie is placed within the boundaries of the browser window, choose a Scale option.

The Scale option sets the SCALE parameter of the OBJECT and EMBED tags. These settings are used if you choose a width and height in the Page Layout section that differs from the movie's original size.

**Default (Show all)** makes the entire movie visible in the specified area. The original aspect ratio of the movie is maintained without distortion. Borders may appear on two sides of the movie.

**No Border** scales the movie to fill the specified area. The original aspect ratio of the movie is maintained without distortion. Portions of the movie may be cropped.

**Exact Fit** makes the entire movie visible in the specified area. However, no attempt is made to preserve the original aspect ratio, and distortion may occur.

**Alignment** specifies the ALIGN attribute for the OBJECT, EMBED, and IMG tags and determines how the movie window is positioned within the browser window. You can choose from one of five options. Choose Left or Right to align the movie along the left or right edge of the browser window, respectively, and crop the top, bottom, and sides, as necessary. (Left crops the right side; Right crops the left side.) Choose Top or Bottom to align the movie along the top or bottom edge of the browser window and crop the left and right sides, and the bottom (if Top is chosen) or top (if Bottom is chosen), as necessary. Choose Default to center the movie in the movie window and crop edges if the movie window is smaller than the movie.
Shockwave settings for Director movies in Aftershock

Use the Shockwave settings in Aftershock to control how Shockwave Director movies play in a browser.

To specify Shockwave settings for Director movies in Aftershock:

1. Select a Director movie and click the Shockwave tab.
   Each movie you've opened in Aftershock can have its own settings.

2. To set the background, enter the hexadecimal code value you want to use, or click Match Movie to use the background color set in the movie file. The color box displays the color you set.
   This option assigns a value to the bgcolor parameter of the OBJECT and EMBED tags. If your Background color value differs from that used in the movie, the new color value overrides the normal background color for the movie when it appears in the browser.
   Background Color does not affect the bgcolor attribute of the BODY tag. The BODY's bgcolor value is set to match the movie's background color for new documents and is left untouched in existing documents. If you want the background color of your HTML page to differ from the normal background color of the Director movie, you must change the value manually in the HTML file.

3. To pause the movie when the HTML document loads, click Paused at Start.
   This option assigns a value to the AUTOSTART parameter. Paused at Start is deselected by default, so that the movie begins to play as soon as it is loaded. If you want to start the movie with JavaScript or in response to a user action, select Paused at Start to set the AUTOSTART parameter to FALSE.

4. To make the browser's palette override the movie's palette, click Browser Palette Overrides Movie Palette.
   Unless you are familiar with taking over the browser palette, you should not change this setting.

5. To enter values for other parameters, select the parameter on the list at the left and enter a value on the right.
   You must have defined external parameters for use with a movie to take advantage of these options.
Alternate Image settings in Aftershock

Use the Alternate Image settings in Aftershock to determine the size and frame of the image file that is displayed if the Shockwave is not installed. The preview window displays the current frame of the movie and the name Aftershock has assigned to the alternative image.

To specify Alternate Image settings:

1. Select a movie and click the Alternate Image tab.
   - Each movie you’ve opened in Aftershock can have its own settings.

2. In the Frame box, enter the frame number from which to generate the JPEG image.
   - Aftershock displays the image of the selected frame on the left.

3. To specify the size of the alternate image enter a value for Width and Height.
   - The default values are the width and height of the Shockwave movie.

Java settings in Aftershock

Use the Java settings options in Aftershock to make the Flash Player Java Edition or Director Player for Java play your movies if the user does not have the Shockwave plugin. Java works best on newer browsers.

To enter Java settings in Aftershock:

1. Select a movie and click the Java tab.
   - Each movie you’ve opened in Aftershock can have its own settings.

2. To determine whether the Java version of your movie is used on all Java-enabled browsers or only on those with robust Java support, choose a Use Java On option:
   - **Newer Browsers with Robust Java Support** displays the alternative JPEG image in place of the Java version of your movie for users with pre-3.0 browsers and no Shockwave plugin.
   - **All Java Enabled Browsers** displays the Java version of the movie on any browser capable of running Java.
3 To locate the class files for Flash Player Java Edition or Director Player for Java, enter a path in the Class File Location field.

- For Flash Player Java Edition, the class file is Flash.class.

- For Director Player for Java, the class file has the same name as the original Director movie followed by the extension DJR.

When the class files are in the same folder as the HTML file, Aftershock automatically finds the class files. If the class files aren’t in the same folder as the HTML file, click Locate and find the class files by using the Locate dialog box.

For Flash movies, the Flash.class file and all of its associated files are stored in the Flash Aftershock/Flash Player Java Edition folder at the time of installation. You need to move or copy these files to a location that mirrors the files’ final location on the server before you click Locate. For example, to have the class files reside in a java/ directory one level down from your HTML file, create a java/ folder on your hard drive in the same folder as your HTML file and copy the class files there. For Director, the packaged CAB, JAR, and ZIP files must be in the same folder as the DJR media file. For information about packaging Director Player for Java class files, see the Save as Java help. Be sure to copy all of the files in the Flash Player Java Edition folder to the new location, not just the Flash.class file.

4 To ensure that the class files are available to the widest number of users, select all three Class Files options: Packed in Cab File for Internet Explorer, Packaged in Jar File for Netscape 4, and Packaged in Zip File for Netscape 3.
Shockwave browser compatibility

Shockwave works with Netscape Navigator as a plugin and with Microsoft Internet Explorer for Windows 95 and NT as an ActiveX control. Shockwave can play Director movies in the following browsers:

<table>
<thead>
<tr>
<th>Browser</th>
<th>Version</th>
<th>Platform</th>
</tr>
</thead>
<tbody>
<tr>
<td>Netscape Navigator</td>
<td>3.0 or later</td>
<td>Windows and Macintosh</td>
</tr>
<tr>
<td>Microsoft Internet Explorer</td>
<td>3.0 or later</td>
<td>Windows</td>
</tr>
<tr>
<td>Microsoft Internet Explorer</td>
<td>4.01 or later</td>
<td>Macintosh</td>
</tr>
</tbody>
</table>

Shockwave also works with browsers that are compatible with the plugin architecture of Netscape Navigator 3.0, including America Online.

When it first encounters an HTML page that references Shockwave, Internet Explorer for Windows 95, 98, and NT asks the user for permission to download the Shockwave ActiveX control. If the user approves, it downloads and installs the control.

*Note:* The Director 7 Shockwave player can also play Shockwave movies created with Director 5 and 6.
INDEX

Symbols
& operator 288
&& operator 288
¬ (continuation symbol). See continuation symbol

Numerics
5.x movies, updating 59
6.x movies, updating 59

A
abbreviating Lingo statements 143
About movie property 58
accelerating sprites 190
actions, behavior inspector
  Beep 123
  Change Cast Member 123
  Change Cursor 123
  Change Ink 123
  Change Location 123
  Change Palette 123
  Change Tempo 123
  Go to Frame 122
  Go to Marker 122
  Go to Movie 122
  Go to Net Page 122
  New Action 123
  Perform Transition 123
  Play Cast Member 123
  Play External File 123
  Restore Cursor 123
  Set Volume 123
  Wait for Time Duration 123
  Wait on Current Frame 122
  Wait Until Click 123
  Wait Until Key Press 123
ActiveX 102, 332
actorList properties 232
Actual tempo (Control Panel) 58
Add button (new cast member) 103

Aftershock
  Alternate Image settings 380
  basics of 371
  changing existing HTML document with 373
  creating HTML document with 372
  Director settings 379
  Java settings 380
  Page Layout settings 376
  Scripting settings 374
  Shockwave settings 377
Air Brush tool (Paint window) 245, 248
aligning sprites 77
Allow Colored Cells 52
Allow Drag and Drop 52
alpha channel
  importing 240
  mask effects 89
Alternate Image settings, Aftershock 380
ancestor
  property 131
  scripts 227
ancestors, in behaviors 131
Animate in Background projector option 361
animated cursors
  creating 216
  using 215
animated GIFs 241
tempo 242
animation
  animated color cursors 215
  Cast to Time command 199
  exchanging cast members 197
  film loops 201
  onion skinning 262
tweening 187
  with a series of cast members 197
  with Lingo 203
anti-aliasing
  setting with Lingo 285
text 278
arguments for handlers 156
arithmetic operators 149
Arrange menu 67
attaching behaviors 116
audio compression. See Shockwave Audio
Auto Coloring 161
Auto Filter command 261
AVI (Video for Windows). See digital video

B
background color 86
background color chip 266
background operations. See network operations 339
Background Transparent ink 64
Beep action 123
Behavior Inspector 120
behaviors
  actions and events 122
  attaching 116, 136
  cast window icon for 136
  changing parameters 118
  changing sequence of 119
  contents of 129
  copying 136
  creating 120
  creating descriptions 128
  creating properties in Lingo 125
  defining properties in 126
  description of 115, 136
  editing in the Script window 121
  handlers in 124
  inheritance 131
  messages to 130
  modifying 120
  numbers of 136
  setting properties with Lingo 125
  streaming 341
  viewing descriptions 119
  writing with 124

bitmaps (continued)
  fonts 270
  image resolution 240
  onion skinning 262
  resizing 255
  shortcuts for changing 250
  tweenable filters 261
Blend
  score display option 73
  sprite setting 70
blending sprites 87, 191
Brightness 179
Bring to Front command 67
browser
  compatibility 382
  playing movies in 43
  preview in 353
  status area text 349
Bucket tool (Paint window) 245
button, tool palette 266

C
call command 131
Cast Member Info. See Cast Member Properties
cast member Name field 98
cast member Number field 98
cast member properties 95, 108
  changing from Lingo 111
cast member properties button 98
cast member script button 98
cast members 93
  ActiveX 332
  animating with 197
  basics of 45
  bitmap 233
  checking whether loaded 343
  creating 102
  creating text 272
  custom thumbnail 110
  description of 45
  editing text 273
  finding 106
  Flash 314
  formatting text in 277
  formatting text with Lingo 285
  icons 97
  identifying in Lingo 145
cast members (continued)
importing 103
importing text 273
in streaming movies 343
moving 99
naming in Lingo 145
numbering in Lingo 145
organizing 101
selecting 99
shapes 266
sorting 101
text 272
tracing 252, 264
unloading 110
viewing properties 108
Cast to Time command 199
Cast window 95
casts
creating 94, 112
external 94
identifying in Lingo 145
moving cast members 99
naming in Lingo 145
numbering in Lingo 145
opening cast windows 95
preferences 97
saving 114
saving as libraries 114
window buttons 95
Change Cast Member action 123
Change Cursor action 123
Change Ink action 123
Change Location action 123
Change Palette action 123
Change Tempo action 123
Changes Only 72
channels 47
marker 47
moving contents of 67
number of 47
palette 47
script 47
showing and hiding effects channels 48
sound 47, 291
tempo 47, 181
transition 47
turning off and on 48
character formatting 274
character spaces. See spaces, character
charToNum function 214
child objects
  basic concepts 227
  clearing from actorList 232
  controlling 232
  creating 229, 230
  properties of 226
  removing 230
Clear Script command 69
clearGlobals command 154
color
  changing in a color palette 178
  changing palettes for bitmaps 255
  choosing 172
  color menu 172, 173
  color picker 172
  favorite colors 173
  of sprites 86
  overview 170
  RGB and index 171
tweening 191
color depth
  changing during import 240
  changing for bitmaps 255
  changing for movies 171
  description of 170
color palettes
  changing colors in 175, 178
  changing for bitmaps 255
  changing while authoring 174
  changing while importing 240
  channel 173
  controlling from Lingo 179
  description of 170
  Image Options 240
  index color 171
  requirements for importing 180
  solving problems with 179
Color Palettes window 174, 175
Color Selection option 57
commands
  clearGlobals 154
  definition of 141
downLoadNetThing 345
getNetText 344
commands (continued)
gotoNetMovie 345
play 208
preLoadNetThing 345
puppetTransition 185
comments 143
comparison operators 149
compressing
movies 359
sounds. see Shockwave for Audio
conditions
describing 148
in a movie 148
setting 147
testing and setting 147
constants, definition of 141
constraining vector shapes 235
contains function 288
continuation symbol (¬)
creating 165
purpose 165
Continuous at Endpoints tweening option 194
Control Panel 58
Convert to Bitmap command 281
converting old movies. see Update Movies
copying lists 160
Copyright movie property 58
corner points in vector shapes 235
Create Projector command 361
creating
the on new handler 229
transitions 184
cropping a movie in a window 222
cropping videos 308
cross-platform keys 214
cue points 310
synchronizing sound and video with 310
using with Lingo 312
current frame (Control Panel) 58
Current Frame Only 91
cursor
animated color cursors 215
checking 76
finding location with Lingo 213
Curvature tweening control 194
curve points in vector shapes 235
custom tiles, creating 259

D
Darken button (Paint window) 253
data, obtaining from a network 343
DCR (Shockwave movies) 357
decelerating sprites 190
decimal numbers 145
Default Palette pop-up menu 57
detecting mouse clicks with Lingo 209
digital video
controlling in the Score 301
controlling QuickTime with Lingo 304
controlling with Lingo 302
cropping 308
determining content of 303
Direct to Stage 300
exporting 364
importing 299
preloading 310
synchronizing with cue points 310
turning tracks on and off with Lingo 304
using on the Internet 309
Direct To Stage Flash movie 315
Direct to Stage. digital video option 300
Director 5 Style Score Display 52
Director, new features in 12
Display Sprite Frames 91
dissolve. See transitions
distributing movies
on disk 358
on Internet 358
on local network 358
distribution formats
Java 358
projector 357
protected 358
Shockwave 357
Dither 256
dithering 180
Download _ Frames Before Playing
playback property 340
downloading considerations 351
downLoadNetThing command 345
Drag cast member control 98
drag-and-drop behaviors. See behaviors
drawing vector shapes 234
dropper tool (Paint window) 245
duration of sprites 80
DXR (protected movies) 358

E

Ease-In and Ease-Out tweening options 194
Editable setting 70
editable text
  creating 279
  creating with Lingo 280
editing
  bitmaps 243
  fields 281
  sprites 196
  text 273
editing scripts 165
effects
  filters 260
    Paint window buttons 251
effects channels 47
elements, definitions of 141
EMBED tag 371
embedded fonts 270
empty lists 157
end frame 80
Enter Frame event 122
Entire Sprite 91
Eraser tool (Paint window) 244
events and actions, included 122
events, behavior inspector
  Enter Frame 122
  Exit Frame 122
  Key Down 122
  Key Up 122
  Mouse Down 122
  Mouse Enter 122
  Mouse Leave 122
  Mouse Up 122
  Mouse Within 122
  Prepare Frame 122
  Right Mouse Down 122
  Right Mouse Up 122
Every frame sprite label option 72
Exchange Cast Members command 195, 198
EXE (projectors) 357
Exit Frame event 122
exporting movies as digital video 364
exporting QuickTime options 367
expressions, definition of 134
Extend Sprite command 80
Extended display 51
Extended score display option 73
extending one-frame sprites 80
external casts 94
external sounds 290
Extreme tweening option 194
eye dropper tool (Paint window) 245
Eyedropper tool 176

F

Fade to Black/White 174
fading sprites 87, 191
FALSE keyword, definition of 148
FALSE, testing for 147
favorite colors, editing 173
Field window 281
fields
  checking content of 288
  creating 281
  modifying 288
file references, URLs as 347
files
  downloading with Lingo 345
  linking to 106
  types supported 105
Fill color (Paint window) 253
fill settings for vector shapes 236
film loops
  creating 202
  editing 203
  using 202
Filter Bitmap command 260
finding cast members 106
finding sprite locations with Lingo 213
First frame 72
Flash movies
  controlling playback with Lingo 322
  controlling with Lingo 317
  creating cast member 314
  importing 314
  managing files 317
  performance tips 325
  playback settings 315
  quality settings 316
  Scale Mode options 316
Flash movies (continued)
  sending Lingo messages with 323
  streaming with Lingo 321
tips for using 317
Flip 70
Flip button (Paint window) 251
flipping Flash movies with Lingo 318
flipping sprites 85
floating-point numbers 145
flow of Lingo 134
Fontmap.txt 58
fonts, embedding in a movie 270
Foreground and Background color 70, 86
foreground color chip 266
Foreground/Background Color control
  (Paint window) 246
Foreground/Destination Color control
  (Paint window) 258
formatting
  characters 274
  fields 281
  paragraphs 275
  text 277
Frame Properties dialog box
  Palette 174
  Sound 291
  Tempo 182
  Transition 184
frame scripts 141
frame-by-frame animation 187
frames
  adding 55
  checking whether content is loaded 343
  identifying with Lingo 56
  in the Score 48
  moving sprites in 79
  selecting, moving, and deleting 55
Full Screen projector option 361
functions (continued)
  netDone 344
  netError 344
  netLastModDate 346
  netMime 346
  netStatus 349
  netTextResult 346
  new 229
  numToChar 214
  return 155
  rollOver 212
getError function 298
getErrorString function 298
getNetText 273
getNetText command 344
getPropertyDescriptionList handler 128
GIFs, animated 241
global variables, displaying 154
Go to Frame action 122
Go to Marker action 122
Go to Movie action 122
Go to Net Page action 122
gotoNetMovie command 345
Gradient (Paint window) 258
gradients
  for bitmaps 258
  for vector shapes 238
Graphic Context Menu, ShockMachine option 341
grid
  aligning sprites to 78
  settings 78
H
Hand tool (Paint window) 244
handlers
  adding other 229
  arguments of 156
  custom 138
  finding 166
  getPropertyDescriptionList 128
  in behaviors 124
  new 230
  passing values to 156
  results from 155
handlers (continued)
  strategies for placing 140
  when run 140
hexadecimal RGB values 171
HTML importing as text 273
HTML, creating a document to run a movie 371
  Hue 179
hyperlink, creating 279

I
icons, cast member 97
Import Pict File as PICT 104
importing
  ActiveX 332
  cast members 103
  color palette requirements 180
  digital video 299
  Director movies 326
  Flash movies 314
  HTML 273
  JPEGs 240
  linking to files 106
  PowerPoint 327
  Preserve Original Data for External
    Editing option 104
  selecting files for 103
  sound 290
  supported file types 105
  text 273
  text with Lingo 273
  Xtras 61
In a Window projector option 361
In Between Special command. See tweening
in-betweening. See tweening
Include Original Data for Editing 104
Index color 57
index color 171
inheritance in behaviors 131
ink
  pop-up menu 70
  score display option 73
inks 88
  Paint window 247
  sprite 88
inspectors
  Behavior Inspector 120
  Sprite 68
  Text Inspector 277
installing
  bitmap filter Xtras 260
  Xtras 60
integers, syntax for 144
internal casts 94
internal sounds
  compressing 295
  using 290
Internet
  digital video and 309
  distributing movies on 358
  Network, preferences 106
See Also
  network operations
Invert colors (paint window) 253
Invert Selection button 177

J
Java applets, creating with Director 358
Java settings, Aftershock 380
joining sprites 81
JPEGs importing 240

K
kerning 274, 275
  about 278
  with Lingo 285
Key Down event 122
key function 213
Key Up event 122
keyCode function 213
keyframes
  creating 196
  description of 187
  selecting 65
  showing path 189
keys
  checking with Lingo 213
  cross-platform equivalent 214
keywords
  definition of 141
  optional 143
LANs, movies on 358
Lasso tool (Paint window) 243, 248
Library palette
  attaching behaviors with 116
  creating new libraries 114
library, creating 114
Lighten button (Paint window) 253
line settings for vector shapes 236
Line Type/Other Line control (Paint window) 247
Linear tweening option 194
Lingo
  elements 141
  for Internet operation 130
  how it flows 134
  overview 133
  possible locations for 136
  syntax 142
  types 141
  typographical conventions 20
  uses 46
  using outdated 59
Lingo menu 164
  inserting elements from 164
Lingo statements, abbreviating 143
Lingo Xtras. see Scripting Xtras
Link to External File 104
linked media 106
linking external casts 113, 114
list element syntax 142
lists
  adding items to 159
  checking contents 159
  copying 160
  creating 157
  disposing of 160
  empty 157
  sorting 160
literal values, expressing 144
Load Font Map 58
local variables. See variables, local
locations for Lingo, possible 136
Lock Frame Durations 183
Lock Frame Durations playback property 340
Loop Until Media at Marker is Available
  streaming behavior 342
Loop Until Media in Frame is Available
  streaming behavior 342
Loop Until Member is Available
  streaming behavior 342
Loop Until Next Frame is Available
  streaming behavior 342
looping
  movies 58
  sound 292
looping frames 208
lower-case letters, using in Lingo 143
Magnifying glass tool (Paint window) 244
Maintain Outdated Ink Mode Limitations 59
marker channels 47
marker keyword, uses for 56
markers 52
Markers window 52
Marquee tool (Paint window) 244, 248
Mask ink 89
masks, for QuickTime 305
Matte ink 64
me variable 229
Member score display option 73
member sprite property 203
menu, Lingo 164
messages 140
  definition of 137
  matching handlers for 140
  order of locations sent to 140
  to sprite scripts 130
  when Lingo responds 140
MIAW. see movie in a window
Motion score display option 73
mouse clicks, detecting with Lingo 209
Mouse Down event 122
Mouse Enter event 122
Mouse Leave event 122
Mouse Up event 122
Mouse Within event 122
Movie Casts command 113
movie in a window
  closing 223
  controlling 221
  creating with Lingo 220
  cropping and scaling 222
movie in a window (continued)
  events involving 224
  interaction with other movies 224
  opening 221
  setting size and location 222
  setting window type 221
Movie Playback Properties dialog box 339
Movie Properties dialog box 57
movie scripts 141
  availability of 136
  cast window icon for 136
  description of 136
Movie Uses Browser Scripting option 375
Movie Xtras dialog box 355
movie, creating 43
movies
  adding frames 55
  changing color depth of 171
  changing color palettes in 173
  compressing 59, 359
  controlling playback 58
  converting 363
  distribution, preparing for 357
  exporting as digital video 364
  looping 58
  on LANs 358
  playing in web browsers 43
  protected 358
  protecting 59
  Shockwave 357
  streaming 338
  updating 59
moving
  cast members 99
  two-frame sprites 80

N
navigation
  jumping and coming back 208
  jumping to different locations 207
  markers 52
netDone function 344
netError function 344
netID, setting 344
netLastModDate function 346
netMime function 346
netStatus function 349
netTextResult function 346
Network
  obtaining data from 343
  preferences 106
network operations
  adapting Lingo for 347
  cancelling 344
  checking 343
  completing 346
  downloading files with Lingo 345
  retrieving results 346
  See also browsers
New Action action 123
New command 43
new features 12
new function 229
New Script command 69
Next/Previous cast member buttons 98
Novell networks, movies on 358
numbers
  decimal 145
  floating-point 145
numToChar function 214

O
OBJECT tag 371
obtaining data from a network 343
one-frame sprites, stretching 80
onion skinning
  description of 262
  registration points for 262
  toolbar for 262
operators
  arithmetic 149
  comparison 149
  definition of 141
  logical 150
  string 150
  types of 148
  optional keywords 143

P
Page Layout settings, Aftershock 376
Paint Brush tool (Paint window) 245, 248
paint tools
  Air Brush 245, 248
  Bucket 245
  Eraser 244
  Eye Dropper 245
  Foreground/Background Color control 246
  Foreground/Destination Color control 258
  Gradient 258
  Hand 244
  Lasso 243, 248
  Line Type/Other Line control 247
  Magnifying Glass 244
  Marquee 244, 248
  Paint Brush 245, 248
  Pattern 246
  Pencil 245
  Registration 244
  shape drawing tools 246
  Text 245
  Transform Bitmap 247

Paint window
  Effects toolbar 251
  Ink pop-up menu 247
  registration points 253
  rulers 248
  switching colors in a selection 253
  tools 243
  using 243
  zoom 249

palette channels 47
palette index color 171
palette transition 174
palettes. See color palettes
panning, QTVR 306
paragraph formatting 275
paragraph formatting with Lingo 284
parent scripts
  and child objects 225
  basic components of 228
  Cast window icon for 137
  description of 137
  equivalent terms in C++ 226
  property variables in 228
  writing 228
parentheses, using in Lingo 142
Pattern tool (Paint window) 246
Pause When Window Inactive playback property 340
pausing a movie 208
Pencil tool (Paint window) 245
percentPlayed property 298
Perform Transition action 123
Perspective button (Paint window) 252
Photoshop filters. See Filter Bitmap command
placing handlers 140
Play button (Control Panel) 58
Play Cast Member action 123
play command 208
Play Every Frame digital video property 300
Play Every Movie projector option 361
Play External File action 123
Play selected frames only (Control Panel) 58
Play While Downloading Movie playback property 340
Playback command 339
playback head
  in Score 49
  moving to markers 52
playback options, ShockMachine 340
playback, controlling 58
playing external sounds 297
PowerPoint
  comparison with Director features 329
  importing 327
preferences
  Editors 121
  Network 106
  Score 51
  script 161
  Sprite 91
Preferred Browser network preference 43
preloading, digital video 310
preLoadNetThing command 345
Premiere filters. See Auto Filter
Prepare Frame event 122
Preserve Original Data for External Editing option 104
Preview in Browser command 353
Progress Bar for Streaming Movies streaming behaviors 342
Progress Bar for URL Linked Media streaming behavior 342
projector 357
  creating 360
  Shockwave 357
  Xtras in 354

392 Index
properties
  actorList 230, 232
  cast member 108
  constraint 211
  definition of 141
  loc of sprite 76
  locH 76
  locH of sprite 76
  mouseV 213
  percentPlayed 298
  rect 83
  setting 147
  soundChannel 298
  sprite 71
  state 298
  streaming 340
  windowList 224
property keyword 125
property variables, declaring 228
protected movies 59, 358
Punctuation characters 271
puppetPalette command 179
puppets
  color palettes 179
  transitions 185
puppetTempo 183
puppetTransition 185
Q
QTVR 304
  interaction 305
  panning 306
QuickTime
  controlling with Lingo 304
  creating interaction with Lingo 305
  masks 305
  QuickTime VR 301
  rotating and scaling with Lingo 306
QuickTime exporting options 367
QuickTime. See digital video
R
Reg Point Horizontal and Vertical 70
registration
  onion skinning 262
  setting points 253
registration points 74
  vector shapes 237
Registration tool (Paint window) 244
Remap Palettes When Needed movie property 180
Remap Palettes When Needed option 58
Remapping colors in bitmaps 256
removing a child object 230
repeat loops 152
repeat loops in network operations 348
repeating an action 152
repeating sounds 292
Reset Monitor to Match Movie's Color Depth
  projector option 361
Reset Rotation and Skew 85
resizing sprites 82
resolution for screen images 240
Restore Cursor action 123
return function 155
rewind (Control Panel) 58
RGB color 171
  specifying 57
Right Mouse Down event 122
Right Mouse Up event 122
rollOver function 212
rollovers, responding with Lingo 212
Roman Characters 271
Rotate angle 70
rotate button (Paint window) 251
rotating and skewing Flash movies with Lingo 318
rotating sprites 83
RTF, importing 273
rulers, Paint window 248
S
Saturation 179
Save All command 114
Save as Shockwave Movie command 359
Save Font Map 58
Save Local ShockMachine option 341
saving
  casts 114
  Save All command 114
  Shockwave movies 359
  Update Movies 59
scaling
  sprites 82
  vector shapes 238
Index
394

scaling a movie in a window 222
Score 44
  basics of 46
  Blend display 73
digital video in 301
Extended display 73
frames 48
Ink display 73
inks 88
markers 52
Member display 73
Motion display 73
number of channels 47, 58
playback head 49
Script display 73
searching for cast members in 107
sounds in 291
sprite labels 72
toolbar 68
zooming 49
score, channels 47, 58
screen resolution for graphics 240
script channel 47
script pop-up, content of 136
Script Preview 51
Script score display 73
Script Window Preferences 161
script window, using 164
Scripting settings, Aftershock 374
Scripting Xtras 61
scripting, interface 162
scriptInstanceList property 131
scripts
  attaching 162
  basics 133
coloring 161
creating 162
editing 165
finding handlers in 166
finding text in 166
general advice about writing 148
indenting 165
making decisions 151
opening 163
overview 133
parent. See parent scripts
planning 135
scripts (continued)
  possible content of 141
  removing 162
tools for writing 162
writing 162
scripts of cast members 141
cast window icon for 137
description of 137
opening 137
scrolling text with Lingo 287
searching for cast members 106
Select Used button 177
selecting
  areas in the Paint window 243, 248
cast members 99
keyframes 65
sprites 65
text 274
Send to Back command 67
sendAllSprites command 130
sendSprite command 130
Set Volume action 123
setting conditions 147
setting the window size and location 222
setting the window type 221
shape drawing tools (Paint window) 246
shapes 266
Sharp Changes tweening option 190, 194
shocked fonts 270
ShockMachine playback options 340
Shockwave
  backward compatibility 59
description of 43
  projector 357
Shockwave Audio
  compressing internal sounds 295
  controlling with Lingo 297
description of 294
Shockwave movies 61
  backward compatibility 382
  browser compatibility 382
  creating 359
  creating with Update Movies command 59
  streaming 339
testing 350
  uses for 357
Shockwave settings, Aftershock 377
Index

Show Data Tips 52
Show Paths command 189
Show Placeholders playback property 340
Show Title Bar projector option 361
size and shape tweening 191
Skew angle 70
Skew button (Paint window) 252
skewing sprites 83
Smooth button (Paint window) 253
Smooth Changes tweening option 190, 194
sorting cast members 101
sorting lists 160
sound
channel 291
compressing internal 295
controlling in the Score 291
controlling with Lingo 293, 297
importing 290
internal and external 290
issues for Windows 293
looping 292
playing external 293, 297
repeating 292
Shockwave Audio 294
Sound Level button (Control Panel) 58
streaming external 290
streaming with Shockwave for Audio 294
synchronizing with Lingo 312
synchronizing with cue points 310
sound channels 47
soundChannel property 298
SoundEdit 16, creating cue points with 310
Space to Time command 200
spaces, character 143
Span Duration 91
splitting sprites 81
Sprite coordinates 70
sprite inks 88
Sprite inspector 68
Sprite Overlay 71
sprites
aligning to each other 77
aligning to grid 78
animating 187
assigning cast member with Lingo 90
basics 63
basics of 45
sprites (continued)
blend 87
blending 191
changing a bounding rectangle 83
changing appearance of 81
changing duration 80
changing frames 79
comparing locations of 76
coordinates 74
creating 64
editing 196
editing properties with Lingo 71
extending 80
fading 191
flipping 85
foreground and background color 86
info panels 71
inks 88
joining 81
labels 72
layering 67
making draggable with Lingo 211
making editable with Lingo 211
moving with the Tweak window 78
one- and two-frame 80
overlay 71
positioning 74
positioning with Lingo 75
preferences 91
properties 68, 71
resizing 82
rotating and skewing 83
scaling 82
selecting 65
setting bounding rectangle of 83
showing and changing paths 189
splitting 81
Sprite Inspector 68
toolbar 68
tweening 187
using inks 88
Width and Height settings 70
Sprites Tweening dialog box 194
Stage 44
location 57
setting size of 57
Stage Selection sprite preference 91
Stage Size projector options 362
Standard Import option 104
Start and End frames 70
start frame 80
state of member property 298
statements
    calling, definition of 138
    order run in 134
Stop button (Control Panel) 58
storyboards 135
streaming
    controlling with Lingo 343
    external sounds 296
    flash movies with Lingo 321
    making movies for 338
    options 339
    score-based 341
    Shockwave Audio 296
    sound 290, 294
strings, changing with Lingo 288
strings, syntax for 144
Switch colors (Paint window) 253
switching cast members 197
symbols
    definition of 147
    uses for 147
Sync to Soundtrack digital video property 300
Synch points. See cue points
synchronizing
    cue points with Lingo 312
    events 181
    sound and video cue points 310
syntax
    case-sensitivity in Lingo 143
    for lists 142
    for strings 144
    of Lingo elements 142

tempo
    comparing actual 182
    controlling from Lingo 183
cue points 310
    for animated GIFs 242
    of the current frame 58
    settings 181
    using the channel 181
terminate at Markers 91
testing movies 350
text
    anti-alias 278
    changing strings with Lingo 288
    checking for user clicks with Lingo 210
    checking specific with Lingo 288
    converting to bitmap 281
    creating 272
    editing cast members 273
    finding in scripts 166
    formatting 277
    formatting cast members 277
    formatting cast members with Lingo 285
    formatting from Lingo 282
    formatting paragraphs with Lingo 284
    hyperlink 279
    importing 273
    importing with Lingo 273
    kerning 278
    making editable 279
    making editable with Lingo 280
    scrolling with Lingo 287
    selecting 274
    Text tool 266
Text Inspector 278
Text tool
    in Paint window 245
    in Tool palette 266
Text window 272
thumbnail, creating custom 110
tile. See Pattern
tiles, custom 259
tinting sprites 86
Tool palette 266
tool Xtras 61
Trace edges button (Paint window) 252
tracing cast members 264
Trails 70
Transform Bitmap command 255
transition channels 47
transition Xtras 61
transitions
    adding 184
    channel 184
    controlling with Lingo 185

396  Index
transitions (continued)
tips for using 185
transition Xtras 184, 185
Transport Control ShockMachine option 341
troubleshooting color palettes 179
TRUE keyword, definition of 148
TRUE, testing for 147
Tweak window 78
tweening
basics 187
bitmap filters 261
blend settings 191
color 191
Ease-in, Ease-out 190
fading 191
path 189
rotation and skew 191
size 191
size and shape 191
speed 190
tips 193

U
unlinking external casts 113, 114
Update Movies command 59, 363
upating movies from older versions 59
upper-case letters, using in Lingo 143
URLs as references in Lingo 347
URLs, maximum length 106

V
values, expressing literal 144
variables
declaring 154
defining local 155
definition of 153
global 154
local 155
me 229
Vector Shape window 234
vector shapes (continued)
  drawing tools 234
  editing 237
  fill and line settings 236
  gradients for 238
  registration point 237
  scaling 238
Verisign Xtra downloading 355
Video for Windows (AVI). See digital video
View menu, Display commands 73
Volume Control ShockMachine option 341

W
Wait for Cue Point tempo option 182
Wait for Mouse Click tempo option 182
Wait for Time Duration action 123
Wait on Current Frame action 122
Wait Until Click action 123
Wait Until Key Press action 123
Warp button (Paint window) 252
Web216 color palette 174, 180
Width of Score Window sprite preference 91
windows
  Cast window 95
closing 223
  Field window 281
  Marker window 52
  Paint window 243
  setting size and location 222
  setting type 221
  Text 272
Windows operating system, sound issues 293
wipe. see transitions
work area 43
writing, a parent script 228

X
Xtras
  Auto Filter command 261
  bitmap filters 260
description of 59
download properties 354
  Filter Bitmap command 260
  importing 61
  installing 60
  managing for distributed movies 354
Xtras (continued)
Scripting 61
tool 61
transition 61, 184, 185

Z
zero point, moving for paint rulers 248
zooming
   Paint window 249
   Score 49
Zooming ShockMachine option 341